Jump to content

ATI MOBILITY 5650 WORKING FULL RES QE/CI ***FB EULEMUR***


  • Please log in to reply
51 replies to this topic

#1
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 724 posts
  • Gender:Male
  • Location:South NSW, Australia
Hi All,

Please see my new post at this topic.

http://www.insanelym...howtopic=250905

#2
Fiber

Fiber

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
Hmmm would this work for 4xxx cards?
I guess it's only for 5xxx and higher? :(

#3
hjs89

hjs89

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
Very interesting. I'll try with my 4570m. What bootloader have you used? Kabyl's boot?

#4
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 724 posts
  • Gender:Male
  • Location:South NSW, Australia

Very interesting. I'll try with my 4570m. What bootloader have you used? Kabyl's boot?





I think it's only 5000 series, will muck around with DSDT to get internal display working.


I'm using rev699 RC5, I don't think it's bootloader related as i'm not using EvoEnabler or ATY_Init

#5
Westie.

Westie.

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
I feel stupid for asking this, but I take this is on Snow Leopard, right?

#6
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 724 posts
  • Gender:Male
  • Location:South NSW, Australia

I feel stupid for asking this, but I take this is on Snow Leopard, right?

Snow Leopard 10.6.6 using 10.7 dev build kexts.

#7
18masterkyle

18masterkyle

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Not working with HP CANADA dv6-3023CA Costco model. Chameleon Loader works fine, but when entering OS, black screen 100% fan

#8
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 724 posts
  • Gender:Male
  • Location:South NSW, Australia

Not working with HP CANADA dv6-3023CA Costco model. Chameleon Loader works fine, but when entering OS, black screen 100% fan





I never said laptop screen works, external monitor atm till I find a fix.

#9
Fiber

Fiber

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
Too bad it's only for 5000 series.. :P

#10
wen1

wen1

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 109 posts
This is a great start. Awesome work. I know it is only a matter of time before you guys figure out the internal display.

#11
Drakulix

Drakulix

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Could you maybe upload all (, not only for 5xxx, ) ati kexts from mac os lion, atlee?
I have a friend with an not working ati mobility hd 4225 card
and I would like to play around with those kexts.

Thanks and nice find :wacko:
Drakulix

#12
hjs89

hjs89

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male

I think it's only 5000 series, will muck around with DSDT to get internal display working.


I'm using rev699 RC5, I don't think it's bootloader related as i'm not using EvoEnabler or ATY_Init


So so :/. I've used rev747 and 10.7 files and I've a corrupted screen (less than before) in my laptop screen. I've checked to connect an external monitor to VGA and HDMI port but didn't reconized it. Maybe forcing to use another Framebuffer :wacko:

Anyway thanks for your post.

#13
neomatrix125

neomatrix125

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
This looks great!
Maybe its worth trying to get my Dell Studio 1749 to actually run OS X properly

#14
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 724 posts
  • Gender:Male
  • Location:South NSW, Australia
Try getting RC5 rev699 but i doubt it's bootloader creating messed up screen, did you double check your dev ID inside the kexts? to see if they match?




I even tested with Anval's latest RC5 build and same results. still picks Megaloden as FB.

#15
Buschtrommel

Buschtrommel

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Looks fine !

Anyone tried this driver with the ATI Mobility 5470 ?

#16
checcco

checcco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
hi atlee! Would you please share your settings? Which bootlader are you using? which options in boot.plist? any modified boot? Thanks

#17
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 724 posts
  • Gender:Male
  • Location:South NSW, Australia
i'm doing a fresh install at the moment but i was using MacOSX Snow Leopard 10.6.6 using a patched kernel, different bootloaders made no difference but i'm going to try again using the ati 5000 bootloader found in the ati graphics section rev700, i will do some more testing, with a framebuffer i get black screen, without framebuffer but using 10.7 kexts i get external monitor but not laptop.
No DSDT, I've read a few getting it working using nomacus FB but i will do more testing, I will try with 10.6.6 kexts but i'm pretty sure not much success rate. :) then i'll move onto binpatching a AppleHDA for this system.

I like Anval's newest bootloader, then netkas released a 32/64bit ATY_Init so i'll use that to change the FB.


I will report back soon. :)

#18
mojtabazarei

mojtabazarei

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:IRAN
hi

i tried on asus n61jq ATI mobility 5730 it work on external display :wacko: not on laptop display


i know it because of LVDS connector :unsure:

http://www.insanelym...p...st&id=88163

#19
checcco

checcco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
Any news atlee? I cant even get my external monitor to' work though I've got a dv6-3103sl which is very similar to yours.
Please help me get at least external monitor. This is what I've done:

1. From my other hack I installed 10.6.3 on my external hd
2. Then applied 10.6.6
3. Overwrite the 4 kexts with the ones provided here.
4. Installed cham, patched kernel and kexts

then i attached my to' laptop and tried to' boot, but i got only my laptop display to' work (without qe/ci)

what's wrong?

#20
mojtabazarei

mojtabazarei

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:IRAN
Hi installed the 10.7 5000 driver on n61jq mobility 5730 the driver is full doesn't have any problem

because i have graphic support for external displays see the in the connector area

there is 3 connector one vga one display port one HDMI these connectors work

but my laptop screen doesn't work because it connected to graphic card by LVDS connector and

apple doesn't support this connector we should edit or dsdt or this driver to make mac os x recognize

this connector to have laptop screen. apple use display port to connect laptop screen to graphic

card so if your screen connected from this way you have laptop screen some acer model are same

as the apple laptops here





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy