Jump to content

[GUIDE] Dell L701X (xps 17 late 2010)

- - - - -

  • Please log in to reply
451 replies to this topic

#441
sl1pm4t

sl1pm4t

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Hey tuxuser, 

 

I'm in the same position as you.

My l501x is working great except for internal keyboard and trackpad.

I get the same boot messages from VoodooPS2Controller.

 

I think this must be a clover issue, for 2 reasons:

- if I boot from Clover to Windows my internal keyboard / trackpad don't work

- I could get the keyboard / trackpad working easily when using Chameleon boot loader.

 

I'm still investigating and will report back here if I get it working. 

I did manage to get the trackpad responding once, but it was very jerky and inaccurate. Also, occasionally the keyboard responds to a key press but then "jams", constantly sending the same key signal forever.

 

My hackintosh seems so much faster booting from Clover than other boot loaders, so I'd really like to get the PS2 working.

 

Cheers

 

 

Hey guys,

 

Thanks a lot for your work on the Dell L501x/L701x - it doesn't seem like an "easy" device to deal with. Am experiencing that currently...

 

EDIT 2

Attached my files for Clover -> L501X GT420M + Intel HD (Optimus), includes all Kexts

Of course its based on the work of vladenas and whitegerry, thx again!

 

Optimus is disabled via DSDT

You just have to put VoodooHDA and patched QE/CI Intel HD 1st Generation Kexts in S/L/E

Intel HD Graphics Kext -> DualLink (cause of FullHD Display) -> Alternate -> Link Width 2 , worked the best for me

 

For initial boot/install you have to delete IntelHDGraphics* from Installer Media!

 

EDIT

Solved the issue by setting the following Option in BIOS

-> USB Emulation -> Disabled

Problem

Internal Keyboard & Touchpad don't work

 

Tried so far

1. Various version of VoodooPS2 & GenericUSBXHCI kexts

2. Expand PS2M / PS2K Section in DSDT

 

Here is maybe useful info, for more detailed info please look in the attached files.

 

Specs

Dell XPS L501X

Intel Core i5 - 560M (Arrandale)

Intel HD 1st Gen + Nvidia GT420M - Optimus - disabled via DSDT

 

OSX Mavericks 10.9.3

 

ID reported by Linux Kernel

(didn't find clear reference to keyboard model)

synaptics: Touchpad model: 1, fw: 7.4, id: 0x1e0b1, caps: 0xd04773/0xa40000/0x8a0400, board id: 3655, fw id: 662324

Used Kexts

CLOVER/kexts/10.9/

Natit.kext

ACPIBacklight.kext - From WhiteGerry
ACPIBatteryManager.kext - From WhiteGerry
IOWMIFamily.kext - From WhiteGerry
RealtekRTL8111.kext - From WhiteGerry

FakeSMC.kext - Latest hwsensors.com
ACPISensors.kext - Latest hwsensors.com
LPCSensors.kext - Latest hwsensors.com
CPUSensors.kext - Latest hwsensors.com
GPUSensors.kext - Latest hwsensors.com

GenericUSBXHCI.kext - Latest RehabMan
VoodooPS2Controller.kext - Latest RehabMan

/S/L/E

AppleHDA.kext - From WhiteGerry
HDACommander.kext - Latest RehabMan
IntelHDGraphics* (patched for 1st Gen IntelHD) 

Debug Messages from VoodooPS2

ApplePS2Controller::start entered...
ApplePS2Controller: initial commandByte = 47
ApplePS2Controller: new commandByte = 44
ApplePS2Controller::start leaving.
ApplePS2Keyboard: Swipe Up: { 003b, 0037, 007e, 107e, 1037, 103b, }
ApplePS2Keyboard: Swipe Down: { 003b, 0037, 007d, 107d, 1037, 103b, }
ApplePS2Keyboard: Swipe Left: { 003b, 0037, 007b, 107b, 1037, 103b, }
ApplePS2Keyboard: Swipe Right: { 003b, 0037, 007c, 107c, 1037, 103b, }
ApplePS2Keyboard::probe entered...
ApplePS2Keyboard::probe leaving.
ApplePS2Keyboard::start entered...
ps2bl: KKCL, KKCM, KKQC methods not found in DSDT
VoodooPS2SynapticsTouchPad Version 1.8.12 loaded...
ApplePS2SynapticsTouchPad::probe entered...
ApplePS2Controller: oldCommandByte = 00
ApplePS2Controller: newCommandByte = 40
ApplePS2Controller: setCommandByte for keyboard interrupt install
VoodooPS2Trackpad: Identify TouchPad command failed
ApplePS2SynapticsTouchPad::probe leaving.
ApplePS2Controller: oldCommandByte = 44
ApplePS2Controller: newCommandByte = 45
ApplePS2Keyboard::start leaving.
ApplePS2SentelicFSP::probe entered...
ApplePS2Controller: Timed out on mouse input stream.
ApplePS2SentelicFSP::probe leaving.
ApplePS2ALPSGlidePoint::probe entered...
E7: { 0x00, 0x00, 0x00 } E6: { 0x00, 0x00, 0x00 }ALPS Device? no
ApplePS2ALPSGlidePoint::probe leaving.
VoodooPS2Mouse Version 1.8.12 loaded...
ApplePS2Mouse::probe entered...
ApplePS2Mouse::probe leaving.

Any help is highly appreciated :)

 

greetz

tux

 

EDIT N°1: Abandoned Natit.kext and injected GFX0 _DSM Method in DSDT, that didn't change anything related to Touchpad & Keyboard though.



#442
tuxuser

tuxuser

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
  • Location:Germany
Hey bud, I already solved it..
Disable USB Emulation in BIOS

#443
sl1pm4t

sl1pm4t

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Sweet, that worked for me too.

 

Does your Trackpad work after sleep? 

Mine wasn't working but I hacked RehabMan's VoodooPS2 code and have it working now.

 

 

Hey bud, I already solved it..
Disable USB Emulation in BIOS



#444
tuxuser

tuxuser

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
  • Location:Germany

EDIT 1 - Brightness / FN Keys are working now - without the need of IOWMIFamily! Big Thx to TimeWalker! Also moved the Thermalzone stuff into DSDT, you don't need a separate SSDT now.

Any suggestions for improvements? - Let me know!

 

I use the following Kexts

ACPIBacklight.kext - Latest RehabMan
ACPIBatteryManager.kext - Latest RehabMan
AppleHDADisabler.kext - No idea tbh
FakeSMC.kext - Latest hwsensors.com
GenericUSBXHCI.kext - Latest RehabMan
RealtekRTL8111.kext - Latest Mieze
VoodooPS2Controller.kext - Latest RehabMan

Made a little DSDT Patch for L501x Optimus (GT420M / Intel HD)

 

Maybe its useful, maybe I f**ked up :P

 

Works for me, except brightness and sleep.

 

greetz

Attached Files



#445
avin7000

avin7000

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
  • Gender:Male
@sl1pm4t @tuxuser hey guys, even I have same Dell L501x with i7 and even I have got this weird keyboard issue :-(

I have not installed Clover on HDD and using it via USB. So if I disable USB Emulation, I can't boot USBs. So is there any better solution for keyboard fix?

You can try my files for l501x: http://pan.baidu.com/s/1i3n7nnf

Do these same settings work with Yosemite as well? And also does this solve that weird keyboard issue?

#446
tuxuser

tuxuser

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
  • Location:Germany
try the other usb ports. the non-USB 3.0 should work

#447
avin7000

avin7000

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
  • Gender:Male

try the other usb ports. the non-USB 3.0 should work

I am using non USB 3.0 ports only. When I disable USB Emulation, I don't have options to boot from USB at all :-/

EDIT: I am an idiot, I can boot into USB actually, it's displayed under 'Removable Devices', I was searching for 'USB Storage'

 

I downloaded @whitegarry's kexts as mentioned herehttp://pan.baidu.com/s/1mgKEu4w

 

Site is in chinese and I can't understand anything :( 

 

So I loaded kexts/config as instructed, but display doesn't appear at all. It gets stuck after 'Missing bluetooth controller transport'. 



#448
tuxuser

tuxuser

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
  • Location:Germany
you need to patch IntelHD 1st Generation Kexts

#449
avin7000

avin7000

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
  • Gender:Male
I downloaded @whitegarry's kexts as mentioned herehttp://pan.baidu.com/s/1mgKEu4w
 
 
So I loaded kexts/config as instructed, but display doesn't appear at all. It gets stuck after 'Missing bluetooth controller transport'. I followed every instructions as given. 
 
1. I am using hardware uuid as Custom UUID:
 
 
<key>CustomUUID</key>
<string>82180000-0000-0000-0200-00020080B0CC</string>
 
2. I generated EDID and added in config:
 
 
<key>CustomEDID</key>
<data>
AP///////wAGEBKgAAAAABwWAQS1MBt4Im+xp1VMniUMUFQAAAABAQEBAQEBAQEBAQEB
AQEBeDeArnA4MkA8MKoAWMEQAAAaeDeArnA4MkA8MKoAWMEQAAAaAAAA/ABpTWFjCiAg
ICAgICAgAAAAAAAAgQKbAQEAAAIBCiAgAPU=
</data>
 
However screen gets stuck. So I used my earlier config and booted. It works. Then I started changing each field of my config to match that of Whitegarry's. And I guess I got almost identical. And it still works! I am comparing each field in Clover Configurator and they are identical. So I don't know why it doesn't work :-/
 
I am attaching three files. 
 
1. The whitegarry given, but edited according to my system, i.e. added EDID and GUID. -- Doesn't work
2. My config which I started from scratch, matches with #1. So it is same as 1. -- WORKS! 
3. Same as #2, without EDID/Graphics section.
 
I don't understand why #1 wouldn't work :|

With #2, laptop turns on and works. however graphics performance is not quite right, i don't find it snappy enough and it turns off after few mins of usage. So I tried removing EDID/Graphics and now it seems to be fine. This is third config. Does wrong EDID can result in laptop shutdown?

Attached Files



#450
whitegerry

whitegerry

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male

It looks strange that #1 wouldn't work for you, haha :)

 

I downloaded @whitegarry's kexts as mentioned herehttp://pan.baidu.com/s/1mgKEu4w
 
 
So I loaded kexts/config as instructed, but display doesn't appear at all. It gets stuck after 'Missing bluetooth controller transport'. I followed every instructions as given. 
 
1. I am using hardware uuid as Custom UUID:
 
 

<key>CustomUUID</key>
<string>82180000-0000-0000-0200-00020080B0CC</string>
 
2. I generated EDID and added in config:
 
 
<key>CustomEDID</key>
<data>
AP///////wAGEBKgAAAAABwWAQS1MBt4Im+xp1VMniUMUFQAAAABAQEBAQEBAQEBAQEB
AQEBeDeArnA4MkA8MKoAWMEQAAAaeDeArnA4MkA8MKoAWMEQAAAaAAAA/ABpTWFjCiAg
ICAgICAgAAAAAAAAgQKbAQEAAAIBCiAgAPU=
</data>
 
However screen gets stuck. So I used my earlier config and booted. It works. Then I started changing each field of my config to match that of Whitegarry's. And I guess I got almost identical. And it still works! I am comparing each field in Clover Configurator and they are identical. So I don't know why it doesn't work :-/
 
I am attaching three files. 
 
1. The whitegarry given, but edited according to my system, i.e. added EDID and GUID. -- Doesn't work
2. My config which I started from scratch, matches with #1. So it is same as 1. -- WORKS! 
3. Same as #2, without EDID/Graphics section.
 
I don't understand why #1 wouldn't work :|

With #2, laptop turns on and works. however graphics performance is not quite right, i don't find it snappy enough and it turns off after few mins of usage. So I tried removing EDID/Graphics and now it seems to be fine. This is third config. Does wrong EDID can result in laptop shutdown?

 

 




#451
avin7000

avin7000

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
  • Gender:Male

It looks strange that #1 wouldn't work for you, haha :)

Yeah :(

So how do I debug this?

#452
avin7000

avin7000

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
  • Gender:Male
and also is your DSDT.aml is vanilla or have you made any tweaks/fixes? @whitegarry





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy