Jump to content

The Fermi "Freeze" Discussion (Possible solutions?)


  • Please log in to reply
249 replies to this topic

#241
AREOS

AREOS

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 287 posts
  • Gender:Male
  • Location:Mexico City
After almost 2 weeks of use in ML there is no freeze in my gtx 460 (GF104 based no freeze since I install Lion a year ago) and I get autosleep function working. But as I said some post before my GTX 560m (GF116 based) on my G74SX laptop is another history. The Freeze that I and others are suffering seems something else. If I use the sleep function it sleep fine but at wake I get the login screen and flickers and the the screen gets black or corrupted the screen freeze I can move the mouse and I get the beach ball spining. I can hear the system sound The system is still working just the screen is freeze no KP. After hard reset in system log I get some NVDAGL channel exception. The same happens if I use some games at full screen or any time I get the display off After idle. If I try to change screen resolution or get mirror display it freeze at blue screen, but again the system is still alive.

My theory is the GLdriver is not disconected or refreshed in the right way and the FB cannot connecticut again.

Please if some one find some help post it!!

Good luck

#242
Riley Freeman

Riley Freeman

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 935 posts
  • Gender:Male
  • Location:The Streets
I stumbled upon a post on a forum earlier from someone with a Gigabyte board and a 460 GTX who was having freezing issues in Windows. They claimed they fixed it by setting the onboard SATA mode in the BIOS from AHCI to IDE. Might be worth a try for anyone who is having freezes. I haven't had any since moving to 10.8 but I also haven't been using it for anything particularly heavy.

#243
ncmontas

ncmontas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
So the only way to solve fermi freeze is by the ML path? Is there no permanent solution other than keeping the VC busy by running video loop or the cuda clock rate apps. Is upgrading to the latest nvidia driver can really solve the problem? need feedback please. --thanks

Lion 1.0.7.4
GTS450
p5kpl-am
E8500
4G

#244
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,123 posts
  • Gender:Male
  • Location:Brazil
I doubt it, people said the same thing when Lion came out.
  • XLR likes this

#245
real3x

real3x

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Gender:Male
I'm with a fermi and the freeze since the far beginning, tried all solution, patched rom (voltage, freq), agressive agpm, soft agpm, and like gringo i always had the freeze (black square at the top left and later freeze without log in console and the last opengl exception), the only solution was cuda clock rate ...

My card is a Gigabyte

GV-N460OC-1GI


Now, 10.8.2 is out since 3 weeks, and, it's definitive, i get 0 freeze since 3 week ... i tried all the things that can freeze my hack, webgl in safari, idle time, 7 days uptime, sleep and wake and nothing, no freeze, since the beginning, before 10.8.2 a freeze occur in max 2 days.

One more thing, we always tried to avoid the GFX to fall down in state 3, the lower state, i tweaked again my agpm to reach state 3 (GPU core 50mhz, etc ...), i'm with this config since a week, and ... no freeze so far (and no lag) ;)

My config : stock nvidia drivers from 10.8.2 - dsdt injection for my GFX (same as GE=yes) - cuda drivers and opencl fix

#246
AREOS

AREOS

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 287 posts
  • Gender:Male
  • Location:Mexico City
Since Lion came out not a single Freeze here. I have a GTX 460 from Zotac. I use the AGPM for GTX 260 inside Mac Pro 5.1 profile, my card use all the 4 PM states and no lag and full performance.

Now I'm on ML 10.8.2 and OpenCL is enabled by default.



#247
XLR

XLR

    2cores1cpu.mov

  • Donators
  • 921 posts
  • Location:חולון
How can you boot with MacPro 5,1 profile without getting a KP on TyMCE kext? Do you have to remove that kext with every system update?

#248
Riley Freeman

Riley Freeman

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 935 posts
  • Gender:Male
  • Location:The Streets

Since Lion came out not a single Freeze here. I have a GTX 460 from Zotac. I use the AGPM for GTX 260 inside Mac Pro 5.1 profile, my card use all the 4 PM states and no lag and full performance.


I had a freeze recently when launching Firefox on my setup. I havent used AGPM for a long time, so I'll give this a try. If nothing else it will get rid of the AGPM unknown platform message during boot. Did you just change the device ID to match and leave everything else as it was?

I still have to patch for OpenCL though.

How can you boot with MacPro 5,1 profile without getting a KP on TyMCE kext? Do you have to remove that kext with every system update?


It's cleaner to use a disabler kext. Here's mine. It disables ApplePolicyControl, AppleTyMCEDriver and AppleUpstreamUserClient. Look at the info.plist to see how it's done.

Attached Files



#249
XLR

XLR

    2cores1cpu.mov

  • Donators
  • 921 posts
  • Location:חולון
Cool, thanks!

#250
ktz

ktz

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male

Where I can check kernel panics log? I have GTS450 with GraphicsEnabler=Yes 10.9

Got some console text over GUI and then it works normal. This is freeze?

 

BTW how GraphicsEnabler works?







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy