Jump to content

The Fermi "Freeze" Discussion (Possible solutions?)


  • Please log in to reply
249 replies to this topic

#221
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,098 posts
  • Gender:Male
  • Location:Brazil
I've been using "CUDA Clock Rate" for this purpose since last summer, set it as login/startup item, set it to 160-200 triangles and hide. There's a modified version attached here in this thread...somewhere...that has no icon so that it is completely invisible when hidden.

According to Activity monitor, it uses around 1% CPU and 16MB RAM.
With it running, GPU temp hovers just below 60 degrees celsius which is acceptable, my GTX 460 doesn't run much cooler than that when idle in Windows 7.

If your refresh rate is 60Hz you need around 180 triangles/sec, on higher refresh rates you can get away with less.

#222
XLR

XLR

    2cores1cpu.mov

  • Donators
  • 889 posts
  • Location:חולון
Wassup folks! Has anyone tried the new Nvidia driver for 10.7.3 yet? http://www.nvidia.co...f01-driver.html

#223
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
indeed but the newer doesn't accept the 460m gtx!!

#224
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,098 posts
  • Gender:Male
  • Location:Brazil
The new driver breaks wake from S3 sleep (it goes to sleep fine but then ends up in coma) and still causes the same freeze as always. GTX 460 here

/EDIT wake from S3 sleep works for me again with the darkwake=1 kernel flag.
Which is odd because from what I have found so far, darkwake=1 is the default.

#225
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
as usual
but how did you install the driver if the setup got stop due to hardware detection?

#226
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,098 posts
  • Gender:Male
  • Location:Brazil
as usual.
copy the installer pkg off of the .dmg, right click, show contents, find distribution.dist, open it with textedit, make the required edits (change the model identifier requirement), save, run the installer.

#227
avkdm

avkdm

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Wassup folks! Has anyone tried the new Nvidia driver for 10.7.3 yet? http://www.nvidia.co...f01-driver.html


Hi All,
I have a "real" mac pro 3.1 and have experienced this freeze - but only in Firefox 11. I Didn't get a freeze until I updated Cuda from 4.1.9 to 4.2.5
I have hex edited the driver for OpenCL to work.
I have rolled back Cuda to see if this fixes it.
Anyone else experience Fermi freeze in OSX Lion on a real Mac Pro?
My card is an ECS GTX460 1 gb

rolled back Cuda 4.1.9 - Still freezes ala KP
rolled back Open CL hex edit - Still freezes
rolled back to original Nvidia driver 270 - still freezes
Original Apple drivers in Lion do not recognise the card.
Only common denominator is that I have just started using Firefox 11 as my Web Browser.
The Machine ran for hours using Chrome without a hitch.
I will test this as well.
edit: mmm strange no freezes after 2 hours - only using Chrome browser.
Firefox get KPs regularly. Ill stop using FF

Edited by avkdm, 27 March 2012 - 11:09 PM.


#228
slayer2333

slayer2333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 204 posts
  • Gender:Male
Hey Guys, i could install the new Nvidia drivers on my G53jw-A1(macro 3,1) with 460m gtx without any problem, i did not get any freeze since then, and osx is much smoother, but i lost like 4-5 fps in cinebench . Im not using osx for games so as long as it goes smooth with photoshop, web browsers and launch pad, i don't care.

#229
tien113

tien113

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
so no solution at this time for gtx460, lion 10.7.3 ??? exept looping video in background ?

#230
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,098 posts
  • Gender:Male
  • Location:Brazil
No, there's no solution.

See post #221 up top, it's not a fix, but way better than looping a video. It's annoying when you can't use your media player for other things.

The modified version of CUDA Clock Rate is available earlier in this thread.

#231
tien113

tien113

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
hi, thanks for helping.

but can you set the triangles and hide it automatic ?

Edited by Gringo Vermelho, 16 April 2012 - 01:11 AM.
Please don't quote entire posts when replying directly below them. Thanks.


#232
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,098 posts
  • Gender:Male
  • Location:Brazil
No, not as far as I know anyway.

It has a weird issue where command+h (hide) will not work right away. You must open another application first, then bring CUDA clock rate to the front, then you can hide it.

It's not very elegant but I prefer using CUDA clock rate to having some looping video occupying VLC because I use it to listen to music and streaming radios sometimes, not a big fan of iTunes.

#233
tien113

tien113

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Did you ever try modified AGPM way ?

I saw many people successfully with that way ...

#234
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,098 posts
  • Gender:Male
  • Location:Brazil
I've tried all known solutions, even tested a couple of modified ROMs with altered power states. Nothing works for me except keeping the card occupied.

I've never seen a 100% confirmation that there are no freezes with a GTX 460 when using a modified AGPM.kext. From what I've read so far, it always freezes sooner or later.

#235
JahRastaMaN

JahRastaMaN

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
  • Gender:Male
  • Location:Brasil
Hello, I wonder if you have any solution for the GTX 560M?
And how could it help?! Thank you.

http://cl.ly/HFr3 - Intel HD OFFline.

http://cl.ly/HHLE - IOREG

http://cl.ly/HCic - teste AGPM.

#236
m4f1050

m4f1050

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
Test OS: 10.7.4 arch=i386 -legacy -f npci=0x3000 pmVersion=0 (only 32bit apps work, running on AMD Phenom II X4 940 processor)
Vid Card: eVGA GTS 450
Video Driver: Retail_270.00.00f06.dmg
Cuda Driver: cudadriver-4.2.macos (4.2.7)

When installing I got an error (yellow triangle with exclamation point) I rebooted with black screen, so I connected video to ATI 5450 (I had this one working before installing the GTS 450 and ran Kext Utility and rebooted again, got video working with GraphicsEnabler=Yes)

I haven't experienced a kernel panic or freeze yet.

----------


Test OS: 10.6.8 arch=i386 -force64 (64bit apps work, running on AMD Phenom II X4 940 processor)
Vid Card: eVGA GTS 450
Video Driver: Retail_256.02.25f1v1.dmg
Cuda Driver: cudadriver-4.2.macos (4.2.7)

Everything installed smooth, when I rebooted it worked right away. I haven't tested a lot since I am testing 10.7.4 but it is the latest driver I found from nVidia, possibly could be worth the try.

#237
tien113

tien113

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
the mountain lion seem fixing the freeze. Im trying it without freeze... 2 days passed...

#238
AREOS

AREOS

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 282 posts
  • Gender:Male
  • Location:Mexico City
Hi, I tried DP1 and I don't had any Fermi Freeze in that release, just a few glitches in some web pages with Safari, but I was happy to see that Fermi Freeze has gone. I let pass DP2 and DP3 and tried DP4, I was disappointed when I found the infamous Fermi Freeze.

So in GM I still have the Fermi Freeze.


I like to ask if someone can upload the NVIDIA kext from DP2 in order to try them. I hope that graphic glitches and Fermi Freeze has gone in that release.

I can't find a working place to download DP2.

Please Help!!!

#239
tien113

tien113

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I never have fermi freeze in ML GM. 2 weeks passed.

#240
scorcho

scorcho

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
Two days in with retail Mountain Lion and there is no freeze on my GTX460, though I still played with AGPM to guarantee that Mission Control and all animations are buttery smooth.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy