Jump to content

[Guida] Installazione SL su Dell XPS 15 L501x


  • Please log in to reply
51 replies to this topic

#1
TyTnMonz

TyTnMonz

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male

-----------------------------------------

AGGIORNAMENTI
31/05 :
  • Disponibile nuovo Kexts Pack per il Post Installazione, testato su 10.6.7.
    Lo trovate allegato in fondo alla guida.
04/05 :
  • Eccoci finalmente! Siamo giunti ad un punto in cui posso direi tranquillamente rilasciarvi un bel pacchettone completo per un'installazione COPLETA e STABILE. Come noterete anche la guida si è decisamente alleggerita...ancora non è perfetto al 1000000% ma il risultato è strabiliante, al limite rilasceremo piccoli aggiornamenti relativi ai singoli pacchetti o al DSDT.
    Buon divertimento!
13/04 :
  • Sta per arrivare un nuovo Pack contenente tutto l'occorrente già Patchato e/o modificato per un perfetto funzionamento, al rilascio di questo Pack la guida verrà leggermente modificata. Aspettate questo pacchetto prima di installare, così fate tutto una volta sola.
24/02 :
  • Modificato punto 14 della guida per l'uso del solo pacchetto ##### 3.2 (la versione 3.1 non è necessaria). Grazie per la segnalazione.
  • Verificata la funzionalità del pacchetto VoodooBattery per avere le informazioni sullo stato di carica. Aggiunto link al pacchetto tra l'elenco del "Materiale occorrente" e installazione al punto 14 della guida.

21/02 :
  • E' finalmente arrivata la scheda WiFi. Confermata la compatibilità "out of the box" per le schede Atheros AR5B93.

12/02 :
  • Aggiunta nota per l'installazione al punto 8. Grazie per la segnalazione.

-----------------------------------------



Ciao a tutti!
Dopo qualche tentativo a vuoto e un paio di problemi sono finalmente qui per proporvi una "guida" all'installazione di Snow Leopard
(ad oggi fino alla versione 10.6.7)
sul notebook in oggetto:

Dell XPS 15 L501x


Attached File  Schermata_2011_02_05_a_02.09.26.png   30.75KB   260 downloads

Premetto che la guida riguarda questo modello specifico,
altri modelli della serie potrebbero necessitare di piccole variazioni nei punti che indicherò man mano.

-------------------------------------------------------------------

Partiamo dalle specifiche tecniche:
  • Processore : Intel Core i7-740M
  • Chipset : Intel Ibex Peak-M HM57, Intel Lynnfield
  • RAM : 4GB DDR3-1333
  • Video : NVIDIA GeForce GT 435M (2048 MB)
  • Audio : Realtek ALC665
  • HD : 500GB Sata
  • WiFi : Intel WiFi Link 1000 BGN
  • Ethernet : Gb Realtek 8168
  • Webcam, Lettore Schede SD, Bluetooth

-------------------------------------------------------------------

Cosa funzionerà/non funzionerà al termine della procedura:
FUNZIONA
  • Video (QE/CI attivi)
  • Audio (perfetto, Linea OUT, IN e HDMI Out)
  • Ethernet
  • Webcam
  • Bluetooth
  • Controlli volume, luminosità e ON/OFF periferiche wireless mediante tasti funzione
  • Tastiera e touchpad
  • Spegnimento
  • Riavvio
  • WiFi : funziona Out Of The Box se acquistate una scheda Atheros AR5B93, 15 € circa dalla baia ( io l'ho presa dagli USA )
  • Sleep
NON FUNZIONA
  • WiFi (possibilità di sostituzione della scheda con una Atheros AR5B93, 15€ circa spedita sulla baia)
  • Sleep

-------------------------------------------------------------------

Ma veniamo alle cose pratiche: di seguito spiegherò nella maniera più semplice possibile i (pochi) passaggi necessari ad ottenere il risultato sopra citato. La mia intende essere una "linea guida" più che una "guida" vera e propria, penso di non essere in grado di insegnare niente a nessuno, riporto semplicemente il procedimento che ho seguito io e che mi ha portato ad avere un bel mostriciattolo tra le mani.
Vi consiglierei di leggere almeno una volta l'intera procedura PRIMA di eseguirla, in modo da sapere già cosa vi aspetta e preparare gli eventuali passaggi, backup, ecc.

Materiale occorrente
  • Snow Leopard Retail DVD
  • BootCD by vladlenas (allegato in fondo al topic) THANKS!!!
    Se non riuscite a bootare con questo usate ##### e seguite la procedura indicata al vecchio punto 5 della guida
  • ##### installer (l'ultima versione che trovate al momento o una precedente)
  • Pacchetto tonymacx86 NVIDIA Update
  • Pacchetto MacOSXUpdCombo10.6.7 scaricato dal sito Apple
  • DELL XPS 15 L501x.zip che trovate allegato in fondo al topic.
    Mettete tutto su una chiavetta USB o un disco esterno.
  • Il vostro BIOS DEVE essere aggiornato alla versione A07 che potete scaricare dal sito ufficiale della DELL relativo al nostro PC
  • File DSDT.aml allegato al post oppure creato da voi (per la procedura di creazione guardate il paragrafo "CREAZIONE DEL DSDT" più avanti)
  • Una seconda partizione con Windows/Linux o altro che vi permetta di accedere alla partizione di OSX (al limite una live di Linux che vi permetta però di scrivere sulla partizione di OSX)
  • AIDA64 + DSDT Editor per Win/Linux per la creazione del proprio DSDT.aml
  • Il sistema è stato testato con il BIOS del Notebook versione A04 e A06
  • VoodooBattery.kext per la misura dello stato di carica. Lo trovate qui .

-------------------------------------------------------------------

Procedimento

1 - Masterizzare la iso di BootCD con il vostro programma preferito.

2 - Inserite il cd nel lettore e riavviate il pc, verificate la versione del BIOS entrando nella finestra di Setup premendo F2 all'avvio. Se la vostra versione è una tra la A04 e la A06 passate al punto successivo, altrimenti leggete il paragrafo "UPGRADE/DOWNGRADE del BIOS" in fondo al topic. Le impostazioni di default del BIOS sono già perfette così come sono, non cambiate nulla.

3 - Premete F12 per visualizzare la finestra delle Opzioni per il Boot. Scegliete di partire dal CD/DVD Rom.

4 - Verrà caricato BootCD con Chameleon 2.0 RC5 r700, estraete il BootCD, inserite il DVD di SL e premete F5 per aggiornare la schermata. Attendete qualche secondo la comparsa dell'icona del DVD di SL.

5 - Selezionate l'icona del DVD di SL e premete invio senza inserire NESSUN kernel flag.


5 - Selezionate l'icona del DVD e inserite i Kernel Flags -v busratio=12 PCIRootUID=1 e premete invio. Se non doveste riuscire ad arrivare alla schermata di installazione aggiungete il flag -x (otterrete -v -x busratio=12 PCIRootUID=1).
Vi ricordo che, essendo la tastiera in configurazione americana, il "-" lo si fa con il tasto [? '] e l'uguale con il tasto [^ ì]; occhio agli spazi.
Nota: il flags "busratio=12" è proprio di questo processore, altri processori su altri modelli potrebbero richiedere un valore diverso; fate riferimento a questa tabella oppure cercate su Google il busratio per il vostro processore.



6 - Arrivati alla schermata principale dell'installazione, se avete già predisposto il disco all'installazione di OSX come di consueto, passate al punto 9, altrimenti (da Disco -> Utility Disco) partizionate il vostro hd in GUID e formattate la partizione destinata a Mac in Mac OS Extended (Journaled) mentre l'altra (o le altre) in FAT.
NB: la procedura formatterà l'intero disco, compresa l'eventuale preinstallazione di Win o altri sistemi, fatevi i vostri backup.

7 - Se volete installare altri sistemi operativi leggete il seguito, altrimenti passate al punto successivo.
Gli altri sistemi operativi (come Windows) possono essere installati anche dopo aver installato OSX che deve però stare sempre e comunque nella prima partizione creata.
Se installate prima OSX e poi Windows, dopo aver installato quest'ultimo dovrete riattivare la partizione di OSX che nel frattempo sarà diventata inattiva per poter bootare con Chameleon.
Per fare ciò seguite questi semplici passaggi: sotto Windows, aprite una finestra CMD (DOS) e scrivete:
  • DISKPART [invio]
  • LIST DISK (per vedere quanti e quali dischi ci sono) [invio]
  • supponendo che abbiate un solo disco chiamato "Disk 0", scrivete SELECT DISK 0 [invio]
  • LIST PARTITION (per vedere quante e quali partizioni ci sono) [invio]
  • cercate quella che contiene OSX e scrivete SELECT PARTITION x (dove x è la partizione di OSX) [invio]
  • ACTIVE [invio]
    dovreste vedere "PARTIZIONE SEGNATA COME ATTIVA" o qualcosa di simile
  • EXIT [invio]
Riavviate e partirà Chameleon.


7 - Installate Win/Linux se desiderate poi fare un DualBoot con questi sistemi, conviene installarli prima di OSX.
Quando il vostro disco sarà partizionato correttamente, il vostro eventuale secondo sistema è installato e operativo e avete tutti i pre-requisiti a posto, potete partire con l'installazione di OSX.


8 - Rieseguite i punti 3 - 4 e 5 esattamente come la prima volta.

Nota: grazie alla segnalazione di alcuni utenti pare che la versione di questo portatile che monta 8GB di RAM crei dei problemi di riavvio continuo dopo la prima installaizone quindi rimuovete uno dei due banchi di RAM in modo da averne solo 4GB, potrete reinserire il secondo banco una volta terminata l'installazione e aggiornato il sistema.

8 - Avviate la procedura di installazione come di consueto e attendetene il completamento. Al termine vi verrà riportato l'esito che sarà "Installazione avvenuta con successo!".

9 - Riavviate, premete F12 per fermare il boot sulla schermata di scelta, togliete il DVD di SL, rimettete il BootCD e questa volta scegliete di bootare dalla partizione su cui avete appena installato OSX. Usate gli stessi Kernel Flags del punto 5 più, eventualmente, il -x. Se tutto è andato bene potrete godervi la presentazione di SL con tanto di audio.

10 - Eseguite la procedura di registrazione come di consueto.

11 - Terminata la procedura finalmente arriverete al Desktop: dato che avete installato la versione 10.6.0 di SL vi ritroverete in Safe Mode, questo perché OSX in quella versione non supporta i processore Core i7, processori che sono supportati ufficialmente solo dalla versione 10.6.4 e successive ( grazie Cura :P ).


In Safe Mode non funziona (almeno a me, ma credo sia sempre così) praticamente niente, nè USB nè Lettore CD/DVD, ecco perchè serve la seconda partizione con Win/Linux: riavviate bootando sempre con l'##### e fate partire Win/Linux, da li dovrete avere accesso alla partizione di OSX (mediante MacDrive sotto Win, non so sotto Linux) in modo da poter copiare, magari sul Desktop di SL, i file che serviranno per il post-install, ovvero: il Combo Update per l'aggiornamento alla 10.6.6, i due pacchetti di #####, il pacchetto tonymacx86 NVIDIA Update e il file DSDT.aml . Copiateli.

13 - Tornate sotto OSX con la ormai solita procedura (##### + Kernel Flags)


14 - Eseguite l'aggiornamento alla 10.6.7 in questo modo:
  • Avviate #####, lasciatelo li aperto senza procedere.
  • Avviate il Combo Update ed eseguite l'installazione, al termine NON riavviate.
  • Tornate a #####, riapritelo se si chiude, e seguite la procedura, selezionate quanto segue:
    • System Utilities - tutte e due
    • Drivers & Bootloaders
    • Miscellaneous
    • FakeSMC, IOUSBFamily Rollback, NullCPUPowerManagement, USB 3.0 NEC/Renesas, Voodoo PS/2 Controller
  • Network
    • Lnx2Mac's RealtekRTL81xx Ethernet (questo pacchetto ha una propria procedura di installazione che dovrete seguire quando richiesta)
  • Bootloaders
    • Chameleon 2.0 RC5 - Prerelease, installerà la versione r699 (usate questa, se nel vostro ##### non dovesse esserci procuratevela)
  • Customization
    • PCI Root ID Fix for Chameleon
  • Themes - quello che volete
  • OSx86 Software - tutti
[/list]15 - Ora scompattate, se già non lo avete fatto, il pacchetto DELL XPS 15 L501x v2.zip che trovate allegato in fondo al topic.

16 - Installate con KextHelper b7 tutti i kexts presenti nella cartella S/L/E.

17 - Copiate e sovrascrivete tutti i file presenti nella cartella Extra dentro la cartella [VOSTRO HD]/Extra

18 - Riparate i permessi con KextUtility, incrociate le dita e riavviate.

19 - Estraete il cd di ##### e riavviate senza fare nulla, se tutto è andato a buon fine SL dovrebbe partire normalmente. Al limite usate il KF -v per verificare eventuali errori in caso di blocco.

Se tutto è andato come dovrebbe potrevete godervi il vostro bel felino!

16 - Giunti al Desktop installate il pacchetto tonymacx86 NVIDIA Update. NON

  • riavviate.
  • Modificate il file com.apple.Boot.plist che si trova in /Extra/ , eliminando la voce PCIRootUID=1 dai Kernel Flags.
  • Riavviate e dovreste avere la grafica abilitata: risoluzione nativa e QE/CI attivi!!!
    NB: il pacchetto tonymacx86 NVIDIA Update, secondo chi lo ha fornito, è compatibile con le schede della serie GeForce GT 430, GTS 450, GTX 460, GTX 465, GTX 470, GTX 480, and GTX 580 e NVIDIA 2xx .
  • Installate VoodooBattery.kext scaricato dal sito ufficiale (l'ultima versione è la 1.3.3 e funziona benissimo) usando KextHelper o altro a vostro piacimento.

-------------------------------------------------------------------

Aggiornamento: Questa parte non è più necessaria, la lascio perché magari può essere utile a qualcun altro.


CREAZIONE DEL DSDT

Testato su Windows7 Home Premium (quello presente al momento dell'acquisto del notebook)

  • Scaricate AIDA64, ex Everest, dal sito di Lavalys. La versione trial va benissimo.
  • Installatelo ed apritelo con diritti di amministratore.
  • Clickate con il tasto destro del mouse sulla parte bassa della finestra e, nel menù contestuale, scegliete ACPI Tool (vedi allegata figura 1)
  • Premete il bottone Save DSDT e salvate il file sul Desktop, si chiamerà acpi_dsdt.bin
  • Scaricate DSDTEditor (allegato al post) e avviatelo. Richiede che sia installato Java e la presenza dell'eseguibile javaw.exe, presente all'interno dello zip. Copiatelo in C:\Windows\System32
  • Ora andate su File -> Extract DSDT
  • Ora su Patch -> Open e caricate il file acpi_dsdt.bin creato in precedenza; nella finestra che si apre date Apply e poi Close
  • Ora IASL -> Compile, ci saranno degli errori -> Fix Errors, ne dovrebbe rimane uno: un doppio click sulla riga dell'errore nella finestra Compile (vedi immagine 2) vi porta alla parte di codice incriminata, cancellate le 4 righe evidenziate in figura, tornate alla finestra Compile, di nuovo Fix Errors e l'errore dovrebbe sparire
  • Ora è necessario modificare il DSDT affinchè non crei il fastidioso problema del reset del BIOS (in realtà non è un grossissimo problema dato che le impostazioni di default del BIOS vanno bene, a meno che a qualcuno di voi, come a me ;) , si rompa l'alimentatore e vi venga in mente di comprarne uno compatibile, non originale. I Dell sono bast***i e si accorgono di non avere il loro alimentatore dando fastidiosi BEEEP all'avvio e non ricaricando più la batteria :censored2: :censored2: , quindi fixiamolo in ogni caso):
    [indent=1]
  • Nella finestra del DSDTEditor, mediante lo strumento cerca (la lente, sesta icona da destra) cercate la stringa "Device (RTC)", arriverete al pezzo di codice visibile in figura 3, cambiate il valore del parametro LENGTH da 8 a 2.
  • Provate a ricompilare tanto per essere sicuri di non aver sbagliato qualcosa. Se non ci sono errori IASL -> Save AML as -> chiamatelo DSDT.aml .

Ecco pronto il nostro DSDT.aml .

Attached File  AIDA.png   135.48KB   246 downloadsAttached File  fix_error.png   384.19KB   282 downloadsAttached File  reboot_fix.png   80.92KB   306 downloads

-------------------------------------------------------------------

Aggiornamento: Questa parte non è più necessaria, la lascio perché magari può essere utile a qualcun altro.

UPGRADE/DOWNGRADE del BIOS

ATTENZIONE: la procedura di Flash del BIOS è una procedura delicata che potrebbe rendere inutilizzabile il pc.
Assicuratevi che l'alimentazione da rete sia attaccata e che la batteria sia inserita e carica.
Non mi assumo nessuna responsabilità per gli eventuali danni che questa procedura potrebbe causare.


La procedura va eseguita da Windows o da DOS.

  • Per eseguire l'upgrade basta andare sul sito della Dell e scaricare il pacchetto di aggiornamento ufficiale della casa madre.
  • Per eseguire il downgrade scaricate l'applicazione Winphlash64 che potete trovare qui (altro non è che la stessa applicazione per l'upgrade modificata per permettere il downgrade) e la versione del BIOS che desiderate (A04 e A06 sono praticamente identiche) dal sito della Dell.
  • Lanciate l'applicazione ufficiale appena scaricata dal sito Dell ma NON eseguite il FLASH (tanto non funzionerà); l'applicazione dovrebbe aver creato dei file temporanei, ci serve quello relativo alla ROM del BIOS e precisamente il file che dovrebbe trovarsi (in Win 7 dovrebbe essere li) in C:\Users\[Vostro nome]\AppData\Local\Temp\BIOS1.WPH . Dovete visualizzare le cartelle e i file nascosti per arrivare li. Copiate il file sul Desktop.
  • Chiudete l'applicazione "originale" e aprite quella "modificata".
  • Mettete la Path del BIOS recuperato dai Temp nella textbox "Specify new BIOS file", selezionate "Backup & Flash" e premete il bottone Flash BIOS.
  • Attendete il termine della procedura, riavviate e controllatene l'esito entrando nella finestra di Setup (F2 all'avvio).

-------------------------------------------------------------------

RINGRAZIAMENTI


Un ringraziamento doveroso a Cura per l'aiuto e per avermi dato il primo fondamentale aiuto per poter partire.

Un grazie ovviamente agli utenti e allo staff di tonymacx86 per averci fornito tutto il materiale utile al pre-install e al post-install.

A vladlenas per aver sviluppato tutti i Kext che troverete nel pacchetto, io ho fatto da cavia :P

-------------------------------------------------------------------


Questa è la mia prima "guida", spero di non aver fatto boiate o scritto stupidate.
Non ho inserito i link ai software forniti da tonymacx86 perchè va contro il loro regolamento e credo anche il nostro. Se invece li posso inserire (puntando direttamente al loro sito, ovviamente) li aggiungerò.

Credo sia tutto per il momento, spero che questo sproloquio risulti utile a qualcuno :P .

Saluti,
TyTnMonz.

Attached File  DELL_XPS_15_L501x.zip   2.47MB   125 downloads
Attached File  DELL_XPS_15_L501x_v2.zip   3.73MB   527 downloads testato con OSX 10.6.7


#2
DriveTheOne

DriveTheOne

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 200 posts
non resta che far funzionare lo sleep..

funziona il final cut pro? bene? va forte? più del Q6600 sicuramente...vero?
la batteria quanto ti dura? ti oscura almeno lo schermo per il risparmio energetico?

nn vedo l'ora di avere un sistema Dell perfetto... :angel:

#3
TyTnMonz

TyTnMonz

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male
Adesso sto aspettando la scheda WiFi che ho acquistato dagli USA, dovrebbe arrivare in settimana, spero.
Poi proverò con gli sleepenabler per vedere se si riesce a fare andare anche lo sleep.

Si, il risparmio energetico è funzionante, come detto nella guida, la luminosità dello schermo può essere regolata manualmente ed entra in funzione automanticamente, diminuendo la luminosità, prima di far partire ad esempio lo screensaver. Purtroppo non ti so dire quanto dura la batteria perchè, come ahimè ho scritto anche nella guida, mi si è rotto l'alimentatore originale e non sono ancora riuscito ad avere uno in sostituzione...sto usando un compatibile che però non mi ricarica la batteria (a causa delle restrizioni imposte da Dell) quindi il portatile lo posso usare solo direttamente alimentato dalla rete elettrica.

FinalCut non l'ho ancora provato.

#4
DriveTheOne

DriveTheOne

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 200 posts
ok, ho visto nella firma...utilizzi la risoluzione a 1366 perchè il tuo monitor ha questa risoluzione o perchè nn funziona la versione fullHD?

prova a disattivare dal bios, il wifi per poi installare il sleepenabler...vedi se funziona! ;)..

se si, direi che è il portatile perfetto! (le cuffie vanno, vero? hdmi? XD esata? insomma bisogna provare tutto prima io dica: è perfetto, lo compro!.. :)

grande! :)

#5
TyTnMonz

TyTnMonz

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male
La risoluzione è nativa: ho la versione 1366x768 perchè, quando mi ero finalmente deciso a comprarlo, gli schermi FullHD erano esauriti, mi sono dovuto accontentare di questo ( e ho risparmiato 200 euro :D ).

L'uscita cuffie funziona, il microfono integrato sembra di no, non ho provato l'ingresso esterno. Non ho periferiche eSata da testare, ma la porta è combo eSata/USB e come USB funziona. Dall'uscita HDMI arriva il video ma non l'audio.

La WiFi può essere accesa/spenta anche direttamente dal sistema, lo sleepenabler semplicemente non l'ho ancora provato.

Domani, se avrò tempo, farò tutte le prove del caso. Resta sintonizzato :) .

#6
DriveTheOne

DriveTheOne

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 200 posts
Ok, perfetto!

se hai bisogno di aiuto, ci sono io (dico per la ricerca dei kext)...
ps: come hai fatto ad avere la scheda 435m e/o processore i7?...non riesco più a trovarlo nei negozi online di Dell :P

Stay tuned! :)

#7
TyTnMonz

TyTnMonz

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male
Era la configurazione top di gamma proposta sotto le feste natalizie. Evidentemente è terminata l'offerta o hanno esaurito le scorte.

Ho provato ad installare l'ultimo sleepenabler ricompilando l'ultimo branch rilasciato da xnu: "funzionicchia", nel senso che mandando il pc in sleep sembra andarci ma in realtà resta acceso, i led sono accesi e la ventola continua ad andare come se si fosse in attività. Forzando però lo spegnimento (tenendo premuto il pulsante di accensione) e riaccendendolo effettivamente si riparte da dove si era lasciato, il pc si risveglia dall'ibernazione e tutto funziona come prima (audio, usb, ecc...). Mi viene però il dubbio che allora funzionasse così anche prima dell'installazione dello sleepenabler.
Sinceramente non ho molta voglia di fare "da cavia", ma se è per il bene della comunità vedrò di sacrificarmi... :P avete proposte da fare a riguardo?

Una volta arrivati ad un punto certo aggiornerò eventualmente la guida.

#8
TyTnMonz

TyTnMonz

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male
Mi è finalmente arrivata la scheda WiFi acquistata dagli USA: confermo la compatibilità e la piena funzionalità out of the box delle schede Atheros AR5B93. :unsure: :wacko:
Guida aggiornata.

#9
TyTnMonz

TyTnMonz

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male
Finalmente ho avuto il tempo di contattare la Dell e farmi mandare l'alimentatore nuovo, ora posso ricaricare la batteria ed eseguire anche qualche test di durata.

Nel frattempo vi segnalo anche la funzionalità del pacchetto VoodooBattery per attivare il monitoraggio della batteria.
Guida Aggiornata.

#10
TyTnMonz

TyTnMonz

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male
Sto collaborando con altri utenti per perfezionare il nostro HackBook Pro ;) .
Presto aggiornamenti sul comparto Audio e Video con pacchetti dedicati e DSDT Injections. Ci stiamo pericolosamente avvicinando al 100% di funzionalità :D :D :D . Stay on touch!

#11
neodomi

neodomi

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Male
ciao per caso sai se questa guida va bene anche per l'xps15 con scheda video nvidia gt540??
comunque ottimo lavoro complimenti

#12
TyTnMonz

TyTnMonz

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male

ciao per caso sai se questa guida va bene anche per l'xps15 con scheda video nvidia gt540??
comunque ottimo lavoro complimenti

Se l'unica differenza è la scheda video direi di si...la GT540 dovrebbe essere supportata dai driver ufficiali installati con il pacchetto NVidiaUpdate. Non te lo posso garantire però.

Approfitto per annunciare che abbiamo quasi completato il nuovo pacchetto per una nuova installazione...ho scoperto che anche se la Scheda Video sembrava funzionare in realtà era a mezzo servizio...anzi forse meno. Ora abbiamo DSDT Injection e kext home made che aumentano di molto le prestazioni del comparto video, kext dedicati per l'audio che fanno funzionare tutte le periferiche e altre piccole migliorie, il tutto a 64bit.

Stiamo mettendo a punto gli ultimi ritocchi, aspetto prima di pubblicare il tutto. Non cambiate canale :D .

#13
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy
Scusa TyTnMonz, funziona anche lo Speedstep ?

#14
AlbeNeX

AlbeNeX

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
salve raga! avevo già installato osx su un altro dell.. un inspiron 6400.. con tanta soddisfazione! quindi diciamo che non sono nuovo del campo.. ho adesso un dell xps 15 l501x con i7 740qm e gt 435m (ovviamente..) hard disk 500gb e ram 4gb entrambe di "stock"..

dapprima avevo a disposizione il solo dvd snow leopard abbinato al macbook di un amico e partiva l'installer ma diceva giustamente "computer non supportato dal disco in uso" (o qualcosa di simile).. adesso ho procurato la versione retail di snow leopard (il dvd bianco con il leopardo per intenderci, anziche il disco grigio) però non riesco proprio ad arrivare all'installer.. ho provato
-v busratio=12 PCIRootUID=1
-v -x busratio=12 PCIRootUID=1

e anche -v -x busratio=17 PCIRootUID=1, questo perchè ho notato più volte che la mia cpu viene rilevata da diverse tool non come i7 740qm ma come i7 820qm.. strano cmq.. ma in ogni caso stesso risultato per le 3 combinazioni e cioè che dopo un po' di caricamento dei necessasri file (stando ancora dentro #####), al momento in cui viene "passato il controllo" all'installer di SL, il pc si riavvia!

avevo come impostazione da bios l'hard disk in modalità ATA ma ho visto che anche mettendo AHCI non cambia nulla..

cosa può essere?


EDIT: auto-risolto.. ho scaricato la versione legacy dell'##### ed ha funzionato =) però strano che con l'altra versione l'altro dvd (non retail) funzionasse!!

#15
TyTnMonz

TyTnMonz

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male

Scusa TyTnMonz, funziona anche lo Speedstep ?

Uhm...sinceramente non so...come faccio a monitorare la frequenza reale del processore in real time?

salve raga! avevo già installato osx su un altro dell.. un inspiron 6400.. con tanta soddisfazione! quindi diciamo che non sono nuovo del campo.. ho adesso un dell xps 15 l501x con i7 740qm e gt 435m (ovviamente..) hard disk 500gb e ram 4gb entrambe di "stock"..
[...]
cosa può essere?

Il BIOS che ti dice riguardo il processore? Che modello ti da? Direi di prendere la sua come risposta buona...che versione di BIOS hai?
Quale versione di ##### stai usando?

#16
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy

Uhm...sinceramente non so...come faccio a monitorare la frequenza reale del processore in real time?

Il BIOS che ti dice riguardo il processore? Che modello ti da? Direi di prendere la sua come risposta buona...che versione di BIOS hai?
Quale versione di iBoot stai usando?



Con VoodooMonitor puoi vedere i moltiplicatori che scattano, se cerchi in area FAQ c'è un topic di Smith@@.
Se riesci a farlo funzionare la carica della batteria durerà molto di più e il processore prenderà un po' di fiato ogni tanto.

#17
AlbeNeX

AlbeNeX

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts

Il BIOS che ti dice riguardo il processore? Che modello ti da? Direi di prendere la sua come risposta buona...che versione di BIOS hai?
Quale versione di ##### stai usando?

ho la A06.. non ho controllato e non posso controllare adesso cosa dice il bios riguardo il processore.

adesso ho usato l'ultima versione di ##### e tutto è filato liscio.. unica nota da fare: subito dopo l'installazione, se avvio osx non va in safe mode.. cioè mi funziona "tutto" o meglio, wifi (con scheda atheros), ethernet, webcam (mi scatta pure la foto profilo..), dvd-rom.. infatti sto scaricando ed estraggo/installo comodamente da osx stesso senza bisogno di windows+macdrive!
altra stranezza dato che ho la stessa identica configurazione tua! hai usato il dvd retail originale con stampigliato Version 10.6 2Z691-6428-A

PS: Un grande grazie per la guida e per lo sbattimento che mi hai evitato! sarei ben lieto di offrirti un caffè o una birra :D


edit: ho completato la procedura tranquillamente ^^ ed è tutto apposto.. unica "pecca" ma che penso presto sistemerò in qualche modo è il trackpad! infatti prima di usare ##### bene o male faceva scroll (a due dita oppure laterale) adesso invece non viene rilevato come trackpad ma come mouse e lo scroll a due dita o laterale non funziona

edit2: neanche il microfono interno va'.. inoltre noto che sta molto più caldo in idle e in uso normale tanto che la ventolina è sempre accesa e il piano d'appoggio delle mani diventa caldissimo.. non oso pensare d'estate cosa succederà XD credo sia dovuto al mancato funzionamento dello speedtest e, sicuramente, anche alla scheda video che magari sarà sparatissima, senza nessuna politica di risparmio energia (problema che tral'altro hanno anche gli ultimi driver video per windows, gli A04)

#18
TyTnMonz

TyTnMonz

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male

ho la A06.. non ho controllato e non posso controllare adesso cosa dice il bios riguardo il processore.

adesso ho usato l'ultima versione di ##### e tutto è filato liscio.. unica nota da fare: subito dopo l'installazione, se avvio osx non va in safe mode.. cioè mi funziona "tutto" o meglio, wifi (con scheda atheros), ethernet, webcam (mi scatta pure la foto profilo..), dvd-rom.. infatti sto scaricando ed estraggo/installo comodamente da osx stesso senza bisogno di windows+macdrive!
altra stranezza dato che ho la stessa identica configurazione tua! hai usato il dvd retail originale con stampigliato Version 10.6 2Z691-6428-A

Hai ragione...io ancora non avevo la scheda WiFi Atheros, quindi non mi andava, la scheda Ethernet invece era un po' ballerina...la primissima installazione l'avevo fatta con la versione 3.1 di ##### che ancora non aveva il kext Lnx2Mac's...la webcam funzionava anche a me (e mi ero stupito di questo), mentre il DVD-Rom sembrava non voler aprire i cd/dvd..a questo punto mi sorge il dubbio che fosse masterizzato male...ma mi pare strano. La seconda volta (l'attuale installazione) avevo già la partizione Windows pronta e tutti i file li, quindi da Mac li ho potuti prendere direttamente senza fare avanti e indietro. Le USB ti funzionavano?
Riguardo la questione processore è un mistero...quale busratio hai usato alla fine? Probabilmente non ti partiva perchè usavi una versione di ##### inferiore alla 2.6, solo da questa in poi infatti sono stati inseriti i driver per la scheda grafica e la necessità di usare il kf "PciRootUID=1".

PS: Un grande grazie per la guida e per lo sbattimento che mi hai evitato! sarei ben lieto di offrirti un caffè o una birra ^_^

Ti pare...ho fatto da cavia ma ne sono soddisfatto...io comunque sono a Milano, non so tu ;) .

edit: ho completato la procedura tranquillamente ^^ ed è tutto apposto.. unica "pecca" ma che penso presto sistemerò in qualche modo è il trackpad! infatti prima di usare ##### bene o male faceva scroll (a due dita oppure laterale) adesso invece non viene rilevato come trackpad ma come mouse e lo scroll a due dita o laterale non funziona

Come scritto qualche post sopra, sta per arrivare un pacchetto completo contenente vari Fix, tra cui questo, conto di rilasciarlo entro fine settimana.

edit2: neanche il microfono interno va'.. inoltre noto che sta molto più caldo in idle e in uso normale tanto che la ventolina è sempre accesa e il piano d'appoggio delle mani diventa caldissimo.. non oso pensare d'estate cosa succederà XD credo sia dovuto al mancato funzionamento dello speedtest e, sicuramente, anche alla scheda video che magari sarà sparatissima, senza nessuna politica di risparmio energia (problema che tral'altro hanno anche gli ultimi driver video per windows, gli A04)

Che il microfono interno non sarebbe andato c'è scritto anche nella guida :rolleyes: ...il nuovo pack corregge anche questo.
Riguardo il calore io non noto un eccessivo surriscaldamento, la ventola è sempre accesa e pare sempre al massimo, è vero, ma la superficie del portatile non si scalda, nemmeno il piano d'appoggio dei polsi. Ieri ho provato a installare VoodooMonitor per verificare la questione speedstep ma mi da KP al boot sia a 64 che a 32 bit (con il nuovo pack si avvia a 64bit ;) ), quindi ho lasciato perdere per il momento, non avevo tempo di verificare, magari appena ho tempo do un'occhiata. Riguardo invece alla scheda video ho scoperto che seguendo la guida il completo funzionamento è solo apparente: QE/CI attivi e risoluzione nativa corretta, ma se provi a fare qualche bench tipo NovaBench vedrai che le prestazioni sono orripilanti.

In conclusione, aspettate un paio di giorni il rilascio del nuovo pack prima di mettervi ad installare tutto e fare le personalizzazioni...così potrete al limite eseguire una nuova e più pulita installazione con tutte le nuove ottimizzazioni. Ora lo scrivo anche in cima alla guida.

#19
AlbeNeX

AlbeNeX

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts

Hai ragione...io ancora non avevo la scheda WiFi Atheros, quindi non mi andava, la scheda Ethernet invece era un po' ballerina...la primissima installazione l'avevo fatta con la versione 3.1 di ##### che ancora non aveva il kext Lnx2Mac's...la webcam funzionava anche a me (e mi ero stupito di questo), mentre il DVD-Rom sembrava non voler aprire i cd/dvd..a questo punto mi sorge il dubbio che fosse masterizzato male...ma mi pare strano. La seconda volta (l'attuale installazione) avevo già la partizione Windows pronta e tutti i file li, quindi da Mac li ho potuti prendere direttamente senza fare avanti e indietro. Le USB ti funzionavano?
Riguardo la questione processore è un mistero...quale busratio hai usato alla fine? Probabilmente non ti partiva perchè usavi una versione di ##### inferiore alla 2.6, solo da questa in poi infatti sono stati inseriti i driver per la scheda grafica e la necessità di usare il kf "PciRootUID=1".
Ti pare...ho fatto da cavia ma ne sono soddisfatto...io comunque sono a Milano, non so tu ;) .
Come scritto qualche post sopra, sta per arrivare un pacchetto completo contenente vari Fix, tra cui questo, conto di rilasciarlo entro fine settimana.
Che il microfono interno non sarebbe andato c'è scritto anche nella guida ;) ...il nuovo pack corregge anche questo.
Riguardo il calore io non noto un eccessivo surriscaldamento, la ventola è sempre accesa e pare sempre al massimo, è vero, ma la superficie del portatile non si scalda, nemmeno il piano d'appoggio dei polsi. Ieri ho provato a installare VoodooMonitor per verificare la questione speedstep ma mi da KP al boot sia a 64 che a 32 bit (con il nuovo pack si avvia a 64bit :P ), quindi ho lasciato perdere per il momento, non avevo tempo di verificare, magari appena ho tempo do un'occhiata. Riguardo invece alla scheda video ho scoperto che seguendo la guida il completo funzionamento è solo apparente: QE/CI attivi e risoluzione nativa corretta, ma se provi a fare qualche bench tipo NovaBench vedrai che le prestazioni sono orripilanti.

In conclusione, aspettate un paio di giorni il rilascio del nuovo pack prima di mettervi ad installare tutto e fare le personalizzazioni...così potrete al limite eseguire una nuova e più pulita installazione con tutte le nuove ottimizzazioni. Ora lo scrivo anche in cima alla guida.

Il problema era il cd di boot che andava con le versioni OEM ma non con le RETAIL.. quindi una cosa banale insomma.. e avevo sempre usato busratio=12 e PCIRootUID=1, quindi ok
gli usb non li ho provati durante la "sosta" sul 10.6.0 quindi non saprei..
l'ethernet invece viaggiava bene (ho trasferito tutto l'occorrente da un altro pc alla velocità media di 30MB/s), niente balletti :D
sorry per il microfono, evidentemente mi sarà sfuggito XD, sarà utilissimo per FaceTime e skype !
per quanto riguarda l'accelerazione grafica il 2d va bene.. anche se ogni tanto da colpi di lag molto percettibili e per nulla tipici di leopard, però tipo frontrow funziona senza problemi (invece spesso e volentieri su altri hackbook con qe/ci attivi, crashava o andava stralento)
attendo allora con ansia questo fix, anche se mi "infogno" in queste robe mangiatempo proprio quando sono sotto esame Xd
ah comunque è un problema per la birra! dato che sono di Catania ahah anche se salirò presto per veder Roger Waters ^^

add: giusto per statistica! ho fatto il novabench e ho ottenuto questi risultati.. in caso chi ha seguito questa guida posti i propri risultati in modo da analizzare meglio la situazione e gli eventuali miglioramenti a seconda dei kext usati

2011-04-13 14:12:12 +0200
Mac OS X 10.6.6
Intel Core i7 @ 1000 MHz
Graphics Card: GeForce GT 435M

4096 MB System RAM (Score: 109)
- RAM Speed: 2954 MB/s

CPU Tests (Score: 368)
- Floating Point Operations/Second: 142721568
- Integer Operations/Second: 304063456
- MD5 Hashes Calculated/Second: 552160

Graphics Tests (Score: 185)
- 3D Frames Per Second: 381

Hardware Tests (Score: 9)
- Primary Partition Capacity: 55 GB
- Drive Write Speed: 54 MB/s

add2: a confrontare questi dati con bench fatti tramite NovaBench su due MacBook Pro rispettivamente edizione fine 2009 (con intel core 2 duo) e aprile 2010 (con i5), i dati non si scostano di molto..
i miei numeri risultano molto migliori del core 2 duo, soprattutto sulla grafica (185 vs 28) e sulla cpu (368 vs 182), ram pressoché identica (109vs108)..
invece il MacBook Pro con i5 risulta migliore sulla ram di quasi il doppio (cosa che non capisco dato che sono entrambe configurazioni da 4gb ddr3, uguale tra l'altro a la ram montata nel macbook precedente), poco inferiore sulla cpu, simile per quanto riguarda la grafica

#20
avin7000

avin7000

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
Thank you very very much for the guide. Can you please tell me post installation instructions ?

in #####, checkboxes and configs ?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy