Jump to content

ATI Radeon HD 5450 Working On Snow Leopard


  • Please log in to reply
159 replies to this topic

#1
terranova2142

terranova2142

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:Deutsch
Sorry For My English BadPosted Image
My graphics card ati radeon hd 5450 working on snow leopard after installed 10.6.6.

And how do make them work

Only For Kernel Vanilla

Waring Backup Your Data
1.Download the all_in_one.rar(down)
2.Install ATI Chameleon bootloader for Radeon HD5000 or kabyl boot
3.The ROM image under /Extra should be named <vendorid>_<deviceid>.rom(ATI 5450 is 1002_68f9.rom)
4.Install Atiframebuffer.kext and ATY_init.kext to S/L/E (ATI5000Controller don’t need)
5.Edit com.apple.boot.plist

<key>Kernel Flags</key>
<string>arch=i386</string
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>UseAtiROM</key>
<string>Yes</string>
<key>AtiFb</key>
<string>Hoolock</string>
<key>Graphics Mode</key>
<string>Your Resolutions </string>

ATI 5450 tested Fb working on Uakari,Vervet,Hoolock and other untested.Recommend Hoolock.

6.Install update 10.6.4 reboot and install graphic update 1.0 (if you get kernel panic after installed graphic update 1.0,try boot –x to safe mode and remove all ATIRadeonX3000.kext,I use hfs+ for windows to remove it )(the graphic update 1.0 only for 10.6.4)
7.Open OSX86Tool repair permissons.
8.Install Update 10.6.6 will add ATIRadeonX3000.kext,ATI5000Controller.kext

After reboot will it work,you need to do step by step,If you get any error tell me. ;)
link download

Attached File  All_in_one.zip   746.09KB   3978 downloads
http://supportdownlo...csUpdate1.0.dmg

Attached File  Screen_shot_2011_02_26_at_11.10.00_AM.png   860.31KB   2759 downloadsATI 5450 is 68f9
ATY_init.kext not support 5450 so it will display the 5500
Attached File  Screen_shot_2011_01_29_at_2.41.12_PM.png   1.31MB   2482 downloads
Attached File  Screen_shot_2011_01_29_at_2.43.13_PM.png   1.24MB   1709 downloads
Attached File  Screen_shot_2011_01_31_at_3.51.37_PM.png   1.23MB   1488 downloads
Attached File  Screen_shot_2011_02_24_at_4.36.12_PM.png   1.01MB   1285 downloads
QE CI it work

Attached Files



#2
james21

james21

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 5 posts
Any chance this would work similarly for the ATI mobility Radeon 4650?

#3
Edward J

Edward J

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Update: Apparently I'm a dumbass. Just follow the instructions, mmmkay? There is apparently a graphics update 1.0 floating around the internet that anyone can find. Silly Me. Found it and all is well....

Hey thanks so much for posting this info.... quick question though... on step 5 after installing update 10.6.4 and then you say to install "Graphics Update 1.0". Where is this found? Is it a file/package or something I download via Software Update?

I am stuck on that step in between 10.6.4 and 10.6.6, Software Update wants to take me to 10.6.6 but I don't got the graphics update yet....

Sorry For My English BadPosted Image
My graphics card ati radeon hd 5450 working on snow leopard after installed 10.6.6.

And how do make them work

Waring Backup Your Data

1.Install ATI Chameleon bootloader for Radeon HD5000
2.The ROM image under /Extra should be named <vendorid>_<deviceid>.rom(ATI 5450 is 1002_68f9.rom)
3.Install Atiframebuffer.kext and ATY_init.kext(ATI5000Controller don’t need)
4.Edit com.apple.boot.plist

<key>Kernel Flags</key>
<string>arch=i386</string
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>UseAtiROM</key>
<string>Yes</string>
<key>AtiFb</key>
<string>Uakari</string>
<key>Graphics Mode</key>
<string>1400x1024x32</string>

ATI 5450 tested Fb working on Uakari,Vervet,Hoolock and other untested

5.Install update 10.6.4 reboot and install graphic update 1.0 (if you get kernel panic after installed graphic update 1.0,try boot –x to safe mode and remove all ATIRadeonX3000.kext,I use hfs+ for windows to remove it )
6.Open OSX86Tool repair permissons.
7.Install Update 10.6.6 will add ATIRadeonX3000.kext,ATI5000Controller.kext

After reboot will it work,you need to do step by step,If you get any error tell me. :lol:
link download

Attached File  All_in_one.zip   746.09KB   3978 downloads

ATI 5450 is 68f9
Attached File  Screen_shot_2011_01_29_at_2.41.12_PM.png   1.31MB   2482 downloads
Attached File  Screen_shot_2011_01_29_at_2.43.13_PM.png   1.24MB   1709 downloads

Apply For All ATI 5000 Series,you need to make own rom and other frambuffer.
Good Luck!!! :)



#4
Edward J

Edward J

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
I think this is it... http://support.apple...csUpdate1.0.dmg

#5
Pechorin

Pechorin

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

2.The ROM image under /Extra should be named <vendorid>_<deviceid>.rom(ATI 5450 is 1002_68f9.rom)
[/size]


Sorry for the stupid question
what to do with the file 1002_68f9.rom???
put it in a folder macintosh HD / Extra? Is that all?

#6
terranova2142

terranova2142

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:Deutsch

Sorry for the stupid question
what to do with the file 1002_68f9.rom???
put it in a folder macintosh HD / Extra? Is that all?


yes put in Macintosh HD / Extra

#7
Edward J

Edward J

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

yes put in Macintosh HD / Extra


Thank you SOOO Much you have NO IDEA how effing happy I am jumping up and down to have this working LOL you really made my day. Take a day off, you deserve it, bro :-)


(or keep helping us :) )

#8
terranova2142

terranova2142

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:Deutsch

Thank you SOOO Much you have NO IDEA how effing happy I am jumping up and down to have this working LOL you really made my day. Take a day off, you deserve it, bro :-)


(or keep helping us :P )

So what's your card and it work?

#9
humm3r

humm3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I have a 5450 and 5770 at home that I'd like to make work for OSX. Does this give you HDMI audio as well?

#10
ximochimo

ximochimo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
HI:

I have an ATI Sapphire HD5450, but I don´t understand steps 1-4... sorry, it's my first Hackintosh... and I don't speak english quiet good

Thanks

#11
terranova2142

terranova2142

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:Deutsch

I have a 5450 and 5770 at home that I'd like to make work for OSX. Does this give you HDMI audio as well?


My monitor not supported HDMI and I not have cable HDMI,if your card working plss report the photo for me :wacko: I want see

#12
ximochimo

ximochimo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Hi:

I have an ATI Sapphire HD5450, and I'm trying your instructions... but I'm doing something wrong... I think I'm not understanding step 2... what it means?

Thanks a lot and sorry for my english

#13
terranova2142

terranova2142

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:Deutsch

Hi:

I have an ATI Sapphire HD5450, and I'm trying your instructions... but I'm doing something wrong... I think I'm not understanding step 2... what it means?

Thanks a lot and sorry for my english



you must download the rom in all_in_one.rar extra rom and put in Macintosh HD / In forder extra

#14
alicious

alicious

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
sorry for the rather noobish question but for step 3, you do mean to just copy them to the /System/Library/Extensions folder, correct?

i'm trying to follow these instructions to the letter and don't want to mess it up.

thanks

#15
angang

angang

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

sorry for the rather noobish question but for step 3, you do mean to just copy them to the /System/Library/Extensions folder, correct?

i'm trying to follow these instructions to the letter and don't want to mess it up.

thanks


"extra" folder is created by Chameleon... in your HD root folder/extra.

#16
alicious

alicious

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

"extra" folder is created by Chameleon... in your HD root folder/extra.


Okay, thanks. I wasn't sure seeing how he didn't say to move those files there but to just

3.Install Atiframebuffer.kext and ATY_init.kext

So I kinda read that as in it had to be actually installed in the folder I mentioned somehow, but copying it over is simple enough. Thanks again.

#17
Vorkey

Vorkey

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Thanks!

Been looking for something to get ATI Radeon 5450 working. I'm going to try it out.

#18
DeMoOL

DeMoOL

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Thanks white_apple_x86 for your work! very nice from spain!

thanks! capture :(

#19
Vorkey

Vorkey

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Well it worked but I think I did something wrong because I don't have any other resolutions apart from the one I added to the boot.plist

Also, its a bit sluggish.

And my vram appears as 256 instead of 512

#20
Pechorin

Pechorin

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Well it worked but I think I did something wrong because I don't have any other resolutions apart from the one I added to the boot.plist

Also, its a bit sluggish.

And my vram appears as 256 instead of 512


i have same problem...
In fact, card appears immediately after the installation clear system, without #####, and then all these manipulations do not give any results ...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy