Jump to content

Mobility Radeon - 10.6.6/7 guide for QE/CI - testing 10.7


  • Please log in to reply
563 replies to this topic

#381
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts
Good job. You're now on the right direction on getting your LVDS working by referring latest macbook pro's IORegistry. As I said before, to know any new property used by dual-link LVDS transmitter is by looking in the latest macbook pro's IORegistry.

From Kizwan's collected reports, maximum fully successful LVDS resolution is WXGA display (1366x768)
Kizwan has stated that this is because higher resolutions require dual link LVDS connection, but this conflicts with Wikipedia
http://en.wikipedia....isual_Interface

That is wikipedia for DVI. It is not LVDS. You can refer to this datasheet for LVDS. Look in the "Description" section:-
"The TC358764 bridge has a single-link LVDS transmitter and can support up to a WXGA panel resolution (1366x768, 24-bit/pixel). The TC358765 bridge has a dual-link LVDS transmitter and can support up to WUXGA panel resolution (1920x1200, 18-bit/pixel)." This is the best document I can find on LVDS with quick search (can't do any extensive search right now).

#382
KUGLee

KUGLee

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
wmarsh

I've used the FB and patch that you posted.
My specs:

Mobo: Dell Inspiron 1545 (Intel)
CPU: Mobile DualCore Intel Core 2 Duo T6600, 2200 MHz
Memory: 2x2 GB DDR2 (400 MHz)
Graphics: ATI Mobility Radeon HD 4330 (512 MB)
Sound: IDT 92HD71B7X
Ethernet: Generic Marvell Yukon 88E8048 PCI-E Fast Ethernet
Wireless: Dell Wireless 1397 WLAN mini
Storage: WDC WD3200BEVT-75ZCT2 298 GB
Optical: Optiarc DVD+-RW AD-7700H

Graphics Processor Properties:
Video Adapter ATI Mobility Radeon HD 4330 (Dell)
BIOS Version 011.022.003.006.032831
BIOS Date 04/21/09,11:28:5
GPU Code Name M92
Part Number BR32831-001
PCI Device 1002-9552 / 1028-02AA (Rev 00)
Process Technology 55 nm
Bus Type PCI Express 2.0 x16 @ x16
Memory Size 512 MB
GPU Clock 300 MHz (original: 450 MHz)
RAMDAC Clock 400 MHz
Pixel Pipelines 4
Texture Mapping Units 8
Unified Shaders 80 (v4.1)
DirectX Hardware Support DirectX v10.1

Memory Bus Properties:
Bus Type DDR2
Bus Width 64-bit
Real Clock 250 MHz (DDR) (original: 500 MHz)
Effective Clock 500 MHz

Monitor

[ InnoLux BT156GW01 ]

Monitor Properties:
Monitor Name InnoLux BT156GW01
Monitor ID INL000A
Manufacturer 1G5D3_156GW01
Monitor Type 15.6" LCD (WXGA)
Manufacture Date 2009
Serial Number None
Max. Visible Display Size 34 cm x 19 cm (15.3")
Picture Aspect Ratio 16:9
Brightness 220 cd/m2
Contrast Ratio 600:1
Maximum Resolution 1366 x 768
Gamma 2.20
DPMS Mode Support None

#383
wmarsh

wmarsh

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 900 posts

wmarsh

I've used the FB and patch that you posted.

Well I guess this is my morning for eating crow.

You have almost my exact computer -- I just have the 1400x900 monitor.

And you must have used the ATIFramebuffer I posted in the 1545 thread, as thats the only one I posted, with my new injector. Seems like an obvious combination, but I was fixated on the 2011MBP kexts and actually did not try that.

Good job. You're now on the right direction on getting your LVDS working by referring latest macbook pro's IORegistry. As I said before, to know any new property used by dual-link LVDS transmitter is by looking in the latest macbook pro's IORegistry.

That is wikipedia for DVI. It is not LVDS. You can refer to this datasheet for LVDS. Look in the "Description" section:-
"The TC358764 bridge has a single-link LVDS transmitter and can support up to a WXGA panel resolution (1366x768, 24-bit/pixel). The TC358765 bridge has a dual-link LVDS transmitter and can support up to WUXGA panel resolution (1920x1200, 18-bit/pixel)." This is the best document I can find on LVDS with quick search (can't do any extensive search right now).

I stand corrected, and thank you for the input.
I have edited the top post.

Now if I can repeat what KUGLee did on my 1545, I will be happy.

#384
wmarsh

wmarsh

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 900 posts

I think this is due to a problem with GraphicsEnabler and have begun working on a fix including a recomplied injector
http://www.insanelym...00#entry1661742

If anyone wants to help work on this Chameleon patch for dual link LVDS, I appreciate the input.

The last significant programming I did was a utility to dump error messages from video memory to printer in CP/M.

I have obtained another partial ioreg, this one from an iMac 11,1

#385
pepito1

pepito1

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

Once we have a modified kext that would work, yes.
Since no other 3xxx people have volunteered, you have the opportunity to be 1st.

Thats why they call it "the bleeding edge"






If you give me a .kext to install, I can be your beta tester.

#386
sydlix

sydlix

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
just tried with the supposedly correct values 12 00, dsdt aml modified with dsm mode, imac 11,1 smbios. LVDS starts off, then detect displays, still BLACK.

#387
wmarsh

wmarsh

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 900 posts

just tried with the supposedly correct values 12 00, dsdt aml modified with dsm mode, imac 11,1 smbios. LVDS starts off, then detect displays, still BLACK.

Same problem I have with new injector. I think there is another piece to the puzzle.

Took another look at the MBP ioreg I posted. There are a few more values I can inject that I missed on 1st pass. None had particularly promising names.

#388
DonKurdi

DonKurdi

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
hi wmarsh have you tried (ATY_init.kext) cause when i deleted it QE/CI has gone!!! maybe it can be one piece of puzzle???

#389
sydlix

sydlix

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

Same problem I have with new injector. I think there is another piece to the puzzle.

Took another look at the MBP ioreg I posted. There are a few more values I can inject that I missed on 1st pass. None had particularly promising names.

wmarsh, I think we are close. I got the display working at boot. DO NOT KNOW WHY. It was extended to to vga I did not have the bar and I could not take any information. It was completely random, I cannot replicate. I have your lines in my boot file but maybe we are looking for something else, like:

http://support.apple.com/kb/TA24192

I think is some kind of bad nvram I dunno.

Investigate.

#390
wmarsh

wmarsh

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 900 posts

hi wmarsh have you tried (ATY_init.kext) cause when i deleted it QE/CI has gone!!! maybe it can be one piece of puzzle???

No I have not tried it. But I did look at it - netkas has a new version - and there are no mobility devid in its info.plist and netkas has said in the past mobility is not supported. Shouldn't be any different than GraphicsEnabler - netkas contributed his code to GraphicsEnabler. But I could look at it again.

#391
mucha

mucha

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male

Same problem I have with new injector. I think there is another piece to the puzzle.

Me too i think there is still some pieces missing, i was doing some testing but so far no more progress :)
i will post my latest find & give up

#392
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

Me too i think there is still some pieces missing, i was doing some testing but so far no more progress :unsure:
i will post my latest find & give up

Please post your configuration at collection's thread. So far I'm the only one has done it. ;)
Sorry, you already did. :P

#393
wmarsh

wmarsh

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 900 posts
I have placed a feature request at voodooprojects.org in the hopes of getting the interest of some of the Chameleon developers in helping us add dual link LVDS support to Graphics Enabler.

#394
mucha

mucha

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male

I have placed a feature request at voodooprojects.org in the hopes of getting the interest of some of the Chameleon developers in helping us add dual link LVDS support to Graphics Enabler.


Get the module_system branche by typing at terminal:

svn co http://forge.voodooprojects.org/svn/chameleon/branches/module_system

you will find source files at your home folder, then replace ati.c file by the one i modded but before compiling make sure to include your device id & default fb as i shrinked that part.
for me it just inject more entries into ioreg (cosmetic), i don't see any difference (but my system is good already), may be it can bring something new for you.
i have tried DSDT injection before but no go too

Attached Files



#395
wmarsh

wmarsh

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 900 posts

Get the module_system branche by typing at terminal:

svn co http://forge.voodooprojects.org/svn/chameleon/branches/module_system

you will find source files at your home folder, then replace ati.c file by the one i modded but before compiling make sure to include your device id & default fb as i shrinked that part.
for me it just inject more entries into ioreg (cosmetic), i don't see any difference (but my system is good already), may be it can bring something new for you.
i have tried DSDT injection before but no go too

What a wonderful surprise! Yesterday I made a list of changes to make -- pretty much mirrored what you did -- I think the EFIDispConfig may have been the key -- and you had already made them! Unfortunately the board went down before I posted a reply.

The properties successfully inject -- attached find ioreg using 10.6.7 Flicker

Testing results:
10.6.7 Kexts: Bootloader works, and Graphics system now starts. Now connects with predicted encoder/decoder of 02 00 which it did not before. QE works. Flicker acts exactly the same with white lines, etc. Shrike no longer connects. Gliff connects (did not before) but screen shakes occasionally. Changing features to 29 05 and 09 03 had no effect.

10.7 kexts: Flicker no longer connects -- black screen -- system functional so I could get ioreg.
Gliff screen scrambled and unreadable. Did not test Shrike.

10.6.7mbp kexts: will test these next. I am hopeful (as stated before) these will work best, but did not want to eat crow by not testing std ones 1st.

Updated version posted on 1st post and on voodooprojects.org

Thank you for your help.

#396
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

svn co http://forge.voodooprojects.org/svn/chameleon/branches/module_system

Can I use the modified ati.c with trunk? Or module_system branch is required for the newly injected property to work properly?

@wmarsh, you ruined the collection's thread. :D The thread supposedly free from discussion. You can post here for any suggestion. Yes, the post format can be anything as long as it's clean. The format I suggest to follow is just a guideline.

#397
CarmeB

CarmeB

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 177 posts
  • Gender:Male
  • Location:Catanzaro, Italy
Little OT: For ati mobility radeon hd3470 function?

#398
wmarsh

wmarsh

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 900 posts

@wmarsh, you ruined the collection's thread. :P The thread supposedly free from discussion. You can post here for any suggestion. Yes, the post format can be anything as long as it's clean. The format I suggest to follow is just a guideline.

NP, I deleted it. But a shorter format would be less intimidating.

Little OT: For ati mobility radeon hd3470 function?

No one has tried 3xxx yet. Don't know if bcc9's tool to generate sensid will work. We welcome your input.

#399
goksel

goksel

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
hello again could you please your files ( thunk s boot file,dsdt and framebuffer) to forum for me and 5738 with 4570 owner thank you all of you

#400
wmarsh

wmarsh

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 900 posts

Get the module_system branche by typing at terminal:

svn co http://forge.voodooprojects.org/svn/chameleon/branches/module_system

you will find source files at your home folder, then replace ati.c file by the one i modded but before compiling make sure to include your device id & default fb as i shrinked that part.
for me it just inject more entries into ioreg (cosmetic), i don't see any difference (but my system is good already), may be it can bring something new for you.
i have tried DSDT injection before but no go too

More testing:
2011 MBP 10.6.7 kexts are exactly like Lion

My Flicker setup (which boots stable but weird colors with trunk) no longer connects with new injector

Alternate Features (29 05 and 09 03) do nothing

Shrike and Gliff give garbled screen and freeze up before fully booting.

I did go through the MacBook ioreg and did not see any more missed keys

I think the thing to do is comment out lines of code in a systematic fashion until we figure out which of the injected values are necessary and which are not. Figure I can do that by consistently booting using the 10.6.7 MBP kexts.

I think the thing to do is comment out lines of code in a systematic fashion until we figure out which of the injected values are necessary and which are not. Figure I can do that by consistently booting using the 10.6.7 MBP kexts.

Mucha - I commented out all the code we added, and rebooted.
This test also gives a black screen with Flicker.
I think the problem may be in module_system, not our code.

So I am going back to v0.1 (based on trunk), adding the additional symbols as you did, and seeing if I get different results.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy