Jump to content

Get your UVC webcam working as Apple iSight


  • Please log in to reply
86 replies to this topic

#81
Signe Landet

Signe Landet

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
I have a Chicony webcam ProdID 0xb300 (45824) VedorID 0x04f2 (1266)
in an Acer Aspire S3-391 (i5-3317U)

It does not show up as an iSight camera, just as a "HD Webcam".

Any suggestions?

#82
jackoloki

jackoloki

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

I found this thread because I'm trying to fix the FaceTime issue that others have complained about; looking *very* pixelated… like 10x the normal size as if the camera were only 30 x 70 pixels… that, and after a half minute, the whole image starts flickering madly.


According to ideasonboard.org the Sunplus 1bcf:2809 webcam that comes with the Dell 3550 *is* supported by the Linux UVC driver, but it didn't say anything about whether the Sunplus 1bcf:2888 that came with my HP 4530s is UVC.


At any rate, I followed the instructions to the letter, editing the AnyiSightCam.kext (all 3 instances of both ID's in hexadecimal) and then installing it in S/L/E. In 'About my Mac' the webcam did show up as a 'Built-in iSight", which it didn't do before the kext... Unfortunately, the webcam simply doesn't function with kext installed... I get no image at all. Same with PhotoBooth.


Anyway, I removed the kext and I'm pretty much back where I started... highly pixelated FaceTime.


Can anyone confirm that the webcam that comes with the HP 4530s is UVC? I mean it is 28XX like that on the Dell's... so, it probably is, wouldn't you think? AND is there anything else I can do aside from the instructions to get my this webcam to function as it is supposed to?


Thanks in advance for any help.

Rob



---



hp 4530s i7 2670QM/2.20 GHz (LJ521UT#ABA)

Mac OSX MountainLion 10.8.1



#83
NoSmokingBandit

NoSmokingBandit

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 317 posts
This got my webcam working, but it refuses to connect in tinychat. It works with http://www.testwebcam.com/ but nothing else online. Any suggestions?

#84
bonzybuddy

bonzybuddy

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi Thanks for this. I have working webcam now!!!!
Vaio VPCEB24FX using 10.8.2 Hazard. :)

#85
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i

Anybody here running Mavericks using this approach to have your webcam work in OS X 10.9?



#86
Ramalama

Ramalama

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Not Telling
  • Location:Germany

Anybody here running Mavericks using this approach to have your webcam work in OS X 10.9?

 

Yes :-)

This Kext is working on every version of OSX, because it's just a info.plist merge kext...

 

@Andy

Thank you very much for this kext, its working awesome on 10.9.2 :-)

 

And it fixed my Camera :-)

Before my Cam's Light didn't turned off, now it turns off:-)

 

Cheers :-)



#87
wh1sker

wh1sker

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male

So my Microsoft VX800 webcam doesn't work anymore. It worked perfectly, but now, the hackintosh "sees" the webcam, but no video, black screen. Also, after a few seconds, the hackintosh FREEZES. It's fricking annoying.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy