Jump to content

Apple Shipping drive DVD fix (for PATA/SATA)


  • Please log in to reply
41 replies to this topic

#21
sama7896

sama7896

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 440 posts
  • Gender:Male

I've made builds for Tiger and Leopard as requested... :D

Thank you very much
Device is listed as Asus in SATA device tree, but as Apple shipping drive in Disc Burning section of System profiler. No burn test yet. Pic bellow.

Attached Files



#22
starobrno1

starobrno1

    InsanelyMac Legend

  • Banned
  • PipPipPipPipPipPipPip
  • 930 posts
  • Gender:Male
Thanks for this fix works really good, now my two dvds show as apple shipping in GA EP45-DS3 hack. However I have this really strange thing happening with my Asus P6T-SE hack where I can only make one of my two dvds show as Apple shipping. What´s even more strange is that in the Asus rig I have two different brand dvds and the one I can´t make show up as Apple shipping is the same kind as the two that actually do show as Apple shipping in my GA rig?

Could it be it has to be two of the same?

These are Sata dvds.

Thanks

#23
Andy Vandijck

Andy Vandijck

    InsanelyMac Deity

  • Coders
  • 1,630 posts
  • Gender:Male
  • Location:Tienen
  • Interests:Programming stuff for Mac OS X...
    Hacking...
    Hard rock (also really big Metallica...

Thanks for this fix works really good, now my two dvds show as apple shipping in GA EP45-DS3 hack. However I have this really strange thing happening with my Asus P6T-SE hack where I can only make one of my two dvds show as Apple shipping. What´s even more strange is that in the Asus rig I have two different brand dvds and the one I can´t make show up as Apple shipping is the same kind as the two that actually do show as Apple shipping in my GA rig?

Could it be it has to be two of the same?

These are Sata dvds.

Thanks

Shouldn't matter.
Just clone the IOKitPersonalities entry n times and set for each DVD.
It should work just fine. ;)

#24
starobrno1

starobrno1

    InsanelyMac Legend

  • Banned
  • PipPipPipPipPipPipPip
  • 930 posts
  • Gender:Male
I did that but I´m sorry it does´nt work. It do work on my GA mobo though but in that rig I have two of the same kind dvd.

#25
mrinehart93

mrinehart93

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
Sorry to be an extreme noob with this, but what info.plist do I need to edit? And I was referred to this thread because my DVD was spinning up without a disc in it every so often... will this fix that problem?

EDIT

I am dumb lol. I edited the info.plist inside the kext, and I replaced the default values as stated by Andy with the values from my dvd drive (HP DVD Writer 1260d). I rebooted, and I still have the "generic drive" in the about this mac. So, I don't think it worked for me. I'm running Snow Leopard with the latest updates.

#26
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,448 posts
  • Gender:Male
  • Location:Tru, Venezuela
Thank you very much dear Andy, worked beautiful for my PATA DVD (ATAPI), even burning, everything ok. The extension is loaded from /E/E. And shipping values (merged with mines) take it from MacBook3,1 (late 2007) IOReg jejeje.
Attached File  6720s_MB31_PataLegacy_Andy.png   46.59KB   263 downloads
Also, following the advise and procedure applied by Smith@@™, additionally I have this:
Attached File  Bus_ATA.png   53.24KB   264 downloads
Info.plist for edition purposes attached. All credits and gratefully to Andy of course. Cheers.

Attached Files



#27
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
Hello Andy, this kext work in 64 bits? I have installed in my System x86_64 and it doesn't load the kext.




Thanks!!!!!!

#28
aylamrin

aylamrin

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 364 posts
  • Gender:Male
  • Location:Bangalore, India.
Even I can't get it to work on 64 bits. I have an ASUS SATA drive.

#29
tdtran1025

tdtran1025

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 358 posts
It does not work for me. I edited the info.plist according to instruction but the BD still shows up as generic. I used Chameleon RC5 r 643.Attached File  1.tiff   70.98KB   11 downloads

Attached Files

  • Attached File  1.tiff   70.98KB   13 downloads


#30
starobrno1

starobrno1

    InsanelyMac Legend

  • Banned
  • PipPipPipPipPipPipPip
  • 930 posts
  • Gender:Male
Even though this look like it works at least with one of my hacks (GA EP45-DS3 Q6600 cpu) the two DVDs I have in it actually seem to not work any better from before. I still get the probs one of them and sometimes both get "locked up", the OS sees them but I can´t access them. In theory it works but when you start to use the DVDs for real it does´nt seem there´s no difference from without this fix.

#31
vamose

vamose

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts
Hi Andy,

Thanks for the guide to fix SATA and non SATA DVD drives. Unfortunately my system has no change with or with out the kext.

Attached are the files and the kext that I am using, will appreciate your help.

My SATA DVD Drive model is LG - GH22NS50

Attached Files



#32
valv

valv

    InsanelyMac Architect

  • Members
  • PipPipPipPipPipPipPip
  • 910 posts
  • Gender:Male
  • Location:Unrevealed Area
  • Interests:Operating Systems<br />Networking<br />Security
a bit off-topic, but, does anybody know of an apple combo drive with bd support ?

#33
Muhammad Adnan Asim

Muhammad Adnan Asim

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:UK
I tried this kext for my `TSSTcorp DVD+-RW TS-T633C` but still no luck.

Is this kext compatible for my drive? can anyone tell.

My drive spec is
vendor identification: TSSTcorp
Product identification: DVD+-RW TS-T633C

Edit:

Finally I got it working. I guess i was using wrong kext. But i am still having a little problem, I am unable to insert the CD/DVD into driver after system startup.

#34
Mammoth

Mammoth

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 625 posts
My question is: Is this perhaps just a cosmetic fix, or is it actually supposed to add functionallity?

#35
joshhh

joshhh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 210 posts
  • Gender:Male
  • Location:Russia, Israel
Will this work with SATA-ODD connected via USB bay?

#36
philip_petev

philip_petev

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
  • Gender:Male
  • Location:Haskovo, Bulgaria

Sorry for resurrecting the topic, but I've noticed this issue on both my desktop and my laptop with OS X 10.8.5. I was able to compile the source as a 64bit-only binary, using SDK 10.8, targeting OS X 10.6 and when I installed it, after the first reboot, my drive was recognized as Mat{censored}a DVD-R UJ-846 in System Information / DIsc burning, but the random spinning remains and usually it starts several minutes after my display has gone to sleep and stops, when I wake it up. Is there anything that can be done about it?

 

Edit 14.10.2013: It seems the 10.8.5 supplemental update solved the problem.



#37
lukin

lukin

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts

Sorry for resurrecting the topic, but I've noticed this issue on both my desktop and my laptop with OS X 10.8.5. I was able to compile the source as a 64bit-only binary, using SDK 10.8, targeting OS X 10.6 and when I installed it, after the first reboot, my drive was recognized as Mat{censored}a DVD-R UJ-846 in System Information / DIsc burning, but the random spinning remains and usually it starts several minutes after my display has gone to sleep and stops, when I wake it up. Is there anything that can be done about it?

 

Edit 14.10.2013: It seems the 10.8.5 supplemental update solved the problem.

 

Thx so much for reporting back about 64bit issue, I thought it didn't work since no one confirmed...would you mind uploading your 64 kext mod please!, would it run with no problem on Mavericks, if so does it still solve the issue?

 

Thx



#38
philip_petev

philip_petev

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
  • Gender:Male
  • Location:Haskovo, Bulgaria

Thx so much for reporting back about 64bit issue, I thought it didn't work since no one confirmed...would you mind uploading your 64 kext mod please!, would it run with no problem on Mavericks, if so does it still solve the issue?

 

Thx

You probably won't need it, if you have installed OS X 10.8.5 with the supplemental update or later. Turning off the Put the hard disk(s) to sleep when possible option in the Energy Saver prefpane will be quite enough.



#39
lukin

lukin

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts

Thx so much...yea I know, turning it off fixes it, can`t help but think that it might be useful to have it, you never know, I`d have to insist if you don`t mind...sorry!



#40
philip_petev

philip_petev

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
  • Gender:Male
  • Location:Haskovo, Bulgaria

Thx so much...yea I know, turning it off fixes it, can`t help but think that it might be useful to have it, you never know, I`d have to insist if you don`t mind...sorry!

There it is.

Debug and Release are 64bit-only, Release Leopard and Release Tiger are 32bit-only.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy