Jump to content

LaCie USB 3.0 drivers are here for OS X


  • Please log in to reply
236 replies to this topic

#121
badur

badur

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I can confirm that updating to the new patched kext fixes the sleep issue. I was actually (accidentally) using the 1.0.7 version of the Lacie driver with the older patched kext. Perhaps this is where the sleep issue was coming from.

Anyway, the driver is working great now! Thanks a lot Genzai!

#122
Powaking

Powaking

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
  • Gender:Male
I can confirm this kext now works for me with Sleep. My rig is listed below. I'm using an eVGA USB3 NEC chipset card with a Seagate GoFlex USB3 external drive. Time Machine backups will be much quicker now. Whoo hoo!!!

#123
kitmac

kitmac

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 209 posts
  • Gender:Male

I can confirm this kext now works for me with Sleep. My rig is listed below. I'm using an eVGA USB3 NEC chipset card with a Seagate GoFlex USB3 external drive. Time Machine backups will be much quicker now. Whoo hoo!!!


thanx im gonna give that EVGA EU30 PCI-E a go.............

#124
nisto91

nisto91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
My seagate usb3 external hd constantly disconnects after about 5 minutes with this driver. Same thing happened in 10.6.7 and now in 10.6.8. Any solution? Oh and I also lose every usb device EXCEPT my usb3 hd after my computer wakes up from sleep.

#125
Adyjay

Adyjay

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Hello guys,

Thanks for the new patched driver,

Can anyone check if Deep Sleep works for you ? Sleep started to work with the driver but I get an instant Kernel Panic on Deep Sleep if I have a USB3 Disk mounted when putting the computer to sleep. I'm not sure if it's something on my part or it's the driver itself that's causing the problem.

Thanks. ;)

#126
longtom

longtom

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 265 posts
You're right!
I also get KP when coming back from sleep if a USB3 device is attached.

#127
Powaking

Powaking

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
  • Gender:Male
I haven't done a deep sleep but I notice time to time that when I wake my machine up from a sleep I get the error that the removable device was not ejected properly. But my drives do mount back up fine and work without issues.

#128
longtom

longtom

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 265 posts
yes, you're right.
repaired permission, than i get no KP.
it seems to be an 10.6.8. issue.
i get these also w/o usb 3.0 kext.

#129
SwingCat

SwingCat

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
I can confirm that the patched kext doesn't work with Lion and the 1.0.7 drivers. Hopefully someone will patch them once LaCie updates their drivers.

#130
Wanna Hack

Wanna Hack

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

I can confirm that the patched kext doesn't work with Lion and the 1.0.7 drivers. Hopefully someone will patch them once LaCie updates their drivers.


The latest patched kext (1.0.7) works with Lion on Cartri Mac BIOS (EP43-UD3L) with a no-name PCI-E host card. In fact, Lacie's installer and unpatched kext works as well. However, if a drive is plugged in the USB 3 port and the system goes to sleep -- manually or automatically -- upon wake, the system complains that the drive was improperly ejected and the system mounts the drive.

Any thoughts on how to edit the kext so that the drive can be plugged in and sleep safely?

Attached Files



#131
elfstones65

elfstones65

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Thanks genzai and of course Modbin.

New one works fine, Lacie PCI Express card and WD My Passport 2 USB 3 version working great.

#132
MacNB

MacNB

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
Thanks for the new patched kext.

I am on 10.6.8 (supplement 1).
It's been a day since I installed it.
I have a FreeAgent GoFlex 1TB USB3.0 drive.
Formatted it as GUID.
Using it for Timemachine.
Initial backup was taking forever ...~ 1MB/s.

I disable Spotlight using:
sudo mdutil -a -i off
That speeded it up. Activity monitor showed around 80MB/s write speed (that's probably cached writes so not impressive but an improvement).

Kept the drive attached all day and went to sleep.
Wake from sleep showed that there's no USB3 drive attached.
I unplugged it and replugged it.
No joy. The drive is not seen.

Looks like sleep issue is not fixed with the new driver ?
Kernel log:
Aug  4 10:12:18 MacPro530 kernel[0]: USBF:	32702.339	Endpoint 0x81 of the USB device "FreeAgent GoFlex" at location 0x200000:  converting Bulk MPS from 1024 to 512 (USB 2.0 Spec section 5.8.3)
Aug  4 10:12:18 MacPro530 kernel[0]: USBF:	32702.340	Endpoint 0x2 of the USB device "FreeAgent GoFlex" at location 0x200000:  converting Bulk MPS from 1024 to 512 (USB 2.0 Spec section 5.8.3)
Aug  4 10:12:18 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler - _xhciCommandStatus [6] remaining [4] requestSize [4]
Aug  4 10:12:18 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler - receive transfer event for a halted ou error endpoint [3]
Aug  4 10:12:18 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler  : cancel  all TD in the Queue
Aug  4 10:12:18 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler - complete on ERR 0 - err 79 for EP-1:IN
Aug  4 10:12:19 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler - _xhciCommandStatus [6] remaining [8] requestSize [8]
Aug  4 10:12:19 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler - receive transfer event for a halted ou error endpoint [3]
Aug  4 10:12:19 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler  : cancel  all TD in the Queue
Aug  4 10:12:19 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler - complete on ERR 0 - err 79 for EP-1:IN
Aug  4 10:12:19 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler - _xhciCommandStatus [6] remaining [8] requestSize [8]
Aug  4 10:12:19 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler - receive transfer event for a halted ou error endpoint [3]
Aug  4 10:12:19 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler  : cancel  all TD in the Queue
Aug  4 10:12:19 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler - complete on ERR 0 - err 79 for EP-1:IN
Aug  4 10:12:19 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler - _xhciCommandStatus [6] remaining [8] requestSize [8]
Aug  4 10:12:19 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler - receive transfer event for a halted ou error endpoint [3]
Aug  4 10:12:19 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler  : cancel  all TD in the Queue
Aug  4 10:12:19 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::TransferEventHandler - complete on ERR 0 - err 79 for EP-1:IN
Aug  4 10:12:20 MacPro530 kernel[0]: jnl: disk3s3: replay_journal: from: 68655616 to: 83368448 (joffset 0x1d1e000)
Aug  4 10:12:21 MacPro530 kernel[0]: jnl: disk3s3: examining extra transactions starting @ 83368448 / 0x4f81a00
Aug  4 10:12:22 MacPro530 kernel[0]: jnl: disk3s3: txn starting at 83368448 (83368448) @ index  61 bnum 6188960 (8192) with disk cksum != blhdr cksum (0xf7748cec 0x3c56d24c)
Aug  4 10:12:22 MacPro530 kernel[0]: jnl: 0xed2a0000 0xe92a0000 0xc0001ff 0x6000000  0xe5db0300 0x4000000 0x0 0xb001200
Aug  4 10:12:22 MacPro530 kernel[0]: jnl: disk3s3: restarting journal replay (68655616 - 83368448)!
Aug  4 10:12:22 MacPro530 kernel[0]: jnl: disk3s3: replay_journal: from: 68655616 to: 83368448 (joffset 0x1d1e000)
Aug  4 10:12:31 MacPro530 kernel[0]: jnl: disk3s3: journal replay done.
Aug  4 10:13:31 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::IssueEndpointCommand - Deconfigure Endpoint
Aug  4 10:13:31 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::XHCIRootHubResetPort detect device on port 2
Aug  4 10:13:31 MacPro530 kernel[0]: UIMCreateControlEndpoint - EP type 0x2
Aug  4 10:13:31: --- last message repeated 1 time ---
Aug  4 10:13:31 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::IssueEndpointCommand - Endpoint is not in running state
Aug  4 10:14:01: --- last message repeated 1 time ---
Aug  4 10:14:01 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::IssueEndpointCommand - Deconfigure Endpoint
Aug  4 10:14:01 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::XHCIRootHubResetPort detect device on port 2
Aug  4 10:14:01 MacPro530 kernel[0]: UIMCreateControlEndpoint - EP type 0x2
Aug  4 10:14:01: --- last message repeated 1 time ---
Aug  4 10:14:01 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::IssueEndpointCommand - Endpoint is not in running state
Aug  4 10:14:31: --- last message repeated 1 time ---
Aug  4 10:14:31 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::IssueEndpointCommand - Deconfigure Endpoint
Aug  4 10:14:31 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::XHCIRootHubResetPort detect device on port 2
Aug  4 10:14:31 MacPro530 kernel[0]: UIMCreateControlEndpoint - EP type 0x2
Aug  4 10:14:31: --- last message repeated 1 time ---
Aug  4 10:14:31 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::IssueEndpointCommand - Endpoint is not in running state
Aug  4 10:15:00: --- last message repeated 1 time ---
Aug  4 10:15:00 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::IssueEndpointCommand - Deconfigure Endpoint
Aug  4 10:15:00 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::XHCIRootHubResetPort detect device on port 2
Aug  4 10:15:00 MacPro530 kernel[0]: PXHCD	isLastTRBinRing - not last link TRB
Aug  4 10:15:00 MacPro530 kernel[0]: UIMCreateControlEndpoint - EP type 0x2
Aug  4 10:15:00: --- last message repeated 1 time ---
Aug  4 10:15:00 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::IssueEndpointCommand - Endpoint is not in running state
Aug  4 10:15:00: --- last message repeated 1 time ---
Aug  4 10:15:00 MacPro530 kernel[0]: disk3s3: I/O error.
Aug  4 10:15:00 MacPro530 kernel[0]: jnl: disk3s3: do_jnl_io: strategy err 0x5
Aug  4 10:15:00 MacPro530 kernel[0]: jnl: disk3s3: end_transaction: only wrote 0 of 918016 bytes to the journal!
Aug  4 10:15:30 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::IssueEndpointCommand - Deconfigure Endpoint
Aug  4 10:15:30 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::XHCIRootHubResetPort detect device on port 2
Aug  4 10:15:30 MacPro530 kernel[0]: UIMCreateControlEndpoint - EP type 0x2
Aug  4 10:15:30: --- last message repeated 1 time ---
Aug  4 10:15:30 MacPro530 kernel[0]: PXHCD	0xffffff805d9f3000::IssueEndpointCommand - Endpoint is not in running state
Aug  4 10:15:30: --- last message repeated 1 time ---
Aug  4 10:15:30 MacPro530 kernel[0]: IOUSBMassStorageClass[0xffffff800ce79000]: The device is still unresponsive after 6 consecutive USB Device Resets; it will be terminated.
Aug  4 10:15:30 MacPro530 kernel[0]: disk3s3: device/channel is not attached.
Aug  4 10:15:30 MacPro530 kernel[0]: hfs: Removed 0 orphaned / unlinked files and 381 directories 
Aug  4 10:15:30 MacPro530 kernel[0]: disk3s3: device/channel is not attached.
Aug  4 10:15:30 MacPro530 kernel[0]: IOBlockStorageDriver[IOBlockStorageDriver]; executeRequest: request failed to start!
Aug  4 10:15:30 MacPro530 kernel[0]: disk3s3: device/channel is not attached.
Aug  4 10:15:30 MacPro530 kernel[0]: __mac_mount() VFS_ROOT returned 6

With the new driver, the TransferEventHandler statements are always there on boot and on attachment.

What's troubling also is the log entry:
Aug  4 10:12:18 MacPro530 kernel[0]: USBF:	32702.340	Endpoint 0x2 of the USB device "FreeAgent GoFlex" at location 0x200000:  converting Bulk MPS from 1024 to 512 (USB 2.0 Spec section 5.8.3)

This appears to be downgrading the USB connection to USB2.0 speeds ?

Anyone else seen any of this ?

#133
cybercap

cybercap

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
  • Gender:Male
  • Location:Strasbourg, France
Hello,

which driver to use for a fresh install of Lion on a H55M-USB3 ?
is the nec modbin USB3 kext included in ##### 3.8 ok ?

or should i use some lacie drivers , or a modified kext found here ?

I have an external USB3 case (with a WDC 1,5tb drive), connected to the blue usb3 port of my mobo

thanks

#134
NIXin

NIXin

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male
  • Location:Krakow, Poland
Anybody hacked the CalDigit driver for 10.7 ?
Could anybody point as to how to hack them, where to start?
I've tried running the patched LaCie, but it seems unstable - either mounts as USB 2.0 (useless) or disconnects during usage - same errors as MacNB is having.

#135
kiwijase

kiwijase

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hello,

which driver to use for a fresh install of Lion on a H55M-USB3 ?
is the nec modbin USB3 kext included in ##### 3.8 ok ?

or should i use some lacie drivers , or a modified kext found here ?

I have an external USB3 case (with a WDC 1,5tb drive), connected to the blue usb3 port of my mobo

thanks


I ran into the problem with hangs on reboot with the driver in ##### 3.8.0 (on a ASUS P8P67 Pro board).
However, using the latest driver from Lacie, then replacing the PXHCD kext on this thread as patched by 'genzai', I was able to get it working without issues. I also disabled 'Legacy USB 3.0 Support' in the BIOS.

#136
jugdus

jugdus

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Here you go! All credit goes to modbin. I was able to diff the original binary with the modbin one and find the edit he made. Those sections were identical in the new driver so i applied the same change to it and it works
P.S. please make sure you install the full LaCie driver package and only then replace the kext using kexthelper or the like.



Many thanks for sharing your modified Modbin USB 3 driver. I can now access the drive attached to the LaCie USB 3 pci express adapter card in Lion on a Gigabyte EP-45T-UD3R :D :)

#137
gbox19

gbox19

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
I'm having the same disconnect issues with my USB 3.0. I have a WD MyBook Essentials 3.0 3TB drive, firmware 2.0.16. I'm using SIIG controller card with firmware 3.0.28.08. Both are the newest that I can find.

I've tried using the original modbin PXHCD.kext as well as the one in ##### 3.8 and the 1.07 Lacie drivers with genzai's modified PXHCD.kext. I've also tried the USBBusFix boot plist flag.

In energy saver, I have sleep set to never and never sleep harddrives. WD sent me a new cable as well.

None of those are doing the trick I still get disconnects after about an hour or so.

Not sure what to do at this point.

Here is some console output, I can't make anything useful from it.

I'm running 10.6.8 on P35-DS3L board.


8/27/11 10:02:27 PM	kernel	um 1035606] [LBlkNum 1] [FSLogMsgID 1385157785] [FSLogMsgOrder First] 

8/27/11 11:00:47 PM	kernel	USBF:	1. 58	AppleUSBOHCI[0xffffff8011a52000]::CheckSleepCapability - controller will be unloaded across sleep
8/27/11 11:00:47 PM	kernel	com.apple.AppleFSCompressionTypeZlib kmod start
8/27/11 11:00:47 PM	kernel	USBF:	1.133	AppleUSBOHCI[0xffffff8011bd8000]::CheckSleepCapability - controller will be unloaded across sleep
8/27/11 11:00:47 PM	kernel	PXHCD	0xffffff80aef1a000:UIMInitialize xHC addressing capability 64 bit register
8/27/11 11:00:47 PM	kernel	PXHCD	0xffffff80aef1a000:UIMInitialize HCSParams2 = 0x11 
8/27/11 11:00:47 PM	kernel	PXHCD	0xffffff80aef1a000:UIMInitialize MAX SCRATCH PAD = 0 
8/27/11 11:00:47 PM	kernel	PXHCD	Force Sleep capability
8/27/11 11:00:47 PM	kernel	USBF:	1.213	AppleUSBEHCI[0xffffff8011b79000]: unable to get filterInterruptEventSource
8/27/11 11:00:47 PM	kernel	USBF:	1.213	AppleUSBEHCI[0xffffff8011b79000]::UIMInitialize - Error occurred (0xe00002be)
8/27/11 11:00:47 PM	kernel	USBF:	1.216	AppleUSBEHCI[0xffffff8011b79000]::start unable to initialize UIM

8/27/11 11:01:52 PM	kernel	USBMSC Identifier (non-unique): 574341575A30323035393239 0x1058 0x1130 0x1016
8/27/11 11:01:52 PM	kernel	USBF:	70.202	IOUSBPipe[0xffffff80145a8fc0]::InitToEndpoint: USB 2.0 Spec (5.8.3) converting Bulk MPS from 1024 to 512
8/27/11 11:01:52 PM	kernel	USBF:	70.203	IOUSBPipe[0xffffff80145a7100]::InitToEndpoint: USB 2.0 Spec (5.8.3) converting Bulk MPS from 1024 to 512

8/28/11 12:49:19 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler - _xhciCommandStatus [6] remaining [4096] requestSize [4096]
8/28/11 12:49:19 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler - receive transfer event for a halted ou error endpoint [6]
8/28/11 12:49:19 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler  : cancel  all TD in the Queue
8/28/11 12:49:19 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler - complete on ERR 0 - err 79 for EP-3:OUT
8/28/11 12:49:19 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler - _xhciCommandStatus [6] remaining [13] requestSize [13]
8/28/11 12:49:19 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler - receive transfer event for a halted ou error endpoint [9]
8/28/11 12:49:19 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler  : cancel  all TD in the Queue
8/28/11 12:49:19 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler - complete on ERR 0 - err 79 for EP-4:IN
8/28/11 12:49:19 PM	kernel	PXHCD	0xffffff80aef35000::ReadyForTransfer - Endpoint state[2] : pipe STALLED 
8/28/11 12:49:19 PM	kernel	PXHCD	[0xffffff80aef35000]::EnqueueTransferDescriptor could not transfer request
8/28/11 12:49:19 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Endpoint is not in running state
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler - _xhciCommandStatus [6] remaining [4096] requestSize [4096]
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler - receive transfer event for a halted ou error endpoint [6]
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler  : cancel  all TD in the Queue
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler - complete on ERR 0 - err 79 for EP-3:OUT
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler - _xhciCommandStatus [6] remaining [13] requestSize [13]
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler - receive transfer event for a halted ou error endpoint [9]
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler  : cancel  all TD in the Queue
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::TransferEventHandler - complete on ERR 0 - err 79 for EP-4:IN
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::ReadyForTransfer - Endpoint state[2] : pipe STALLED 
8/28/11 12:49:26 PM	kernel	PXHCD	[0xffffff80aef35000]::EnqueueTransferDescriptor could not transfer request
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Deconfigure Endpoint
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::XHCIRootHubResetPort detect device on port 2
8/28/11 12:49:26 PM	kernel	UIMCreateControlEndpoint - EP type 0x2
8/28/11 12:49:26 PM	kernel	UIMCreateControlEndpoint - EP type 0x2
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Endpoint is not in running state
8/28/11 12:49:26 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Endpoint is not in running state
8/28/11 12:49:55 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Deconfigure Endpoint
8/28/11 12:49:55 PM	kernel	PXHCD	0xffffff80aef35000::XHCIRootHubResetPort detect device on port 2
8/28/11 12:49:55 PM	kernel	UIMCreateControlEndpoint - EP type 0x2
8/28/11 12:49:55 PM	kernel	UIMCreateControlEndpoint - EP type 0x2
8/28/11 12:49:55 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Endpoint is not in running state
8/28/11 12:49:55 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Endpoint is not in running state
8/28/11 12:50:25 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Deconfigure Endpoint
8/28/11 12:50:25 PM	kernel	PXHCD	0xffffff80aef35000::XHCIRootHubResetPort detect device on port 2
8/28/11 12:50:25 PM	kernel	UIMCreateControlEndpoint - EP type 0x2
8/28/11 12:50:25 PM	kernel	UIMCreateControlEndpoint - EP type 0x2
8/28/11 12:50:25 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Endpoint is not in running state
8/28/11 12:50:25 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Endpoint is not in running state
8/28/11 12:50:55 PM	kernel	PXHCD	isLastTRBinRing - not last link TRB
8/28/11 12:50:55 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Deconfigure Endpoint
8/28/11 12:50:55 PM	kernel	PXHCD	0xffffff80aef35000::XHCIRootHubResetPort detect device on port 2
8/28/11 12:50:55 PM	kernel	UIMCreateControlEndpoint - EP type 0x2
8/28/11 12:50:55 PM	kernel	UIMCreateControlEndpoint - EP type 0x2
8/28/11 12:50:55 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Endpoint is not in running state
8/28/11 12:50:55 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Endpoint is not in running state
8/28/11 12:51:24 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Deconfigure Endpoint
8/28/11 12:51:24 PM	kernel	PXHCD	0xffffff80aef35000::XHCIRootHubResetPort detect device on port 2
8/28/11 12:51:24 PM	kernel	UIMCreateControlEndpoint - EP type 0x2
8/28/11 12:51:24 PM	kernel	rage] [FSLogMsgID 1921864543] [FSLogMsgOrder Last] 
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	hfs: err 6 reading VH blk (3TB Storage)
8/28/11 12:51:24 PM	kernel	disk1s2: media is not present.
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	
8/28/11 12:51:24 PM	kernel	hfs: err 6 reading VH blk (3TB Storage)
8/28/11 12:51:25 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Endpoint is not in running state
8/28/11 12:51:25 PM	kernel	PXHCD	0xffffff80aef35000::IssueEndpointCommand - Endpoint is not in running state


#138
rtrtrtrt

rtrtrtrt

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

I haven't done a deep sleep but I notice time to time that when I wake my machine up from a sleep I get the error that the removable device was not ejected properly. But my drives do mount back up fine and work without issues.


Installed an Asus U3S6 card into a Macpro 2008 running 10.6.8 with all updates.

Using the latest 1.0.7 Lacie drivers and the updated kext from genzai/modbin, I get the same result as Powaking.

Will leave drive mounted and update if problems over next few days.
--------------------
Update
All fine with reading and writing files over last couple of days.
Will use it as normal now and see how it goes - backups etc

#139
lollo78

lollo78

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Hi, thanks a lot for your work.
This is my experience...
I've installed Lacie 1.0.7 and replaced pxhcd.kext with the latest genzai patch.

Now, with genzai patch, OS X Lion go to sleep only one time and it successfully restore itself with mouse or keyboard keys. But If I try to put again in Sleep mode, the system remain in Sleep mode and the only solution is to use the power button. But if I make this the motherboard BIOS reset to default parameters. Why?

A clarification. This always happens: with the USB 3.0 hard disk plugged (and after the first wake up appear the same error of Wanna Hack -post #130-) or without it.

Best regards

#140
macki55

macki55

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hello,

I am trying to use a patched version of the LaCie 1.0.7 driver for OS X 10.5.

According to modbin's info (thank you veeeeeery much) I changed the only occurance of:
cmp ax, 59Fh
   jz goodboy
to:
cmp ax, 59Fh
   jmp goodboy

I also compared genzai's patch of the OS X 10.6 version with the original one and it seems that nothing else has to be changed. Or is the 10.5 patch more complex?

I installed the complete LaCie driver, replaced the patched file and repaired permissions as stated in modbin's installation instructions.

The problem is, that after booting and connecting the HDD (a USB3 dock "Fantec MR-USB 3.0 docking station" connected to the original LaCie USB3 adapter card in a Mac Pro with OS 10.5.8) the HDD doesn't even show up in System Profiler nor Disk Utility and doesn't get mounted.

I get the following messages in dmesg:
PXHCD	0x846df000::IssueCommand command status 4
PXHCD	0x846df000::DeviceInitialisation - Address Device Command failed 
PXHCD	0x846df000::UIMCreateControlEndpoint -fail to initialize device 
PXHCD	0x846df000::ReadyForTransfer - fail to get device context 
PXHCD	[0x846df000]::EnqueueTransferDescriptor has not enough free TRB for transfer
PXHCD	0x846df000::ReadyForTransfer - fail to get device context 
PXHCD	[0x846df000]::EnqueueTransferDescriptor has not enough free TRB for transfer
PXHCD	0x846df000::ReadyForTransfer - fail to get device context 
PXHCD	[0x846df000]::EnqueueTransferDescriptor has not enough free TRB for transfer
PXHCD	0x846df000::ReadyForTransfer - fail to get device context 
PXHCD	[0x846df000]::EnqueueTransferDescriptor has not enough free TRB for transfer
USBF:	176.380	[0xd1edd00] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 4 of hub @ location: 0x0)
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
USBF:	177.834	[0xd1edf00] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 2 of hub @ location: 0x0)
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
USBF:	180.307	[0xd1edf00] The IOUSBFamily was not able to enumerate a device.
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
USBF:	180.535	[0xd1edf00] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 2 of hub @ location: 0x0)
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
USBF:	184.208	[0xd1edf00] The IOUSBFamily was not able to enumerate a device.
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
USBF:	184.848	[0xd1edf00] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 2 of hub @ location: 0x0)
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
USBF:	189.721	[0xd1edf00] The IOUSBFamily was not able to enumerate a device.
PXHCD	0x846df000::UIMCreateControlTransfer - Super Speed device other than LaCie is not supported - Vendor ID[174c]
USBF:	190.358	[0xd1edf00] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 2 of hub @ location: 0x0)

When the HDD dock is connected to a USB2 port it just works fine.
Unfortunately I don't have any other USB3 devices to test with.

Has anyone an idea what the problem might be?

Thank you very much and best regards





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy