Jump to content

How to remove FakeSMC.kext? (Kernel Panic)


  • Please log in to reply
4 replies to this topic

#1
richardmacx

richardmacx

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
I have OSX 10.6.4 iatkos Version 2 installed

I tried to install FakeSMC to monitor my 8800GS temperature from this tutorial:

http://www.projectos...?showtopic=1206

I installed with Kext helper the following files
iStat_pro.wdgt_wBattery.zip
SMC_util2.zip
smcK_Stat_i.app.zip
FakeSMC_rev405_Snow.zip

after installed FakeSMC my OSX got kernel panic and frozen with the message "You must restart..." at the Apple Logo Loading.

I've tried to use Single user mode boot (-s), but was unable to remove FakeSMC.kext. So I tried safemode (-x). I was able to get in and deleted FakeSMC.kext from /System/Library/Extensions/.

When try to boot normally I got hung at loading without any message. on Verbose mode I found it is hanging at:
"ACPI_SMC-PlatformPlugin::registerLPCDriver - failed to locate SMC driver"

Once again when I try to go to safemode (-x), it hung at blue screen before login logo.

How do I completely remove FakeSMC and its plugin and back to the way it was before?

Thanks

#2
David23

David23

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,921 posts
  • Gender:Male
  • Location:Como
with macdrive you can write to the mac disk...

#3
richardmacx

richardmacx

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

with macdrive you can write to the mac disk...


I don't get what you mean. I am trying to remove FakeSMC and its related extensions from my system.

#4
kalel83

kalel83

    Kryptonian

  • Donators
  • 191 posts
  • Gender:Male
  • Location:127.0.0.1

I don't get what you mean. I am trying to remove FakeSMC and its related extensions from my system.



are you using dsmos? or.. how is the encrypted files being decrypted on the fly

facesmc is not primarily for monitoring temp, it's for filesystem decryption, same as the old dsmos kext

#5
richardmacx

richardmacx

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
no worry. I just reinstalled the sucker back to 10.6.3 with iatkos s3 v2 and everything is working again.

I've read somewhere that I must remove FakeSMC.kext and IOPlatformFamily...kext, then reinstall IOPlatformFamily...kext. However, I couldn't find a link to download IOPlatformFamily and I've wasted 2 days to figure it out. It took me about an hour to reinstall from fresh with all kexts working. I am looking into backup for osx from now on. I've heard apple time machine is not that great comparing to windows backup but that is another issue.

Anyhow, thanks for your feedbacks
Richard





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy