Jump to content

Compaq mini 311c - all working except unplugging power crashes OSX


  • Please log in to reply
8 replies to this topic

#1
Sp0oner

Sp0oner

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
Hi, I have installed iATKOS S3 v2 on my Compaq mini 311c 1101SA and so far seem to have everything working (including wifi) but one problem still exists.

If I unplug the power or plug it back in whilst running OSX it crashes giving the normal message to power off etc. I assume it needs some sort of power management support. Would be handy to have this fixed so when running off battery I can plug the power in without having to shutdown first.

In fact one other issue as well, if I unplug the external dvd drive from the USB that crashes it too although this isn't such an issue.

Has any one else come across this and know how to fix it?

#2
Daniel Gustavsson

Daniel Gustavsson

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Sweden

Hi, I have installed iATKOS S3 v2 on my Compaq mini 311c 1101SA and so far seem to have everything working (including wifi) but one problem still exists.

If I unplug the power or plug it back in whilst running OSX it crashes giving the normal message to power off etc. I assume it needs some sort of power management support. Would be handy to have this fixed so when running off battery I can plug the power in without having to shutdown first.

In fact one other issue as well, if I unplug the external dvd drive from the USB that crashes it too although this isn't such an issue.

Has any one else come across this and know how to fix it?

No!

#3
power_of_copies

power_of_copies

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
please put here how you make your configuration in iatkos s3 v2 ?

#4
Sp0oner

Sp0oner

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts

please put here how you make your configuration in iatkos s3 v2 ?


Yep got your pm, I will dig out my notes tomorrow and post up the install config I selected.

#5
unclemik

unclemik

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Location:IT

Yep got your pm, I will dig out my notes tomorrow and post up the install config I selected.


me too, thanks
mik

#6
Sp0oner

Sp0oner

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
OK so once S3 v2 is at the section to choose what to install I used the following:

Boot Loader = Anval
Patches = 32bit, graphic enabler, -pci 1, change rtc patch to rtc 32 bit patch
Add the atom kernel
Hardware add battery
Sound = Voodoo HDA driver
PS/2 Mouse Keyboard Apple Ps/2 Driver

I did not install anything for wireless or ethernet. Ethernet worked on its own but wireless I did a search for kexts and got one working. I'd need to do more digging to give exact details.

#7
power_of_copies

power_of_copies

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
for wireles can you put here the kext? please, do you have a bluetooth?

#8
Sp0oner

Sp0oner

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts

for wireles can you put here the kext? please, do you have a bluetooth?


Sorry only just seen this. I'll have a look to dig it out but wont be for a couple of days as away from home.

#9
mcdull

mcdull

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 184 posts
Any updates?
I am also interested in getting the stock wifi card to work. Seems no one succeed before.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy