Jump to content

Samsung R Series Notebooks


  • Please log in to reply
328 replies to this topic

#301
Morphium

Morphium

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
Got my sound running again with Joses fix. Cleared out everything and now it works on 10.6.8 again. This took me some serious time.

#302
loKEY

loKEY

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Bungo, noticed you posted that u got your battery fixed for 10.7.x in Zprood's topic, would u mind posting your new dsdt so i can add the fix to my dsdt?i have a q430 but the dsdt's are very similar to the r series

#303
Bungo

Bungo

    InsanelyMac Sage

  • Coders
  • 296 posts
  • Gender:Male

Bungo, noticed you posted that u got your battery fixed for 10.7.x in Zprood's topic, would u mind posting your new dsdt so i can add the fix to my dsdt?i have a q430 but the dsdt's are very similar to the r series

Sure, here u r Attached File  DSDT_R780JS03_Bungo.dsl.zip   30.7KB   130 downloads. Use with care, many fixes applied may not work for you properly!

My legacy (thanks to AnV) Attached File  LegacySamsungR780JS03.kext.zip   2.77KB   97 downloads fixing some things, you can use as an exemple.

Thanks to Slice we can get info about AC adapter in SysProf/Power. Edit/add an ACID key under SMCKeys in FakeSMC.kext's plist (i'm using v2.5), put this <85d67f7e a005100c> value taken from some MBP and modified to get 90W (0x5a) ;). It's only cosmetics but may be someone know how to get real info of AC adapter?

My kexts in S/L/E: Attached File  SamsungR780JS03_Bungo.zip   1.58MB   182 downloads
Extra: Attached File  SamsungR780JS03_Boot&smbios.plist.zip   1.76KB   123 downloads

#304
scheffe94

scheffe94

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I want to install Mac OS X Snow Leopard on my Samsung R780. But i can't install it. When i boot Verbose than there comes [PCI Configuration begin] but nothing happens. When i boot normal it's stopping at the Apple Logo. Can anyone help me? :)

#305
antagon

antagon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
write

PCIRootUID=0

got the same problem

#306
antagon

antagon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
@ bungo: your dsdt is working fine for my machine, didn´t get your fixes apllied to my own one without compilation errors, so i tried yours, works nice, but i can´t see battery status it´s just crossed and shows no battery at all...
i also installed the AppleACPIBatteryManager to SLE, no success...
what is the purpose of the legacy kext ?



got it... installed 10.6.8 appleacpiplatform kext to sle...

nice one !!

#307
scheffe94

scheffe94

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
@antagon: Works fine thank you. Must i enter this Bootflag every time or can i store it anywhere?

#308
antagon

antagon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
I just need to enter it during the installation process, after installing chimera it isn´t necessary anymore...

if you still need it add it to org.chameleon.boot.plist...

#309
loKEY

loKEY

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
word, thanks bungo. it's going to take me awhile to go through your dsdt but its gotta be one of the best i've seen, especially with all the comments. i've got battery in 10.7 with a 10.6.8 appleacpiplatform, but i think that kext is causing problems so i'm trying to implement the 8 bit register fix. how stable is the r7 with this dsdt? and what's your geekbench if u don't mind me asking?

#310
Bungo

Bungo

    InsanelyMac Sage

  • Coders
  • 296 posts
  • Gender:Male

@ bungo: your dsdt is working fine for my machine, didn´t get your fixes apllied to my own one without compilation errors, so i tried yours, works nice, but i can´t see battery status it´s just crossed and shows no battery at all...
i also installed the AppleACPIBatteryManager to SLE, no success...
what is the purpose of the legacy kext ?

got it... installed 10.6.8 appleacpiplatform kext to sle...

nice one !!

I'm using stock AppleACPIPlatform (v1.4) and works fine with AppleACPIBatteryManager after fixing BAT in my DSDT (read this and this).
My Legacy integrates many Legacies in one file (and do some cosmetics :wink2: ). E.g. My AppleIntelPanelA section changes the range of brightness control (moving the start point to darker) - you can suit it for your needs. Lowest level value (0x18) is related (shouldn't be lower) to 10th byte (0x13) in pwm-info in DSDT (under GFX0 injection) - check ApplePanelTable (under PNLF) in IORegExplorer. At the end most important thing - F10T544b value is my panel's DisplayProductID (under AppleBacklightDisplay) 0x544b allow to load legacy. In fact Brightness has 17 steps - first is 0x00 (off)

#311
narandill

narandill

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
post moved few posts down.

Edited by narandill, 26 February 2012 - 08:17 AM.


#312
balun-posse

balun-posse

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Interests:SCOOTER FAN
Hi! Who has Samsung R710 or like laptop, help me, please! Does not work brightness control.

#313
narandill

narandill

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Samsung R590 - Lion 10.7.3 Package

1. SPECS

  • Chipset: Intel HM55
  • Processor: Intel Core i5 450M 2.4 GHz
  • Audio: Realtek ALC269
  • WIFI: Atheros AR9285 ("Broadcom 14e4:4727" reported by "lspci")
  • LAN: Marvell Yukon 88E8059 ("Yukon 11ab:4381" reported by "lspci")
  • Video: NVIDIA GeForce GT 330M
  • SATA & IDE: AHCI SATA
2. WHAT IS WORKING
  • Chipset: Intel HM55
  • Processor: Intel Core i5 450M 2.4 GHz (with generating C- and P-States)
  • Audio: Realtek ALC269 (working with patched AppleHDA.kext, IOAudioFamily.kext and my DSDT, no need for crappy Voodoo)
  • WIFI: Atheros AR9285 ("Broadcom 14e4:4727" reported by "lspci") - replaced by Dell Mini wifi card 1015, works OOB
  • Video: NVIDIA GeForce GT 330M (working by EFI string, good info in system)
  • SATA & IDE: AHCI SATA (use those settings in bios: Legacy USB- disabled, AHCI mode- manual, AHCI- enabled, S3 USB Wake up-Enabled, Charge when sleep- disabled);
  • Webcam
  • All USB Ports
  • CD-ROM
  • Brightness control - by keys CTRL+UP/DOWN ARROW
  • Volume control - by keys Fn+LEFTRIGHTARROW
  • Sleep - no CMOS reset when using patched AppleRTC from E/E and orginal in S/L/E
3. WHATS NOT WORKING OR NOT TESTED
  • LAN: Marvell Yukon 88E8059 ("Yukon 11ab:4381" reported by "lspci")
  • Card Reader
4. INSTALL METHOD
  • Booted with rBoot LE
  • install iAtkos L2
  • move files to places and repair perm
  • 10.7.3 Combo Update
4.1 Do not install:
  • EvOreboot.kext
  • nullcpupowermenagment.kext
  • voodoohda.kext
5. DOWNLOAD

http://www.mediafire...f6c66h7v9fn0uxb

#314
Morphium

Morphium

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
Bungo,

please give me a helping hand. I am stuck in some way-

I upgraded my install to 10.7.3 and have some minor flaws which werent present on Snow.

I grabbed all of your newly posted files and set up my install with them as I have the same machine like you.

Bluetooth behaves very unreliable and the system says it does not find a keyboard so that the bluetooth wizard starts searching for one after booting into the system every time. It bothers me as Lion somehow does not get any information upon my Keyboard being there.

Fix:

Go into System Preferences
Go into Bluetooth
Click the Advanced button at the bottom
Uncheck the first two boxes which say "Open Bluetooth Assistant at startup if no keyboard/mouse is detected"



Was this a reason for your Bluetooth module exchange for the DELL one? My Magic Mouse also jumps occassionally. The question is why does the module work under Snow perfect then.

Do I have to change some of your personal settings in the legacy kext like your bluetooth module and DVD drive to mine?

Lion feels nice but it messes up my joy with these issues.

Also how do I get rid of the:

incorrect image signature

before startup. I use Chimera latest build. :(

#315
derekreid

derekreid

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 213 posts
  • Location:Canada

Still "Self Assigned IP" problem. Finally got smart and can connect now with my trusty Zonet USB Wireless Adapter. I don't want it to be permanent, but for now it works. Anyone else have ideas?


Not a full solution either, but changing the wireless mode to g-only (not b/g/n mixed) I have no problems. Unfortunately you don't always have access to the router settings.

Also, I followed antagon's method on page 12 to get alc 296 working, sound seems crisper at high levels and the mic works well. Thanks antagon.


Still on 10.6.8 here.

#316
Bungo

Bungo

    InsanelyMac Sage

  • Coders
  • 296 posts
  • Gender:Male

Was this a reason for your Bluetooth module exchange for the DELL one? My Magic Mouse also jumps occassionally. The question is why does the module work under Snow perfect then.

I decided to change my BT module because of annoying Magic Mouse lags (Snow and Lion).

Do I have to change some of your personal settings in the legacy kext like your bluetooth module and DVD drive to mine?

It is a Legacy kext consolidated in the one file nothing else.
After many tests i removed all BT code except "My Bluetooth" section, it's a legacy code for my new BT module with coresponding idProduct and idVendor to loading BroadcomUSBBluetoothHCIController plug-in.

Also how do I get rid of the:

incorrect image signature

before startup. I use Chimera latest build. :(

I do not have any experiences with Chimera.

#317
Morphium

Morphium

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
Ah I see. Thanks for the heads up

One more new finding:
When I am going to set the system into sleep, it simply reboots. Do I have to make the change for the suspend to Ram via Terminal? Hibernate=0
Thats when the incorrect image signature comes up as the sleep did not work.

EDIT:
Could you also point me to the proper bluetooth module on ebay to exchange it like yours? I hate the lagging on my MMouse, too. Is it necessary to make a complete dissasembly of the device for the bluetooth exchange? Thanks.

#318
Bungo

Bungo

    InsanelyMac Sage

  • Coders
  • 296 posts
  • Gender:Male

One more new finding:
When I am going to set the system into sleep, it simply reboots. Do I have to make the change for the suspend to Ram via Terminal? Hibernate=0
Thats when the incorrect image signature comes up as the sleep did not work.

Yes

EDIT:
Could you also point me to the proper bluetooth module on ebay to exchange it like yours? I hate the lagging on my MMouse, too. Is it necessary to make a complete dissasembly of the device for the bluetooth exchange? Thanks.

Try to search a module from Samsung, Acer, Dell, etc. with BCM92046 chipset. Probably you'll need to change a small connection cabel too (original may not fit).

#319
Morphium

Morphium

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male

Yes

Try to search a module from Samsung, Acer, Dell, etc. with BCM92046 chipset. Probably you'll need to change a small connection cabel too (original may not fit).


I found these ones and I am not sure which one fits best.

http://www.ebay.de/itm/270836056554
http://www.ebay.de/itm/180686404802
http://www.ebay.de/itm/300530318087

Apart from the change of the connection cable, is a complete dissasembly necessery to get to the module? This may be a difficult task for me.

#320
Bungo

Bungo

    InsanelyMac Sage

  • Coders
  • 296 posts
  • Gender:Male

I found these ones and I am not sure which one fits best.

http://www.ebay.de/itm/270836056554
http://www.ebay.de/itm/180686404802
http://www.ebay.de/itm/300530318087

Apart from the change of the connection cable, is a complete dissasembly necessery to get to the module? This may be a difficult task for me.

First and second one are mini PCI-e cards, you need an USB (internal) module like last one. Check photos - first one shows BCM92046 (Bluetooth 2.1) but second one BCM92045NMD (Bluetooth 2.0) :blink:.
In my case the new module has a wider socket therefore I needed new connection cable from e.g. Samsung NC10 (http://allegro.pl/52...2332779433.html) or N120 (http://allegro.pl/bl...2323555568.html) or similiar.
You can try this one http://www.ebay.de/itm/300530318087 but on your own risk.

To get the module you need to remove almost all bottom screws, remove dvd drive - one is hide under, to remove a keyboard press 3 latches over keys: F1, F9, PgDn and delicately lift it up, disconect cables and tapes, remove top case - you can use a plastic ruler sliding along the edge. BE CAREFUL!. The module is sticked to a bottom side of a top case.

Good Luck!

P.S. Chimera 1.9.2 booter works for me (sleep, wake etc.). What is a benefit of using Chimera instead of official Chameleon?





1 user(s) are reading this topic

1 members, 0 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy