Jump to content

EeePC 1000H Snow Leopard 10.6.4 Tutorial


  • Please log in to reply
104 replies to this topic

#81
marven

marven

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I followed this guide for update to 10.6.7:
http://www.root86.or...10.6.4-Tutorial

#82
artic1980

artic1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Pianura padana
I upgraded via update anything. not I used combo

#83
artic1980

artic1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Pianura padana
finally everything works now are also able to activate QE / ci was now

#84
apocalypse-666

apocalypse-666

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts

I followed this guide for update to 10.6.7:
http://www.root86.or...10.6.4-Tutorial



marven,

Could you please write in English what you have done to upgrade to 10.6.7 ?

#85
rurouniq3

rurouniq3

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Location:Lisboa

marven,

Could you please write in English what you have done to upgrade to 10.6.7 ?



Hello,

Plz Marven and artic1980 :(

Make a tutu for 10.6.4 to 10.6.7

#86
artic1980

artic1980

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Pianura padana
I have update with software update end stop. i don't have the retail i have the distro

#87
Paciotti

Paciotti

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hello everyone
I installed my hackintosh, but I hate the Ralink app that start automatically, so I write 2 applescript application.
One (ModifyRalinkApp) is for modify the WirelessUtilityCardbusPCI app to not show any icon in the Dock. This also affect the app list in cmd+tab. You can use my script if you choose the default location for Ralink app. If you didn't, you can open the script with applescript editor and change the path of the .app package.
The other (HideRalink) is for auto-hiding the windows that come up at startup. This time you have to copy it to your preferred location (I choose the Utility folder under Application) and set the app to start at login. Again: if you want to make sure I didn't write malicious code, you can open the script through the applescript editor (do it! for both the script!)

Let me know if you have some issue with them.

EDIT: I made a mistake with a file... I remove the zip, it will be uploaded again soon.

EDIT 2: I don't understand why the HideRalink script is not working if loaded at startup... can someone try it and reporting if it works?

Attached Files



#88
apocalypse-666

apocalypse-666

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
Hello everyone, after accidentally ruining my system while trying to upgrade to 2 GB RAM and update my DSDT, i had to reinstall everything to my Asus Eee 1000H. This time I decided to follow the German Tutorial but i had no luck installing with the new method. So I decided to upgrade from a fresh 10.6.3 installation to 10.6.7. Here is what I did:

1-Make sure you follow the original tutorial to install 10.6.3 and test if everything's working

2-Install Combo Update 10.6.7 DON'T RESTART

3-Delete /Extra/ folder

4-Delete ACPI4ASUS.kext (if present) in /System/Library/Extensions/

5-Download 1000H_Snow_Leopard.zip from attachments, copy S_L_E folder contents to /System/Library/Extensions/ then drag&drop Extensions folder on Kext Utility.app to repair extensions

6-Copy new Extra folder and correct DSDT file from 1000H_Snow_leopard.zip to /

7-Install Chameleon (using boot folder from 1000H_Snow_leopard.zip)

sudo su

diskutil list (find your OSX partition, it usually is disk0s2, then modify the remaining code accordingly)

cd /folder/with/boot/files/ (i copied the boot folder to desktop then I use /users/username/desktop/boot/)

fdisk -f boot0 -u -y /dev/rdisk0

dd if=boot1h of=/dev/rdisk0s2

cp boot /

8-Make partition active (just in case)

sudo fdisk -e /dev/disk0

f 2

write

y

exit

9-Restart computer with boot tags -x -v

10-Repeat updating /System/Library/Extensions/ with Kext Utility.app

11-Repair permissions on Terminal

sudo diskutil repairPermissions /

12-Make boot faster

sudo chown root:admin /

13-Done! ;)

I hope this works for you too...

Cheers!

Attached Files



#89
johnnynmonic

johnnynmonic

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hey, made an account to say thanks very much for the tutorial, works perfectly. I had some trouble getting started, as I don't have a mac to make the installation flash drive, but got things working in the end.

My only issue is the audio output is very very low. If I make a skype call, I need to use headphones, as the sound is too low hear anything over the speakers. Does anyone have a solution for this?

Running 10.6.4 perfectly aside from the sound issue. Thanks klohannes!

#90
johnnynmonic

johnnynmonic

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Followed the update procedure to 10.6.7 as explained in post #88, and can confirm that it works perfectly (FWIW, I skipped step #12). For anyone wondering if it's worth the hassle, I would recommend upgrading - the OS feels snappier, my sound is louder (maybe an updated version of voodoohda.kext in the download package?), and adds compatibility to quite a few apps in the app store.

#91
Dari

Dari

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Hi,

i followed this Tutorial, but my mac is hanging at this point:

npvhash=4095
PAE enabled
Darwin Kernel Version 10.7.0: Sat Jan 29 15:17:16 PST 2011; root:xnu-1504.9.37~1/RELEASE_I386
vm_page_bootstrap: 510923 free pages and 13365 wired pages
standard timeslicing quantum is 10000 us
mig_table_max_displ = 73
AppleACPICPU: ProcessorId=1 LocalApicId=0 Enabled
AppleACPICPU: ProcessorId=2 LocalApicId=1 Enabled
calling mpo_policy_init for Quarantine
Security policy loaded: Quarantine policy (Quarantine)
calling mpo_policy_init for Sandbox
Security policy loaded: Seatbelt sandbox policy (Sandbox)
calling mpo_policy_init for TMSafetyNet
Security policy loaded: Safety net for Time Machine (TMSafetyNet)
Copyright © 1982, 1986, 1989, 1991, 1993
The Regents of the University of California. All rights reserved.
MAC Framework successfully initialized
using 10485 buffer headers and 4096 cluster IO buffer headers
IOAPIC: Version 0x20 Vectors 64:87
ACPI: System State [S0 S3 S4 S5] (S3)
AppleIntelCPUPowerManagement: initialization complete
RTC: Only single RAM bank (128 bytes)
mbinit: done (64 MB memory set for mbuf pool)
From path: "uuid",
Waiting for boot volume with UUID 673159FA-5388-35AA-9B82-8258B806C45C
Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>
com.apple.AppleFSCompressionTypeZlib kmod start
com.apple.AppleFSCompressionTypeZlib load succeeded
AppleIntelCPUPowerManagementClient: ready
USBMSC Identifier (non-unique): 10D0717347FF 0x59b 0x47a 0x0
Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/EUSB@1D,7/AppleUSBEHCI/Iomega Select HDD@fd300000/MSC Bulk-Only Transfer@0/IOUSBMassStorageClass/IOSCSIPeripheralDeviceNub/IOSCSIPeripheralDeviceType00/IOBlockStorageServices/IOBlockStorageDriver/SAMSUNG HM160HI Media/IOGUIDPartitionScheme/Untitled@2 BSD root: disk1s2, major 14, minor 5
Waiting for DSMOS...
systemShutdown false
jnl: disk0s1: replay_journal: from: 4172288 to: 5266944 (joffset 0x4ab000)
jnl: disk0s1: journal replay done.
jnl: disk0s2: replay_journal: from: 8266752 to: 9189376 (joffset 0x457000)
disk0s2: journal replay done.
BTCOEXIST off
wl0: Broadcom BCM4311 802.11 Wireless Controller
5.10.131.36
AirPort_Brcm43224: Ethernet address 00:1a:73:14:a6:45
IO80211Controller::dataLinkLayerAttachComplete(): adding AppleEFINVRAM notification
AirPort: Link Down on en0. Reason 1 (Unspecified).
Previous Shutdown Cause: 3
DSMOS has arrived

I do have tested it without graphics driver, but it does not give me any error, or boot to gui.
I can get to single user mode, but i can only type if i boot in safe mode (-x).
Can someone help me?

#92
J.Picard

J.Picard

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
  • Gender:Male

Hi,

i followed this Tutorial, but my mac is hanging at this point:

I do have tested it without graphics driver, but it does not give me any error, or boot to gui.
I can get to single user mode, but i can only type if i boot in safe mode (-x).
Can someone help me?


I see that you update to 10.6.7.
So did you use the original german tutorial for 10.6.7 from klohannes?

#93
Dari

Dari

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Yes i used the tutorial from Klohannes.

#94
apocalypse-666

apocalypse-666

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts

Yes i used the tutorial from Klohannes.


Please try to use my method, I am writing you from my 1000H with a working SL 10.6.7 system :)

#95
cmj1

cmj1

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hello everyone, after accidentally ruining my system while trying to upgrade to 2 GB RAM and update my DSDT, i had to reinstall everything to my Asus Eee 1000H. This time I decided to follow the German Tutorial but i had no luck installing with the new method. So I decided to upgrade from a fresh 10.6.3 installation to 10.6.7. Here is what I did:

1-Make sure you follow the original tutorial to install 10.6.3 and test if everything's working

2-Install Combo Update 10.6.7 DON'T RESTART

3-Delete /Extra/ folder

4-Delete ACPI4ASUS.kext (if present) in /System/Library/Extensions/

5-Download 1000H_Snow_Leopard.zip from attachments, copy S_L_E folder contents to /System/Library/Extensions/ then drag&drop Extensions folder on Kext Utility.app to repair extensions

6-Copy new Extra folder and correct DSDT file from 1000H_Snow_leopard.zip to /

7-Install Chameleon (using boot folder from 1000H_Snow_leopard.zip)

sudo su

diskutil list (find your OSX partition, it usually is disk0s2, then modify the remaining code accordingly)

cd /folder/with/boot/files/ (i copied the boot folder to desktop then I use /users/username/desktop/boot/)

fdisk -f boot0 -u -y /dev/rdisk0

dd if=boot1h of=/dev/rdisk0s2

cp boot /

8-Make partition active (just in case)

sudo fdisk -e /dev/disk0

f 2

write

y

exit

9-Restart computer with boot tags -x -v

10-Repeat updating /System/Library/Extensions/ with Kext Utility.app

11-Repair permissions on Terminal

sudo diskutil repairPermissions /

12-Make boot faster

sudo chown root:admin /

13-Done! :D

I hope this works for you too...

Cheers!






tried the steps updating to 10.6.8.... safeboot OK... but normal bootup has screen corruption...
Have to try again using 10.6.7

#96
ktutza2006

ktutza2006

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
can anyone post me a quick steps for installing snow on my 1000h using windows? i don't have acces to a mac or hackintosh

#97
cyberghoser1

cyberghoser1

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts

To update to 10.6.8 Follow the same procedure as post #88 and just proceed with the following:

1. Download Nawcom 10.6.8 Legacy Kernel Installer & Correct GMA950 kexts for 10.6.8 (using AppleIntelIntegratedFramebuffer.kext from 10.6.6 to fix brightness issue after wake, only in hibernate mode)
2. Launch the pkg installer it will take care of the kernel and sleepenabler.



3. Follow the guide in post #88 and be sure to include when you copy kexts from SLE to /System/Library/Extensions to add the kexts you downloaded from this post.

Update: Speedstep works with this Voodoopowermini.kext http://www.mediafire...h3ko0nrs8n88er8

Update: Sleep Works!!! Finally i hated this part, but fixed it.

Download this sleepenabler.kext: http://www.mediafire...jwvrx030c646c4j
create within your /Extra folder an Extensions folder and put the sleepenabler.kext you downloaded in there
Drag the Extensions folder from /Extra you created into the Kext Utility app, let it do its job.
Once done, open up terminal and enter:

sudo chown root:wheel /Extra/Extensions/

and enter your password as requested, voila sleep works!

Fix Mac App Store, Unknown error has occured.

In 10.6.8 it might appear that login to the Mac App Store is impossible, this is due that Ethernet is first checked and if not present the login will not be possible, to fix this issue just do the following steps:

1. Make sure you installed the AttansicL1eEthernet.kext
2. Download EFI Studio here
3. Open EFI Studio and choose from the list Ethernet, and click Add, you will have an output in a new window, look at the bottom there is a string like:
 

4b00000001000000010000003f0000000100000002010c00d041030a0000000001010600011c0101060000007fff0400160000006200750069006c0074002d0069006e0000000500000001

Open up your com.apple.boot.plist file located in /Extra with TextEdit
and add the following lines before the last </dict>:
 

<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>device-properties</key>
<string>XXX</string>

Where XXX is the string you got from EFI Studio in step 3.

Save your file, and reboot, you should now be able to login in the Mac App Store!


To enable hibernation, if you prefer it over normal sleep (fix the wake brightness problem), open terminal and issue this command:

 

sudo pmset -a hibernatemode 1

For hotkeys just use spark and set your shortcuts with the ctrl key.

Now this is a complete working 10.6.8 Mac OS X on the ASUS Eee PC 1000H!

Until I found a way to make the ralink chip use the airport like prefpane and icon from aquamac here is some nice utility that will auto quit the ralink utility upon boot, this script will check if a gateway is set, and if so, will auto close the ralink utility, no user input needed, just add it into your login items under account settings, its attached in this post. Credits to Carlos from insanelywind, i adapted the script for the ralink utility. Optional: I added with it Paciotti's Mod that will hide the icon in the dock, just execute once the applescript and enter your password.

Attached Files



#98
cyberghoser1

cyberghoser1

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts

How to stop hard drive clunk noises, bad head parking for Asus EEEPC 1000H

Hard drive clicking noise is due to bad apm management under OSX and maybe other operating systems, in this tutorial i will cover the problem under OSX.

Steps:

Since original 2204 bios does not have an option to turn on AHCI for the Hard Drive we have to use a modded one, don't panic its easy. AHCI is needed to allow hdapm to work, otherwise its impossible under SL to avoid this issue.

Step A (Precaution, it is at your own risk, messing with the BIOS can be bad for your netbook)

Download this Bios(2204) Modded with AHCI feature: http://www.mediafire...x7k2of7g33kmqcw credits to bios mods folks!
Extract the file and put 1000H.ROM in a 1gb usb stick formated with fat16 system file (maybe 2gb usb sticks works too but not over that size) or burn it to a cd (do it under windows, on mac i had no success and the bios rom file whas not found by ez flash)

Step B

Connect your usb with the 1000H.ROM file in the computer and start your asus eeepc 1000h and hit atl+f2 when you see your bios screen
EZ Flash will start and scan usb devices for the 1000H.ROM file.
Once it found it it will start programming the new bios.
Please don't unplug your Power AC Cord, just don't touch the netbook until the EZ Flash tells you to turn it off.

Step C

Boot up your asus eeepc 1000H again, this time you should see some clouds(hehe) that's the modded bios logo, hit f2 and enter in bios. (Or f1 as requested because configutation is changed)

Under Advanced set ATA/IDE Configuration to Enhanced
Under the same category set Sata Mode to AHCI

You are done with the bios. Save and Exit.

Boot into your Mac OS X.

Download hdapm from here: http://mckinlay.net.nz/hdapm/
Install it, and reboot.

You should see under the console(Utilities folder)something like this:

9/12/12 3:43:40 PM hdapm2[44] disk0: ST9160827AS
9/12/12 3:43:40 PM hdapm2[44] Set APM Level to 0xfe: Success

If not, sometimes the original plist of hdapm fails to load, but don't panic we have a solution for this too!

Download Lingon here: http://www.mediafire...5wbbk4gtmgwbthd, lingon is an app that allows us to make custom plist daemon launchers, and we will create one for hdapm, to be sure its executed at every login.

This version of lingon is an old one and was free from sourceforge but the link does not exist anymore so i uploaded it for you.

Launch Lingon and do the following:

You have to create a new .plist for hdapm. Click on New (top-left in the program) and check ‘User Daemons’ and then ‘create’. In the 1st field fill in:

hdapm2

the 2nd field:

/usr/local/bin/hdapm disk0 max

and on the bellow box, check:

"Run it when it is loaded by the system (at startup or login)"

You created hdapm2, as you can see on the left. Go into /Library/LaunchDaemons and delete the hdapm.plist and leave the hdapm2.plist intact, reboot and hdapm will successfully start upon boot.

Now reboot and under console you should see something like this:

9/12/12 3:43:40 PM hdapm2[44] disk0: ST9160827AS
9/12/12 3:43:40 PM hdapm2[44] Set APM Level to 0xfe: Success

Congratulations, no more Clunks, clicks or whatsoever! Happy silence!

Note about the bios: Restart takes more time, its a known bug, just wait few seconds and it will restart. You'll have to live with it, better this than those bad clicks on the disk ;-)

#99
hshar

hshar

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male

To update to 10.6.8 Follow the same procedure as post #88 and just proceed with the following:

1. Download Nawcom 10.6.8 Legacy Kernel & Correct GMA950 kexts for 10.6.8 (using AppleIntelIntegratedFramebuffer.kext from 10.6.6 to fix brightness issue after wake, only in hibernate mode)
2. Rename mach_kernel to mach_kernel_old and copy Nawcom's 10.6.8 Legacy Kernel to / and rename it to mach_kernel:

sudo mv /mach_kernel /mach_kernel_old
sudo mv /legacy_kernel-10.6.8 /mach_kernel


Thanks cyberghoser1 for the guide. Downloading the 10.6.8 combo update right now.

Ready to implement the procedure. However the download link for "Nawcom 10.6.8 Legacy Kernel" gives me only 3xx kb (4 kb). Have tried to extract the downloaded file but still get ONLY 4 kb. I assume that the download link is broken or the file is corrupted. What is the approximate size of the kernel? Is there any other download link I can use?
Thanks in advance.

Edited by hshar, 09 February 2013 - 01:35 PM.


#100
Cucurbitacée

Cucurbitacée

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
Hi everyone,

Thanks to a mix of this tutorial and the German one I've achieved a 99% working 1000H running 10.6.8. :star_sunglasses:

I'm coming here to know if anyone has a clue to fix the last 1%.

Here are the last points that bother me:
  • The webcam is not working, if I start Photo Booth I can see the green led lighting on. But the screen stays black and if I try to capture something the software hangs.
  • fn hotkeys are partially working. The num pad, page up, page down, home and end are working. But the ones likes volume or brightness are not working. Which is strange because at least the brightness control is working during startup (the grey Apple logo).
  • Chameleon only sees 800x600 resolutions, then I had to use SwitchResX to get proper 1024x600.
See, these are minor issues and I can do perfectly with them. But in case someone has any idea to get to 100%, I'd gladly take them. :whistle:

Here is a screenshot of the video info from Chameleon and the settings of my org.chameleon.Boot.plist through Chameleon Wizard, in case it can help:
Posted Image

Posted Image

Thanks in advance. :wub:





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy