Jump to content

Iphone SDK on Leopard?


  • Please log in to reply
5 replies to this topic

#1
supergnu

supergnu

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
Hi!

Is it somehow possible to run the latest IPhone SDK (IOS 4.1) on leopard? i'm running on 1.5.8 (iDeneb 1.3 with iDeneb combo update) and when i try to install the SDK it tells me that i need at least 1.6.2


Thanks for the help!

#2
Wa7ed Men el NaSS

Wa7ed Men el NaSS

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
the iPhone SDK 4 requires at least 10.6.3

i have a problem
i have installed mac osx 10.6.3 iAtkos s3 v2 on my Dell studio 1537 and all drivers works except the USB
i have installed the iphone sdk 4.1 and i have installed it and it works fine, but after i restart my laptop and try to enter the mac again it gives me an error msg "Please, hold down the power button and try to restart your machine ..."
i tried to only install mac and other programs and it works fine only when i install the ios sdk 4.1 it fails !!!
any solutions ???

Thanks a lot,
Saad !

#3
Scottapotamas

Scottapotamas

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 357 posts
  • Gender:Male
Attached File  xcode.png   65.68KB   27 downloads

You cannot run XCODE 4 on Leopard. It explicitly requires snowleopard. Installing it shouldn't be too hard. Search the forums



And to Wa7ed Men el NaSS,
There are a few issues with XCODE 4, not xcode 3.2.x with iOS4, because i believe it changes a driver or two somewhere.

You appear to be having a kernel panic. Boot your hackintosh into verbose mode (-v from the text line) and tell/post an image of the text that shows on the panic.

#4
umairhaque

umairhaque

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 6 posts
Budy i am successfully Running Xcode 3.1.4 with iphone sdk 3.1.3 on Snow leopard 10.6.1 by Hazard and its working perfectly....

#5
Scottapotamas

Scottapotamas

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 357 posts
  • Gender:Male
You are talking about 3.1.4. we are talking about xcode 4 beta (its up to 5 now)

And here's a little resource for everyone, need a developer licence

http://connect.apple...oa/wa/downloads

You can get all the previous versions of everything way back to the 10.1 version of xcode...

#6
umairhaque

umairhaque

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 6 posts
yup Scottapotamas but i also need to upgrade mac os.. because xcode 4 support 10.6.3 above... so i am currently running 10.6.1. and i will upgrade it but every thing takes some time





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy