Jump to content

BeamSync, How could i know if it is enabled? What is that ?


  • Please log in to reply
8 replies to this topic

#1
MacBeholder

MacBeholder

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Location:Brazil
Is there a way to see if BeamSync is enabled on my osx ?
I´m wiht oxs 10.4.7 Jas

Beam Sync is already disabled wiht this version ?
What kind of trouble may i have, disabling it?
What is the best method ?

But clearly, I would like to see the status of this
if it is enabled or disabled.

Everything is ok with my intel gma900 graphic card.

Thanks man

#2
Rammjet

Rammjet

    InsanelyMac V.I.P.

  • Gurus
  • 5,302 posts
  • Gender:Male
Go to Terminal in the Utilities folder and type:

sudo defaults write /Library/Preferences/com.apple.windowserver Compositor -dict deferredUpdates 0

That will disable Beamsync

#3
MacBeholder

MacBeholder

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Location:Brazil

Go to Terminal in the Utilities folder and type:

sudo defaults write /Library/Preferences/com.apple.windowserver Compositor -dict deferredUpdates 0

That will disable Beamsync

Thanks Rammjet!
I just paste your code on terminal an my bean sync was disabled!

I Ran xbench and it increase the overall result from 68 to 85 !!!!!!

But just it
I don t feel any change performance in my usual use of applications.
And i can feel my eyes tearing, it seems that bean sync helps a lot my miope eyes.

Please, how could I turn on again bean sync via terminal ?
Just to test it after .....

Very Thanks man!!!

#4
Rammjet

Rammjet

    InsanelyMac V.I.P.

  • Gurus
  • 5,302 posts
  • Gender:Male

Please, how could I turn on again bean sync via terminal ?


It is best used on an LCD monitor not a CRT.

To turn it back on, just use the same command, but change the 0 to a 1

#5
MacBeholder

MacBeholder

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Location:Brazil
Thanks for the patience
Well i used the command
sudo defaults write /Library/Preferences/com.apple.windowserver Compositor -dict deferredUpdates 1

to turn on back again bean sync, but it does not work.
Im still feeling the tearing , and my xbench are up to 87

before i ran
sudo defaults write /Library/Preferences/com.apple.windowserver Compositor -dict deferredUpdates 0

xbench was at 65.

If you could help me again, will be greatful
Thanks Rammjet

#6
Rammjet

Rammjet

    InsanelyMac V.I.P.

  • Gurus
  • 5,302 posts
  • Gender:Male
The values are:

0 = disable beamsync
1 = Auto beamsync
2 = force beamsync

To check your current setting, run this in Terminal:

defaults read /Library/Preferences/com.apple.windowserver Compositor -dict deferredUpdates

It will give you the value of "deferredUpdates"

#7
MacBeholder

MacBeholder

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Location:Brazil
Thanks again!!! but it still dont work.... /
i put 2 to force, and reestar , then used
defaults read /Library/Preferences/com.apple.windowserver Compositor -dict deferredUpdates

and it shows me 2
but in xbench the same result as if beamsync disabled.
And im still feeling the tearing ...

#8
Rammjet

Rammjet

    InsanelyMac V.I.P.

  • Gurus
  • 5,302 posts
  • Gender:Male
Try a reboot. Values in the plist are read at boot time.

#9
MacBeholder

MacBeholder

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Location:Brazil
Ok man, it works now !!
But i enabled QE2D to make it work.

now with beamsync on , xbench = 77
with beamsync off, xbench = 87.90

uow , all this with just 512 of ram....
I ll put 1GB plus, and last see if i definely let just MAC OSx to my webdesign job.

Thanks a lot
Need something, just ask :(

Excuse my english, Im from Brazil !





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy