Jump to content

Asus EEE 1215N


  • Please log in to reply
249 replies to this topic

#161
AnalogMan

AnalogMan

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Thank you all for your work in bringing OS X to the 1215N. The posts from AnalogMan, Devout, theHAWKS and others have all been very helpful in finally getting OS X installed on my machine.

I currently have the existing Windows 7 installation, OS X 10.6.7, and Ubuntu 10.10 all installed on the internal HDD and booting via Chameleon (selecting the linux partition starts up GRUB2)

I do have a few issues/questions though.

After several attempts and trying many different methods, I ended up following mostly the posts from Devout and AnalogMan to install 10.6.3 and then the 10.6.7 update. I am able to boot from Chameleon with -v -f, but if I try to do it normally it always hangs.

My Wifi is now working, but I cannot get full resolution display working.

I'm pretty new to the OSx86 scene and have very limited experience with OS X in general (which I hope to rectify with this installation), so I'm wondering if anyone knew anything I could try to make it work.

Where does it hang? A grey screen? Can you boot with just -v and tell us where it hangs?
If it's hanging on just a grey screen than Chameleon isn't patching the video. Which is odd as NetbookInstaller 0.8.5pre should have done that when you ran it on 10.6.3

Open your Extra/com.apple.Boot.plist file and find this line:
<key>Graphics Mode</key>
<string>1366x768x32</string>

If you don't have that line you could try booting up with
boot: "Graphics Mode" = "1366x768x32" and see if that works. If it does then you'd need to add that key to your boot plist

I don' t use modified (with dev. id) AppleIntelGMA950 or AppleIntelIntegratedFrameBuffer.
Uses 10.6.7 kexts with my DSDT.aml.


Hey, thanks for the DSDT, with it I was able to get sleep working properly, thank you!

#162
Devout

Devout

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts
I'm glad my posts help. It was such a task of figuring out how to install the OS onto my netbook from the posts before, so I just had to write a guide. The update post can be replaced with Analogs post of how to update to 10.6.7, so that's pretty cool, if you want to run 10.6.7. It looks like the only things we need is QE/CI support. (Or wireless for poor broadcom holders, like mine ;))

I'm running pure Windows 7 again on my 1215N, since I've decided to install it on my desktop machine. I can enjoy QE/CI once again, and it's running like a hawk. I'll visit regularly for future develops tho.

#163
desj

desj

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Where does it hang? A grey screen? Can you boot with just -v and tell us where it hangs?
If it's hanging on just a grey screen than Chameleon isn't patching the video. Which is odd as NetbookInstaller 0.8.5pre should have done that when you ran it on 10.6.3

Open your Extra/com.apple.Boot.plist file and find this line:
<key>Graphics Mode</key>
<string>1366x768x32</string>

If you don't have that line you could try booting up with
boot: "Graphics Mode" = "1366x768x32" and see if that works. If it does then you'd need to add that key to your boot plist



Hey, thanks for the DSDT, with it I was able to get sleep working properly, thank you!


Yes it was hanging at a gray screen. Booting with "Graphics Mode" = "1366x768x32" made it work once with full resolution, but now it keeps hanging at the same black screen unless I boot with -v -f (which then leaves me without full resolution again).

Here is a picture of where it hangs.

Posted Image


This is what my Boot.plist looks like.

Posted Image

#164
AnalogMan

AnalogMan

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Well, the hang is being caused by your audio drivers. I still get that occasionally but usually booting again or at most a third time gets me passed. As for your boot.plist it's the same as mine.

Just to make sure I specify, theHAWKS extra folder I used was NOT the one in devout's tutorial post but the one theHAWK posted himself in this post: Here

#165
fghj

fghj

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi guys , i finally managed to boot into osx again :D
But when i upgraded using Devouts guide, something went wrong :(
When i reeboted the graphical bootloader was gone and when I try to boot into OS X i get "Unable to locate module /Extra/modules/Symbols.dylib.

If i press any key at that point I'm getting to Chameleon v2.0-RC5 bootloader. If I choose OS X from there I only get a grey screen(black if i boot with -v -f). Is there a way to fix this?

#166
Devout

Devout

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts

Hi guys , i finally managed to boot into osx again :D
But when i upgraded using Devouts guide, something went wrong :)
When i reeboted the graphical bootloader was gone and when I try to boot into OS X i get "Unable to locate module /Extra/modules/Symbols.dylib.

If i press any key at that point I'm getting to Chameleon v2.0-RC5 bootloader. If I choose OS X from there I only get a grey screen(black if i boot with -v -f). Is there a way to fix this?


Strange, my upgrade guide for 10.6.5 is very patcy since I haven't had the time to fully write out everything and test it. Sorry for inconvenience, follow the following posts for more stable information ^__^.

#167
DeVaL!aN

DeVaL!aN

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I finally able to run mac properly. But weird thing is. My trackpad and keyboard doesn't function.. but usb mouse do function tho.

I going to get a keyboard to try later.

Any idea how is this happen?

I'm on 10.6.5 now

#168
Devout

Devout

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts

I finally able to run mac properly. But weird thing is. My trackpad and keyboard doesn't function.. but usb mouse do function tho.

I going to get a keyboard to try later.

Any idea how is this happen?

I'm on 10.6.5 now


You need to use the IOUSBFAMILY.kext from 10.6.3

#169
DeVaL!aN

DeVaL!aN

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

You need to use the IOUSBFAMILY.kext from 10.6.3


thanks for the suggestion.

i found the kext from 10.6.3 installation disk.

but previously i trial and error. i loaded apple.ps2 controller kext. now i got kernel panic.
i plugged my drive into windows with macdrive. deleted the kext from S/l/e folder.

Attached Files



#170
DeVaL!aN

DeVaL!aN

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
im so frustrated these day.

i made a fresh new installation for more than 15 times already.

today i did everything very carefully. i installed fresh new 10.6.3. then without restart i installed 10.6.5, loaded extra folder and mach_kernel_atom into root.

reboot, and everything works perfectly. then i put AtherosL1C.kext into /extras/Extension run extra_update.app and reboot once it done.

wifi and ethernet works perfectly once reboot.

but trackpad and keyboard totally dead. usb keyboard and usb mouse is working. things is the usb keyboard is borrowed from friend. and it doesnt make sense that my keyboard doesnt work.

i loaded IOUSBFAMILY.kext into /extras/Extension and run extra_update.app again. once reboot, kernel panic.

anyone have idea here? please help... :)

#171
AnalogMan

AnalogMan

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

im so frustrated these day.

i made a fresh new installation for more than 15 times already.

today i did everything very carefully. i installed fresh new 10.6.3. then without restart i installed 10.6.5, loaded extra folder and mach_kernel_atom into root.

reboot, and everything works perfectly. then i put AtherosL1C.kext into /extras/Extension run extra_update.app and reboot once it done.

wifi and ethernet works perfectly once reboot.

but trackpad and keyboard totally dead. usb keyboard and usb mouse is working. things is the usb keyboard is borrowed from friend. and it doesnt make sense that my keyboard doesnt work.

i loaded IOUSBFAMILY.kext into /extras/Extension and run extra_update.app again. once reboot, kernel panic.

anyone have idea here? please help... :(

After the 10.6.5 upgrade is done (not using 10.5.7? If you do you don't need the Atheros Kext), are you rerunning NetBookInstaller before loading the Extra folder and running extra_update?

You Install 10.6.3.
Upgrade to 10.6.7 (or 5 in your case)
Run NetBookInstaller
Copy Extra folder
Run update_extra
Reboot

#172
DeVaL!aN

DeVaL!aN

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

After the 10.6.5 upgrade is done (not using 10.5.7? If you do you don't need the Atheros Kext), are you rerunning NetBookInstaller before loading the Extra folder and running extra_update?

You Install 10.6.3.
Upgrade to 10.6.7 (or 5 in your case)
Run NetBookInstaller
Copy Extra folder
Run update_extra
Reboot


Thanks man. i think i found the culprit. the Microsoft Mouse 3500, the nano receiver is plugged in throughout the installation process and kill the keyboard and trackpad.

i unplugged it. reinstalled twice with all random sequence, it jz works.. now still figuring out how is 1366x768 going to work. i replaced the DSDT, put in extra folder. nothing work.

any different made with nvidia driver installed?

#173
Niksda

Niksda

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hey Guys!
I got the Asus 1015pn Netbook, which is pretty similar to the 1215.
I am wondering if your Tutorial might work also on my 1015pn.
i got Snow Leopard running with iAtkos S3v2 and a tutorial, but its not very smooth and i think ion2 is recognized as Ion and i didnt figure out how to upgrade it.

Some Questions.
I didnt quite understand most of the things u discussed here (prolly cause im noob ;)) but i will get it work with a proper tutorial!, so :
Is Intel GMA 3150 working? Cause i read plenty of threads saying its not compatible with snow
Is Nvidia ION 2 working? with full performance?

Greets, Niksda.
PS: Im German, so if anyone of you guys is German pls PM me so i can ask u some questions!

EDIT: i tried the Tutorial by DEVOUT on my 1015pn and its WORKING!!
in this thread i saw some screenshots in spanish or smth. where both graphiccards were listed GMA 3150 and NVIDIA GT218, so i assume u figured smth out to make them both work?

#174
mattk926

mattk926

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Ok guys, I'm new to the hackintosh scene. I got osx 10.6.3 installed. Ran the 10.6.7 Combo update, before restarting i ran the netbook installer and it is just hanging at regenerating DSDT.aml. anyone got any ideas?

** UPDATE ** ok so i ran the netbook installer from THEHAWKs pacakge and it worked... now the problem i'm getting is the wifi. At the university we use WPA 2 Enterprise and its having difficulties connecting properly. Without THEHAWKs netbookinstaller it seemed to work fine and connect and get an IP address. this was using the KEXT from an earlier post. Any ideas? **

#175
TheCONDOR

TheCONDOR

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male
  • Location:Italy
Linux users solved their problems with Nvidia Optimus:

http://www.martin-juhl.dk/


We can hope in a porting for OSX? :rolleyes:

#176
meat CRime

meat CRime

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Linux users solved their problems with Nvidia Optimus:

http://www.martin-juhl.dk/


We can hope in a porting for OSX? :rolleyes:


Awesome man, shouldn't be long now. :P

#177
flatfrog

flatfrog

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Hey Guys,

Even though Bumblebee solves the Nvidia Optimus problem on the Linux side You shouldn't get Your hopes up. Until the GMA3150 is working this solution won't work even if it's been ported to OS X. Let's just hope Meklort comes up with a brilliant solution for the GMA3150 :-)

Cheers

#178
NightDemon

NightDemon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
anyone already tried to install lion dp4?

#179
MacieKK

MacieKK

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Hi!

I haven't been reading this discussion for about 3 months.
Anything has changed ION2 gt218?
Is there any way to turn it on on 1215n?

greetings
MacieKK

#180
NightDemon

NightDemon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts

Hi!

I haven't been reading this discussion for about 3 months.
Anything has changed ION2 gt218?
Is there any way to turn it on on 1215n?

greetings
MacieKK


following the topic to get these answers too

and a lion installation





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy