Jump to content

ATI Radeon HD6000, HD5000 and HD4000 series support in Chameleon


  • Please log in to reply
859 replies to this topic

#581
Martuzki

Martuzki

    Back 2 the Mac ;-)

  • Members
  • PipPipPipPip
  • 243 posts
  • Gender:Male
  • Location:Germany
what about the Radeon 4570 Mobility?

#582
FKA

FKA

    are we there yet?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,626 posts
  • Gender:Male

i don't know what is valv's booter with CPU PM enabled


Do you have in boot.plist:

<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>

?

If you do, you should look at this: http://www.projectos...p?showtopic=564

The remove of IRQ from Device (_PIC ... is also a fix for a stutter issue when CPU Power management is running!

Please note if you add IRQ to HPET device it is more commonly:

IRQNoFlags ()
{2}
IRQNoFlags ()
{8}

As apposed to

IRQNoFlags ()
{0}
IRQNoFlags ()
{8}

But this can be checked by looking at 'IOInterupSpecifieres' in IOregexplorer (google for download and is part of XCode tools.)
i.e. If I set 0 and 8 , I can see that the OS is using 2 and 8 regardless. So I set 2 and 8 in DSDT!

Note: IRQ values in IOregExplorer are in Hex but are in Decimal in DSDT!

D

#583
Guest: ^Andy^_*

Guest: ^Andy^_*
  • Guests
Is it just me or is this getting very off topic? :D

#584
FKA

FKA

    are we there yet?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,626 posts
  • Gender:Male

Is it just me or is this getting very off topic? :D


a little bit! :P

#585
TH3L4UGH1NGM4N

TH3L4UGH1NGM4N

    (~_~)

  • Retired
  • 1,156 posts
  • Gender:Male
  • Location:Wonderland
  • Interests:(~_^)
Nothing wrong with going a bit off topic so long as you aren't floating into Limboland in a thread

#586
Piero87

Piero87

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 221 posts

Do you have in boot.plist:

<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>

?

If you do, you should look at this: http://www.projectos...p?showtopic=564

The remove of IRQ from Device (_PIC ... is also a fix for a stutter issue when CPU Power management is running!

Please note if you add IRQ to HPET device it is more commonly:

IRQNoFlags ()
{2}
IRQNoFlags ()
{8}

As apposed to

IRQNoFlags ()
{0}
IRQNoFlags ()
{8}

But this can be checked by looking at 'IOInterupSpecifieres' in IOregexplorer (google for download and is part of XCode tools.)
i.e. If I set 0 and 8 , I can see that the OS is using 2 and 8 regardless. So I set 2 and 8 in DSDT!

Note: IRQ values in IOregExplorer are in Hex but are in Decimal in DSDT!

D


i try to install the anval boot 5.1.4, and i add this:
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>PatchKernel</key>
<string>Yes</string>
to the boot.plist, but it's the same, i make another example if i open xcode, and i go to developer documentation, the xcode crash and exit, why??or if when i open the first time safari that there is the animation presentation safari crash....please help...i don't do the part of IRQ because i haven't understood it...

i see that the system block every some second, i'm looking the activity monitor and the number of thread for example or the cpu use graphic, blocks for some second...block the all system...damn...any idea?

p.s. i really need developer documentation of xcode and wanna fix it please help

sorry for the off topic

#587
FKA

FKA

    are we there yet?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,626 posts
  • Gender:Male

i try to install the anval boot 5.1.4, and i add this:
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>PatchKernel</key>
<string>Yes</string>
to the boot.plist, but it's the same, i make another example if i open xcode, and i go to developer documentation, the xcode crash and exit, why??or if when i open the first time safari that there is the animation presentation safari crash....please help...i don't do the part of IRQ because i haven't understood it...

i see that the system block every some second, i'm looking the activity monitor and the number of thread for example or the cpu use graphic, blocks for some second...block the all system...damn...any idea?

p.s. i really need developer documentation of xcode and wanna fix it please help

sorry for the off topic


Sorry to dump this back on Mohamed but I think you need to move these questions back to his install thread.
I don't know enough about AMD installs and it sounds like you have something fundamentally wrong with yours, unrelated to your graphics card!

Cheers and good luck
D

#588
bbeepp

bbeepp

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:Poland
I have two questions:

1. Is ATI 5450 supported in this Chameleon? Card id is - 68f9

2. Should I use "UseAtiROM" com.apple.boot.plist with ROM image or it has another purpose?

#589
wastez

wastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 166 posts
  • Gender:Male

Do you have in boot.plist:

<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>


Does this work on an amd system? Would be really interessting!!!

Thx & Greetz

#590
FKA

FKA

    are we there yet?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,626 posts
  • Gender:Male

Does this work on an amd system? Would be really interessting!!!

Thx & Greetz


Looks like it!
http://www.insanelym...p...t&p=1626934

#591
FKA

FKA

    are we there yet?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,626 posts
  • Gender:Male
Hi Kabyl

I'm back with your booter full time as I'm gettin some video errors with the others!

I've got a few odderties if you don't mind having a look?

MSR_IA32_PERF_STATUS (0x198): 0x0616082006000820max: 8 current: 8CPU: Vendor/Model/ExtModel: 0x756e6547/0x17/0x1CPU: Family/ExtFamily:      0x6/0x0CPU: MaxCoef/CurrCoef:      0x8/0x8CPU: MaxDiv/CurrDiv:        0x0/0x0CPU: TSCFreq:               3215MHzCPU: FSBFreq:               401MHzCPU: CPUFreq:               3215MHzCPU: NoCores/NoThreads:     4/4CPU: Features:              0x0000025fAttempting to read GPTRead GPTReading GPT partition 1, type C12A7328-F81F-11D2-BA4B-00A0C93EC93BReading GPT partition 2, type 52414944-0000-11AA-AA11-00306543ECACReading GPT partition 3, type 426F6F74-0000-11AA-AA11-00306543ECACRead HFS+ file: [hd(0,3)/System/Library/CoreServices/.disk_label.contentDetails] 16 bytes.Read HFS+ file: [hd(0,3)/Extra/com.apple.Boot.plist] 1057 bytes.Attempting to read GPTRead GPTReading GPT partition 1, type C12A7328-F81F-11D2-BA4B-00A0C93EC93BReading GPT partition 2, type 52414944-0000-11AA-AA11-00306543ECACReading GPT partition 3, type 426F6F74-0000-11AA-AA11-00306543ECACRead HFS+ file: [hd(1,3)/System/Library/CoreServices/.disk_label.contentDetails] 16 bytes.Attempting to read GPTRead GPTReading GPT partition 1, type C12A7328-F81F-11D2-BA4B-00A0C93EC93BReading GPT partition 2, type 48465300-0000-11AA-AA11-00306543ECACRead HFS+ file: [hd(0,3)/Extra/Themes/Daves/theme.plist] 2714 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/background.png] 966 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/logo.png] 333 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_generic.png] 5347 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_hfsplus.png] 12670 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_hfsraid.png] 18469 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_ext3.png] 12538 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_fat16.png] 5102 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_fat32.png] 5254 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_ntfs.png] 10969 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_cdrom.png] 5228 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_selection.png] 1262 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_scroll_prev.png] 1012 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_scroll_next.png] 1013 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_boot.png] 1747 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_verbose.png] 4116 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_ignore_caches.png] 4051 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_single_user.png] 4114 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_memory_info.png] 1634 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_video_info.png] 1593 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_help.png] 1711 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_verbose_disabled.png] 1370 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_ignore_caches_disabled.png] 1445 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_single_user_disabled.png] 1485 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_selection.png] 323 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/progress_bar.png] 344 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/progress_bar_background.png] 369 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/text_scroll_prev.png] 733 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/text_scroll_next.png] 743 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/font_console.png] 3499 bytes.Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/font_small.png] 6244 bytes.Read HFS+ file: [hd(0,3)/Extra/com.apple.Boot.plist] 1057 bytes.Read HFS+ file: [hd(0,3)/com.apple.boot.S/Library/Preferences/SystemConfiguration/com.apple.Boot.plist] 358 bytes.Read HFS+ file: [hd(0,3)/System/Library/CoreServices/SystemVersion.plist] 479 bytes.Loading Darwin 10.6Loading kernel mach_kernelRead HFS+ file: [hd(0,3)/mach_kernel] 4096 bytes.Read HFS+ file: [hd(0,3)/mach_kernel] 5579907 bytes.LoadDrivers: Loading from [/Extra/Extensions.mkext]Read HFS+ file: [hd(0,3)/Extra/Extensions.mkext] 4096 bytes.Read HFS+ file: [hd(0,3)/Extra/Extensions.mkext] 49944 bytes.LoadDrivers: Loading from [/com.apple.boot.S/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext]Read HFS+ file: [hd(0,3)/com.apple.boot.S/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] 4096 bytes.Read HFS+ file: [hd(0,3)/com.apple.boot.S/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] 4393815 bytes.LoadDrivers: Loading from [/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext]Read HFS+ file: [hd(0,3)/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] 4096 bytes.Read HFS+ file: [hd(0,3)/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] 4393815 bytes.Read HFS+ file: [hd(0,3)/Extra/DSDT.aml] 28665 bytes.Using PCI-Root-UID value: 0ATI card POSTed, reading VBIOS from legacy spaceATI Juniper ATI Radeon HD 5770 1024MB (Vervet) [1002:68b8] (subsys [1682:2991]):: PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)Read HFS+ file: [hd(0,3)/Extra/smbios.plist] 684 bytes.Intel P45/G45 DRAM Controller [8086:2e20] at 00:00.0Frequency detected: 643 MHz (1286) Dual Channel     CAS:9 tRC:9 tRP:9 RAS:24 (9-9-9-24)SMBus CmdReg: 0x3Scanning SMBus [8086:3a30], mmio: 0xfe6fec04, ioport: 0x400, hostc: 0x1SPD[0] (size): 146 @0x50Slot: 0 Type 24 2048MB (DDR3 SDRAM) 1286MHz Vendor=Kingston      PartNo=99U5471-002.A00LF SerialNo=8C2E17ACSPD[0] (size): 146 @0x51Slot: 1 Type 0 0MB (EPROM) 1286MHz Vendor=NoName      PartNo= SerialNo=8C2E17ACSPD[0] (size): 146 @0x52Slot: 2 Type 24 2048MB (DDR3 SDRAM) 1286MHz Vendor=Kingston      PartNo=99U5471-002.A00LF SerialNo=8D2EFCABSPD[0] (size): 146 @0x53Slot: 3 Type 24 2048MB (DDR3 SDRAM) 1286MHz Vendor=Kingston      PartNo=99U5471-002.A00LF SerialNo=8D2E19ACSPD[0] (size): 176 @0x54Slot: 4 Type 0 0MB (EPROM) 1286MHz Vendor=NoName      PartNo= SerialNo=8D2E19ACSPD[0] (size): 176 @0x55Slot: 5 Type 0 0MB (EPROM) 1286MHz Vendor=NoName      PartNo= SerialNo=8D2E19ACSPD[0] (size): 255 @0x56SPD[0] (size): 255 @0x57CPU is Intel® Core™2 Quad  CPU   Q9450  @ 2.66GHz, family 0x6, model 0x17Type: 0, Length: 24, Handle: 0x0BIOSInformation:    vendor: Apple Inc.    version: IM91.88Z.008D.B08.0904271717    releaseDate: 11/06/2009Type: 1, Length: 27, Handle: 0x1SystemInformation:    manufacturer: Apple Inc.    productName: iMac9,1    version: 1.3    serialNumber: W87234JHYA4    uuid: 00020003-0004-0005-0006-000700080009    wakeupReason: 0x6    skuNumber: To Be Filled By O.E.M.    family: iMacType: 2, Length: 15, Handle: 0x2BaseBoard:    manufacturer: Apple Inc.    product: Mac-F2218FC8    version: 1.0    serialNumber: To be filled by O.E.M.    assetTagNumber: To Be Filled By O.E.M.    locationInChassis: To Be Filled By O.E.M.    boardType: 0xAType: 3, Length: 21, Handle: 0x3SystemEnclosure:    manufacturer: MICRO-STAR INTERNATIONAL CO.,LTD    type: 3    version: 1.0    serialNumber: To Be Filled By O.E.M.    assetTagNumber: To Be Filled By O.E.M.Type: 4, Length: 40, Handle: 0x4ProcessorInformation:    socketDesignation: CPU 1    processorType: 3    processorFamily: 0xC2    manufacturer: Intel    processorID: 0x10677    processorVersion: Intel® Core™2 Quad  CPU   Q9450  @ 2.66GHz    externalClock: 401MHz    maximumClock: 3215MHz    currentClock: 2666MHz    serialNumber: To Be Filled By O.E.M.    assetTag: To Be Filled By O.E.M.    partNumber: To Be Filled By O.E.M.Type: 7, Length: 19, Handle: 0x5Type: 7, Length: 19, Handle: 0x6Type: 7, Length: 19, Handle: 0x7Type: 5, Length: 24, Handle: 0x8Type: 6, Length: 12, Handle: 0x9Type: 6, Length: 12, Handle: 0xaType: 6, Length: 12, Handle: 0xbType: 6, Length: 12, Handle: 0xcType: 8, Length: 9, Handle: 0xdType: 8, Length: 9, Handle: 0xeType: 8, Length: 9, Handle: 0xfType: 8, Length: 9, Handle: 0x10Type: 8, Length: 9, Handle: 0x11Type: 8, Length: 9, Handle: 0x12Type: 8, Length: 9, Handle: 0x13Type: 8, Length: 9, Handle: 0x14Type: 8, Length: 9, Handle: 0x15Type: 8, Length: 9, Handle: 0x16Type: 8, Length: 9, Handle: 0x17Type: 8, Length: 9, Handle: 0x18Type: 8, Length: 9, Handle: 0x19Type: 8, Length: 9, Handle: 0x1aType: 8, Length: 9, Handle: 0x1bType: 8, Length: 9, Handle: 0x1cType: 8, Length: 9, Handle: 0x1dType: 8, Length: 9, Handle: 0x1eType: 8, Length: 9, Handle: 0x1fType: 8, Length: 9, Handle: 0x20Type: 8, Length: 9, Handle: 0x21Type: 8, Length: 9, Handle: 0x22Type: 8, Length: 9, Handle: 0x23Type: 8, Length: 9, Handle: 0x24Type: 9, Length: 13, Handle: 0x25Type: 9, Length: 13, Handle: 0x26Type: 9, Length: 13, Handle: 0x27Type: 9, Length: 13, Handle: 0x28Type: 10, Length: 6, Handle: 0x29Type: 13, Length: 22, Handle: 0x2aType: 16, Length: 15, Handle: 0x2bType: 18, Length: 23, Handle: 0x2cType: 19, Length: 15, Handle: 0x2dType: 17, Length: 27, Handle: 0x2eMemoryDevice:    deviceLocator: DIMM1    bankLocator: BANK0    memoryType: DDR3    memorySpeed: 1286MHz    manufacturer: Kingston    serialNumber: 8C2E17AC    assetTag: AssetTagNum0    partNumber: 99U5471-002.A00LFType: 18, Length: 23, Handle: 0x2fType: 20, Length: 19, Handle: 0x30Type: 17, Length: 27, Handle: 0x31MemoryDevice:    deviceLocator: DIMM2    bankLocator: BANK1    memoryType: SDRAM    memorySpeed: 1286MHz    manufacturer: NoName    serialNumber: 8C2E17AC    assetTag: AssetTagNum1    partNumber: PartNum1Type: 18, Length: 23, Handle: 0x32Type: 20, Length: 19, Handle: 0x33Type: 17, Length: 27, Handle: 0x34MemoryDevice:    deviceLocator: DIMM3    bankLocator: BANK2    memoryType: DDR3    memorySpeed: 1286MHz    manufacturer: Kingston    serialNumber: 8D2EFCAB    assetTag: AssetTagNum2    partNumber: 99U5471-002.A00LFType: 18, Length: 23, Handle: 0x35Type: 20, Length: 19, Handle: 0x36Type: 17, Length: 27, Handle: 0x37MemoryDevice:    deviceLocator: DIMM4    bankLocator: BANK3    memoryType: DDR3    memorySpeed: 1286MHz    manufacturer: Kingston    serialNumber: 8D2E19AC    assetTag: AssetTagNum3    partNumber: 99U5471-002.A00LFType: 18, Length: 23, Handle: 0x38Type: 20, Length: 19, Handle: 0x39Type: 22, Length: 26, Handle: 0x3aType: 32, Length: 20, Handle: 0x3bType: 34, Length: 11, Handle: 0x3cType: 28, Length: 22, Handle: 0x3dType: 36, Length: 16, Handle: 0x3eType: 35, Length: 11, Handle: 0x3fType: 27, Length: 14, Handle: 0x40Type: 36, Length: 16, Handle: 0x41Type: 35, Length: 11, Handle: 0x42Type: 27, Length: 14, Handle: 0x43Type: 36, Length: 16, Handle: 0x44Type: 35, Length: 11, Handle: 0x45Type: 39, Length: 22, Handle: 0x46Type: 131, Length: 6, Handle: 0x46AppleProcessorType:    ProcessorType: 0x501Type: 132, Length: 6, Handle: 0x47AppleProcessorBusSpeed:    ProcessorBusSpeed (QPI): 0.0GT/sType: 127, Length: 4, Handle: 0x48Customizing SystemID with : 00020003-0004-0005-0006-000700080009Read HFS+ file: [hd(0,3)/Extra/DSDT.aml] 28665 bytes.ACPI table not found: SSDT.amlFADT: Restart Fix applied!FADT: Using custom DSDT!Starting Darwin x86_64

With memory detection it hangs looking at memory slots that aren't there!!

Some times only 1 extra slot sometimes 2, sometimes slot 4 or 5 or both sometimes slot 7?

SPD[0] (size): 176 @0x54 Slot: 4 Type 0 0MB (EPROM) 1286MHz Vendor=NoName       PartNo= SerialNo=8D2E19AC SPD[0] (size): 176 @0x55 Slot: 5 Type 0 0MB (EPROM) 1286MHz Vendor=NoName       PartNo= SerialNo=8D2E19AC

Only slot 0, 1, 2 ,3 are filled (4 slots in total on this MB.)

Also the last SPD read say's size 176 - the other 3 are 255?

I have always had a memory error shown in System Profiler with MSI boards, during diagnostics check. Maybe this is the problem?

Power On Self-Test:  Last Run:	09/02/2011 00:12  Result:	Failed  Failure Type:	Memory  Memory Slots:	DIMM1/BANK0, DIMM2/BANK1, DIMM3/BANK2, DIMM4/BANK3

Secondly:- System UUID shown above is not registered in System Profiler. Although i think that in system profiler is correct (checking in windows now) and is not taken from EN0 Mac address!

UUID shown in bdmesg is correct but not shown in System Profiler.

Any help appreciated!

D

#592
bcc9

bcc9

    InsanelyMac Legend

  • Coders
  • 1,278 posts
  • Gender:Male
I did some more testing with the various AtiConfig choices for my 5670, and found that Uakari seems to be the best choice. Summary of working ports:
Uakari: DVI, HDMI, no displayport
Baboon: DVI, no HDMI, no displayport
Eulemer: no DVI, no HDMI, no displayport
Vervet: no DVI, no HDMI, displayport

Obviously this is not ideal as I haven't been able to get all 3 ports working at once.

I would hope there would be a better way to figure out the optimal config port setting instead of playing adventure with the 31 different choices. I note that netkas's ATY_Init injects display-connect-flags and connector-type for the relevent card ports; would be nice if these could just be set to control the working ports. But do these actually work or are they read-only ioregistry values that are only controlled by the AtiConfig name?

For now, my updated ati.c change for the sapphire 5670 is:
--- ati.orig.c	2011-02-04 23:15:12.629289002 -0800
 +++ ati.c	2011-02-04 23:14:53.339289026 -0800
 @@ -377,6 +377,7 @@
	  { 0x68D8,	0x5730174B,	CHIP_FAMILY_REDWOOD,	"ATI Radeon HD 5730",				kNull		},
	  { 0x68D8,	0x21D91458,	CHIP_FAMILY_REDWOOD,	"ATI Radeon HD 5670",				kBaboon		},
	  { 0x68D8,	0x03561043,	CHIP_FAMILY_REDWOOD,	"ATI Radeon HD 5670",				kBaboon		},
 +	{ 0x68D8,	0xE151174B,	CHIP_FAMILY_REDWOOD,	"ATI Radeon HD 5670",				kUakari		},
	  { 0x68D9,	0x301017AF,	CHIP_FAMILY_REDWOOD,	"ATI Radeon HD 5630",				kNull		},
	  { 0x68DA,	0x301017AF,	CHIP_FAMILY_REDWOOD,	"ATI Radeon HD 5630",				kNull		},
	  { 0x68DA,	0x30001787,	CHIP_FAMILY_REDWOOD,	"ATI Radeon HD 5630",				kNull		},

Additionally, since this card includes HDMI audio, I added hda-gfx entries to my DSDT for the card's address 0 and address 1.
(I think it would be nice for chameleon to includes these automatically when it sees an ATI audio controller at PCI slot .1)

However, even after adding the two hda-gfx entries, I get the AppleHDA driver attached under the HDAU node but no HDMI audio shows up under my audio settings. Do I have to hack AppleHDA as well for this to work? My ioregistry for the graphics & audio are attached.

Attached Files



#593
Sennen

Sennen

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Thank you very much for your work on this. Upgraded to a Sapphire Radeon HD 5770 and both DVI ports worked on first bootup using the Chameleon 2 RC5 Unofficial Package Installer and Kabyl's boot file.

Cinebench 11.5 gives 29-30 fps with a Core i7 920 processor and SMproductname set to MacPro3,1 in smbios.plist. Still looking into C- and P-state settings.

#594
MasterLen

MasterLen

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts
  • Location:Berlin

Thank you very much for your work on this. Upgraded to a Sapphire Radeon HD 5770 and both DVI ports worked on first bootup using the Chameleon 2 RC5 Unofficial Package Installer and Kabyl's boot file.

Cinebench 11.5 gives 29-30 fps with a Core i7 920 processor and SMproductname set to MacPro3,1 in smbios.plist. Still looking into C- and P-state settings.


Do not set your model to Macpro3,1 otherwise you will not get the right profile for your processor.
You have to set your SMproductname to Macpro5,1 or Macpro4,1 to get the nehalem profile....

Here is my complete Extra folder with fully editet DSDT and fakesmc with plugins....

http://www.insanelym...p...t&p=1634219

Regards

#595
FKA

FKA

    are we there yet?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,626 posts
  • Gender:Male

However, even after adding the two hda-gfx entries, I get the AppleHDA driver attached under the HDAU node but no HDMI audio shows up under my audio settings. Do I have to hack AppleHDA as well for this to work? My ioregistry for the graphics & audio are attached.


I've noticed that you need to have an HDMI monitor that is HDMI audio capable connected before you see the hdau option in System Profiler/ Audio

D

#596
Sennen

Sennen

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Do not set your model to Macpro3,1 otherwise you will not get the right profile for your processor.
You have to set your SMproductname to Macpro5,1 or Macpro4,1 to get the nehalem profile....

Here is my complete Extra folder with fully editet DSDT and fakesmc with plugins....

http://www.insanelym...p...t&p=1634219

Regards


Thank you for that, I'll give Macpro5,1 a go.

#597
bcc9

bcc9

    InsanelyMac Legend

  • Coders
  • 1,278 posts
  • Gender:Male

I've noticed that you need to have an HDMI monitor that is HDMI audio capable connected before you see the hdau option in System Profiler/ Audio

Yes, and so I tested thru my denon HDMI AVR and attached display. The ioregistry info I posted was when that HDMI connection was my only active connection.
I know that some 5770 users have reported working HDMI audio. I'm wondering whether there were any extra steps taken such as rolling back AppleHDA to 10.6.3, or injecting a layout-id, or explicitly configuring an HDMI pathmap (should auto-generate I believe).

#598
FKA

FKA

    are we there yet?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,626 posts
  • Gender:Male

Yes, and so I tested thru my denon HDMI AVR and attached display. The ioregistry info I posted was when that HDMI connection was my only active connection.
I know that some 5770 users have reported working HDMI audio. I'm wondering whether there were any extra steps taken such as rolling back AppleHDA to 10.6.3, or injecting a layout-id, or explicitly configuring an HDMI pathmap (should auto-generate I believe).


I'm using tmongkols patched appleHDA for alc888 (199f12) but have had HDMI workling also with stock AppleHDA.

I have only added hdau under GFX (address 0) entry in DSDT at address 1 like you have.
I wonder if some cards have different codecs? I can't remember is there any device id listed with lspci for your hda device?

EDIT - here's my hadu device in lspci:

01:00.1 Audio device [0403]: ATI Technologies Inc Unknown device [1002:aa58]


D

#599
bcc9

bcc9

    InsanelyMac Legend

  • Coders
  • 1,278 posts
  • Gender:Male

I wonder if some cards have different codecs? I can't remember is there any device id listed with lspci for your hda device?

EDIT - here's my hadu device in lspci:

01:00.1 Audio device [0403]: ATI Technologies Inc Unknown device [1002:aa58]


D

From a few posts back:
01:00.1 Audio device [0403]: ATI Technologies Inc Redwood HDMI Audio [Radeon HD 5600 Series] [1002:aa60]
Subsystem: PC Partner Limited Device [174b:aa60]

So slightly different pci id. Also my HDMI codec is:

Codec: ATI R6xx HDMI
Address: 0
AFG Function Id: 0x1 (unsol 0)
Vendor Id: 0x1002aa01
Subsystem Id: 0x00aa0100
Revision Id: 0x100200

per ALSA info (/proc/asound/card1/codec#0) under linux.

#600
FKA

FKA

    are we there yet?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,626 posts
  • Gender:Male

From a few posts back:
01:00.1 Audio device [0403]: ATI Technologies Inc Redwood HDMI Audio [Radeon HD 5600 Series] [1002:aa60]
Subsystem: PC Partner Limited Device [174b:aa60]

So slightly different pci id. Also my HDMI codec is:

Codec: ATI R6xx HDMI
Address: 0
AFG Function Id: 0x1 (unsol 0)
Vendor Id: 0x1002aa01
Subsystem Id: 0x00aa0100
Revision Id: 0x100200

per ALSA info (/proc/asound/card1/codec#0) under linux.


Sorry I didnt look back! also I havent looked in AppleHDA. Is aa60 listed? have you tried fluffing devid 58 aa or adding correct 60 aa in DSDT?

EDit - not being flippant I am also looking.

D





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy