Jump to content

Chameleon 2.3svn Official PKG Installer & Binaries

Bootloader Chameleon

  • Please log in to reply
4125 replies to this topic

#4121
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 3,075 posts
  • Gender:Male
  • Location:Stuttgart / Germany

Hi,

 

i did: 

 

  1. boot without FileNVRAM.dylib (or kext if any)
  2. delete all hidden .nvram.plist created on each partition that may have it.
  3. install the new Enoch and the new FileNVRAM.dylib and reboot once with new stuff.

Last reboot (after using new boot / new FileNVRAM.dylib, new kernel / kext.plist structure,

i got Chameleon error HALTED (screenshoot). 

Attached File  DSCF0828.jpg   17.45KB   0 downloads

 

Attached kexts.plist and kernel.plist.

 

Now i am on backup partition (older Chameleon ) and copy boot RC1 (which worked) back on / .

I let new FileNVRAM.dylib (RC3) and try to boot with boot RC1 +  FileNVRAM.dylib RC3....

 

 

 

 

 

 

@mitch_de since there was a bug with the old module I published, I advice you to:

  1. boot without FileNVRAM.dylib (or kext if any)
  2. delete all hidden .nvram.plist created on each partition that may have it.
  3. install the new Enoch and the new FileNVRAM.dylib and reboot once with new stuff.

off course before rebooting again ensure that you selected the Web Driver in the NVIDIA Driver Manager. Let me know.

 

Files:

attachicon.gifboot_rc3.zip

attachicon.gifFileNVRAM.dylib_rc3.zip

 

examples of how use new plist:

attachicon.gifkernel.plist.zip

attachicon.gifkexts.plist.zip

Attached Files



#4122
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 3,075 posts
  • Gender:Male
  • Location:Stuttgart / Germany

????

Went back to RC1 + FileNVRAM RC1 (which worked before i tried RC 3) = same chameleon Error , but now in line 365 (RC3 line 371) ?

How can that be?

Did RC3 something with the prelinked kernel so that RC1 fail also?

 

EDIT: I now set ALL patch to NO in kexts.plist - RC1 + FileNVRAM RC1 worked again :)

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>AICPMPatch</key>
	<false/>
	<key>AppleRTCPatch</key>
	<false/>
	<key>OrangeIconFixSata</key>
	<false/>
	<key>TrimEnablerSata</key>
	<false/>
</dict>
</plist>

Are the key values always boolean (also newer RC3) like in RC1?

 

Something wrong with kext patcher, because i set all to NO,

bdmesg shows i patched something!!!

GA-EP35:~ andreasm$ bdmesg
Enoch (2852 Micky1979 rc1)
Logging started: 2017/03/23, 11:10:38
....
Boot UUID of 'Mac_OSX'  (GPT HFS+): A887B8AC-171B-3F08-B2E1-2C85B032D013
Kernel Cache file path (OS X 10.11 and newer): /System/Library/PrelinkedKernels/prelinkedkernel
Loading Kernel Cache from: 'Mac_OSX' (GPT HFS+)
Booting on OS X 10.11.6 (15G1217)
...
[ KERNEL PATCHER START ]

	Will patch for 15.6.0 kernel version.

	KernelBooter_kexts state:  enabled!
	KernelPm           state: disabled!
	KernelLapicError   state: disabled!
	KernelLapicVersion state: disabled!
	KernelHaswell      state: disabled!
	KernelcpuFamily    state: disabled!
	KernelSSE3         state: disabled!
	- Searching for booter extensions pattern:
	Found El Capitan SIP pattern: patched!
	Found EL Capitan EXT pattern: patched!
	2 substitution(s) made.
Kernel patcher: done!

[ KEXTS PATCHER START ]
	Patching IOAHCIBlockStorage: 1 substitutions made!  
	Patching AppleAHCIPort: 0 substitutions made!
Kexts patcher: done!


Why   Patching IOAHCIBlockStorage: 1 substitutions made!  , if i set all to NO / this key isnt set to anything?!

The patched  IOAHCIBlockStorage isnt in the kext.plist (not set), and in such a case - patch part isnt set to YES/NO, the patcher should always (default) NOT!!! patch this part.

 Perhaps thats the reason for the error / halted - chameleon tries to patch something should not patch OR this key isnt in the kext.plist at all > memory error?



#4123
Micky1979

Micky1979

    I realized that I am lucky

  • Moderators
  • 4,797 posts
  • Gender:Male
  • Location:a 100m dal Tevere, vicino a Peppe

Line 371 is:

Find = malloc(FindPtr->dataLen);

Ok, thanks to you now I have where to look for fixing bugs. If some patches autoenables is another bug that cause the error on line 371 just because in reality ther's no Find data, but now I have to look something to fix, and to me that help so mutch!

In truth I have everything set to yes, so that lately I have not tried to disabling functionalities. But I will.

Available for other tests? (but now is strictly reccomended to install Enoch in a usb stick). Until 18:00 I cannot do nothing (now here is 13:08)


Thanks for this new Boot rc3 file and your help.

However no matter how I have tried these Boot rc1, rc2 & rc3 files not working in my Z87 hackintosh.

At present only Enoch r.2848 and Clover r.4035 work.

I'll keep on trying to find out the reason why !

Ok, I have to fix something before a new test for you...



#4124
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 3,075 posts
  • Gender:Male
  • Location:Stuttgart / Germany

Yep, sure i will help with newer tests. I also think that something in the code of reading and computing of kexts.plist went wrong.



#4125
Micky1979

Micky1979

    I realized that I am lucky

  • Moderators
  • 4,797 posts
  • Gender:Male
  • Location:a 100m dal Tevere, vicino a Peppe

Anyway you have "IOAHCIBlockStorage" set in your kexts.plist..  and also the "TrimEnablerSata" key act on the same kext, so what happen if you remove it?



#4126
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 3,075 posts
  • Gender:Male
  • Location:Stuttgart / Germany

Anyway you have "IOAHCIBlockStorage" set in your kexts.plist..  and also the "TrimEnablerSata" key act on the same kext, so what happen if you remove it?

No, i havent. That kexts.plist was for the RC 3.

I use the attached.

Attached File  kexts.plist.zip   1.29KB   0 downloads

 

Or is IOAHCIBlockStorage = OrangeIconFixSata fix key, which is set to NO?







Also tagged with one or more of these keywords: Bootloader, Chameleon


2 user(s) are reading this topic

1 members, 0 guests, 1 anonymous users


© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy