Jump to content

Can open some AVI files, but not others


  • Please log in to reply
5 replies to this topic

#1
AmightySi

AmightySi

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Hey,

Ive got a problem opening some AVI files on my portable hard drive. Some open fine, where as some I cant open, delete, rename or do anything with. There just white icons.

When I try to delete these files, it states there already in use by another program. But there not. When I try to change the default opening program it says there finder files and i dont have the required privileges.

Whats going on here? Ive tried repairing permissions, ejecting hard drive and restarting. All to no avail.

Just to point at, this isnt an OSx86 machine, its an almost brand new iMac.

#2
FKA

FKA

    are we there yet?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,626 posts
  • Gender:Male
Try to open with VLC player. AVI is just the carrier for the file, the codec can be various and QTime player might not be able to handel it.
Also see: http://perian.org/

If your drive is formatted NTFS and you aren't running NTFS3g or paragon NTFS you will have read only access to the drive!

D

#3
AmightySi

AmightySi

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Try to open with VLC player. AVI is just the carrier for the file, the codec can be various and QTime player might not be able to handel it.
Also see: http://perian.org/

If your drive is formatted NTFS and you aren't running NTFS3g or paragon NTFS you will have read only access to the drive!

D


Thanks, but I am trying to open them with VLC player. The OS doesnt recognize the files as being AVI's even though the file extension is AVI. Some files work fine with VLC, but other files have white icons and you cant do anything with them, not open, delete or rename them. Its strange that some AVI files work and some dont. Ill upload a screenshot of what it looks like:

Posted Image

#4
FKA

FKA

    are we there yet?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,626 posts
  • Gender:Male
and they open ok in windoz?

#5
AmightySi

AmightySi

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

and they open ok in windoz?


As far as I know yes. They previously opened fine in osx, they have just suddenly became un-openable via the icon. I just found that if I drag one of the IVA's that wont work into the VLC app directly, it will play. It just wont allow me to open them via the icon. When I go to delete the file, it tells me that its in use by another program, and if I try to set the opening program to quick time it tells me I dont have the permissions required.

Weird how 90% of the AVI files work, and these dont.

#6
Ranguvar

Ranguvar

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
Those other AVIs are either corrupted or are otherwise different.
Please run mediainfo on a "no icon" AVI and a working one.

Can you just open VLC and then use its menu to open the other AVIs, does that work?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy