Jump to content

INTEL E1000e Working With 82566mm [SOLVED]


  • Please log in to reply
No replies to this topic

#1
petopay

petopay

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
  • Gender:Male
  • Location:GH
I recently installed Retail Leopard 10.5.6 and Upgraded to 10.5.7.

In 10.5.6, Ethernet worked with INTEL 82566mm but had minor problems. When I updated to 10.5.7, it was terrible. :D Ethernet fails upon booting. So I managed to search and found INTEL E1000e kext and installed it. Ethernet showed but still had problem connecting. All I did was to Install both INTEL E1000e and INTEL 82566mm kexts. My Ethernet is now stable and working upon start up. :D

I have only tried this on my Intel 82577lm. If you want to try this just follow the steps.

- First Download both INTEL 82566mm and INTEL E1000e kexts

http://www.insanelym...howtopic=128931
http://www.insanelym...howtopic=219114

- Then follow the next Steps.

1)Open Terminal and Type "kextstat" (without quotes) to catch your system information and especially the version of com.apple.iokit.IONetworkingFamily, com.apple.iokit.IOPCIFamily, com.apple.kpi.bsd, com.apple.kpi.iokit, com.apple.kpi.libkern, com.apple.kpi.mach.

2) Go to the directory of Intel82566MM.kext/Contents/Info.plist and Intel82566MM.kext/Contents/Info.plist and replace the version string with your system's.


This is the Version String on My OSX 10.5.7:

<key>OSBundleLibraries</key>
<dict>
<key>com.apple.iokit.IONetworkingFamily</key>
<string>1.6.1</string>
<key>com.apple.iokit.IOPCIFamily</key>
<string>2.5</string>
<key>com.apple.kpi.bsd</key>
<string>9.7.0</string>
<key>com.apple.kpi.iokit</key>
<string>9.7.0</string>
<key>com.apple.kpi.libkern</key>
<string>9.7.0</string>
<key>com.apple.kpi.mach</key>
<string>9.7.0</string>
</dict>

3) Make sure you have your Device Id labelled in or just add it to IOPCIPrimaryMatch in the plist, eg. Device Id 0x10608086.

4) Install Both Using Kext Helper and Reboot! :D

Thanks to "ktbos" and "dingguijin" for support. :D :D





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy