Jump to content

[Tutorial] AMD 10.6.8 Retail Snow Leopard Guide!


  • Please log in to reply
297 replies to this topic

#21
nisto91

nisto91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
I'm gonna do your method and then I'll report back to you.

#22
nisto91

nisto91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
Ok I did everything you did and now when I get to the chameleon screen and choose the snow leopard hd it shows the apple logo for a brief second and then it restarts. I'm thinking kernel problem but I don't know considering I have the exact same mobo and cpu as you.

#23
sirbow2

sirbow2

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 728 posts
  • Gender:Male
from an earlier post by me:




i think it is because you didnt tell chameleon to use the amd 10.6.4 kernel instead of the vanilla kernel.

this is what my com.apple.boot.plist looks like

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string></string>
<key>Kernel</key>
<string>bt(0,0)mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Timeout</key>
<string>5</string>
<key>device-properties</key>
<string></string>
</dict>
</plist>


the text below makes chameleon use mach_kernel form the root of my EFI partition, mach_kernel for me is the amd legacy kernel for 10.6.4

<key>Kernel</key>
<string>bt(0,0)mach_kernel</string>

if you change the (0,0) part of <key>Kernel</key><string>bt(0,0)mach_kernel</string> it will change where it looks for the different kernel, 0,0 means HD0 partition0


it is the same exact problem, it happened to me before i added <key>Kernel</key>
<string>bt(0,0)mach_kernel</string> to my com.apple.boot.plist

#24
nisto91

nisto91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
Ok, I've added everything to the boot.plist and now I'm getting still waiting for root device.

#25
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male

Ok, I've added everything to the boot.plist and now I'm getting still waiting for root device.

have you set sata to achi if not do it
if no
try this kexts
http://nawcom.com/os.../10.6/SATA/ATI/
it must work ;)

#26
sirbow2

sirbow2

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 728 posts
  • Gender:Male
yes, Mohamed Khairy is right try setting all your hd's to ahci, if that doesnt work try the kext, but if you have the same hardware as me you dont need that kext.

PS, Mohamed Khairy did you get your install working?

#27
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male

yes, Mohamed Khairy is right try setting all your hd's to ahci, if that doesnt work try the kext, but if you have the same hardware as me you dont need that kext.

PS, Mohamed Khairy did you get your install working?



yes finally i know the cause of problem by luck when disabling all thing on MB :D

the cause is from raid

see this

Posted Image

see to machine check

when the snow check my system configuration it stop on check raid

it may be aproblem on patched kernel

so i destroed my raid

and change sata to achi and modfied info of orgnial appleachiport to identify my sb750 :D inexchange of unknown standard achi controller i can name it with my name :D lol

every thing work perfect audio eth hd5770 sleep work with enabler but usb unloaded across sleep did you know asolution for this

anther thing iwant my dvb-s card work tevii s420 :( iam tring on it

thanks for question :)

#28
sirbow2

sirbow2

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 728 posts
  • Gender:Male
you could probably fix your raid problem by a kext.

hmm i thought it unloading across sleep wasnt an error.

but id love to have that sleep kext because i cant get sleep to work! :(

i didnt see any thing on your tv tuner card for os x, but you never know it might work :D

#29
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male

you could probably fix your raid problem by a kext.

hmm i thought it unloading across sleep wasnt an error.

but id love to have that sleep kext because i cant get sleep to work! :(

i didnt see any thing on your tv tuner card for os x, but you never know it might work :)


i tried many kexts now i delte raid and so i dont need raid

i know the problem after sleep all usb not work means no mouse no keyboard no bluetooth ............. but the reset audio vedio eth work after sleep

this is the kexts http://www.insanelym...p...st&id=72783

but when wake up system will tell you usb consuming large power :P

about dvb-s card i want to contact with programer like voodoohda programer he might help me on it

there are an old driver but not work for me :D

#30
nisto91

nisto91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
I've done everything. I tried those two kexts and changed the sata in the bios to ahci and I'm still getting the root device error. I'm lost.

#31
sirbow2

sirbow2

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 728 posts
  • Gender:Male
nisto91,

1. how many dvd drive, hd's do you have? make sure the are all on the blue sata ports, reset your bios to optimized defaults and set every thing to AHCI

2. if that doesnt work try the rd=diskXsX command at chameleon, with the HD's in AHCI of course

3. just for the heck of it try setting all sata's to IDE mode, it happened to me before, the DVD required IDE mode while the HD install wouldnt boot unless in ahci mode


im just trying to recreate my computer setup

#32
sirbow2

sirbow2

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 728 posts
  • Gender:Male
this guide will be updated once i get sleep working w/o any USB issues

#33
sahack

sahack

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Woah, that's basically the same platform as mine! i've bookmarked this.
thanks, dude.

#34
sirbow2

sirbow2

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 728 posts
  • Gender:Male
no prob

#35
Setura

Setura

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Female
  • Location:NZ
I dont mean to look stupid but I cant seem to find your 'My EFI Partition.zip'.

I have almost the exact same hardware as you (just a 880 instead of 890 motherboard and my graphics card is an old Nvidia 8800 gts. Still the same hex-core processor etc.) but I keep failing to get snow leopard working. I think all I need is whatever is in this 'My EFI Partition.zip'.

I am a long time mac user but this is my first hackintosh build. I did momentarily get normal leopard working but when it died (user error, trying to get SL on too and failed) I cant seem to remember how I got it to work. Any help on what you did to get Leopard working would be good if Snow Leopard fails.

I have SL installed on my AMD hackintosh but it freezes at the load screen with the apple. I think that it might have something to do with only having charmelion 2 rc5, an AMD kernel [legacy kernel 10.4.0] but none of these other files. My Extras folder is empty!

Would you be able to help me obtain the files (ktexts, plists and whatever else...) that you used. I know this pc I built is leopard compatible (if I could get that working again...) but I would prefer snow leopard.

and I defiantly don't want to get stuck with windows...

(note: I used my real mac to get it this far and so I can easily put the rest of these files right into their places if I get them)

#36
sirbow2

sirbow2

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 728 posts
  • Gender:Male
sorry setura but i was stupid when i reuploaded the zip, it was over 10MB so it didnt upload correctly its there now
:thumbsup_anim:

yes you should have kexts in /E/E, most definatly why its not working

copy + paste the efi folder and you should be good to go but dont use the DSDT as it may not work or mess up ur system(i doubt it but you never know), the only dsdt fix you have to do (its realy easy is the RTC CMOS f, or you could just use LegacyRTC.kext instead. the RTC kext is not in the ZIP

if you you need leopard again use Ideneb 1.6 it works great as a backup OS, its what i use it for! and it has complete compatibility, except for sleep but i dont care for a backup OS

sorry for the 3 day wait for the response

#37
Setura

Setura

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Female
  • Location:NZ
Sorry about taking so long. My Firefox must have not been properly refreshing the page (so I thought that no one was replying.)

I managed to get 10.5 working with iaktos7 (only took about 40 install attempts, not kidding...) and although it not perfect its just a back up os.


Now that I have the kexts...

The first time I loaded Snow Leopard with them all it seemed to work fine (just no graphics or sound... but I found I had forgotten the VoodooHDA.kext and I might have found my 8800 gts's driver.) I did have to use -f -v (i think...) for it to start but then it kinda froze when shutting down. (well... I used it just to see what it was doing. I'm not sure if it helped or not)

Now it fails to start and it says it cannot find my kernal, or it says waiting for root device.

I still could not find a kernal so I got the legacy kernal (which my machine cannot seem to find.) I direct it to drive 3,0 (my forth hard drive, first of two partitions... correct me if that is listed wrong but it says it cannot find legacy_kernal on 3,0)

do I tell it to look for mach_kernal or the new one? and do I just put my new kernal in the root of the drive with my bootloader?

"RTC CMOS f" sorry, no idea what it is.
LegacyRTC.kext - seems to only be for 32 bit (and I use and would like to keep using 64)

What kernel do you use? (and would you recommend it? note that this is 10.6.4 my hackintosh is running as that is what I coppied from my real mac)

also.. is the dsdt the dsdt.aml in the extra folder? and if I dont use it, where would I find the replacement thingie?


0ne last thing... my bootloader is rc5 beta. Also I try the rc4 one too.

#38
sirbow2

sirbow2

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 728 posts
  • Gender:Male

"RTC CMOS f" sorry, no idea what it is.

sorry that was supposed to be RTC CMOS fix, its for a DSDT but i think it would be easier for you to just use the Legacy RTC kext, their is a legacyRTC kext that is 64 bit(attached at the end of post)

Now it fails to start and it says it cannot find my kernal, or it says waiting for root device.

I still could not find a kernal so I got the legacy kernal (which my machine cannot seem to find.) I direct it to drive 3,0 (my forth hard drive, first of two partitions... correct me if that is listed wrong but it says it cannot find legacy_kernal on 3,0)

do I tell it to look for mach_kernal or the new one? and do I just put my new kernal in the root of the drive with my bootloader?.....

What kernel do you use? (and would you recommend it? note that this is 10.6.4 my hackintosh is running as that is what I coppied from my real mac)

use the kernel(mach_kernel) in the My EFI Partition-Update zip file in the first post of the thread

copy my com.apple.boot.plist from My EFI Partition-Update zip to your /Extra folder and place mach_kernel from the EFI zip to the root of your Partition with chameleon on it. then change "bt(0,0)mach_kernel" in the com.apple.boot.plist to search for the mach_kernel (the kernel i provided) in the partiton w/ chameleon on it.

EDIT\\ Also go to your backup OSX and type "sudo diskutil list", it will give you a list of the partition map of all your HD', post the results here and i will make sure its searching in the right place for the kernel etc. etc., also tell me where the Retail osx is installed and where Chameleon is installed so i can help

also.. is the dsdt the dsdt.aml in the extra folder? and if I dont use it, where would I find the replacement thingie?

a DSDT is DSDT.aml or DSDT.dsl. .AML means the DSDT is compiled, .DSL means uncompiled and can be edited. a DSDT isnt required and since your using the RTC kext, i dont think you need one

0ne last thing... my bootloader is rc5 beta. Also I try the rc4 one too.

the RC5 boot loader is fine to use

Attached Files



#39
Setura

Setura

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Female
  • Location:NZ
I have everything(snow leopard + bootloader + kernal and extra folder) installed on Snowleopard II

I just realised that you might have meant the extra folder to be on EFI partition. Is that correct? (what else should be shifted to partitions other than SnowLeopard II?)

Now it says that my hibernate image is out of date (or something like that) and refuses to start. (should I try something like -v or -f?. Haven't had time to try yet today.)

and I removed the dsdt and put the other file in the extra/extentions/ folder.

Attached Files



#40
sirbow2

sirbow2

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 728 posts
  • Gender:Male

I just realised that you might have meant the extra folder to be on EFI partition. Is that correct? (what else should be shifted to partitions other than SnowLeopard II?)

you need to have Extra in the root of partition that chameleon was installed on

and I removed the dsdt and put the other file in the extra/extentions/ folder.

what do you mean by "Other" file

Now it says that my hibernate image is out of date (or something like that) and refuses to start. (should I try something like -v or -f?. Haven't had time to try yet today.)

look at the boothelp file for chameleon, you can do this in the Chameleon bootloader when you start your computer, when your in bootloader put the selector over OSX and press the down arrow their should be a boot help option, select it, thier should be option somewheres that says something about hibernate image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy