Jump to content

OSX86 インストールの助けがいる人いませんか?


  • Please log in to reply
24 replies to this topic

#1
TennisGeek

TennisGeek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:Boston 'burb, born in Japan
  • Interests:Tennis, Computer, Mac
2010 Aug 5th - 8月5日 更新

質問については、新しいトピックを作ってください。
よろしくお願いします。



何もないのも退屈だし、困っていることがあればどんどん質問してください。

-- TG

#2
rainyday

rainyday

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
 NEC Express5800 110Ge(マザーはIGABYTE GA-5YASV-RH)、Quad Q9650にiboot(nvidia)でSnowをインストールする夢をみました。10.6.0は何の問題も無いのですが10.6.4にした途端iphone 3GS(ios4)が認識されなくなりました。
 本体の USBコネクタでもハブでもかわらず。もちろんiTuneでも認識されません。充電もされないのです。
 ほかのUSB機器は全く問題なく作動します。ほかに似た事例も無いようなので調べるに調べられません。
 こんな夢なんとかならないでしょうか?

#3
TennisGeek

TennisGeek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:Boston 'burb, born in Japan
  • Interests:Tennis, Computer, Mac

 NEC Express5800 110Ge(マザーはIGABYTE GA-5YASV-RH)、Quad Q9650にiboot(nvidia)でSnowをインストールする夢をみました。10.6.0は何の問題も無いのですが10.6.4にした途端iphone 3GS(ios4)が認識されなくなりました。
 本体の USBコネクタでもハブでもかわらず。もちろんiTuneでも認識されません。充電もされないのです。
 ほかのUSB機器は全く問題なく作動します。ほかに似た事例も無いようなので調べるに調べられません。
 こんな夢なんとかならないでしょうか?


インストールと前々関係ないけど...

●チェック1

まず、 Terminal を起動して、

tail -f /var/log/system.log

としてください。 システムのログが順次表示されます。

この状態で iPhone をつなぐと何か新しい行が出てくるはずです。
どういうメッセージが出ますか?

また、 iTunes は バージョン9.2 以降でないと動作しないはずです。


●チェック2

とりあえず、試しに新しいアカウントを作ってみて、そこで iPhone をつないでみてください。
もしもそれでなにか反応があるのであれば、あなたのユーザーの ~/Libraries/ のどこかに問題があるのでしょう。
めんかもしれないけど、 iTunes の preference か iTunesHelper のpreference を消してみてください。

●チェック3

connect.apple.com に行って登録して、 xcode をダウンロードして、 USB Prober を使えば、 Mac が見ている USB 機器が表示されます。
そこに出てくるようなら、ハードウェアの問題ではなくなにかソフトウェアが特定のiPhoneを無視しているようになっている気がします。


ハードウェアで問題がある場合、よくあるのは USB の power profile がパワーを使いすぎるような宣言をする場合、そのデバイスが切り離されてしまいます。 チェック1に出てくるメッセージに注目してください。

また、 ios4 に更新した後、 full restore が必要になった例もあるので、 full restore を試してみるのも手です。

Good luck.

-- TG

#4
rainyday

rainyday

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
 有難う御座います。
 Logをまず見てみます。
 またご報告します。
 

#5
rainyday

rainyday

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
試してみました。
iphoneを繋ぐとlogは

com.apple.usbmuxd[14]: DeviceRequestAsync failed: 0xe00002c2

 というメッセージがでます。
 手元にあるiphoen 3G OSは3.0.1も同じメッセージがでます。

 アカウントを変えてログを取っても同じメッセージでした。
 xcodeのUSB Proberでは長いですが以下、コピペします。
 この状態ではキーボード、マウス、iphone しか繋いでいません。

Full Speed device @ 1 (0x1A000000): ............................................. UHCI Root Hub Simulation (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
Port Information: 0x021d
Expansion slot Root Hub
Captive
Internal Device
Connected
Enabled
Full Speed device @ 1 (0x3A000000): ............................................. UHCI Root Hub Simulation (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
Port Information: 0x021d
Expansion slot Root Hub
Captive
Internal Device
Connected
Enabled
Full Speed device @ 1 (0x5A000000): ............................................. UHCI Root Hub Simulation (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
Port Information: 0x021d
Expansion slot Root Hub
Captive
Internal Device
Connected
Enabled
High Speed device @ 1 (0xFA000000): ............................................. EHCI Root Hub Simulation (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
Port Information: 0x061d
Built-in Root Hub
Captive
Internal Device
Connected
Enabled
Full Speed device @ 1 (0x1D000000): ............................................. UHCI Root Hub Simulation (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
Port Information: 0x021d
Expansion slot Root Hub
Captive
Internal Device
Connected
Enabled
Full Speed device @ 1 (0x3D000000): ............................................. UHCI Root Hub Simulation (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
Port Information: 0x021d
Expansion slot Root Hub
Captive
Internal Device
Connected
Enabled
Low Speed device @ 2 (0x3D100000): ............................................. USB-PS/2 Optical Mouse (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
Port Information: 0x001a
Not Captive
Attached to Root Hub
External Device
Connected
Enabled
Full Speed device @ 3 (0x3D200000): ............................................. Hub in Apple Extended USB Keyboard (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
Port Information: 0x001a
Not Captive
Attached to Root Hub
External Device
Connected
Enabled
Full Speed device @ 4 (0x3D230000): ............................................. Apple Extended USB Keyboard (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
Port Information: 0x0019
Captive
External Device
Connected
Enabled
Full Speed device @ 1 (0x5D000000): ............................................. UHCI Root Hub Simulation (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
Port Information: 0x021d
Expansion slot Root Hub
Captive
Internal Device
Connected
Enabled
High Speed device @ 1 (0xFD000000): ............................................. EHCI Root Hub Simulation (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
Port Information: 0x061d
Built-in Root Hub
Captive
Internal Device
Connected
Enabled
High Speed device @ 2 (0xFD200000): ............................................. iPhone (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
Port Information: 0x001a
Not Captive
Attached to Root Hub
External Device
Connected
Enabled

#6
TennisGeek

TennisGeek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:Boston 'burb, born in Japan
  • Interests:Tennis, Computer, Mac
ログから簡単にいえることは、 USB ポートが全然動作していないと思います。
> com.apple.usbmuxd[14]: DeviceRequestAsync failed: 0xe00002c2
に引き続いてもう少しログは出ていませんか?

com.apple.usbmuxd[14]: DeviceRequestAsync failed: 0xe00002c2

High Speed device @ 2 (0xFD200000): ............................................. iPhone (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))


私の MacBook に iPhone をつないだ状態では

High Speed device @ 3 (0xFD100000): ............................................. Composite Device "iPhone"

と出るので、 USB が全然通信していないのだと思います。
iPhone がつながっていない状態では、 Keyboard / Mouse の所に kIOReturnBadArgument は出ていますか?
もしそうなら、 USB が最初から全然動作していないのかもしれません。
(USB keyboard/mouse はつながっているけどもしも PS2 kext が入っていると USB PS2 emulation -> PS2 Kext keyboard/mouse というので動作してる可能性がある。)

iPhone なしの状態で kIOReturnBadArgument が出ていないのであれば、電源付きの USB2 ハブを買ってきて、 iPhone をそれにつないでみることをお勧めします。 USB Root hub が、 power overdraw で動いていないのかもしれません。

-- TG

#7
rainyday

rainyday

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
 何度もご返信有り難うございます。

[quote name='TennisGeek' date='Jul 5 2010, 03:50 AM' post='1504749']
ログから簡単にいえることは、 USB ポートが全然動作していないと思います。
> com.apple.usbmuxd[14]: DeviceRequestAsync failed: 0xe00002c2
に引き続いてもう少しログは出ていませんか?

いえこれ以上は何もでていません。

iPhone がつながっていない状態では、 Keyboard / Mouse の所に kIOReturnBadArgument は出ていますか?
もしそうなら、 USB が最初から全然動作していないのかもしれません。
(USB keyboard/mouse はつながっているけどもしも PS2 kext が入っていると USB PS2 emulation -> PS2 Kext keyboard/mouse というので動作してる可能性がある。)

 仰る通りKeboardやMouseも
Hub in Apple Extended USB Keyboard (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
USB-PS/2 Optical Mouse (did not respond to inquiry - kIOReturnBadArgument (0xe00002c2))
 と出ています。
 
 ps2kextは入れた覚えはないのですが。。。
 iboot経由でインストールすると入れてくれるものなのでしょうか?

iPhone なしの状態で kIOReturnBadArgument が出ていないのであれば、電源付きの USB2 ハブを買ってきて、 iPhone をそれにつないでみることをお勧めします。 USB Root hub が、 power overdraw で動いていないのかもしれません。

 USBハブはすべてパワーアダプタ付きのものを使用しています。
 
 USBがps2kextでシュミレーションされるならiphoneも認識してほしいところです。
 何か手は無いのでしょうか?

#8
Dreamwatcher

Dreamwatcher

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
DSDTでUHCI/EHCIのUSBのパッチ(エラッタ対策)はしていますか?DSDTの修正がまだなら、とりあえずMultiBeastに含まれるUSBFamliyMOD 9.9.9を試してみてください(non DSDTなシステムでUSBを使えるようにする修正kextです)。もしくは、10.6.2以前に含まれるIOUSBFamliy.kextにロールバックするのでも可です。

http://tonymacx86.bl...064-update.html

GIGABYTEのM/B(BIOS)で発生している問題なのですが、10.6.3以降にアップデートすると、DSDTでUSBのパッチを当てていないと正常に動作しない問題が発生しています。10.6から10.6.4にアップデートしたらiPhoneを認識しなくなったとのことなので、これが原因じゃないかと思います。

http://www.tonymacx8...php?f=38&t=1549

10.6のバックアップに戻せるか、再インストール可であれば、10.6->10.6.2->10.6.3と順番にあげていってみてください。恐らく、10.6.3にした時点で問題が再現すると思います。

なお、iBootにはノートPCなどUSB接続のキーボードがない環境も考慮して、インストール時にはVoodooPS2Controlerがロードされますが、後処理のMultiBeastで選択しなければインストール環境には入らないと思います。kextstat -lでロードされているkextがわかるので、念のため確認しておくと良いかと思います(/System/Libray/Extensionsの下を確認しても良いですが)。

#9
rainyday

rainyday

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
 で、で、で、で、出来ました!!!!
 まずUSBFamliyMOD 9.9.9とVoodooPS2Controlerをmultibeastでインストールしたのですが駄目でした。
 kextstat -lでロードされているのは確認できたのですが。。。
 
 次に10.6.2で使用しているIOUSBFamily.kext 3.8.5をDLしてインストールしたら目出たく認識しました。
 ロールバックの方法が解らなかったのですがそのまま上書きでOKでした。
 system/Libray/ExtensionsにあるIOUSBFamily.kextのVerを確認するとverが3.8.5なので上書きしたのだなと思った訳です。

 張って頂いたリンクも見てみました。
 前例があったのですね。
 調べて頂いてすいません。

 私一人ではここまで辿り着けなかったです。
 ホントに有り難う御座いました!
 

#10
TennisGeek

TennisGeek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:Boston 'burb, born in Japan
  • Interests:Tennis, Computer, Mac
動いてよかったですね。

ただし、古いバージョンの kext で動かした場合次のアップデートで動かなくなる可能性も高いし、 dreamwatcher の指摘のとおり DSDT でも直るのであれば、 DSDT を修正したほうがいいと思います。

DSDT の取得方法は書いてあるので、 DSDT をアップロードしてはいかがですか?
今の使える状態はそのままとしておいても、DSDT を直せば次のアップデートの時になにもしないでも動く可能性があるのでお勧めします。

-- TG

 で、で、で、で、出来ました!!!!
 まずUSBFamliyMOD 9.9.9とVoodooPS2Controlerをmultibeastでインストールしたのですが駄目でした。
 kextstat -lでロードされているのは確認できたのですが。。。
 
 次に10.6.2で使用しているIOUSBFamily.kext 3.8.5をDLしてインストールしたら目出たく認識しました。
 ロールバックの方法が解らなかったのですがそのまま上書きでOKでした。
 system/Libray/ExtensionsにあるIOUSBFamily.kextのVerを確認するとverが3.8.5なので上書きしたのだなと思った訳です。

 張って頂いたリンクも見てみました。
 前例があったのですね。
 調べて頂いてすいません。

 私一人ではここまで辿り着けなかったです。
 ホントに有り難う御座いました!
 



http://discussions.i...j...0&tstart=15

どうも 10.6.3 の USB HID kext は、本物の Mac でも問題があるようです。
kext の巻き戻しが正解かもしれません。

私の4台(2台本物、2台まがいもの :P;)のいずれでも問題が出ていません。
Gigabyte の1台は、 DSDT が修正されまくっているので、スリープの問題はでていません。
Gigabyte の問題は、スリープのことを指されているのだと思うのですけどちがいますか?

-- TG

DSDTでUHCI/EHCIのUSBのパッチ(エラッタ対策)はしていますか?DSDTの修正がまだなら、とりあえずMultiBeastに含まれるUSBFamliyMOD 9.9.9を試してみてください(non DSDTなシステムでUSBを使えるようにする修正kextです)。もしくは、10.6.2以前に含まれるIOUSBFamliy.kextにロールバックするのでも可です。

http://tonymacx86.bl...064-update.html

GIGABYTEのM/B(BIOS)で発生している問題なのですが、10.6.3以降にアップデートすると、DSDTでUSBのパッチを当てていないと正常に動作しない問題が発生しています。10.6から10.6.4にアップデートしたらiPhoneを認識しなくなったとのことなので、これが原因じゃないかと思います。

http://www.tonymacx8...php?f=38&t=1549

10.6のバックアップに戻せるか、再インストール可であれば、10.6->10.6.2->10.6.3と順番にあげていってみてください。恐らく、10.6.3にした時点で問題が再現すると思います。

なお、iBootにはノートPCなどUSB接続のキーボードがない環境も考慮して、インストール時にはVoodooPS2Controlerがロードされますが、後処理のMultiBeastで選択しなければインストール環境には入らないと思います。kextstat -lでロードされているkextがわかるので、念のため確認しておくと良いかと思います(/System/Libray/Extensionsの下を確認しても良いですが)。



#11
rainyday

rainyday

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
 仰る通りアップデートするたびに困るのも何ですのでDSDTでどうにかなるならどうにかしたいのですがじ、実はDSDTが何をするものか解ってなくてExtraフォルダにaml拡張子のファイルを入れてるのだな位なことしか解っていません。
 
 張って頂いたリンクのどこかにDSDTファイルがあるのでしょうか? 
 
 スリープ機能はスリープすると復帰したことがないので使ってないのです。
 すいませんです。
 

#12
tititi

tititi

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
ハードウェアで問題がある場合、よくあるのは USB の power profile がパワーを使いすぎるような宣言をする場合、そのデバイスが切り離されてしまいます。 チェック1に出てくるメッセージに注目してください。
:unsure:
http://www.panbeadssales.com/

#13
itanimi

itanimi

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
:D 今日は。
GA-G45M-UD2HにQ8400またはE6850, 4GB RAM, GF9800GTを使用して、Kakewalk+リテールSnowLeopard10.6を使いSLをインストールしていますが、未だにRADEON4850でのインストールに成功した事が有りません。
この4850はGIGABYTEのFanless, 1GBでfanの数が減って静かに運用出来る事を期待していたのですが、##### ATIを使ってもSLを入れたとたんに動きが止まってしまいます。
最新のiMacではシステムVGAが4850の筈なのに何でこうなってしまうのでしょう。

何か秘訣の様なものが有ればお教え頂けると有難いのですが。
ひょっとしてリテールSLは10.6.2以上でないといけないとか。

#14
Aslan1976

Aslan1976

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
 初めましてTennisGeek様。初歩的な質問ですが、宜しくお願いします。
以下の構成及びインストール手順にてインストールしました。以下手順の
3-5の間にはグラボも認識し(解像度変更、デュアルディスプレイOK)、
ネットにも繋がったのですが、6の再起動後にはどちらも認識しなくなって
いました。ネットについてはR1000SL.kextを入れて認識したのですが、
NX8600GTがどうにも認識できずに困っています。試した方法としては、
EFI Studio(EFI STring)、NVEnabler、NVEnabler64、NVKush、Natit、
NVInjectorです。DSDTは無しで稼動しています。OSインスト直後では
認識してたことから、グラボ自体は対応していると思うのですが、
どうにも認識のさせ方が分かりません。お手数をお掛けしますが、御教授
頂けたらと思います。


構成
Mother Board : P55A-UD3R Rev.1 (BIOS : F9)
CPU : i7 860
Graphic card : MSI 8600GT


当方インストール手順
1. ##### Supportedにてブートローダー立ち上げ
2. SnowLeopard 10.6のDVDに入れ替え後立ち上げ、及びインスト
3. ##### Supportedにてブートローダー立ち上げ、Snowleopardから立ち上げ
4. ##### 2.11を開いた後、10.6.4アップデート
5. #####+System Utilitiesインストール
6. 再起動

※インストール時にメモリ8G、PCIスロットにTI社FWボード有り
 取外しせずにインストール実施しました。

#15
TennisGeek

TennisGeek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:Boston 'burb, born in Japan
  • Interests:Tennis, Computer, Mac
様づけはやめて、「さん」でいきましょう。 様なんて気持ち悪い。

「DSDTは無しで稼動しています。」 が問題なので、DSDT を直せば動作するとおもいます。

EFI string は、 DSDT にエントリーを足すのと同じことをしている訳で、 NVEnabler はそれを kext で行っているにすぎません。

私の nVidia Quadro NVS290 にもあるように、 DSDT を直せば、 nVidia カードは動作する可能性が高いです。

とはいえ、最初に試してみるのは一番新しい Chameleon の GraphicsEnabler だとおもいます。
まずは、最新の Chameleon をダウンロードしてインストールして、

http://www.insanelym...howtopic=223547
の「★ ブートローダーを新しくしておく」の手順で Chameleon を更新します。

で、 /Extra/com.apple.Boot.plist の中に

<key>GraphicsEnabler</key>
<string>Yes</string>

を入れます。 ちなみに私の /E/c.a.B.p です。

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
		<key>Kernel</key>
		<string>mach_kernel</string>
		<key>Kernel Flags</key>
		<string></string>
		<key>GraphicsEnabler</key>
		<string>Y</string>
		<key>Timeout</key>
		<string>5</string>
		<key>Graphics Mode</key>
		<string>1920x1200x32</string>
		<key>Theme</key>
		<string>DType</string>
		<key>GUI</key>
		<string>Y</string>
</dict>
</plist>

Chameleon がブート時に自動的にカードを検出して、 EFI string と同じことをしてくれます。
自動検出なので、間違いが減ると思います。

それがうまく行かなかったら、 DSDT を変更しましょう。
http://www.insanelym...howtopic=223760
に取得方法が書いてあります。 DSDT をとってアップロードしてください。


 初めましてTennisGeek様。初歩的な質問ですが、宜しくお願いします。
以下の構成及びインストール手順にてインストールしました。以下手順の
3-5の間にはグラボも認識し(解像度変更、デュアルディスプレイOK)、
ネットにも繋がったのですが、6の再起動後にはどちらも認識しなくなって
いました。ネットについてはR1000SL.kextを入れて認識したのですが、
NX8600GTがどうにも認識できずに困っています。試した方法としては、
EFI Studio(EFI STring)、NVEnabler、NVEnabler64、NVKush、Natit、
NVInjectorです。DSDTは無しで稼動しています。OSインスト直後では
認識してたことから、グラボ自体は対応していると思うのですが、
どうにも認識のさせ方が分かりません。お手数をお掛けしますが、御教授
頂けたらと思います。


構成
Mother Board : P55A-UD3R Rev.1 (BIOS : F9)
CPU : i7 860
Graphic card : MSI 8600GT


当方インストール手順
1. ##### Supportedにてブートローダー立ち上げ
2. SnowLeopard 10.6のDVDに入れ替え後立ち上げ、及びインスト
3. ##### Supportedにてブートローダー立ち上げ、Snowleopardから立ち上げ
4. ##### 2.11を開いた後、10.6.4アップデート
5. #####+System Utilitiesインストール
6. 再起動

※インストール時にメモリ8G、PCIスロットにTI社FWボード有り
 取外しせずにインストール実施しました。


##### / Easy Beast は使ったことが無いのですが、ようするに kext の集合ですよね。

-- TG

#16
Aslan1976

Aslan1976

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
 TennisGeekさん、アドバイス有り難う御座います。
Chameleonは2.0RC4がインスト済みで,GraphicsEnabler=Yes
も /E/c.a.B.pに追記済みですので、ご指摘の通りDTDSを入れて見たい
と思います。DTDSをいじるのは初めてですので、Tonymac氏が公開している
P55A-UD3R F9用のDTDSとDTDS Patcher GUIで作成したものの中身を覗き
つつ、TennisGeekさんの過去に書いて下さったスレッドを参考にACPI-Tables-日付.zip、
pci-list.txt、pnp-list.txtを取得して中身を覗いてみようかと思います。ご指示にあります
ように、DTDSが機能したらここにUPしたいと思います。またそれまでに御助力を願う場面
も多々ありそうですが・・・

追伸 ##### EasyBeastはKext及びユーティリティのパッケージ化されたもの・・・
    だと思います(知識が圧倒的に足らないため、思うとしか書けません)。

 

#17
Aslan1976

Aslan1976

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
 TennisGeekさん、こんばんは。あれから自分なりに試してみましたが、以下の状況で躓いて
おります。なにぶんDSDTを入れて立ち上げること自体初めてのため、立ち上げることすらできま
せんでした。Firewireで思い当たることは、PCIスロットにTexas InstrumentのFWボードを入れて
いるのです。お手数ですが、思い当たる問題点および解決策がありましたらご教授下さい。


1. TennisGeekさんのガイドを参照して、Chameleon 2.0 RC3をインストール後、RC4に置き換え
  るもHDDから立ち上がらず、ブートセレクト画面まで到達前に強制再起動

2. 10.6.4Comboをインストールすると、ブートセレクタまで到達するも、
Firewire GUID = ffffffffffff is invalid!と繰り返され立ち上がらず

3. Ubuntuを立ち上げ、これまたTennisGeekさんのガイドを参考にpci-list.txt、ACPI-Tables-日付.zip
  pnp-list.txtを取得。ACPI-Tables-日付.zip内のDSDTと名前のついたファイルをDSDTと改名して、
extraフォルダーに入れるも、2と同じ状況。
  ※取得したファイルを添付致します

com.apple.boot.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>

<key>Kernel</key>
<string>mach_kernel</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel Flags</key>
<string>arch=i386</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>0</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
</dict>
</plist>


SMbios

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMbiosvendor</key>
<string>Apple Inc.</string>
<key>SMbiosversion</key>
<string>MP31.88Z.006C.B05.0802291410</string>
<key>SMmanufacter</key>
<string>Apple Inc.</string>
<key>SMproductname</key>
<string>MacPro3,1</string>
<key>SMsystemversion</key>
<string>1.0</string>
<key>SMUUID</key>
<string>7A5BBEE0-E9AC-617F-CC10-625485993F16</string>
<key>SMserial</key>
<string>091000043635</string>
<key>SMfamily</key>
<string>mac</string>
<key>SMboardmanufacter</key>
<string>Apple Inc.</string>
<key>SMboardproduct</key>
<string>Mac-F42C88C8</string>
<key>SMmemtype</key>
<string>24</string>
<key>SMmemspeed</key>
<string>1600</string>
<key>SMmemmanufacter_1</key>
<string>G.Skill</string>
<key>SMmemmanufacter_3</key>
<string>G.Skill</string>
<key>SMmempart_1</key>
<string>TWIN2X4096-6400C5</string>
<key>SMmempart_3</key>
<string>TWIN2X4096-6400C5</string>
<key>SMmemserial_1</key>
<string>0x48092D503537345336304350362D09352020</string>
<key>SMmemserial_3</key>
<string>0x48092D503537345336304350362D09352021</string>
</dict>
</plist>

Attached Files



#18
TennisGeek

TennisGeek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:Boston 'burb, born in Japan
  • Interests:Tennis, Computer, Mac
Linux 使わなくても、 MacOS からも DSDT が取得できます。

http://www.insanelym...howtopic=215844

のスクリプトを試してください。

-- TG

 TennisGeekさん、アドバイス有り難う御座います。
Chameleonは2.0RC4がインスト済みで,GraphicsEnabler=Yes
も /E/c.a.B.pに追記済みですので、ご指摘の通りDTDSを入れて見たい
と思います。DTDSをいじるのは初めてですので、Tonymac氏が公開している
P55A-UD3R F9用のDTDSとDTDS Patcher GUIで作成したものの中身を覗き
つつ、TennisGeekさんの過去に書いて下さったスレッドを参考にACPI-Tables-日付.zip、
pci-list.txt、pnp-list.txtを取得して中身を覗いてみようかと思います。ご指示にあります
ように、DTDSが機能したらここにUPしたいと思います。またそれまでに御助力を願う場面
も多々ありそうですが・・・

追伸 ##### EasyBeastはKext及びユーティリティのパッケージ化されたもの・・・
    だと思います(知識が圧倒的に足らないため、思うとしか書けません)。

 



#19
TennisGeek

TennisGeek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:Boston 'burb, born in Japan
  • Interests:Tennis, Computer, Mac
まず、ブートすることから解決しましょう。
DSDT の変更は、おそらく何度か繰り返しが必要になると思うので別のトピックで扱います。

Chameleon 2.0 RC3 をインストーラーで走らせるとディスクからブートしますか?
インストール直後はディスクから起動できていましたよね?

いま、 ##### を見てきました。

Choose one of the following options directly following a fresh installation and update:


つまり ##### (DSDT 不使用) か、UserDSDT (DSDT を使う)のいずれかを選択するということなので、 ##### を使った場合、 nVidia カードが正しく検出されないのであれば、 DSDT を使うしか手が無いため、 ##### を使うことができません。

NOTE: #####, and UserDSDT install Chameleon RC4 by default, so you'll not need to check that option.


ということなので、 ##### を使えば Chameleon RC4 はインストールされるため、私の提供した Chameleon をインストールする必要はありません。

RC3 を入れるとむしろバージョンが後退していることになりますのでお勧めしません。

別のトピックから DSDT.aml を取り出してインストールに使ってください。
また、他の場合にも述べましたがインストール中には不要なものは全部取り払ってください。
というわけで、ちゃんとブートできるようになるまでは Firewire カードはとり外しておいてください。
ブートできるようになれば、元に戻しましょう。

Firewire GUID = ffffffffffff is invalid!

は今のところ不明です。

ところで、 PCI IDE カードも入っていると思いますが違いますか?

追記


06:03.0 FireWire (IEEE 1394) [0c00]: Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
06:05.0 IDE interface [0101]: Integrated Technology Express, Inc. IT8213 IDE Controller [1283:8213] (prog-if 85 [Master SecO PriO])

をよく見てみると、これは両方ともオンボード?

-- TG

 TennisGeekさん、こんばんは。あれから自分なりに試してみましたが、以下の状況で躓いて
おります。なにぶんDSDTを入れて立ち上げること自体初めてのため、立ち上げることすらできま
せんでした。Firewireで思い当たることは、PCIスロットにTexas InstrumentのFWボードを入れて
いるのです。お手数ですが、思い当たる問題点および解決策がありましたらご教授下さい。


1. TennisGeekさんのガイドを参照して、Chameleon 2.0 RC3をインストール後、RC4に置き換え
  るもHDDから立ち上がらず、ブートセレクト画面まで到達前に強制再起動

2. 10.6.4Comboをインストールすると、ブートセレクタまで到達するも、
Firewire GUID = ffffffffffff is invalid!と繰り返され立ち上がらず

3. Ubuntuを立ち上げ、これまたTennisGeekさんのガイドを参考にpci-list.txt、ACPI-Tables-日付.zip
  pnp-list.txtを取得。ACPI-Tables-日付.zip内のDSDTと名前のついたファイルをDSDTと改名して、
extraフォルダーに入れるも、2と同じ状況。
  ※取得したファイルを添付致します



#20
Aslan1976

Aslan1976

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
 TennisGeekさん、御丁寧に御指導及びDSDTの製作を有り難う御座います。

昨日のChameleon 2.0 RC3のインスト、RC4へのアップグレードについては、
クリーンインストール直後に行いましたので、EasyBeastは使用していない
状態です。なお、Chameleonの導入自体はTennisGeekさんから頂いたものを
使用し、RC4へのアップグレードも御指導そのままに行いましたので、恐らく
問題はないかと思います。

 ちなみに、正しいDSDTを導入できていないためかChameleon 2.0RC3 の
導入RC4への置き換え直後、コンボアップデート前のHDDからのBOOTは不可
でした。唯一確認できたHDDからブートできる状態は、以前に導入していたEasyBeast
を導入していた時のみです。

 今は職場から書込みをしているためすぐには試せませんが、帰宅後に頂いた
DSDTファイルを入れて起動をしてみたいと思います。その結果は確認完了後
すぐに報告致します。

確認事項
①何もいじらずに頂いたDSDTで起動可能かどうか
②Firewireボードを取り外した状態で起動可能かどうか

 現在スロット及びUSBにささっているものは以下の通りです。

06:03.0 FireWire (IEEE 1394) [0c00]: Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
06:05.0 IDE interface [0101]: Integrated Technology Express, Inc. IT8213 IDE Controller [1283:8213] (prog-if 85 [Master SecO PriO])

FireWireはPCIスロットへ追加したボードで、IDE interfaceはオンボードだと思います。

①マザー:Gigabyte製 P55A-UD3R Rev.1 F9 BIOS
②USBハブ(4個口) × 2
③ロジクール製マウス   (USBハブ)
④ロジクール製キーボード (USBハブ)
⑤ロジクール製ヘッドセット(USBハブ)
⑥プラネックス製Bluetooth (マザーのUSBへ直接)
⑦FireWire PCIボード Texas Instruments社チップ(PCIスロット)
⑧MOTU製896mk3(Firewireボード)
⑨MSI製NX8600GT 256M
⑩G.Skill製DDR3メモリ 4G ×2
⑪i7 860 CPU
⑫HDD 320G 1基
⑬HDD  1T 1基(SnowLeopardはここにインスト)
⑭SSD 80G 1基

⑭にWindows7 WindowsXP Ubuntuがインストール済みです





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy