Jump to content

How I got my ALC888 working in 10.9 Without DSDT


  • Please log in to reply
54 replies to this topic

#41
Elad Nava

Elad Nava

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
Confirmed Working on 10.8 Mountain Lion! :)

#42
Huckleberry Pie

Huckleberry Pie

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 203 posts
  • Gender:Male
Yep, it works on Mountain Lion GM, alright. Was about to give up and re-reinstall ML after a botched update from Lion, but at least this one kinda' saved the day for me.

#43
GianfrixMG

GianfrixMG

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
Hi! I'm on Lion 10.7.3 and this is the first AppleHDA.kext that seems working on my Acer Aspire 5930G :D
But there's just one problem; the card seems recognized in the audio settings but actually there's no sound! Also the system profiler seems quite strange; check the attached pictures out...
Attached File  AudioPrefs.tiff   82.8KB   8 downloads
Attached File  AudioPrefs2.tiff   84.77KB   5 downloads
Attached File  Profiler.tiff   92.67KB   7 downloads

I'm quite noob in this Hackintosh world, can someone help me? If useful, here are the verbs I found in Windows Registry:
Attached File  PinConfigOverRides.txt   505bytes   8 downloads

P.S.: I have three jacks, Headphone, Mic and Line In

EDIT: I'm also having this errors on boot, I saw them booting with -v

Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 1656 goto Exit
Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 203 goto Exit
Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 1656 goto Exit
Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 203 goto Exit


#44
Elad Nava

Elad Nava

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
Did you check all ports? Can you change system volume from taskbar / keyboard keys?

#45
GianfrixMG

GianfrixMG

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Did you check all ports? Can you change system volume from taskbar / keyboard keys?


Whoa, that was fast :D
Yes, I tried all the ports but none of them was working :( I can also change the volume from taskbar and keyboard keys, but there's still no sound...
Also, the "Master" sliders in Audio MIDI Config are at 0 and greyed out, for all the inputs/outputs O.o
Attached File  AudioMidi.tiff   100.92KB   3 downloads

#46
Hackintosh2000

Hackintosh2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:Unites States of America

Hi folks,
I have been trying countless combinations of kexts from around the net to get my ALC888 sound working.


Why didn't you just install VoodooHDA and then modify the kext? To find device and vendor ID look at THIS. Be sure to install JAVA JDK or the System Info program will not work. Your output should look like this...

Posted Image
Be sure to choose the right audio device. My graphics card has an audio device. That is presumably for HDMI.

Copy the installed VoodooHDA to the desktop. Now right click on the installed VoodooHDA kext and click "show package contents". A folder called contents should be visible. Double click on that. You should see a file called "Info.plist". Open that with TextEdit. Modify the two lines just like the guide says. Your finished product should look something like this...

Posted Image
Once you are sure everything is correct save the file and reinstall it back into s/l/e using kextwizard. Delete the AppleHDA kext. Repair permissions and rebuild caches and then reboot. Everything should work... hopefully. You will have to go into the Voodoo prefpane to make some adjustments for optimal sound. Check out the guide I linked to earlier it has some other edits you can do to the Info.plist if you need to tweak VoodooHDA beyond what you can do in the prefpane. This method works well to get rid of VoodooHDA kernel panics.

It's not "vanilla" but you only add one kext and you actually delete another. The thing is if you do an update you must remember to remove the AppleHDA kext or you could have a KP.

#47
Elad Nava

Elad Nava

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
I tried VoodooHDA, it had terrible quality if I remember correctly and low sound volume for my card.

#48
GianfrixMG

GianfrixMG

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
VoodooHDA used to work, but with some cracks sometimes and mic not working... I read somewhere AppleHDA was better so I wanted to try it... I'll try modifying the kext :)

#49
Hackintosh2000

Hackintosh2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:Unites States of America

I tried VoodooHDA, it had terrible quality if I remember correctly and low sound volume for my card.


Like I said modify the kext, tweak the sliders in the prefpane and if you need to do tweaking beyond that edit the Info.plist. I believe your low volume issue with VoodooHDA could be solved with this...

Posted Image
I have found installing VoodooHDA is only the first step. A lot of people have to tweak it a bit to get optimal sound.

Caveat! I have not tried other sound methods. They may sound better than VoodooHDA even with all the tweaks. I am in the process of exploring DSDT. I will report back if I get it working and it sounds better.

#50
acero

acero

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
hi,giantfrix
try this link http://www.osx86.net...alc888s_v2.html ,this kext has also hdmi for g105M working,very nice kext...
codec address 0

#51
GianfrixMG

GianfrixMG

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

hi,giantfrix try this link http://www.osx86.net...alc888s_v2.html ,this kext has also hdmi for g105M working,very nice kext... codec address 0


Uhmmmmm.... I have the same vendor and device IDs of this guy's sound card :D Another one to try :D

#52
GianfrixMG

GianfrixMG

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
The only kext giving me some sort of sound actually is VoodooHDA, but with some cracks and freaking white noise on microphones :( I was trying to mess up with NodesToPatch after getting all the infos with getdump, but it's such a mess and I don't know where to start! :S

#53
acero

acero

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
hi,
you should have same node id as this kext,i use this one on my acer and working perfectly but maybe different verbs.....
need to edit dsdt or use hda enabler anyway.
you can compare verbs with yours.
bye.

#54
Rowas

Rowas

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
After a long struggle, I used this method... and it works!!! Gosh. I was up all night and I wish I would have come here first.

Confirmed working on

Dell Inspiron 530s
2GB DDR2
Geforce 405 1 GB
ALC 888

OSX 10.8.2 Mountain Lion

Thank you so much.

#55
Elad Nava

Elad Nava

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts

Just dropping in to confirm that this still works on Mavericks 10.9. :)







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy