Jump to content

10.6.4 legacy kernel for INTEL/AMD ready to download by qoopz/nawcom/AnV/BlackKnight/mucha - a few new features


  • Please log in to reply
180 replies to this topic

#41
XPbIM3

XPbIM3

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Russia,Yekatherinburg
Reporting symptoms on sse2 (dothan) machine:

-it seems that sse3 emu is not working since first release of legacy kernel for SnowLeo.

-distorted graphics-safari hangs-openGL and other sse3 software fails.

-the most annoying thing: system cannot umount disks successfully. (anyway manual umount from console works.)

I don't know if that matters - no HPET in my machine.10.5.8 works almost fine with "avakov" kernel, but no OpenGl sse3 support anyway.I think our older machines needs stable sse3emus, so serious revision of sse3emu code is required, there is something wrong inside.

#42
davisin666

davisin666

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Posted Image


WTF??
My system:
Athlon X2 5200+ @2.7 (stock)
Geforce 9800gt Evga 512mb
MSI k9n2gm-fd (Chipset Geforce 8200, MCP78)
Kingston 2gb ram (1x2GB SODIMM)
PS2 Keyboard
USB mouse

Kexts:

AppleACPIPS2NUB.kext
FakeSMC.kext (Rev 277)
nforcelan.kext
viarhine.kext
voodoohda.kext

GraphicsEnabler for QE/CI
Chameleon RC5pre6
DSDT patched

Any ideas??

____________________________________________________________________________________________

LOL, La solución fue borrar nForceLAN.kext, OWNED XD

#43
M@dMac

M@dMac

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Mérida, Venezuela
EDIT:

nevermind, legacy kernel has a blacklister, perhaps you need a newer boot loader....

my pc
amd phenom ii x4 955
asus m4a78t-e
hd 5770

raid0 two hard 500
hard 640gb

i tried every kernel from v 10.0 to v 10.4 but no way to pass this panic
i used also 9.8.0 that work well on leopard but no thing panic too
i used two sources for set up retail 10.6.3 and iatkos s3 v2
this is picture of kernel panic
Posted Image


thanks sorry for my english



#44
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,135 posts
  • Gender:Male

EDIT:

nevermind, legacy kernel has a blacklister, perhaps you need a newer boot loader....


which boot loader you think it will work
i tried Chameleon RC4 Installer Package (based on AsereBLN 1.1.9)
but the same panic :)

#45
drule

drule

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts

which boot loader you think it will work
i tried Chameleon RC4 Installer Package (based on AsereBLN 1.1.9)
but the same panic :D


Try using the current official Chameleon release (rev 684), it worked for me, while AserBLN's gave me problems - I have a Pentium D.

#46
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,135 posts
  • Gender:Male

Try using the current official Chameleon release (rev 684), it worked for me, while AserBLN's gave me problems - I have a Pentium D.


i tried it also but the same panic :rolleyes:
itried also AnVAL the latest one but no hope

#47
connstance

connstance

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Kexts:

AppleACPIPS2NUB.kext
FakeSMC.kext (Rev 277)
nforcelan.kext
viarhine.kext
voodoohda.kext

GraphicsEnabler for QE/CI
Chameleon RC5pre6
DSDT patched

Any ideas??


Try to remove nforcelan.kext.

#48
davisin666

davisin666

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Try to remove nforcelan.kext.


Como que ya lo solucioné, gracias!
Esperando el nuevo kernel xDDDDDDD, funciona la raja este pero quiero 64 bits xD
Great work guys, thanks from Chile!

#49
M@dMac

M@dMac

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Mérida, Venezuela
hi, prasys posted a file & source for a PC_EFI 10.6 (RC3) based boot loader, it's pretty good!

file

source

#50
davisin666

davisin666

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Another kernel panic, but now using Adium
Posted Image

Kexts
AppleACPIPS2NUB.kext
ApplePS2Controller.kext
AppleRTC.kext
Cuda.kext
FakeSMC.kext (Rev. 319)
IOATAFamily.kext (Fix)
IOPCIFamily.kext (Fix)
IOUSBFamily.kext (Fix)
LegacyAppleAHCIPort.kext
LehacyAppleIntelPIIXATA.kext
LegacyIOAHCIBlockStorage.kext
LegacyAppleRTC.kext
NullCPUPowerManagement.kext
SleepEnabler.kext
VoodooHDA.kext
ViaRhine.kext

I also updated nvidia drivers and installed cuda, and Sleep is fine but at wake I have a lot of mouse lag, I removed AppleUpstreamUserClient.kext, AppleTYMCEDriver.kext, AppleIntelCPUPowerManagement.kext and the other blacklisted kext xD, but i have no success :C

My bootloader is AnVAL4 and i have patched the DSDT with DSDT Patcher and Hpet its on and patched and
I have installed Growl too xD

My system
AMD Athlon X2 5200+ @3.02Ghz
MSI K9N2GM-FD (Mcp78s nVidia 8200 Chipset)
2gb Ram (1x2gb)
EVGA 9800gt 512mb Superclocked
WD 320gb SATA
IDE DVD Drive, working with ApplePCGenericATA.kext

Sorry for my bad Inglish jajajaja xD

#51
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,135 posts
  • Gender:Male

i tried it also but the same panic :D
itried also AnVAL the latest one but no hope


any help yet
kernel cant detect fregunecy of cpu it says 0.00000000000 :)

#52
drule

drule

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts

any help yet
kernel cant detect fregunecy of cpu it says 0.00000000000 :)


I'm actually experiencing the same problem, but don't get a KP. My FSB frequency is shown as 200, bus ratio at 14, but even though TSC reports that my Pentium D 820 clock frequency passed it reports it as 0.0000000....

I've been adjusting my DSDT to get AppleLPC to load (even entering my Dev ID directly into the info.plist), but so far no luck.

#53
Andrea3000

Andrea3000

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts

I'm actually experiencing the same problem, but don't get a KP. My FSB frequency is shown as 200, bus ratio at 14, but even though TSC reports that my Pentium D 820 clock frequency passed it reports it as 0.0000000....

I've been adjusting my DSDT to get AppleLPC to load (even entering my Dev ID directly into the info.plist), but so far no luck.


Me too, I have a Pentium D 820 and FSB frequency is shown as 200MHz (that is the right value), bus ratio at 14 (even this is correct) but CPU Frequency is reported as 0MHz!
TSC verification test is passed anyway and the system boots without issue.
When I was using version 10.0 of this great kernel CPU Frequency was reported correctly
Any hints?

#54
drule

drule

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts

Me too, I have a Pentium D 820 and FSB frequency is shown as 200MHz (that is the right value), bus ratio at 14 (even this is correct) but CPU Frequency is reported as 0MHz!
TSC verification test is passed anyway and the system boots without issue.
When I was using version 10.0 of this great kernel CPU Frequency was reported correctly
Any hints?


Even the version of this legacy kernel for 10.6.3 reported the CPU frequency correctly for me, but for some reason this broke in the current version.

#55
Andrea3000

Andrea3000

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts

Even the version of this legacy kernel for 10.6.3 reported the CPU frequency correctly for me, but for some reason this broke in the current version.


I'm going to think that this is only a visualization problem...CPU is probably synced regardless of what is written as CPU frequency as long as it passes the tsc check and fsb and bus ratio are reported correctly, isn't it?

#56
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,135 posts
  • Gender:Male

hi, prasys posted a file & source for a PC_EFI 10.6 (RC3) based boot loader, it's pretty good!

file

source


thanks but the same panic
the system detect fsb correct busratio also but frequncey is 0.00000
any help :(

#57
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,135 posts
  • Gender:Male
i think the bootloader isnt the problem
the problem is from kernel so
what changes between leopard and snow leopard kernels ?
and how can i use leopard kernel on snow leopard? :P
because 9.8.0 kernel work very good for me

#58
scififan68

scififan68

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 151 posts
  • Gender:Male

i think the bootloader isnt the problem
the problem is from kernel so
what changes between leopard and snow leopard kernels ?
and how can i use leopard kernel on snow leopard? :P
because 9.8.0 kernel work very good for me

Using a Leopard kernel on Snow Leopard is impossible, but there's a Darwin 10.3 kernel that works very well for me, Get it here. :)

#59
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,135 posts
  • Gender:Male

Using a Leopard kernel on Snow Leopard is impossible, but there's a Darwin 10.3 kernel that works very well for me, Get it here. :P


thanks
but
Posted Image
it correct cpu freq but panic occur
like 10.0 ,10.2 blackknight kernel

#60
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,135 posts
  • Gender:Male
i use this my edited bootcd using bootcdmaker on vmware snow leopard :P
http://www.mediafire...pxp3s2qaidj0qh5

it contain
kernel 10.3 that you send
and boot AnVAL4 13/7/2010

and kexts
Posted Image

if any one can test it for me to ensure that is correct bulid for amd systems :rolleyes:
thanks





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy