Jump to content

Mac OS X guest unlocker for VMware


  • Please log in to reply
463 replies to this topic

#141
Ricksterm

Ricksterm

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
This also seems to work with vmware player, I had to rename the folder to vmware workstation to get the script to run, then renamed it back to vmware player after. I now have the option for Mac OS X Server.

I have installed OS X but when I boot I just see this:
Attached File  Untitled_1.jpg   181.7KB   405 downloads

have I done something wrong or is this definitely not going to work?

it doesn't really matter as I have OS X installed natively on this computer and dual boot with windows 7. but I would like to be able to use both at once due to needing windows booted a lot as my web cam (which I stream over ustream) does not work properly in OS X.

#142
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,881 posts
  • Gender:Male
  • Location:Manchester UK

I tried it but it crashes at boottime. I attached a screenshot that shows the error-message.

One idea. Can you turn of the Hyper-threading in the BIOS to see whether that affects the image running on your desktop PC?

#143
amorph

amorph

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
No - unfortunately not. Still the same Error-Message :D

#144
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 922 posts
  • Gender:Male
  • Location:Darlington UK

This also seems to work with vmware player, I had to rename the folder to vmware workstation to get the script to run, then renamed it back to vmware player after. I now have the option for Mac OS X Server.

I have installed OS X but when I boot I just see this:
Attached File  Untitled_1.jpg   181.7KB   405 downloads

have I done something wrong or is this definitely not going to work?

it doesn't really matter as I have OS X installed natively on this computer and dual boot with windows 7. but I would like to be able to use both at once due to needing windows booted a lot as my web cam (which I stream over ustream) does not work properly in OS X.

What version of OS X are you trying to install from the DVD or ISO?

No - unfortunately not. Still the same Error-Message :(

Guy's, I had an issue when upgrading from 10.6.2 to 10.6.3 on an i7 620M, which was resolved with 10.6.4 as Apple updated support for Core i processors in 10.6.4 which was broken in 10.6.3, so I guess the X980 is not supported yet and will have to wait until Apple catch up and launch a machine with an X980 CPU. So I would recommend going back to 10.6.2.

#145
amorph

amorph

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

What version of OS X are you trying to install from the DVD or ISO?


Guy's, I had an issue when upgrading from 10.6.2 to 10.6.3 on an i7 620M, which was resolved with 10.6.4 as Apple updated support for Core i processors in 10.6.4 which was broken in 10.6.3, so I guess the X980 is not supported yet and will have to wait until Apple catch up and launch a machine with an X980 CPU. So I would recommend going back to 10.6.2.


Does that mean, that 10.6.2 supports the X980 CPU?

#146
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 922 posts
  • Gender:Male
  • Location:Darlington UK

Does that mean, that 10.6.2 supports the X980 CPU?

Not totally sure, but I think the restrictions regarding supported processors was tightened in 10.6.3, and then some Core i processors added in 10.6.4, like your and mine i7 620M. But my i7 620M worked under 10.6.2 but not 10.6.3, that is why I am suggesting give it a try. Sorry that is the best I can advise, cheers MSoK.

#147
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,881 posts
  • Gender:Male
  • Location:Manchester UK

Not totally sure, but I think the restrictions regarding supported processors was tightened in 10.6.3, and then some Core i processors added in 10.6.4, like your and mine i7 620M. But my i7 620M worked under 10.6.2 but not 10.6.3, that is why I am suggesting give it a try. Sorry that is the best I can advise, cheers MSoK.

The other option is to go back to the Darwin.iso boot method, as never seen the commpage error with the legacy kernel with boot-132. Finally Chameleon RC5 also adds additional CPU detection code, but it isn't released yet.

#148
Ricksterm

Ricksterm

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts

What version of OS X are you trying to install from the DVD or ISO?


This disc has 10.6.2 on it. it is a distro though (hazards 10.6.2 with option for server), works in virtual box just fine but I prefer VMWare player.

In VMWare player:

I have to remove the efi part of the config file to get the DVD to boot,

I then install OS X Server with chameleon RC4... trying to boot with that is just says "Operating System Not Found"

I install OS X without chameleon RC4 and then add the EFI part back to the config file and then I just get that weird EFI boot thing with the yellow and white text.

In virtual box it works pretty well with chameleon RC4

#149
Hairball

Hairball

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I am on a Mac 10.6.4 Server, Running a fresh install of Fusion 3.0.1,

Running the ./macosx command I receive the following results:


sh-3.2# ./macosx
Mac OS X guest unlocker for VMware, version 7

Directory /Library/Application Support/VMware Fusion:
File vmware-vmx:
Unlocking Mac OS X guest on non-Mac host ...
Too few match sites.
File vmware-vmx-debug:
Unlocking Mac OS X guest on non-Mac host ...
Too few match sites.
File vmware-vmx-stats: Missing file.

File /Applications/VMware Fusion.app/Contents/MacOS/vmware:
Unlocking Mac OS X guest on non-Mac OS X host (method 1) ...
Too few match sites.
sh-3.2#


Any ideas what this means? It looks like it is erroring out but I can't tell.

#150
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,881 posts
  • Gender:Male
  • Location:Manchester UK

I am on a Mac 10.6.4 Server, Running a fresh install of Fusion 3.0.1,

Running the ./macosx command I receive the following results:


sh-3.2# ./macosx
Mac OS X guest unlocker for VMware, version 7

Directory /Library/Application Support/VMware Fusion:
File vmware-vmx:
Unlocking Mac OS X guest on non-Mac host ...
Too few match sites.
File vmware-vmx-debug:
Unlocking Mac OS X guest on non-Mac host ...
Too few match sites.
File vmware-vmx-stats: Missing file.

File /Applications/VMware Fusion.app/Contents/MacOS/vmware:
Unlocking Mac OS X guest on non-Mac OS X host (method 1) ...
Too few match sites.
sh-3.2#


Any ideas what this means? It looks like it is erroring out but I can't tell.


It is for Fusion 3.1.0 not Fusion 3.0.1.

This disc has 10.6.2 on it. it is a distro though (hazards 10.6.2 with option for server), works in virtual box just fine but I prefer VMWare player.

In VMWare player:

I have to remove the efi part of the config file to get the DVD to boot,

I then install OS X Server with chameleon RC4... trying to boot with that is just says "Operating System Not Found"

I install OS X without chameleon RC4 and then add the EFI part back to the config file and then I just get that weird EFI boot thing with the yellow and white text.

In virtual box it works pretty well with chameleon RC4


Best bet is t use a vanilla retail version of Snow Leopard, as that is what the virtualization in VMware expects. There are too many other variables in "distros" to easily find what is causing the issue.

#151
empora

empora

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Thanks for this fantastic contribution. This is the first one that works, after trying to install dozens of others. I guess my system is so unusual that your's is the only one that works. I have a problem though with my screen resolution. It is set to 1280x768 and can not be changed. Any idea's how to solve this? Many thanks in advance for anyone who has a solution.

hardware: Asus Z8NR-D12 motherboard with 2x E5520 Xeon processors, 20Gb memory and Nvidea video. No connection to the www until now. Could an installation of VMware tools solve my problem?

software: VMware workstation 7.1.0 and Snow Leopard 10.6.3

#152
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 922 posts
  • Gender:Male
  • Location:Darlington UK

Thanks for this fantastic contribution. This is the first one that works, after trying to install dozens of others. I guess my system is so unusual that your's is the only one that works. I have a problem though with my screen resolution. It is set to 1280x768 and can not be changed. Any idea's how to solve this? Many thanks in advance for anyone who has a solution.

hardware: Asus Z8NR-D12 motherboard with 2x E5520 Xeon processors, 20Gb memory and Nvidea video. No connection to the www until now. Could an installation of VMware tools solve my problem?

software: VMware workstation 7.1.0 and Snow Leopard 10.6.3

I have a Dual Processor Xeon E5520 HP Z600 Workstation and SL runs really well, using Albert's unlocker. Firstly update to 10.6.4, then use one of Donk's darwin iso files, either the latest 310 or the earlier 310b6, link below, to install the VMware tools this will solve the resolution issue as well as allow you to use shared folders. Mount the darwin.iso and then you will get the option to install the tools, you cannot install the tools natively from VMware Workstation or Player, you need to mount the darwin.iso.

http://www.insanelym...p...t&p=1527301

Hope this helps, MSoK.

#153
empora

empora

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

I have a Dual Processor Xeon E5520 HP Z600 Workstation and SL runs really well, using Albert's unlocker. Firstly update to 10.6.4, then use one of Donk's darwin iso files, either the latest 310 or the earlier 310b6, link below, to install the VMware tools this will solve the resolution issue as well as allow you to use shared folders. Mount the darwin.iso and then you will get the option to install the tools, you cannot install the tools natively from VMware Workstation or Player, you need to mount the darwin.iso.

http://www.insanelym...p...t&p=1527301

Hope this helps, MSoK.


Thanks for the quick reply,
I'll try your solution tomorrow. Hope this helps.

#154
tworthen

tworthen

    InsanelyMac Protégé

  • Donators
  • 2 posts
  • Gender:Male
  • Location:Southern California
  • Interests:anything involving computers...

Good day.

I wrote a little program which allows to create a virtual machine and run any flavor of Mac OS X

  • Mac OS X
  • Mac OS X Server
inside the virtual machine, using any VMware product
  • VMware Workstation for Windows
  • VMware Workstation for Linux
  • VMware Fusion for Mac OS X
on any Intel-based physical machine
  • PC
  • Mac
I hope you will enjoy it. For details, please read the file README.txt. Give me your feedback about it in this forum.


Your excellent program is hard coded to drive c:. My VMware install wound up on Drive F: (don't ask). Moving it was not easy.


Suggest adding a switch variable to specify which drive it goes to, to work its magic.

#155
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 922 posts
  • Gender:Male
  • Location:Darlington UK

Your excellent program is hard coded to drive c:. My VMware install wound up on Drive F: (don't ask). Moving it was not easy.


Suggest adding a switch variable to specify which drive it goes to, to work its magic.

Try Donk's updated script, link below, it should solve the issue.

http://www.insanelym...p...t&p=1517645

#156
empora

empora

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Thanks 'Mac Son of Knife'. I managed to get the 1900x1200 resolution installed. It works perfectly.

I had no experience with mac on windows at all but this looks promising.

Thanks again, Empora

#157
tziehmer

tziehmer

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

You need VMware to write accelerated video drivers for Mac OS X, and they currently have not done so. Running Mac OS X in a VM is OK, but not a good idea if you want to do video, picture or audio work.


Dear all,

My greatest respect to all of you for your noble efforts!

My university (I'm a student in NL) chooses and offers with a good discount a notebook of the year every August/September. It's always a PC, however, Macs have reached big mindshare here and me and my friends want iLife and Keynote a lot.

I'd like you experts to weigh in on an important decision I'll have to make in this back-to-school time: Donk, Albert and the other pros, with my focus on working with iLife/iWork and CS, what's your advice: using this solution with a HP Elitebook 8540p (i5 540M, NVS 5100) or biting the bullet and paying for a MBP?

Many thanks for your two cents. It's very appreciated.

#158
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 922 posts
  • Gender:Male
  • Location:Darlington UK
I have just noticed an update is available for VMware Workstation from 7.1.0 to 7.1.1, I am sure this will break the unlocker, but not sure if it will re-install and work under 7.1.1. I will have a look, but be warned until we get a response from Albert and / or Donk DO NOT Update to 7.1.1, MSoK!

#159
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,881 posts
  • Gender:Male
  • Location:Manchester UK

I have just noticed an update is available for VMware Workstation from 7.1.0 to 7.1.1, I am sure this will break the unlocker, but not sure if it will re-install and work under 7.1.1. I will have a look, but be warned until we get a response from Albert and / or Donk DO NOT Update to 7.1.1, MSoK!


The unlocker still works fine for Workstation 7.1.1 on Windows. I haven't tried yet on Linux, or with Player or Fusion.

One update. I did upload a script to try and sort out some of the issues around paths and the USB Arbitration service on Windows. As I said at the time, was written from memory and not tested, and consequently doesn't work. Attached is a new Windows batch file to fix the issues. Download to same folder as the unlocker windwos-32.exe, and rename to windows.cmd.

Dear all,

My greatest respect to all of you for your noble efforts!

My university (I'm a student in NL) chooses and offers with a good discount a notebook of the year every August/September. It's always a PC, however, Macs have reached big mindshare here and me and my friends want iLife and Keynote a lot.

I'd like you experts to weigh in on an important decision I'll have to make in this back-to-school time: Donk, Albert and the other pros, with my focus on working with iLife/iWork and CS, what's your advice: using this solution with a HP Elitebook 8540p (i5 540M, NVS 5100) or biting the bullet and paying for a MBP?

Many thanks for your two cents. It's very appreciated.


Mac all the time! You won't get anything that uses accelerated graphics working inside VMware, and sound is also variable in quality. You can then use Fusion and/or Bootcamp to run Windows

Attached Files



#160
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 922 posts
  • Gender:Male
  • Location:Darlington UK

The unlocker still works fine for Workstation 7.1.1 on Windows. I haven't tried yet on Linux, or with Player or Fusion.

One update. I did upload a script to try and sort out some of the issues around paths and the USB Arbitration service on Windows. As I said at the time, was written from memory and not tested, and consequently doesn't work. Attached is a new Windows batch file to fix the issues. Download to same folder as the unlocker windows-32.exe, and rename to windows.cmd.

Donk, sorry for the alarm, just did not have time to check whether the Unlocker would be OK with 7.1.1, well not until tonight. So once again thanks for your speedy input and solution. I assume the script is the same one you posted before?

Also does your script work with a Player only configuration, or could it be easily modified to support Player?





4 user(s) are reading this topic

0 members, 4 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy