Jump to content

[Guide] Sony VAIO VPCF115FM 10.6.3 installation, Chameleon on own partition, dual boot.


  • Please log in to reply
64 replies to this topic

#41
icebun

icebun

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

hello, thanks for your guide
i had follow until step 6
however, after i erase the disk and install,
after 10 minute or longer,
it show installation failed
mac cant install on this computer...

Posted Image
Posted Image

i try to reinstall again and view the installer log with show error only
then i notice that the log show:
Install failed: The installer could not start up the computer from the disk "MAC". Try selecting your disk using the Startup disk utility.
Posted Image

can i know what format need to install mac os? ( mac os extended or?)
my current hard disk got 4 partition
it's partition map scheme is master boot record
is this the problem make me installation failed?

can i install mac os on it without format the whole hard disk?
because my win 7 system still at partition 1

now i planning to boot back my win7,
but when i boot the hard disk
it show: Missing operating system
OMG... now my desktop is death zzz

help me please ><
thanks for ur guide alot!!!



i still got the same problem even i install to another empty hardisk
i using Mac OS X Snow Leopard_10a432_userdvd version
restore it to a external hard drive using VM Mac OS X 10.6.2

any 1 know what problem with this error?

#42
Mammoth

Mammoth

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 625 posts

i still got the same problem even i install to another empty hardisk
i using Mac OS X Snow Leopard_10a432_userdvd version
restore it to a external hard drive using VM Mac OS X 10.6.2

any 1 know what problem with this error?


This procedure is for 10.6.3 only, not 10.6.2 and has to be on a blank drive.

From the looks of your error messages and what you have said, it does not look like you followed the guide at all. Was this thread at the top of the list and you just blindly posted here? Not cool.

#43
Phantom Thief Dark Mousy

Phantom Thief Dark Mousy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male

i still got the same problem even i install to another empty hardisk
i using Mac OS X Snow Leopard_10a432_userdvd version
restore it to a external hard drive using VM Mac OS X 10.6.2

any 1 know what problem with this error?


Your installation did not fail, it succeded you need only to boot it up and it'll work, the only issue is that the bless tool could not set the laptop to boot from the hard drive. its a common error, just use the boot cd and boot the snow leopard partition and you'll be fine

#44
Mammoth

Mammoth

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 625 posts
*UPDATE MAY 29, 2010 *

First of all, I'm sorry for all the constant version updates to the Guides and some other files, but when I find something wrong I feel very compelled to fix it. So with that said, all guides and the Mammoth Boot CD have just been rolled to versions 1.20. I HOPE I will not need to make any more changes (at least for a while) to any of these.

The good news is, all my talk about issues with the keyboard and TrackPad have been resolved, and now the CORRECT way! NO MORE Preboot.dmg file installed on our Cham drives!!! Just FORGET everything I said about all of that previously, in fact, in the v1.20, Part III guide, all references to that subject have been REMOVED as none of that is part of the installation procedure going forward with v1.20! (Yes, I'm happy too.)

I have wrote up procedures that will allow all of you to correct this on your current installations, so you don't have to reinstall or waste your time trying to figure out how to "undo it", I've done all that for you! Just go to the FILES section and download the fix instructions. You WILL need Mammoth Boot CD v1.20 to fix everything as the corrected files are there.

Mammoth


#45
Fb2003

Fb2003

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Hi, nice topic....very interesting :)
I need a laptop for VJ work.
Currently I use a i7 desktop hackintosh...(runs very stable)...lot of dragging with hardware...

Is a sony vaio i7 hackintosh a good and stable solution for my problem?
Or am I better off paying 1500 euro's more for a comparable macbook pro?

#46
Mammoth

Mammoth

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 625 posts

Is a sony vaio i7 hackintosh a good and stable solution for my problem?


Absolutely NOT! I am selling my VAIO and getting the HP DV8T to become my Windows 7 & OS X HacBook Pro.

http://www.shopping..../computer_store

Read this thread:

http://www.insanelym...howtopic=218556


Mammoth

#47
Mammoth

Mammoth

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 625 posts
* UPDATE JUNE 2, 2010 *

Part IV of the Installation Guide will be posted tomorrow!


This is the guide that will show you how to get Windows 7 installed, and not just how to install Windows 7, most of us know how to do that, but how to take the factory image of Windows 7 from Sony and install THAT in our Hack system. We'll also setup our Repair installation of OS X, and I'll finally show you how to get networking setup using a firewire cable so you can transfer files and get on the Internet from your VAIO and be able to get updates from Apple.

So look for that being posted within the next 24 hours or so.

Mammoth


#48
Mammoth

Mammoth

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 625 posts
* UPDATE JUNE 3, 2010 *

In working to complete Guide Part IV, I discovered a critical step that was left out of Guide II which COULD make it so that Windows 7 wont install! Originally when I posted this update, I thought everyone would experience this. Then I did some more testing and could not repeat the issue. So I apologize if this has happened to you, but it looks like chances are, it has not. : )

If you try to install Windows 7 using Windows 7 installation media such as DVD and it keeps saying that it cannot install because the partition type is GPT, this is the issue I am talking about.

At any rate, please download the updated / corrected version of Guide Part II (v1.25) from the FILES section as the added steps should help prevent this from happening to you.


(Part IV is almost done, so hold on for that too! The issue discussed above prevented me from completing Part IV sooner.)


#49
Mammoth

Mammoth

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 625 posts
* UPDATE JUNE 3, 2010 *

Part IV of the Installation Guide has FINALLY been posted!


This is the guide that shows you how to get Windows 7 installed, and not just how to install Windows 7, most of us know how to do that, but how to take the factory image of Windows 7 from Sony and install THAT so you don't have to waste HOURS and days trying to get a fully working version of Windows 7 on a LAPTOP.

We'll also setup our Repair installation of OS X, and I finally show you how to get networking using a firewire cable connected to another Mac / Hack system, so you can transfer files and get on the Internet from your VAIO PLUS be able to get updates from Apple.

This is the biggest guide, packed with the most information and tips, so get it now from the FILES section of the first post.

PLEASE post your comments at some point.

Thanks,

Mammoth


#50
Mammoth

Mammoth

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 625 posts
@MacMan50

Hey Mac Man 50,

So today my DV8T arrived in Alaska, so it's slowly making its way to me. Looks like it's still on target for a June 15th arrival. I've already started to gear up for starting the new thread and laying some groundwork for DV8T installation.


So hang tight and we'll get this thing going!

Mammoth

#51
Mac Man 50

Mac Man 50

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
Excellent news.

#52
maly70

maly70

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male

* UPDATE JUNE 3, 2010 *

Part IV of the Installation Guide has FINALLY been posted!


This is the guide that shows you how to get Windows 7 installed, and not just how to install Windows 7, most of us know how to do that, but how to take the factory image of Windows 7 from Sony and install THAT so you don't have to waste HOURS and days trying to get a fully working version of Windows 7 on a LAPTOP.

We'll also setup our Repair installation of OS X, and I finally show you how to get networking using a firewire cable connected to another Mac / Hack system, so you can transfer files and get on the Internet from your VAIO PLUS be able to get updates from Apple.

This is the biggest guide, packed with the most information and tips, so get it now from the FILES section of the first post.

PLEASE post your comments at some point.

Thanks,

Mammoth


Hi Mammoth;

i intalled yesterday SL 10.63 on my Vaio F113F/D that has:

intel i7 cpu

nvidia 310M video card (after installation i got 1600x900 only)

6GB memory

and the other vaio F11s have.

i copied recovery partition into an external HD before wipe out the hard drive.

After i installed using Mammoth cd boot then inserted SL 10.63 dvd and push F5, the installation was successful from the first try, then i reboot and used Mammoth boot cd to bootup the system and it did bootup! this is great Mammoth (exactlly as you said in your guide). But i still use the boot cd to Boot.

Then i installed windows7 in windows partition as mentioned in the guide, the installation was smooth and as it use to, when 10.63 started i realized that when i click on about this mac the system refresh ans goes back as after the first boot and getting backup option. Is this normal? i can't run About this Mac at all! i run system profile, i noticed that the memory showed is only 2GB on it ( i have 6 GB) and profile for macpro 6.1, i have no internet connection as you mentioned in your guide and have no sound and icons for other partitions or OSX partition icon on the desktop.

How to install Chameleon in the Cham partition? ( still have Cham empty partition) and of i install Chameleon does it affect the windows boot system ? and the boot cd has not the folder you mentioned in your guide except the one in the root ( and it is not the one that is required) how i can get that folder?

if there is a fix for wireless lan and sound please let me know

Your Guide is great and is the first easy to follow, Please Keep it up

Thank you Mammoth for this best guide

maly70

#53
Mammoth

Mammoth

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 625 posts

Hi Mammoth;

i intalled yesterday SL 10.63 on my Vaio F113F/D that has:

intel i7 cpu

nvidia 310M video card (after installation i got 1600x900 only)

6GB memory

and the other vaio F11s have.

i copied recovery partition into an external HD before wipe out the hard drive.

After i installed using Mammoth cd boot then inserted SL 10.63 dvd and push F5, the installation was successful from the first try, then i reboot and used Mammoth boot cd to bootup the system and it did bootup! this is great Mammoth (exactlly as you said in your guide). But i still use the boot cd to Boot.

Then i installed windows7 in windows partition as mentioned in the guide, the installation was smooth and as it use to, when 10.63 started i realized that when i click on about this mac the system refresh ans goes back as after the first boot and getting backup option. Is this normal? i can't run About this Mac at all! i run system profile, i noticed that the memory showed is only 2GB on it ( i have 6 GB) and profile for macpro 6.1, i have no internet connection as you mentioned in your guide and have no sound and icons for other partitions or OSX partition icon on the desktop.

How to install Chameleon in the Cham partition? ( still have Cham empty partition) and of i install Chameleon does it affect the windows boot system ? and the boot cd has not the folder you mentioned in your guide except the one in the root ( and it is not the one that is required) how i can get that folder?

if there is a fix for wireless lan and sound please let me know

Your Guide is great and is the first easy to follow, Please Keep it up

Thank you Mammoth for this best guide

maly70


Hello Maly70!

Glad the guide has worked so well for you! I put a lot of effort into it so it would be just that easy and work. :P

On the "About This Mac", that is a problem all of these VAIO machines are doing under OS X. I don't know why or how to correct that. You have discovered you can launch System Profiler though, so that's what I was doing.

The memory, bus, CPU, and other stats are controlled by SMBIOS.plist. Those are mostly cosmetic.

On installing Chameleon, did you download all 4 guides? The part for installing Chameleon is in Part III. Do you have v1.20 of the boot CD? Many people have downloaded the guides and boot CD and not had this problem. Perhaps something in the burn process is failing? Get the free program "SimplyBurns" (which is OS X not Windows), and use that to burn the CD and let me know how that works.

To get sound working, you could try VoodooHDA, and for wireless, if you can buy an actual Apple WiFi card (that will fit in the machine) and swap out the existing card, that MAY work. If you could borrow one from someone to test, that would be best.

I'm very happy you have enjoyed the guides, that they have been so useful to you, AND that you took the time to reply. Thank YOU! :D


Note that I no longer have my VAIO, I sold it on eBay and replaced it with an HP DV8t. Following is my new thread for that machine:
http://www.insanelym...howtopic=221653

Mammoth

#54
maly70

maly70

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
Hi again;

i reinstalled 10.63 again yesterday with the latest boot cd you mentioned yesterday, the first defference is that the display was better and briter then before but still have the same issues that i told you about.

i tried to installed or transfer chameleon to Cham partition but for some how it did not (duno why)

i just dragged extra folder as you mentioned and then ...404 file and then typed the commands you said and no chance to get the booting from cham partition!

i still using the boot CD til i figure out how to install chameleon part from boot cd.

Can i install chameleon directly from osx 10.63 to cham partition?

Will this harm windows boot partition and/or osx partition?

Thank you for this new boot cd, i realy now comfirm that the latest boot cd is better and more stable then the first one. ( after booting with boot cd v.1.20) under verboose mode the system sees more devices than before.

VoodooHDA is not compatible at all (i got kernel panic after i install it )

i installed i7 fix for Atheros but still did not work, the sound in system profiler has more details than before.

That's all i have now Mammoth and good luck

maly70

#55
Mammoth

Mammoth

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 625 posts

Hi again;

i reinstalled 10.63 again yesterday with the latest boot cd you mentioned yesterday, the first defference is that the display was better and briter then before but still have the same issues that i told you about.

i tried to installed or transfer chameleon to Cham partition but for some how it did not (duno why)

i just dragged extra folder as you mentioned and then ...404 file and then typed the commands you said and no chance to get the booting from cham partition!

i still using the boot CD til i figure out how to install chameleon part from boot cd.

Can i install chameleon directly from osx 10.63 to cham partition?

Will this harm windows boot partition and/or osx partition?

Thank you for this new boot cd, i realy now comfirm that the latest boot cd is better and more stable then the first one. ( after booting with boot cd v.1.20) under verboose mode the system sees more devices than before.

VoodooHDA is not compatible at all (i got kernel panic after i install it )

i installed i7 fix for Atheros but still did not work, the sound in system profiler has more details than before.

That's all i have now Mammoth and good luck

maly70



Hi again Maly70,

Is your machine a "VPCF115FM/B" or maybe it's slightly differenct? Maybe that could be the case. There could be something strange/wrong with your hard drive, but I doubt it. If you have the exact same machine and parts in it and I had to place money on a bet as to what the problem is, I would say there is something you are missing, or interpreting incorrectly with the instructions. I say that only because so many people have setup their machines with this method and either not had the issue or not reported it. If anyone else could post about this, that would be great.

Chameleon (Cham) is not part of OS X or its 10.6.3 DVD. So no to that question.

My other suggestion would be to look at this part of the procedure on the newer guides I have created on my DV8t thread. They are tailored for the DV8t, so hopefully that won't be more confusing, but I have worded things differently and steamlined the process. Check it out here:

http://www.insanelym...howtopic=221653


Also, for those who still have this machine and could help out Maly70, that would be great.



Mammoth

#56
ejbm

ejbm

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi.
When i put Snow Leopard DVD and hit ENTER my sony VPCF115FM restarts.
I used MAMOOTH BOOT CD and SNOW LEOPARD 10.6.3 Retail.
Can you help me?
Thanks.
Goodbye.
Eduardo.

#57
ricardoplugins

ricardoplugins

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Could you please tell me what was the problem(s) when you try to make a hackintosh with your sony vaio i7 ??? I hope you can guide me on your experience
Thanks a lot !!

skydivemail@yahoo.com
_______________________

[quote name='Mammoth' date='Jun 1 2010, 05:54 PM' post='1480206']
Absolutely NOT! I am selling my VAIO and getting the HP DV8T to become my Windows 7 & OS X HacBook Pro.

#58
ricardoplugins

ricardoplugins

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Does anyone know about Snow leopard in a SONY VAIO i7 ( VPCF13PFX )
I'm pretending to use it for Final Cut Pro (so audio & video must work)

Hardware content:
Processor: i7-740QM 1.73 GHz
VIDEO: NVIDIA® GeForce® GT 310M / GT 425M
AUDIO: Realtek® Audio HD PCEE

ETHERNET: Marvell® Yukon® 88E8057 PCI-E Gigabit Ethernet
WIRELESS: Marvell® Atheros® AR9287 Wireless Network Adapter
MOTHERBOARD: Intel® 5 Series 6 Port SATA AHCI

Please anything you know will be really helpfull
Thanks
skydivemail@yahoo.com

#59
Lord_Richard_2

Lord_Richard_2

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:WI

Hi.
When i put Snow Leopard DVD and hit ENTER my sony VPCF115FM restarts.
I used MAMOOTH BOOT CD and SNOW LEOPARD 10.6.3 Retail.
Can you help me?
Thanks.
Goodbye.
Eduardo.


to boot to the disc you have to use the boot arguments "busratio=12 cpus=8" to get it to boot. Busratio sets the bus speed or id im assuming, and cpus=8 sets the max cpu threads to be 8 (which is what the i7 wants from every OS).

I used the hazard snow leopard 10.6.6intel install to get it to work (dont select any graphics or audio packages otherwise it wont boot because of kernel panics).
I did not need to put "busratio=12 cpus=8" to boot mac after it installed though, but if it doesnt boot (restarts right away) then try that.

Also use EasyBCD to add an entry to windows boot loader to another partition for mac. This will save countless hours of having to swap disc. After the first time of installing macosx86 i had to use startup repair from my win7 disc to set my windows partition as active. It does it automatically and changes a few partition numbers, but after that i could install and reinstall without using my windows disc.

Make sure to select chamelion rc5 in the hazard customizations selection (and no kernel as i7 works on vanilla kernel) to get it installed right.

Does anyone know about Snow leopard in a SONY VAIO i7 ( VPCF13PFX )
I'm pretending to use it for Final Cut Pro (so audio & video must work)

Hardware content:
Processor: i7-740QM 1.73 GHz
VIDEO: NVIDIA® GeForce® GT 310M / GT 425M
AUDIO: Realtek® Audio HD PCEE

ETHERNET: Marvell® Yukon® 88E8057 PCI-E Gigabit Ethernet
WIRELESS: Marvell® Atheros® AR9287 Wireless Network Adapter
MOTHERBOARD: Intel® 5 Series 6 Port SATA AHCI

Please anything you know will be really helpfull
Thanks
skydivemail@yahoo.com


I have a sony vaio VPCF13YFX if thats what you meant. mine has same specs as you mentioned, except it says i have an "Intel Centrino Advanced-N 6250 AGN" wireless card.
I also have geforce 425m and a blue ray drive.
My mobo seems to match yours as being Intel5 series. (so it wasnt affected by i7 sandy bridge recall as series 6 was).

BTW i got ALC275 working from a kext i found online, they must have known what vender id and model id's to change in some kext. It does use VoodooHDA kext as a base tho, but hey it works (but still unsure if it is stereo, and surround sound)

#60
Lord_Richard_2

Lord_Richard_2

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:WI

Does anyone know about Snow leopard in a SONY VAIO i7 ( VPCF13PFX )
I'm pretending to use it for Final Cut Pro (so audio & video must work)

Hardware content:
Processor: i7-740QM 1.73 GHz
VIDEO: NVIDIA® GeForce® GT 310M / GT 425M
AUDIO: Realtek® Audio HD PCEE

ETHERNET: Marvell® Yukon® 88E8057 PCI-E Gigabit Ethernet
WIRELESS: Marvell® Atheros® AR9287 Wireless Network Adapter
MOTHERBOARD: Intel® 5 Series 6 Port SATA AHCI

Please anything you know will be really helpfull
Thanks
skydivemail@yahoo.com


I have a Sony Vaio VPCF13YFX, i think you meant a Y instead of a P. My computer has all the same specs (i7 740QM processor) but has an nvidia geforce 425GM and a Intel Centrino Advanced-N 6250 AGN wifi card.
ALC275 audio

I have gotten my audio to work, but ethernet and wifi and graphics card are unrceognized.
It also only sees 2gb (so only first stick in slots available?) and also my USB ports do not work, yet my keyboard and trackpad work fine. My "About this mac" screen causes the GUI to crash but it just reloads right away. And when my computer is on the fans go to full speed and the CPU runs hot like it is doing a lot of processes even if i am idling at the desktop. Powermanagement problem kext? i have no idea.

I used hazard 10.6.6 intel distro and installed it using no audio/graphics options.
I also have mac on a seperate partition dual booting win7x64 using windows bootloader and chamelion on the mac partition. I used EasyBCD for windows to add the entry to the windows boot loader.
To boot Hazard distro i had to press f8 at main screen and enter "busratio=12 cpus=8" to boot it, otherwise it restarts quickly.

i also have a problem with my audio even thought it works. Every time i boot up mac i hear a low faint hiss coming from my speakers, like its playing a small noise. Everytime it turns off i get a small pop sound. I think it is applying a voltage or reading the baseline level as being higher so it plays a low sound. how can i check/change this? Anybody else encounter this with ALC275 enabled with a VoodooHDA kext? (I found it online and i think they just edited the vender/model id's)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy