Jump to content

[How To] Install Snow Leo on Acer 6292

- - - - -

  • Please log in to reply
113 replies to this topic

#61
peach-os

peach-os

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,286 posts
  • Location:lago di constanza
because berlusconi blocked all keyboards that he can´t control :)

I can´t help with that, but look for that problem in the italian forum - I´m pretty sure you will find a solution there.

#62
marcussebe

marcussebe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:ITALY

because berlusconi blocked all keyboards that he can´t control :)

I can´t help with that, but look for that problem in the italian forum - I´m pretty sure you will find a solution there.



:D :D :D


Thanks...I call Ruby :D

Good day
by Marcuss

#63
marcussebe

marcussebe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:ITALY
Hi Peach-os,
I have a new question...I upgrade the sistem at SL 10.6.4, all work ferfect, but in the System Profile - Graphics Card the chip model is GM950, why?? The TM6292 have X3100 ;)

I backup and replace all GMA x3100 extensions, but in the System Profile isn't select? is correct?

...can I upgrade on 10.6.5 and lather?the system work?

thanks a lot
by Marcuss

#64
peach-os

peach-os

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,286 posts
  • Location:lago di constanza
the x3100 is the followup of the GM950

as long it´s working and you have QE / CI it doesn´t matter - just cosmetics

you can even update online to 10.6.7 without any issues, but I recommend always to do a backup before.

#65
marcussebe

marcussebe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:ITALY

with the new HW Sensors from here http://www.projectos...p?showforum=165

a comfortable measuring is available to control temps for cpu, graphics,cpu voltage and other sensors. great work!



install the HW Sensors to S/L/E IntelCpuMonitor doesn´t work from Extra. I deleted in SuperIOFamily already all plugins that aren´t needed to make boot time shorter

to get proper speedstepping you have to check first Generate P-States, Generate C-States and Drop SSDT in Chameleon preferences.

but it won´t start throttling before setting the needed model id in smbios.plist

according to the hardware specs of the Acer6292 it should be MacBook3,1 , because the closest match is the MacBook late 2007 - but this won´t work!
MacPro3,1 would give you speedstepping, but avoid some functions. to keep everything working (i.e. coolbook if needed)
I decided to follow silencers guide here http://www.insanelym...howtopic=211705
and to create a legacy.kext for the acer6292. all credits to him !

put the attached legacyAcer6292.kext in Extra and set the model to MacBook3,2 in SMBios.plist, reboot -
et voilá! speedstep is working! you can proof it with voodoomonitor



p-states in vodoomonitor - throttling at lowest p-state - highest p-state

you can see the throttling also in the free version of coolbook and use it to raise the cpu load for testing



all needed files are in the attached package, except iStat for measuring - look for last free version 2.0 or you have to buy it for 16 bucks !

EDIT: if you experience kernel panics, get rid of iStat or other hardware sensors !


Hi Pech-OS,
I have some questions to your speedstepping guide:
1) now I have S.L. 10.6.2. Your guide works in S.L. 10.6.3, 10.6.4 ..... ?
2) ....you have to check first Generate P-States, Generate C-States and Drop SSDT in Chameleon preferences...
I insert DropSSDT=Yes in the config file of Chameleon
how check Generate P-States, Generate C-States ?
3) ...put the attached legacyAcer6292.kext in Extra and set the model to MacBook3,2 in SMBios.plist...
How can I set the model to MacBook3.2 ??

Thank you for your help
by Marcussebe

#66
marcussebe

marcussebe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:ITALY

Hi Pech-OS,
I have some questions to your speedstepping guide:
1) now I have S.L. 10.6.2. Your guide works in S.L. 10.6.3, 10.6.4 ..... ?
2) ....you have to check first Generate P-States, Generate C-States and Drop SSDT in Chameleon preferences...
I insert DropSSDT=Yes in the config file of Chameleon
how check Generate P-States, Generate C-States ?
3) ...put the attached legacyAcer6292.kext in Extra and set the model to MacBook3,2 in SMBios.plist...
How can I set the model to MacBook3.2 ??

Thank you for your help
by Marcussebe


nothing ;(

#67
peach-os

peach-os

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,286 posts
  • Location:lago di constanza

nothing ;(


sorry.....I didn´t see your post earlier


1) now I have S.L. 10.6.2. Your guide works in S.L. 10.6.3, 10.6.4 ..... ?

ALL

2) ....you have to check first Generate P-States, Generate C-States and Drop SSDT in Chameleon preferences...
I insert DropSSDT=Yes in the config file of Chameleon
how check Generate P-States, Generate C-States ?

easiest is to check all in chameleon prefpane that comes with chameleon RC5


3) ...put the attached legacyAcer6292.kext in Extra and set the model to MacBook3,2 in SMBios.plist...
How can I set the model to MacBook3.2 ??


you should have a smbios.plist file in EXTRA - otherwise create one - if you search for smbios.plist you will find tons of examples - and it´s selfexplaining - easy to understand

#68
marcussebe

marcussebe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:ITALY

sorry.....I didn´t see your post earlier


1) now I have S.L. 10.6.2. Your guide works in S.L. 10.6.3, 10.6.4 ..... ?

ALL

2) ....you have to check first Generate P-States, Generate C-States and Drop SSDT in Chameleon preferences...
I insert DropSSDT=Yes in the config file of Chameleon
how check Generate P-States, Generate C-States ?

easiest is to check all in chameleon prefpane that comes with chameleon RC5


3) ...put the attached legacyAcer6292.kext in Extra and set the model to MacBook3,2 in SMBios.plist...
How can I set the model to MacBook3.2 ??


you should have a smbios.plist file in EXTRA - otherwise create one - if you search for smbios.plist you will find tons of examples - and it´s selfexplaining - easy to understand


Hi Peach,I put legacyAcer6292.kext in /Extra/Extensions? or in /Extra/ ?
...and where i put voodoomonitor.kext ?

#69
peach-os

peach-os

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,286 posts
  • Location:lago di constanza
hmm....two months later ;)

the last months I didn´t get any emails from insanely for some reason - sorry.
I´m pretty sure you figured it out yourself meanwhile - but just in case: every kext that begins with "voodoo"
should be in S/L/E. Also I don´t think you´ll need voodoomonitor really

#70
LachlanDMcCahon

LachlanDMcCahon

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:London, England
  • Interests:I like computers, cars and cooking.
Hi everyone, sorry to revive this thread but i have a problem. I followed parts of this guide to install OSX onto my 6292 (602....) and everything works in 10.6.3 (even the webcam for photobooth and ichat) except when i update to 10.6.4 i loose ethernet. any ideas to fix this. i re instaled the BMC kext given but still nothing. Any ideas to rectify this?

#71
peach-os

peach-os

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,286 posts
  • Location:lago di constanza
did you install the iopcifamily.kext ? it doesn´t work without that.

#72
LachlanDMcCahon

LachlanDMcCahon

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:London, England
  • Interests:I like computers, cars and cooking.

did you install the iopcifamily.kext ? it doesn´t work without that.

Yes, i did.
i installed it thrice, with no success. then i tried removing a preferences.plist file in system as suggested on a website. this reset all my network devices. after a permission repair it worked for about 5 mins. then after a reboot nothing.
it works in 10.6.3, 10.6.4 it doesnt work, updated to 10.6.5 and still nothing. ive tried the IOPCIfamily.kext and it doesnt work.
any other ideas.

did you install the iopcifamily.kext ? it doesn´t work without that.


HOWEVER
in 10.6.5, the IWI driver works for my Intel 4965AGN card with the realtek wireless util.
i have a Netgear WG111v2 so i had it installed. i tried the iwi driver and it showed up as ethernet so i started the uti and it works fine :Dim on my hackintosh now
10.6.5 QE/CI WIFI/Webcam etc. JUST NO ETHERNET! lol

did you install the iopcifamily.kext ? it doesn´t work without that.


HOWEVER
in 10.6.5, the IWI driver works for my Intel 4965AGN card with the realtek wireless util.
i have a Netgear WG111v2 so i had it installed. i tried the iwi driver and it showed up as ethernet so i started the uti and it works fine :Dim on my hackintosh now
10.6.5 QE/CI WIFI/Webcam etc. JUST NO ETHERNET! lol

#73
peach-os

peach-os

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,286 posts
  • Location:lago di constanza
the 4965? can´t believe it´s working - please upload the extensions

you should always check if IONetworkingFamily.kext was updated - if there is a new one you have to replace the
AppleBCM5701.kext with a patched one inside the IONetworkingFamily.kext again to make it work.

I attached the actual files I use for 10.6.8 - everything working - also LAN
temperatures now dropped with current settings and speedstepping to 45°- 50° idle :rolleyes:

Attached File  Acer6292_10.6.8.zip   4.07MB   41 downloads

the patched Apple BCM working up to 10.6.8

Attached File  10.6.3.5787M.zip   180.79KB   31 downloads

#74
LachlanDMcCahon

LachlanDMcCahon

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:London, England
  • Interests:I like computers, cars and cooking.

the 4965? can´t believe it´s working - please upload the extensions

you should always check if IONetworkingFamily.kext was updated - if there is a new one you have to replace the
AppleBCM5701.kext with a patched one inside the IONetworkingFamily.kext again to make it work.

I attached the actual files I use for 10.6.8 - everything working - also LAN
temperatures now dropped with current settings and speedstepping to 45°- 50° idle :)

Attached File  Acer6292_10.6.8.zip   4.07MB   41 downloads

the patched Apple BCM working up to 10.6.8

Attached File  10.6.3.5787M.zip   180.79KB   31 downloads


I shall download those kexts. i have found my 6292 is most stable on 10.6.7 as it is now, i am typing from it.
The 4965 was working partially with a combination of the IWI4965.kext i found on kexts.com and use of the realtek wifi utility that i use for my usb wifi dongle. it can detect networks and connect to open wifi but will reject and WEP/WPA encrypted networks.

Also, i installed Lion 10.7.0 on my other partition and it works mostly. native ethernet and sound, my realtek wifi dongle doesnt work neither does the webcam or wifi. i can change resolution but have no graphics acceleration (QE/CI) been changing info.plist files all day and still no success.
i used the method posted for an acer aspire on the osx86 wiki.

Ill get those kexts now and keep you posted on Lion.

#75
LachlanDMcCahon

LachlanDMcCahon

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:London, England
  • Interests:I like computers, cars and cooking.
UPDATE:
Thanks for that BMC kext,, it did the trick. i now have ethernet and everything else except my 4965 no longer picks up wifi XD
One other thing. my Netgear wireless dongle now registers in Network Preferences as a Bluetooth PAN and conflicts with the actual bluetooth card.
Both bluetooth and the dongle now operate on the same thing in preferences and if i try to use both i get a conflict error.
any ideas?
Thanks again
Lachlan McCahon

Another UPDATE:
Just deleted every thing in networking, remade them all and it all lines up fine. Thanks, i now have a 98% working OSX notebook
:) :D
Ill keep trying to get the 4965 working again.

#76
peach-os

peach-os

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,286 posts
  • Location:lago di constanza
don´t waste your time with the 4965 - get a Broadcom 4311 for 10 - 15 bucks in the bay and replace it. it will be recognized as Airport and very easy to replace ( I did it in less than 3 minutes).

is bluetooth onboard on your 6292?

#77
LachlanDMcCahon

LachlanDMcCahon

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:London, England
  • Interests:I like computers, cars and cooking.

don´t waste your time with the 4965 - get a Broadcom 4311 for 10 - 15 bucks in the bay and replace it. it will be recognized as Airport and very easy to replace ( I did it in less than 3 minutes).

is bluetooth onboard on your 6292?

Yes, i have the Acer TM 6292 602G16Mn with an onboard bluetooth card. it worked out of the box and is recognised as an apple mobile bluetooth device.
it works very well with the magic mouse i bought the other day =D
the main issue for the broadcom cards with me is my wireless router ONLY operates on 5ghz dual band 802.11N so both those ABG cards are useless.
My ethernet broke again and nearly every second reboot i need to reinstall the PCI kext and the appleBMC kexts and that annoys me a lot. not sure why.
in other news. using the chameleon 2.0 pkg installer works to install lion with the XMove method. same compatability as 10.6.8 but i lost QE and CI.

also, in 10.6.8, my X3100 has started registering as a GMA 950, i am aware that those cards are essentially the same but its still annoying.

any tips for improving battery life, atm i get about 1.5 hours compared to 3+ hours under the windows 8 dev beta and win 7.

thanks for all the help thus far.

one last item, did you performa combo update to 10.6.8 or the apple 10.6.8 v 1.1 update?
i used a combo update and my 10.6.8 is very unstable. frequent kernel panics during boot or normal use and as mentioned earlier, constant reinstalls of the ethernet kext are required.

#78
peach-os

peach-os

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,286 posts
  • Location:lago di constanza
I don´t have any of these problems. with the last files I provided and a clean vanilla install no problems at all.
I did the updates step by step - no combo.
my graphics is still recognized as x3100. did you try my files, including the dsdt? are you using IOPCMCIAFamily.kext?

#79
LachlanDMcCahon

LachlanDMcCahon

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:London, England
  • Interests:I like computers, cars and cooking.

I don´t have any of these problems. with the last files I provided and a clean vanilla install no problems at all.
I did the updates step by step - no combo.
my graphics is still recognized as x3100. did you try my files, including the dsdt? are you using IOPCMCIAFamily.kext?


Yes, i am using a vanilla install, step by step 10.6.3->10.6.4->etcetera. and am using all the files provided by you (thanks for them btw =D)

Upgrading to 10.6.8 is of no real concern to me, i am content to dual boot 10.6.7 and Lion. seems stable enough.

I have tried every combination of patched IOPCIfamily, IOnetworking and BMC but i cannot get ethernet to work, any other tips i can try?

Thanks for all the sterling work so far =D

and the webcam works perfectly in photobooth and iChat without any extentions. just install CamTwist and set it to PIP. open your webcam software THEN open camtwist and voila! working webcam.

#80
LachlanDMcCahon

LachlanDMcCahon

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:London, England
  • Interests:I like computers, cars and cooking.
OK THEN!
Have you installed and tried iAtkos L1 yet?
i am downloading it now but was wondering if you have had any success with it.
when i get it i shall be utilising a USB installer with chameleon 2.
if you have, can you tell me what install options you used.
If you have not, i shall try various install options and inform you of my successes.
I hope i have the hardware support i get with snow leo, but anyway, here goes!
:) :angry2: :angry2: :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy