Jump to content

HP 311 & NetbookBootMaker / NetbookInstaller


  • Please log in to reply
80 replies to this topic

#1
mattkime

mattkime

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
I'm trying to get my HP 311 to work with 10.6 - 10.6.3 using the NetbookBootMaker and NetbookInstaller.

Here are some suggested directions - http://docs.google.c...1...jN2Zt&hl=en

My result -

1) The SL installer doesn't recognize the trackpad and therefore requires the use of an external mouse. Otherwise it works fine.

2) After running the NBI, the screen resolution was stuck at 1024x768. (didn't use the correct driver??)

3) Running the 10.6.3 combo updater resulted in a flickering screen on reboot.

Do you have any advice on how to salvage the install? Any advice on how to perform the install successfully?

---

2nd attempt -

I found that step 8 in your process wasn't necessary - the machine booted to the new install without being directed toward it.

Steps 10-12 - Running NBI are what lowers the screen res.

Sleep doesn't work.

Didn't upgrade any further. I've tried it a few times and has always resulted in a flickering screen.

#2
mosslack

mosslack

    InsanelyMac Legend

  • Donators
  • 881 posts
  • Gender:Male
  • Location:Mid-south Central Indiana
Okay, I'm curious if you got the NBBM to work? Originally I used the NBBM from the Asus 1201N project as I already had it available. When I use the 0.8.4 RC1 version of NBBM, it fails to boot at all. Did you have to do anything special to get it to work?

EDIT: I must of been using a flash drive with some residue hidden files as I tried another one and it works fine now. Am presently installing SL. The trackpad does not work so I'm using a mouse.

If you want to try something else, try using this version of NBBM to install SL:

http://redirectingat...okBootMaker.zip

This is the one from the Asus 1201N which I used the first time. Trackpad works fine with it.

#3
mattkime

mattkime

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
My actions were very basic. I clone SL to a USB drive and then ran NBBM on it. Install OS X. Nothing more. Using the standard version of NBBM 0.8.4RC1.

What process did you use?

#4
mosslack

mosslack

    InsanelyMac Legend

  • Donators
  • 881 posts
  • Gender:Male
  • Location:Mid-south Central Indiana
As outlined above, apparently my flash drive had some residue hidden files so I used another one and am now installing SL on the hard drive. Almost finished, I wanted a system which was mostly identical to yours for better troubleshooting. Will let you know when I get it installed.

EDIT: I rearranged the steps a bit and have the DSDT file installed just after you remove NVEnabler.kext. This makes a big difference in how it comes up after the initial reboot after installing NBI. I got a KP the first time but used verbose and it booted fine the second time. It came up with full resolutions and QE/CI working. I am now installing the 10.6.3 update. Hopefully it will come back up after the reboot just fine.

EDIT2: I was afraid of that. The problem seems to be removing NVEnabler to soon. Apparently when NBI runs after the 10.6.3 update, it reinstalls NVEnabler, which causes the flashing. Remove it again and run UpdateExtra will cure the problem for you. I think we need to address this issue to meklort and see about a special routine for the Mini 311.

#5
mosslack

mosslack

    InsanelyMac Legend

  • Donators
  • 881 posts
  • Gender:Male
  • Location:Mid-south Central Indiana
Well, I thought I had it figured out, but now it won't boot at all. The error is No HPETs available so I'm not really sure how to proceed now. I may attempt a boot with the flash drive to see what I get, but it looks like this may be a complete bust.

EDIT: Sometimes I hate Hackintoshes. I had just given up on this thing booting again when I tried it one more time with no verbose. Booted just fine. Sound works, wifi, but sleep appears to be a problem now. I only tested by closing the lid, but it does not come back out of sleep once it goes in it appears. I'm getting rather tired of playing with it this evening, may save it for a rainy day.

#6
mattkime

mattkime

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
yeah, i understand the frustration.

any idea what would cause sleep to fail?

would be nice if i could solve that part since you've pushed it this far.

unfortunately I'd need to find a forum where there are plenty of people with the time to do a lot of explaining.

#7
phubai

phubai

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

Well, I thought I had it figured out, but now it won't boot at all. The error is No HPETs available so I'm not really sure how to proceed now. I may attempt a boot with the flash drive to see what I get, but it looks like this may be a complete bust.

EDIT: Sometimes I hate Hackintoshes. I had just given up on this thing booting again when I tried it one more time with no verbose. Booted just fine. Sound works, wifi, but sleep appears to be a problem now. I only tested by closing the lid, but it does not come back out of sleep once it goes in it appears. I'm getting rather tired of playing with it this evening, may save it for a rainy day.


Well, selfishly, I hope you've decided to give it another go..I cancelled my 1201n and have a 311 which is supposed to be here tomorrow. Is there anything you'd like me to try differently? I plan on starting this tomorrow evening after work. I had the latest NBI/NBB but would be willing to try the previous one you've linked above if you think it might give different results.

pb

#8
mosslack

mosslack

    InsanelyMac Legend

  • Donators
  • 881 posts
  • Gender:Male
  • Location:Mid-south Central Indiana

yeah, i understand the frustration.

any idea what would cause sleep to fail?

would be nice if i could solve that part since you've pushed it this far.

unfortunately I'd need to find a forum where there are plenty of people with the time to do a lot of explaining.


Well, selfishly, I hope you've decided to give it another go..I cancelled my 1201n and have a 311 which is supposed to be here tomorrow. Is there anything you'd like me to try differently? I plan on starting this tomorrow evening after work. I had the latest NBI/NBB but would be willing to try the previous one you've linked above if you think it might give different results.

pb


You guys should know that I contacted meklort and told him about the guide I had made to install via NBBM/NBI. His commets are listed below:

Just some changes for those instructions.
Skip step 8 and 10, unless if you absolutely cannot boot without them (the bootloader is installed before you reboot the the first time. basically NBI is run already for you). If you do boot using the flash drive and apply an update, not all files will get updated correctly.

Also, don't use KextUtility. Instead, you can pot VoodooHDA.kext inside of /Extra/AdditionalExtensions. Iy also shouldn't need to remove AppleHDA, but I'm not certain about that. Once you install *any* kext, even if you use KextUtilty (which you shouldn't'), run UpdateExtra. I should be able to make NBI detect if Extra or /S/L/E changed, and then run at bootup, but this is safer either way.

I'll remove NVEnabler in the future.

Evan


I plan to try this as soon as I have some free time, not sure I'll get it done this evening though.

Here is the link to the guide I told him about:

http://docs.google.c...1...jN2Zt&hl=en

If you guys want to give it a go feel free.

EDIT: I am currently trying meklort's suggestions on a new install. Will let you know how it turns out. I have updated the guide to reflect his instructions.

#9
phubai

phubai

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
Excellent! I'm anxious to hear how it went. I just checked with Amazon, and they haven't even shipped the mini 311, so I have my doubts about receiving it by 4/21. I'm not in any hurry, beyond wanting to try this out. I ordered the Dell 1510 through Amazon and it ended up coming directly from Dell and they sent me two of them and only charged for one. I tried to do a return to give them one back, but it kept complaining about my order number being incorrect or no record of, so I may have to keep the 1201n arriving tomorrow, and which I'm supposed to return, so that I have a place to put the extra 1510! lol

#10
mosslack

mosslack

    InsanelyMac Legend

  • Donators
  • 881 posts
  • Gender:Male
  • Location:Mid-south Central Indiana
Not going so well. Everything is fine up until the 10.6.3 update is install, then when it comes back up with the screen flashing I can't get it to stop. Closing the lid doesn't work as it won't wake back up. I even tried booting via a USB hard drive with my backup and removing the NVEnabler.kext from the internal hard drive, but even with that it still flashes. More work to be done it appears.

At least with the 1201N coming, you can look it over to be sure. Heck, I have 3 netbooks and I use them all!

EDIT: I have sent another message to meklort in hopes this can be fixed. I think removing the NVEnabler.kext from the NBI might work if I could figure out how to do that. May give it a shot tomorrow if meklort has no more ideas.

#11
phubai

phubai

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
Well, thanks for trying it. I was hopeful of course and I still think you're close. I'm going to do some searching on the blinking screen issue to see what I can find that may help. Once I get the mini, if you want me to try something different or in parallel, I'll be glad to.

Yeah, the 1201n will make my 3rd if I keep it. I have a Toshiba 305n in addition to the mini and 1201n on the way and just might have to keep it!

pb

#12
mattkime

mattkime

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
I see the NVEnabler.kext here -

NetbookInstaller 0.8.4 RC1.app/Contents/Resources/SupportFiles/machine/General/Extensions

do i simply need to remove it and rerun the app on my SL installer USB drive? Or can I remove it from the USB drive directly?

poking around inside the app actually made a lot of sense. might want to talk to him about it so we can make mods and try them without bugging him to modify it.

#13
mosslack

mosslack

    InsanelyMac Legend

  • Donators
  • 881 posts
  • Gender:Male
  • Location:Mid-south Central Indiana

I see the NVEnabler.kext here -

NetbookInstaller 0.8.4 RC1.app/Contents/Resources/SupportFiles/machine/General/Extensions

do i simply need to remove it and rerun the app on my SL installer USB drive? Or can I remove it from the USB drive directly?

poking around inside the app actually made a lot of sense. might want to talk to him about it so we can make mods and try them without bugging him to modify it.


Yeah, I haven't had time to do that, but I believe that is where he is headed to remove it completely. The problem with removing it prior to running NBI is that it will just get reinstalled when NBI runs after the update. That was my next step to remove it from the NBBM/NBI on the flash drive. If you try that, let us know how it works.

Well, thanks for trying it. I was hopeful of course and I still think you're close. I'm going to do some searching on the blinking screen issue to see what I can find that may help. Once I get the mini, if you want me to try something different or in parallel, I'll be glad to.

Yeah, the 1201n will make my 3rd if I keep it. I have a Toshiba 305n in addition to the mini and 1201n on the way and just might have to keep it!

pb


Have you tried to Hack the Toshiba? I always wanted to try one, but after my experience trying to Hack my laptop I gave up on the idea.

I think what I am gonna do is to repeat the install up to just before the 10.6.3 update and clone it. That way I can experiment a bit easier without having to reinstall from scratch each time. I may even give 10.6.2 a try to see just how well it does or doesn't work. Jump in anywhere when you get your new toy.

#14
mosslack

mosslack

    InsanelyMac Legend

  • Donators
  • 881 posts
  • Gender:Male
  • Location:Mid-south Central Indiana
Okay, I have a new install following the guide I have revised up to step 12. At this point, the system is stable and sound it working with VoodooHDA installed as meklort advised to do. I am presently cloning the install to a USB hard drive and will then continue my experiments, hopefully I can figure out the correct procedure to get this working. I may try to remove the NVEnabler.kext from the NBI app to see if that keeps it from being reinstalled after the update. I may also try 10.6.2 to see if that will work. Will report on my progress when I have something to report.

EDIT: Experiment #1 failed. I removed the NVEnabler.kext from the NBI app and then did the 10.6.3 update. When the system restarted after installing the update, the NBI icon appeared and remained forever. I finally shut it down after about 15-20 minutes. I then tried to boot verbose and it doesn't really go very far before it just stops. No panic, just doesn't go any further. I'm restoring the install back to the hard drive in preparation for experiment #2. This will be installing 10.6.2 instead with no removal of NVEnabler.kext.

EDIT 2: Some good news, the 10.6.2 update works just fine, even with NVEnabler.kext in place. I have not checked sleep yet, but sound and wifi both work well.

#15
mattkime

mattkime

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
yeah, i knew 10.6.2 worked well.

It does sound like removing NVEnabler.kext is a necessary step forward. Otherwise you get the flickering screen.

hopefully meklort will have some suggestions for another round of trials.

#16
mosslack

mosslack

    InsanelyMac Legend

  • Donators
  • 881 posts
  • Gender:Male
  • Location:Mid-south Central Indiana
Didn't get to report this last night, but choosing sleep from the Apple menu causes the system to KP. So even though it appears to work fine, there are still problems. Have not heard back from meklort, but I suppose he has been pretty busy as of late what with moving and all.

How is the HF4/5 going? I should do an install of that on a USB so I can have a good working system to use if need be, but I have so many systems running that I suppose there is really no need.

#17
phubai

phubai

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

Have you tried to Hack the Toshiba? I always wanted to try one, but after my experience trying to Hack my laptop I gave up on the idea.

Jump in anywhere when you get your new toy.


I've not tried to Hack the Toshiba but was tempted. They've had some success with the 205 model, and I was tempted but needed a working netbook for my travels at the time. I might try it at some point tho.

I have my mini 311, installed a new HD and replaced the WLAN w the Dell 1510. I'm dl'g the 10.6.2 combo and already have the 10.6.3 so I'm trying to decide which way to go with it. The beauty of the HP is the HD access (and battery life compared to the 1201N) so I might just try the HF4/5 on another HD too. I do still need to flash my bios for the Dell 1510 though, right? I'd almost forgotten that.

What to do, what to do? lol

pb

#18
mosslack

mosslack

    InsanelyMac Legend

  • Donators
  • 881 posts
  • Gender:Male
  • Location:Mid-south Central Indiana
Yeah you need the de-whitelisted BIOS, mine is F.04, but I think the F.14 is available now. Good luck.

#19
mosslack

mosslack

    InsanelyMac Legend

  • Donators
  • 881 posts
  • Gender:Male
  • Location:Mid-south Central Indiana
I'm currently working on a solution to the 10.6.3 update problem which I believe will work. I'm in the final stages of testing and will post a revised guide once I have it worked out. The solution was so simple I could kick myself for not thinking of it sooner. Stay tuned for details.

EDIT: It works! I've updated the guide which is located here:

http://docs.google.c...1...jN2Zt&hl=en

Please test and advise if this works for you. Thanks!

#20
mattkime

mattkime

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
ack! you're such a tease!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy