Jump to content

[GUIDE]: The MacBookPro18 Project


  • Please log in to reply
498 replies to this topic

#461
19gc88

19gc88

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Italy

Use IORegisteryExplorer. Open it, File > Save As. Upload it here.
What is exactly the touchpad problem? Open up System Preferences > Trackpad and play with the settings.


Here it is.

Trackpad problem solved.

Ps. Really thank you for your efforts.

Attached Files



#462
JBraddock

JBraddock

    Ph.D (Can) in Human Rights

  • Members
  • PipPipPipPipPipPipPip
  • 549 posts
  • Location:UK

Here it is.

- Update your system to 10.6.7.
- If you are using Chameleon RC5, make these changes to boot.plist
- Go into you bios and make sure you have "Enable C6 States" set to Yes.
- After doing these, send me another IOREG dump.

Apart from the above points, finally, after doing these (Update to 10.6.7 etc), give one more shot to my DSDT file to see if it makes any difference. There have been many changes since Snow Leopard came out in terms of speed step, especially after 10.6.3. We need to make sure that Snow Leopard version is not the issue here.

P.S. Download 10.6.7 Combo Update from Apple. That way, you wouldn't have to run Software Update in the future.

#463
19gc88

19gc88

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Italy

- Upgrade your system to 10.6.7.
- If you are using Chameleon RC5, make these changes to smbios.plist
- Go into you bios and make sure you have Enable C6 States set to Yes.
- After doing these, send me another IOREG dump.

Apart from the above points, finally, after doing these (Update to 10.6.7 etc), give one more shot to my DSDT file to see if it makes any difference. There have been many changes since Snow Leopard came out in terms of speed step, especially after 10.6.3. We need to make sure that Snow Leopard version is not the issue here.


Thanks. I'll give a try.

#464
JBraddock

JBraddock

    Ph.D (Can) in Human Rights

  • Members
  • PipPipPipPipPipPipPip
  • 549 posts
  • Location:UK

Thanks. I'll give a try.

- If you are using Chameleon RC5, make these changes to smbios.plist

Sorry, those changes need to be made to boot.plist.

#465
19gc88

19gc88

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Italy

Sorry, those changes need to be made to boot.plist.


Ok. I try.

#466
19gc88

19gc88

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Italy
All right.
Your DSDT doesn't work, neither with 10.7.7.
I'm using the patched DSDT, gives me full QE/CI, shutdown-restart, bluetooth, keyboard-trackpad, sleep/wake, webcam, dvd.

One thing:
You said i had to modify plist. In com.apple.plist there's "EnableC6state", not "GenerateC6States". I changed it, but in the plist I downloaded there was "GenerateC6States", only "GeneratesPStates".
If you need, i can zip it and put it here.


Ps. I was forced to modify the DSDT (removing HDEF) to install VoodooHDA. Now it works perfectly.

Pps. I can no more boot with NawcomModCd.

#467
JBraddock

JBraddock

    Ph.D (Can) in Human Rights

  • Members
  • PipPipPipPipPipPipPip
  • 549 posts
  • Location:UK
Change EnableC6State to EnableC4State and also add the following.

<key>GenerateCStates</key>
<string>Yes</string>

You should have a stable machine now with Chameoleon RC5. There are a couple of fixes that I could add to your working DSDT but they are not urgent. We'll come to those later. Obviously, there is something different about your machine. Finally, make sure you have the latest bios for HDX, which is F32 or F34 depending on your model.

Next month I am planing to open a new thread on OS X Lion (Hopefully)

Enjoy.

#468
19gc88

19gc88

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Italy
The pc seems to work well.What fixes have you got for my DSDT?
The post about Lion is a good idea. I'll follow you there, if you need some tester.
ps. for the bios, I'll check my bios and let you know.

#469
JBraddock

JBraddock

    Ph.D (Can) in Human Rights

  • Members
  • PipPipPipPipPipPipPip
  • 549 posts
  • Location:UK

The pc seems to work well.What fixes have you got for my DSDT?
The post about Lion is a good idea. I'll follow you there, if you need some tester.
ps. for the bios, I'll check my bios and let you know.

SATA, Removing unused devices to reduce to size of the DSDT, thermal zone etc. But don't worry, we'll work on them later and most of them don't really affect the functionality.

If you made the changes to the boot.plist, please upload another IOREG dump so that I could have a look at it.

#470
19gc88

19gc88

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Italy
Ok. Tomorrow i'll give you the ioreg dump.

#471
JBraddock

JBraddock

    Ph.D (Can) in Human Rights

  • Members
  • PipPipPipPipPipPipPip
  • 549 posts
  • Location:UK
I updated to 10.6.8 and everything seems to work fine. As usual, for those using AppleHDA, you have to rollback AppleHDA to restore the sound.

I've created another AppleHDA (2.0.5) based on the kext of 10.6.8, which is also for Lion. I might post it later.

Only thing I noticed is that spinning ball during the boot seems to get disappeared so don't panic and wait. I think it is something to the with AnVaL. Because I don't have this problem on my desktop, which uses Chameleon RC5.
Anyway, it is just a cosmetic.

Enjoy,

#472
disarmed

disarmed

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

I updated to 10.6.8 and everything seems to work fine. As usual, for those using AppleHDA, you have to rollback AppleHDA to restore the sound.

I've created another AppleHDA (2.0.5) based on the kext of 10.6.8, which is also for Lion. I might post it later.

Only thing I noticed is that spinning ball during the boot seems to get disappeared so don't panic and wait. I think it is something to the with AnVaL. Because I don't have this problem on my desktop, which uses Chameleon RC5.
Anyway, it is just a cosmetic.

Enjoy,


I also noticed the spinning ball is gone but I haven't installed AnVal yet. I just came from a fresh install then applied 10.6.8 combo update and #####.

#473
JBraddock

JBraddock

    Ph.D (Can) in Human Rights

  • Members
  • PipPipPipPipPipPipPip
  • 549 posts
  • Location:UK
I noticed that there are quite a people suffering PCI Begin error. Thankfully, HDX boots fine despite spinning wheel thing.

Tomorrow I'll install Lion DP4 and see what happens.

#474
JBraddock

JBraddock

    Ph.D (Can) in Human Rights

  • Members
  • PipPipPipPipPipPipPip
  • 549 posts
  • Location:UK
Attached File  Screen_Shot_2011_06_27_at_17.40.37.png   69.31KB   24 downloads

- Installation is straight forward.
- GPU, keyboard, trackpad, bluetooth, speed step, restart etc are all working. PCI Begin problem is here but OS X boots fine.
- HP Atheros 9280 works great and supports AirDrop.
- Battery kext is not working as previously reported.
- I was able to patch AppleHDA of Lion for our chipset. It works great. Still no audio after sleep.
- Animations in Launchpad and Fullscreen apps are not that smooth.
- I couldn't figure out how kext cache is working so I have to boot with -f.
- Safari is buggy. I've already witnessed a few crucial bugs.
- Since I am running from a usb HDD, it is hard to tell how good the performance is but Lion is definitely not ready for prime time. I expect at least two more releases before Lion being shipped.

I'll open a new thread soon.

#475
disarmed

disarmed

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
I have some problem when I played video files with SplayerX. When at fullscreen & max window, videos lag. During normal windowed playback, they're ok.

Before I installed the 10.6.8 combo update, kexts & AnVal (as in JBraddock's post in page 18), SplayerX is running smoothly at fullscreen & window mode.

I attached my IOReg dump if anybody wants to check.

Thanks!

Attached Files



#476
thanh hoang

thanh hoang

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
Installed Lion GM with full support:
Wifi : Broadcom 4311=> replace with IO80211.kext with 10.6.7
Battery: use Of JBraddock work good but System info not show
Sound: Legacy+dsdt+apple HDA of JBraddock
PCI config: replace 2 file 0f 10.6.7\
Speedtep: work good, p8700=> geek bench 3940
Sleep: work ok but sound failed
Thanks JBraddock hope u open new thread for Lion.
Posted Image
Posted Image
Posted Image

#477
JBraddock

JBraddock

    Ph.D (Can) in Human Rights

  • Members
  • PipPipPipPipPipPipPip
  • 549 posts
  • Location:UK

I have some problem when I played video files with SplayerX. When at fullscreen & max window, videos lag. During normal windowed playback, they're ok.
Before I installed the 10.6.8 combo update, kexts & AnVal (as in JBraddock's post in page 18), SplayerX is running smoothly at fullscreen & window mode.

I attached my IOReg dump if anybody wants to check.
Thanks!

I don't know if the reason is that you don't have C-States activated.
Please take a look at your boot.plist to make sure that you have the necessary keys in it.
As explained above, if you are using Chameleon RC5 you need to change a few lines to get C-States working.

On 10.6.8, type:
ioreg -lw0 | grep AICPMVers
It should return "AICPMVers" = 19136773, which means that C States is activated.

Installed Lion GM with full support:
Wifi : Broadcom 4311=> replace with IO80211.kext with 10.6.7
Battery: use Of JBraddock work good but System info not show
Sound: Legacy+dsdt+apple HDA of JBraddock
PCI config: replace 2 file 0f 10.6.7\
Speedtep: work good, p8700=> geek bench 3940
Sleep: work ok but sound failed
Thanks JBraddock hope u open new thread for Lion.

- Did you have to replace those two kexts to get Lion working? When I tried DP4, it was working fine despite its getting stuck at PCI Begin.
- You don't have Serial Number injected, which was in the smbios.plist I'd shared.
- I see that you are trying to create mkext for Lion but based on my experience in DP4, it doesn't work properly. When I used that, my wifi and bluetooth got broken.

I'll open a new thread but I am waiting for the final release as it might be out in a week or two. BTW, how is the graphic performance on Lion. Honestly, I really didn't like it on DP4. Hope they improved it.

#478
thanh hoang

thanh hoang

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
graphic performance on Lion=> I have a same problem, i think cause power management (battery), when battery ok, it good, replace 2 kexts for me boot normal, hdx 16 is good

#479
disarmed

disarmed

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
I tried to install Lion GM but got stuck with the spinning wheel.

To those who successfully installed Lion GM, how long did it take for the spinning wheel to stay on the screen before it boots and start installation process?

#480
nkrazor

nkrazor

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Bulgaria/UK

I tried to install Lion GM but got stuck with the spinning wheel.

To those who successfully installed Lion GM, how long did it take for the spinning wheel to stay on the screen before it boots and start installation process?



No more than 1-2 minutes. Try and use this guide if you want, it worked for me.

http://www.insanelym...howtopic=260594





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy