Jump to content

Help! FW Update : iTunes & FW Version Issues?


  • Please log in to reply
No replies to this topic

#1
crashnburn_in

crashnburn_in

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
Help! FW Update : iTunes & FW Version Issues?

This chart shows the Release Sequence with dates and version numbers for iTunes and iPhone Firmwares:

Posted Image
Picasa Web Albums - Abhi

Typical Update Process involves the following steps-

• SyncBackup of iPhone FW A by iTunes X
• JB/Unlock by some Tool
• Restore FW B by iTunes X
• SyncRestore iPhone FW B by iTunes X

Now here there is a huge gap between what I currently have & where I need to go.

iTunes: 8.2
iPhone 2G: 2.2

Now, I know 8.2 can handle Backups for 2.2.

My fear is there might be some issues / incompatibility between iTunes versions / iPhone FW that are too far apart.
Now, I am wondering if it might mess up my
• iPhone
• Backups
• Cracked IPAs
• Cydia Apps
• Any other Settings / Data

I am wondering which of the following is what I need to do:

1) I update to iTunes 9.0.3 / 9.1 assuming and hoping it safely works with 2G 2.2
(I am wondering if that would be with / without cracked apps).
Anyone experimented with that?

Update iTunes X > Y
• SyncBackup of iPhone FW A by iTunes Y
• JB/Unlock by some Tool
• Restore FW B by iTunes Y
• Sync Restore iPhone FW B by iTunes Y

2) I update to iTunes 9.0.3 / 9.1 in the middle assuming & hoping it does no mess the SyncBackups & SyncRestore Data i.e. SyncDATA is handled / managed across versions
(I am wondering if that would be with / without cracked apps)

• SyncBackup of iPhone FW A by iTunes X
• JB/Unlock by some Tool
Update iTunes X > Y
• Restore FW B by iTunes Y
• Sync Restore iPhone FW B by iTunes Y

OR

3) Do I need to do some R&D to determine which special sequence involving multiple versions of iTunes works best? Especially given the order of / releases and Release dates of iPhone FW & iTunes.

ALSO:
Cracked Apps / .IPAs that are in iTunes & on iPhone… How do I ensure they survive when I go across from a:
2.2 FW: Mobile Substrate (Some pre-AppSync that allowed Cracke IPAs)
to
3.1.x FW: AppSync for Installd






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy