Jump to content

[Resolvido]Snow - Instalação


  • Please log in to reply
52 replies to this topic

#21
avcoura

avcoura

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male
Instalou e deu o mesmo erro que o amigo postou no tópico de falha...rsrsr...vou continuar o tutorial aqui..
Daqui a pouco volto...^^ Vlw!!


Nossa...garrei de novo...
extrai o arquivo do Charmeleon, mas no terminal dá "No such file or directory"

EDIT: Escrevi errado no terminal..malz..agora que eu vi aqui...

Bom...cheguei nessa parte aqui:

fdisk -e /dev/diskD
f P
write
y
exit

quando digito "f 6" (que é o número da partição do Snow) aparece invalid partition number..mas eu tenho certeza que é essa..pelo menos é o que está na lista...

EDIT 2: Descobri o problema...tipo o meu disco é assim.. disk0s6, mas a partição é 3...agora,será que fiz certo no terminal..no lugar do P coloquei 6 todas as vezes exceto no "f P"... vamo ver...qualquer coisa faço tudo de novo..

#22
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Você tem partição extendida?

Cole aqui o resultado do comando diskutil list.

#23
avcoura

avcoura

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male

Você tem partição extendida?

Cole aqui o resultado do comando diskutil list.


Até que deu certo entre aspas...na hora de selecionar a partição do Snow, deu Kernel Panic..vou reinstalar aqui..jajá volto com resultados..

#24
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Ao invés de reinstalar tudo, tira uma foto do kernel panic. Dependendo do problema não adianta reinstalar, basta aplicar um patch no DSDT ou instalar uma kext.

#25
avcoura

avcoura

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male

Ao invés de reinstalar tudo, tira uma foto do kernel panic. Dependendo do problema não adianta reinstalar, basta aplicar um patch no DSDT ou instalar uma kext.


Não sei..acho que cometi algum erro no esquema do Chameleon...já está acabando aqui..qualquer coisa mando o kernel panic...
Olha o diskutil
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *149.1 Gi disk0
1: Windows_NTFS 58.6 Gi disk0s1
2: Apple_HFS Leopard 20.0 Gi disk0s5
3: Apple_HFS Snow Leopard 40.0 Gi disk0s6
4: Windows_NTFS Dados 30.5 Gi disk0s7

#26
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
É que normalmente coincide o número no início da linha (coluna #) com o da partição (diskDsP).

No fdisk você tem que usar "f 3" mesmo.

Vou dormir daqui a pouco, se demorar continuamos amanhã.

#27
avcoura

avcoura

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male

É que normalmente coincide o número no início da linha (coluna #) com o da partição (diskDsP).

No fdisk você tem que usar "f 3" mesmo.

Vou dormir daqui a pouco, se demorar continuamos amanhã.


tipo..preciso fazer isso de novo??já reinstalou...

#28
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Se você apagou a partição antes de reinstalar (o que seria recomendável) precisa instalar o Chameleon denovo, sim. Acho que ativar a partição não precisa, ela ainda deve estar ativa. Digite "p" no fdisk para verificar, tem um * na partição ativa.
fdisk: 1> p
Disk: /dev/disk0	geometry: 60801/255/63 [976773168 sectors]
Offset: 0	Signature: 0xAA55
		 Starting	   Ending
 #: id  cyl  hd sec -  cyl  hd sec [	 start -	   size]
------------------------------------------------------------------------
 1: 07	0   1   1 - 1023 254  63 [		63 -  766991232] HPFS/QNX/AUX
 2: AF 1023 254  63 - 1023 254  63 [ 766991295 -  104888385] HFS+		
*3: AF 1023 254  63 - 1023 254  63 [ 871879680 -  104888385] HFS+		
 4: 00	0   0   0 -	0   0   0 [		 0 -		  0] unused


#29
avcoura

avcoura

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male
Acho que descobri meu erro...eu instalei as kext na pasta extensions do próprio mac e não na extra...hum..agora vamo ver se entra... Toda kext que eu quiser instalar tem que ser na pasta extensions dentro da pasta extra?

Deu kernel Panic...os 4 idiomas e umas letras no fundo..se quiser amanhã arrumo um jeito de mandar a foto..
Desculpe qualquer incomodo ai... :(

#30
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Na verdade tanto faz, só que se instalar na pasta Extensions do Mac tem que reparar as permissões e reconstruir o cache, ou fazer o boot com "-f" (ignorar cache). Na pasta Extra não tem esse problema, mas algumas kexts só funcionam na pasta do Mac mesmo, acho que a VoodooPS2 é uma delas (até funciona na Extra, mas não 100%). As kexts citadas no tópico podem ser instaladas na Extra.

Sobre o panic, faça o boot no modo verbose para ver as mensagens de erro, então tire a foto. A tela dizendo para desligar o computador eu conheço bem :(

Continuamos amanhã.

#31
avcoura

avcoura

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male
isso inclui..rede,wirelles,som... tudo tem que ser colocado na pasta do mac...?? pode usar o kext helper??

Ok...amanhã coloco a foto..

Obrigado pela paciência...^^Até amanhã!!

#32
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Sim, estas que você citou normalmente precisam ser instaladas na pasta de extensions do Mac.

Pode usar o Kext Helper, mas recomendo simplesmente arrastar para a pasta e depois rodar o Kext Utility, ele já atualiza o cache.
http://www.insanelym...howtopic=140647

Mas isso depois de já estar com o Snow rodando.

#33
avcoura

avcoura

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male
Okay então Old..
Muito orbrigado...amanhã coloco a foto do kernel panic, terei que achar pilha pra minha máquina aqui..rsrsrs...
Mais uma vez..obrigado pela paciência...

Abraço e até amanhã!!

#34
avcoura

avcoura

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male
Bom..vamos então...
A primeira imagem é a do Charmeleon, a segunda é quando clico na partição Snow Leopard e a terceira o Kernel Panic..

Qualquer coisa tiro outra...

Attached Files



#35
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Você está usando o modo verbose? (seta para baixo ao selecionar a partição do Snow no Chameleon)

Tá meio fora de foco a imagem, e o que interessa está escondido.

Mas uma coisa tá estranha, é impressão minha ou aparece kernel 10.1.1?

#36
avcoura

avcoura

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male

Você está usando o modo verbose? (seta para baixo ao selecionar a partição do Snow no Chameleon)

Tá meio fora de foco a imagem, e o que interessa está escondido.

Mas uma coisa tá estranha, é impressão minha ou aparece kernel 10.1.1?


Estou usando modo verbose na última foto sim..mas apertando f8 e depois -v..Mas vou tirar outra foto..quanto ao kernel acho que aparece isso mesmo..

#37
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Não vou te dizer que é a causa do problema, mas para ter certeza você teria que reinstalar, modificando o OSInstall.mpkg original do seu DVD. O arquivo que eu enviei é de um DVD que tem a kernel 10.0.0, e o seu tem a 10.1.1 (nunca tinha visto), então pode ter outras diferenças.

Você pode copiar o arquivo do DVD original com esse comando (desmonte a imagem modificada e insira o DVD)
cp /Volumes/Mac\ OS\ X\ Install\ DVD/System/Installation/Packages/OSInstall.mpkg ~/Desktop

Você instalou o Chameleon RC4, né?

O seu CPU roda kernel vanilla no Leopard? Caso contrário, vai precisar de kernel modificada também no Snow.

#38
avcoura

avcoura

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male
Ahh..minha câmera é muito ruim..tirei uma outra aqui...vê se dá pra enxergar...

Acho que roda sim...tem como verificar se roda kernel vanilla??

bom..não sei..instalei o do Leopard que é o RC2 do dvd do iatkos e fiz aquele do tutorial...

Attached Files



#39
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Mas instalou o RC4 conforme o tutorial? Com o RC2 o Snow não sobe, tem que ser no mínimo o RC3.

Rode esse comando no terminal, tem que aparecer um * ao lado da partição do Snow
sudo fdisk /dev/disk0

Qual é o CPU?

#40
avcoura

avcoura

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male

Mas instalou o RC4 conforme o tutorial? Com o RC2 o Snow não sobe, tem que ser no mínimo o RC3.

Rode esse comando no terminal, tem que aparecer um * ao lado da partição do Snow

sudo fdisk /dev/disk0

Qual é o CPU?


rodei o comando..verifica na imagem anexa..

CPU é tipo, Intel Dual Core?? no everest aparece: Intel® Dual CPU T2390 @ 1.86 GHz

Edit: a imagem ta errada.. ta com o * na partição 1...
No seu tutorial..tá instalar Charmeleon 2.0

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy