Jump to content

Arrrgh.... Still waiting for root device


  • Please log in to reply
48 replies to this topic

#1
Carlos Paixao

Carlos Paixao

    Getting Oracle

  • Members
  • PipPipPipPip
  • 191 posts
  • Gender:Male
  • Location:Sete Lagoas, MG - BRASIL
Amigos do forum,
eu estou tentando instalar o SL 10.6.2 Retail de tudo quanto eh jeito mas nao saio do lugar por causa do tal do 'Still waiting for root device' e de quebra, ainda mostra a msg ''ApplePS2Controller: Timed out on mouse input stream. ApplePS2Mouse: probe failed'', o que isso quer dizer?

Ta ai os detalhes:

Bootloader: boot123 (bootslv3-wifi-noextra)
GA-p35-ds3 rev. 2.0
hd 2x western digital 160Gb sataII (raid0) + hd western digital caviar blue 500GB (normal)
processador E6750
OS: Windows 7 64 bit
config. bios:

AHCI mode ENABLED
HPET ENABLED 64 bit
S.M.A.R.T ENABLED

Procedimento:

Depois de configurar a bios como descrito acima, reinicio o pc com o bootloader dentro.

Quando abre a tela do boot123, troco o cd pelo dvd SL 10.6.2 Retail e teclo f5

booto com a opcao "-v" para acompanhar o processo, mas sempre trava na msg de erro que citei neste topico.


Ja nao sei o que fazer, pois tentei tudo que eu imaginava dar certo... sera que tem um cd bootloader especifico para a GA-P35-DS3????

Alias, a minha gravadora eh IDE... sera que tem como instalar pelo USB?

Conto com a ajuda de vcs, amigos!

Muito obrigado....

#2
OuVerRos

OuVerRos

    InsanelyMac Legend

  • Local Moderators
  • 1,288 posts
  • Gender:Male
  • Location:Garopaba - SC
Seus HDs tb são IDE?
Tem como vc deixar somente um HD e testar a instalação?
Vc pode desconectar o HD que tem o windows e fazer esse teste pra tentar instalar o Snow?

Meu horario de almoço chegou ao fim ... =[

Leia aqui

#3
Carlos Paixao

Carlos Paixao

    Getting Oracle

  • Members
  • PipPipPipPip
  • 191 posts
  • Gender:Male
  • Location:Sete Lagoas, MG - BRASIL

Seus HDs tb são IDE?
Tem como vc deixar somente um HD e testar a instalação?
Vc pode desconectar o HD que tem o windows e fazer esse teste pra tentar instalar o Snow?

Meu horario de almoço chegou ao fim ... =[

Leia aqui



E ai, cara!

Aqui, todos meus HDs sao sata II, sendo que esta instalado o W7 em dois deles (RAID0) e o que sobrou eu utilizo apenas para backup, (normal, fora do esquema Raid0).

Eu estava pensando mesmo em desconectar os hds em RAID para tentar o boot apenas para o SL. Acontece este ultimo hd (o de backup que falei) tem 100gb nao particionados, sera que da pra instalar sem ter que formata-lo primeiro, utilizando este espaco nao particionado, ou terei que zerar o HD?

Valeu, amigo...

#4
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Provavelmente o boot CD que você está usando não tem kext para a sua controladora IDE, ou a kext não tem o device ID da sua controladora.

Sugestões:

1) Usar o Empire EFI
http://www.insanelym...howtopic=211526

2) Criar um boot CD e incluir a kext da controladora IDE, com o device ID no Info.plist
http://www.insanelym...howtopic=213183

3) A mais garantida, e que você mesmo sugeriu, instalar pelo USB. Você vai precisar de um Mac OS funcionando e um pen drive de pelo menos 8 GB. Basta usar o utilitário de disco para restaurar o DVD para o pen drive e usar o myHack (veja o tópico sobre o Empire EFI) para instalar o boot no pen drive.

Sobre a mensagem do ApplePS2Controller, você está usando teclado ou mouse PS/2? Caso contrário é normal aparecer esta mensagem.

#5
Carlos Paixao

Carlos Paixao

    Getting Oracle

  • Members
  • PipPipPipPip
  • 191 posts
  • Gender:Male
  • Location:Sete Lagoas, MG - BRASIL

Provavelmente o boot CD que você está usando não tem kext para a sua controladora IDE, ou a kext não tem o device ID da sua controladora.

Sugestões:

1) Usar o Empire EFI
http://www.insanelym...howtopic=211526

2) Criar um boot CD e incluir a kext da controladora IDE, com o device ID no Info.plist
http://www.insanelym...howtopic=213183

3) A mais garantida, e que você mesmo sugeriu, instalar pelo USB. Você vai precisar de um Mac OS funcionando e um pen drive de pelo menos 8 GB. Basta usar o utilitário de disco para restaurar o DVD para o pen drive e usar o myHack (veja o tópico sobre o Empire EFI) para instalar o boot no pen drive.

Sobre a mensagem do ApplePS2Controller, você está usando teclado ou mouse PS/2? Caso contrário é normal aparecer esta mensagem.




Meu teclado eh ps/2 (mas eu tenho adaptador usb, se for preciso). Meu mouse eh usb mesmo.

Esse bootmaker roda no win7? Por que se nao, nao tem como! E eu tb nao conheco nenhuma alma viva aqui perto de casa que tenha OSX instalado...

Mas obrigado assim mesmo! Quando chegar em casa vou testar o empire EFI tb.

#6
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Não, o BootCDMaker só roda no Mac OS X.

Tenta com o Empire EFI, é de longe o melhor e mais completo boot CD que eu já testei.

Se conseguir um drive de DVD SATA emprestado, também deve resolver o seu problema.

#7
Carlos Paixao

Carlos Paixao

    Getting Oracle

  • Members
  • PipPipPipPip
  • 191 posts
  • Gender:Male
  • Location:Sete Lagoas, MG - BRASIL
Valeu, meu caro. Vou tentar o EFI.

#8
Carlos Paixao

Carlos Paixao

    Getting Oracle

  • Members
  • PipPipPipPip
  • 191 posts
  • Gender:Male
  • Location:Sete Lagoas, MG - BRASIL

Provavelmente o boot CD que você está usando não tem kext para a sua controladora IDE, ou a kext não tem o device ID da sua controladora.

Sugestões:

1) Usar o Empire EFI
http://www.insanelym...howtopic=211526

2) Criar um boot CD e incluir a kext da controladora IDE, com o device ID no Info.plist
http://www.insanelym...howtopic=213183

3) A mais garantida, e que você mesmo sugeriu, instalar pelo USB. Você vai precisar de um Mac OS funcionando e um pen drive de pelo menos 8 GB. Basta usar o utilitário de disco para restaurar o DVD para o pen drive e usar o myHack (veja o tópico sobre o Empire EFI) para instalar o boot no pen drive.

Sobre a mensagem do ApplePS2Controller, você está usando teclado ou mouse PS/2? Caso contrário é normal aparecer esta mensagem.



Amigo,

estou baixando agora o empire efi pq o link que eu baixei anteriormente nao era iso...

Mas, eu tentei gravar a imagem do bootloader para p35, no entanto, ao iniciar pelo cd apareceu a msg - "chksum iso failed. Sorry, the image disk is corrupted" (ou algo parecido com isso...). Entao eu fui tentando com o boot123 enquanto o efi nao baixava... dai eu bootei com o seguinte comando: plataform=X86PC -v -f -x

quando fiz isso o boot parecia que ia funcionar direitinho, ficou carrengando uma serie de drivers durante uns 7-8 minutos, quanto parou e voltou para tela preta, aparemtemente quando ia carregar o smbios...

Algum parecer por parte de vcs??

#9
Carlos Paixao

Carlos Paixao

    Getting Oracle

  • Members
  • PipPipPipPip
  • 191 posts
  • Gender:Male
  • Location:Sete Lagoas, MG - BRASIL

Valeu, meu caro. Vou tentar o EFI.



Anem... aki, nada deu certo ate agora. Tentei dar boot com o Empire EFI, mas deu "memory alocation error". Tentei com a versao Legacy, e o cd de boot nem carregou...aparecendo a msg "Image chksum error. Sorry... the iso image is corrupted."

Entao eu fui tentando com o boot123 dai eu bootei com o seguinte comando: plataform=X86PC -v -f -x

quando fiz isso o boot parecia que ia funcionar direitinho, ficou carrengando uma serie de drivers durante uns 7-8 minutos, quanto parou e voltou para tela preta, aparemtemente quando ia carregar o smbios...

Algum parecer por parte de vcs?? OuVerRos?

#10
OuVerRos

OuVerRos

    InsanelyMac Legend

  • Local Moderators
  • 1,288 posts
  • Gender:Male
  • Location:Garopaba - SC
Minha sugestão é:

Desconectar tds os HDs e deixar somente o que vai ser instalado o Mac.
Ir na Bios e fazer um reset Load Default pra ficar com parametros de fabrica e ajustar somente o AHCI.
Deixar o HD como First Boot e o resto em Disable e no restart com o DVD do Empire no drive vc usa a tecla F12 pra escolhe o DVD como boot (na minha placa é F12 na sua pode ser F10/F11 ou outra)
Se não rolar com Empire e nem com o Boot 132 dai vc talvez precise usar uma distro iAtkos ou iDeneb e instalar o Leopard e fazer um Cd Boot especifico pro seu hardware e depois fazer a instalação do Snow.

PS: Só uma pergunta ... antes tarde do que nunca. Vc esta usando mesmo um DVD do SL retail certo? ... Cd Boot só vai funcionar se o DVD for Retail. Se o seu SL ai é outro não precisa de cd boot.

#11
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Para estar tendo estes erros de "checksum" e "image corrupted" eu imagino que você esteja com problema no drive de DVD ou nas mídias.

A demora de 7-8 minutos lendo os drivers é por conta do parâmetro "-f" (ignorar caches), ao invés de ler o arquivo de cache (Extensions.mkext) ele lê cada kext individualmente, mas isto não faz diferença, acaba parando no mesmo lugar que se não usasse o "-f", só demora mais para chegar lá.

#12
Carlos Paixao

Carlos Paixao

    Getting Oracle

  • Members
  • PipPipPipPip
  • 191 posts
  • Gender:Male
  • Location:Sete Lagoas, MG - BRASIL

Minha sugestão é:

Desconectar tds os HDs e deixar somente o que vai ser instalado o Mac.
Ir na Bios e fazer um reset Load Default pra ficar com parametros de fabrica e ajustar somente o AHCI.
Deixar o HD como First Boot e o resto em Disable e no restart com o DVD do Empire no drive vc usa a tecla F12 pra escolhe o DVD como boot (na minha placa é F12 na sua pode ser F10/F11 ou outra)
Se não rolar com Empire e nem com o Boot 132 dai vc talvez precise usar uma distro iAtkos ou iDeneb e instalar o Leopard e fazer um Cd Boot especifico pro seu hardware e depois fazer a instalação do Snow.

PS: Só uma pergunta ... antes tarde do que nunca. Vc esta usando mesmo um DVD do SL retail certo? ... Cd Boot só vai funcionar se o DVD for Retail. Se o seu SL ai é outro não precisa de cd boot.



Sim, Retail. Comprei original.

#13
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 11,137 posts
  • Gender:Male
  • Location:Rio de Janeiro
use snow by hazard

a sua placa eh uma das mais compativeis e eh a placa q eu uso

coloque em ahci lah em cima e ide na parte debaixo

depois de instalar tera de deletar a appletymcedriver


mount -uw /
rm -rf/system/library/extensions/appletymcedriver.kext
exit

isso no single user

-s

#14
Carlos Paixao

Carlos Paixao

    Getting Oracle

  • Members
  • PipPipPipPip
  • 191 posts
  • Gender:Male
  • Location:Sete Lagoas, MG - BRASIL

use snow by hazard

a sua placa eh uma das mais compativeis e eh a placa q eu uso

coloque em ahci lah em cima e ide na parte debaixo

depois de instalar tera de deletar a appletymcedriver


mount -uw /
rm -rf/system/library/extensions/appletymcedriver.kext
exit

isso no single user

-s


Cara,
nao entendi "coloque AHCI em cima e IDE debaixo". Seria para ativar o AHCI mode, e alterar o modo de acesso aos hds para IDE? Mas meus hds sao sataII.

Pode ser mais especifico?

Ja tentei o boot da maneira que OuVerRos e Oldnapalm me aconselharam tb, mas ate agora, sem sucesso.

Eu acho que tem um disco de boot que seria o ideal para mim, se chama p35xxx bootloader, mas acho que so funciona para quem tem Linux instalado...

Eu tb consegui uma Imagem USB na net do SL com uns arquivos de boot.

Vou tentando aqui e qualquer coisa eu posto pra vcs...

Valeu

#15
OuVerRos

OuVerRos

    InsanelyMac Legend

  • Local Moderators
  • 1,288 posts
  • Gender:Male
  • Location:Garopaba - SC
Carlos já que vc esta iniciando deveria instalar uma versão iAtkos ou iDeneb modificada numa partição desse HD. E depois com o cdbootmaker fazer um cd boot especifico pra sua configuração e dai fazer a instalação retail do snow.

As versões modificadas são mais faceis de instalar por já terem bootloader e drivers disponiveis pra marcação na customize.

Despois que vc estiver mais acostumado com o ambiente do Mac vc faz a instalação retail com o dvd original do snow na outra partição. Pode até ficar com os dois pois sempre que precisar ajustar algo no Snow vai precisar do Leopard, pois alguns ajustes é preciso ser feito no sistema do Mac.

#16
Carlos Paixao

Carlos Paixao

    Getting Oracle

  • Members
  • PipPipPipPip
  • 191 posts
  • Gender:Male
  • Location:Sete Lagoas, MG - BRASIL

Carlos já que vc esta iniciando deveria instalar uma versão iAtkos ou iDeneb modificada numa partição desse HD. E depois com o cdbootmaker fazer um cd boot especifico pra sua configuração e dai fazer a instalação retail do snow.

As versões modificadas são mais faceis de instalar por já terem bootloader e drivers disponiveis pra marcação na customize.

Despois que vc estiver mais acostumado com o ambiente do Mac vc faz a instalação retail com o dvd original do snow na outra partição. Pode até ficar com os dois pois sempre que precisar ajustar algo no Snow vai precisar do Leopard, pois alguns ajustes é preciso ser feito no sistema do Mac.



Nesse caso, qual seria a versao mais atual que vc me recomendaria, OuVerRos? E o processo de instalcao pra essas versões nao precisa de bootloader?

E depois de instaldo, como faco para criar um cd de boot especifico para minha mobo?

Valeu, cara.

#17
OuVerRos

OuVerRos

    InsanelyMac Legend

  • Local Moderators
  • 1,288 posts
  • Gender:Male
  • Location:Garopaba - SC
Eu gosto do iAtkos e a versão mais autal dele é a v7 10.5.7 e tem tb o iDeneb v1.6 10.5.8

No iAtkos além do que já vem marcado, vc marca:

SMBIOS-EFI
x86 ACPI
OHR

Drivers de video vc marca conforme sua placa de video. Na duvida marca somente NVkush e depois vc faz a EFI string do seu video com o EFIStudio

SATA/IDE ...
AHCI
Intel SATA/IDE
JMicrom SATA/IDE
VIA SATA/IDE
ATI SATA/IDE
nForce SATA/IDE
Generic IDE
USB
AppleHDA

Rede marca conforme seu hardware.


Leia esses topicos nessa ordem:
1. http://www.insanelym...howtopic=211752
2. http://www.insanelym...howtopic=209644
3. http://www.insanelym...howtopic=213183

#18
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Cara, se for fazer isso, o que eu também acho uma boa idéia, procure usar outro PC, se possível, para gravar o DVD da "distro" do Leopard (sim, elas tem boot próprio). Tenho impressão que seu gravador está com algum problema, pois não é normal ter erros de checksum no boot do CD, como você falou.

Com o Leopard instalado, ao invés de criar um boot CD para instalar o Snow, você pode usar o método do USB ou instalar direto pelo Leopard para outra partição.

#19
Carlos Paixao

Carlos Paixao

    Getting Oracle

  • Members
  • PipPipPipPip
  • 191 posts
  • Gender:Male
  • Location:Sete Lagoas, MG - BRASIL

Cara, se for fazer isso, o que eu também acho uma boa idéia, procure usar outro PC, se possível, para gravar o DVD da "distro" do Leopard (sim, elas tem boot próprio). Tenho impressão que seu gravador está com algum problema, pois não é normal ter erros de checksum no boot do CD, como você falou.

Com o Leopard instalado, ao invés de criar um boot CD para instalar o Snow, você pode usar o método do USB ou instalar direto pelo Leopard para outra partição.



Obrigado.

Vou baixar o iAtkos e ver o que que eu arrumo aqui...

A minha placa de video eh uma ECS GTS 250. Gosto mt dela, nao devo ter problemas com drivers, sera?

Qualquer coisa eu falo com vcs denovo.

Mais uma vez, muito obrigado galera.

#20
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Meu irmão tem uma GTS 250, mas é da XFX, funciona 100% com o GraphicsEnabler do Chameleon.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy