Jump to content

[Aiuto] ASUS P5Q Problema IDE


  • Please log in to reply
29 replies to this topic

#21
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 5,220 posts
  • Gender:Male
  • Location:Canary Islands

@ piccolino i dischi sotto windows funzionano perfettamente,
@ mrmojorisin17 il post ha senso invece....perchè altrimenti non avrebbe senso l'intero forum non credi?
che poi uno e libero di rispondere o non..è un'altro paio di maniche...
e non metto in dubbio che smith e piccolino stanno cercando di aiutarmi...e che ringrazio

ma mi chiedo come tanta gente capace non sprechi 2 parole in merito...


Ciao frank86
Lo kext che ti ha proposto smith@@ ha risolto o almeno in parte i tuoi problemi sotto OSX?
Anche se i problemi non sono solo tuoi ma riguardano chiunque abbia quel controller (lo possiedo anche io).
Non e' che la gente non scambi due parole o non voglia aiutare (rimane evidente che questo forum non e' un Help Desk), ma probabilmente non si e' trovato nella tua stessa condizione.

Come ti dicevo prima anche io possiedo quel controller, ma non l'ho mai usato (ho tutto su SATA),
quindi gente come me e' all'oscuro della cosa... ,ma proprio grazie a gente come te che fa luce su queste problematiche , si riescono a trovare soluzioni.

Non voglio smielarla troppo ma spero che si sia capito almeno in parte il mio pensiero.

Fabio

#22
frankx86

frankx86

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 107 posts
  • Gender:Male
  • Location:italia
Ciao Fabio grazie per l'interessamento, allora; no, tutti i kext che mi hanno proposto non hanno risolto nulla,
nessun cambiamento... e per fortuna nessun kernel panic :-)))
anche io ho roba in sata 2 hd in raid...
ma ho anche 3 hd da 500 gb + un ottimo masterizzatore Ide che vorrei utilizzare sotto osx...sai che sollievo fare i backup senza ricorrere a valanghe di cd e dvd :-)
il tuo pensiero è stato afferato perfettamente :P

#23
Smith@@™

Smith@@™

    InsanelyMac LOL

  • Retired
  • 2,928 posts
  • Gender:Male
  • Location:Somewhere over the rainbow...ITALIA!
  • Interests:Dark matter and dark energy. E basta. HD3000. E basta.
frank, ti e' mai balenata l'idea che "le persone in gamba" non sono onniscienti? Pensavo fosse scontato... Il tuo problema non e' "comune" col quel controller. Cerco di spiegarmi: molti necessitano di avere funzionante il controller pata per quel chipset e con i kexts postati aggiungendo il relativo id si risolve nel 99% dei casi. Per quel controller Marvell, che dannato lo e', ma solo per l'e-sata, non per altro.

Comunque mi defilo dalla polemica, prova questo:

Attached File  AppleVIAATA.kext.zip   137.01KB   15 downloads

Prova anche qui o qui o qui

Fai sapere;)

#24
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,515 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....

@ piccolino i dischi sotto windows funzionano perfettamente,
@ mrmojorisin17 il post ha senso invece....perchè altrimenti non avrebbe senso l'intero forum non credi?
che poi uno e libero di rispondere o non..è un'altro paio di maniche...
e non metto in dubbio che smith e piccolino stanno cercando di aiutarmi...e che ringrazio

ma mi chiedo come tanta gente capace non sprechi 2 parole in merito...


Per non essere trattati come fai tu.

Giorgio

#25
frankx86

frankx86

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 107 posts
  • Gender:Male
  • Location:italia

frank, ti e' mai balenata l'idea che "le persone in gamba" non sono onniscienti? Pensavo fosse scontato... Il tuo problema non e' "comune" col quel controller. Cerco di spiegarmi: molti necessitano di avere funzionante il controller pata per quel chipset e con i kexts postati aggiungendo il relativo id si risolve nel 99% dei casi. Per quel controller Marvell, che dannato lo e', ma solo per l'e-sata, non per altro.

Comunque mi defilo dalla polemica, prova questo:

Attached File  AppleVIAATA.kext.zip   137.01KB   15 downloads

Prova anche qui o qui o qui

Fai sapere;)


Ho provato anche quelli.. non succede nulla , quel 99% per me è molto alto :-) quale sarebbe la procedura del ID?

#26
Smith@@™

Smith@@™

    InsanelyMac LOL

  • Retired
  • 2,928 posts
  • Gender:Male
  • Location:Somewhere over the rainbow...ITALIA!
  • Interests:Dark matter and dark energy. E basta. HD3000. E basta.

Ho provato anche quelli.. non succede nulla , quel 99% per me è molto alto :-)


Ti sembra alto perche' non ti funziona avendo quell' id in particolare, ma per gli altri 3, 4, 5 id della stessa famiglia il problema non esiste, o comunque e' facilmente risolvibile.
Ho una Deluxe e una Pro della stessa famiglia, il Marvell di entrambe funziona col primo kext che ti ho postato;)


quale sarebbe la procedura del ID?


C'e' gia' l'id

#27
copil

copil

    InsanelyMac Deity

  • Banned
  • PipPipPipPipPipPipPipPipPipPip
  • 2,483 posts
  • Gender:Male
  • Location:Italy
frankx86 prova a prendere l'ID come dice smith magari da windows (lo ricavi da gestione periferiche) lo inserisci nell' info.plist del kext (mostra contenuto pacchetto) che ti ha dato dovrebbe fungere...

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>CFBundleDevelopmentRegion</key>
<string>English</string>
<key>CFBundleExecutable</key>
<string>AppleVIAATA</string>
<key>CFBundleGetInfoString</key>
<string>1.0.2, Copyright Apple Computer, Inc. 2004</string>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.AppleVIAATA</string>
<key>CFBundleInfoDictionaryVersion</key>
<string>6.0</string>
<key>CFBundleName</key>
<string>Apple VIA ATA Driver</string>
<key>CFBundlePackageType</key>
<string>KEXT</string>
<key>CFBundleShortVersionString</key>
<string>1.0.2</string>
<key>CFBundleSignature</key>
<string>????</string>
<key>CFBundleVersion</key>
<string>1.0.2</string>
<key>IOKitPersonalities</key>
<dict>
<key>VIA ATA Driver</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.AppleVIAATA</string>
<key>IOClass</key>
<string>AppleVIAATADriver</string>
<key>IOProviderClass</key>
<string>AppleVIAATAChannel</string>
</dict>
<key>VIA PATA Controller</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.AppleVIAATA</string>
<key>Hardware Name</key>
<string>82C571</string>
<key>IOClass</key>
<string>AppleVIAATARoot</string>
<key>IOPCIPrimaryMatch</key>
<string>0x05711106</string>
<key>IOProbeScore</key>
<integer>1000</integer>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>ISA Bridge Matching</key>
<dict>
<key>IOPCIClassMatch</key>
<string>0x06010000&amp;0xffff0000</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
</dict>
<key>Serial ATA</key>
<false/>
</dict>
<key>VIA SATA Controller</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.AppleVIAATA</string>
<key>Hardware Name</key>
<string>8237 SATA</string>
<key>IOClass</key>
<string>AppleVIAATARoot</string>
<key>IOPCIPrimaryMatch</key>
<string>0x43851002 0x43801002 0x43791002 0x43761002 0x528810B9 0x31491106 0x35121095 0x2360197b 0x2361197b 0x2363197b 0x2365197b 0x2366197b 0x28258086 0x28208086 0x522910B9 0x528910B9 0x05911106 0x31491106 0x05911106 0x55131039 0x610111ab 0x612111ab 0x611111ab 0x610211ab</string>
<key>IOProbeScore</key>
<string>1000</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>Serial ATA</key>
<true/>
</dict>
</dict>
<key>OSBundleLibraries</key>
<dict>
<key>com.apple.iokit.IOATAFamily</key>
<string>1.5.0d1</string>
<key>com.apple.iokit.IOPCIFamily</key>
<string>1.1</string>
<key>com.apple.kernel.iokit</key>
<string>1.1</string>
</dict>
<key>OSBundleRequired</key>
<string>Local-Root</string>
</dict>
</plist>

se non dico cavolate dovrebbe essere quello marcato in blu...il kext postato è l'ultimo di smith...sostuisci l'ID con quello tuo che prendi da windows...

#28
cicetto

cicetto

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

Scusate ho lo stesso problema con i dischi ire, ma il controller non è il silicon image??



#29
copil

copil

    InsanelyMac Deity

  • Banned
  • PipPipPipPipPipPipPipPipPipPip
  • 2,483 posts
  • Gender:Male
  • Location:Italy

cicetto

ciao-ma di quale scheda p5q?



#30
Fabio1971

Fabio1971

    InsanelyMac Legend

  • Retired
  • 12,712 posts
  • Gender:Male

Scusate ho lo stesso problema con i dischi ire, ma il controller non è il silicon image??

Servirebbero più info

 

Fabio







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy