Jump to content

[How To] X800 XL set up with working Display Manager and QE/CI


  • Please log in to reply
231 replies to this topic

#21
phoenix3200

phoenix3200

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 116 posts
hmm...maybe they never finished developing that driver for OS X...

What version of kext files are you using? People seem to have the best luck with .4 or .5 kext files (at least for 9700)

As far as lowercase/capital C, it should make no difference. The letters are simply part of the hex numbering scheme, and Info.plist is processed by the system before the file you HexEdited is processed, meaning that it doesn't matter.

Is the card running through AGP? You might have to search around for the AGP->PCI kext file people are circulating. And for my last idea, you might check to see if QE/CI is even supported on the Apple computers that would have used that kext - which includes everything from the Radeon 8500 LE to the 9200 Pro.

P.S. From the research I just did, it looks like your comp should support QE, but not CI. You might look at finding some way of disabling CoreImage, seeing as that could be what's crashing your system.

#22
silverbullit

silverbullit

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
Well. The Emac has a radeon 9200 and it supports CI. But it didn't mention QE. My system isn't really crashing its just the apps themselves shut down. I tried teh 9700 kexts again with no luck. My card supports AGP. But its on a sony vaio s150 laptop. So maybe its just pci. Im gonna try the kexts files when I find them. Im runing 10.4.6. So thats probably it. How do I know if the cards runing through agp? Im going to try different kext files. But Im not gonna play any games on my pc. I only need the screen big. Which I wasn't able to do until I read your instructions. Thanks for the awesome help.

#23
thefabulous9mm

thefabulous9mm

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts

Well. The Emac has a radeon 9200 and it supports CI. But it didn't mention QE. My system isn't really crashing its just the apps themselves shut down. I tried teh 9700 kexts again with no luck. My card supports AGP. But its on a sony vaio s150 laptop. So maybe its just pci. Im gonna try the kexts files when I find them. Im runing 10.4.6. So thats probably it. How do I know if the cards runing through agp? Im going to try different kext files. But Im not gonna play any games on my pc. I only need the screen big. Which I wasn't able to do until I read your instructions. Thanks for the awesome help.


Hi,

The 9200 AGP does not have QE, i have a G4 Emac....sorry! ;)

#24
chris76ca

chris76ca

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
it did this and got it working a diffenent way because the manual editing of the kext through hex editing did not work for me for some reason so the first thing i did was install the koverg patch got qe/ci working then came back and did the callisto patch qe/ci now not working, so then i changed to CallistoFB and rebooted and there it was qe/ci and resolution changing but heres the thing when i try to put the computer to sleep everything goes fine except when trying to resume screen will not come back up and then i reboot and cant get back into the os stopes before boot and hangs. nay solutions?

#25
phoenix3200

phoenix3200

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 116 posts
The Koverg patch does the same thing as the Hex Edit...it's just that Koverg's patch wouldn't work for me, so I manually did it.

I don't know much about sleep mode with the drivers, but you might be able to reset the graphics settings by doing the following:

Boot into Single User mode (-s)

/sbin/mount -uw /
rm -f /Library/Preferences/com.apple.window*
rm -f /Library/Preferences/ByHost/com.apple.window*
rm -f /Library/Preferences/ByHost/com.apple.pref*
rm /System/Library/Extensions.mkext
rm /System/Library/Extensions.kextcache
reboot
If that doesn't work, do what this post says to do to remove Callisto, and then reinstall Callisto.

#26
chris76ca

chris76ca

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

The Koverg patch does the same thing as the Hex Edit...it's just that Koverg's patch wouldn't work for me, so I manually did it.

I don't know much about sleep mode with the drivers, but you might be able to reset the graphics settings by doing the following:

Boot into Single User mode (-s)

/sbin/mount -uw /
rm -f /Library/Preferences/com.apple.window*
rm -f /Library/Preferences/ByHost/com.apple.window*
rm -f /Library/Preferences/ByHost/com.apple.pref*
rm /System/Library/Extensions.mkext
rm /System/Library/Extensions.kextcache
reboot
If that doesn't work, do what this post says to do to remove Callisto, and then reinstall Callisto.


Thanks for the reply ps your guide was the only guide way i was able to get the Callisto driver to work thank you , and also is the callisto crashing or do you think its the koverg patch? im using 10.4.5 and ati radeon x800 pro pcie

#27
phoenix3200

phoenix3200

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 116 posts
I think it's the power saving feature, which I'm failrly certain Omni never developed. If I was you (which, if you have a laptop, this might not be possible), I would just turn off your monitor manually.

Power saving features seem to cause problems for me a lot - I had to turn off the disk power saving feature because OS X didn't know how to wake my hard drives back up, causing a computer crash.

#28
silverbullit

silverbullit

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
No QE eh. Oh well. Im very glad and happy I got the extended resolution. It really makes such a humongous difference. Guess Ill just save for a new machine. Man Im sure glad I got callisto working.

#29
poppicu

poppicu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Location:EU
  • Interests:MacOSX
Well works fine finally with QE/CI, all resolution , and energy save for monitor work too (sleep after x minutes)
My card : Asus Extreme AX550 128 M pciex
:blink:

#30
moorjp3

moorjp3

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Thanks for all the info.

I finally got my atix600 at full resolution (1680x1050) and with QE going. I used the Callisto 008 patch and
changed the 9700 files like suggested and it all works.

Radeon Mobility X600 (M24) (PCIE):

Chipset Model: Radeon Mobility X600 (M24) (PCIE)
Type: Display
Bus: PCIe
Slot: PCI
VRAM (Total): 256 MB
Vendor: ATI (0x1002)
Device ID: 0x3150
Revision ID: 0x0000
Displays:
Cinema Display:
Display Type: LCD
Resolution: 1680 x 1050
Depth: 32-bit Color
Core Image: Supported
Main Display: Yes
Mirror: Off
Online: Yes
Quartz Extreme: Supported

running OSX and WindowsXP on a partitioned Compaq x6000.

#31
timeshifter

timeshifter

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts
Followed the instructions in "Part 1, Callisto Installation" and now have 1280 x 800 on my Dell Inspiron 6000 with the X300 card. I used Callisto_b003fixed. Yesterday I tried b008 and ended up reinstalling Mac OS. Not sure if it was a difference in versions or the fact that I followed omni's instructions (maybe incorrectly). I had a black screen shortly after boot and that was it.

Thanks OP for the very clear instructions!

#32
Hyperi0n

Hyperi0n

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
If your installing from a 10.4.6 DVD that is truly 10.4.5 with Combo Update and your in need of .5 kexts to make QE work... use Pacifist (http://www.charlessoft.com/) to extract the ati kexts from the installer package on the CD, worked for me. (I got black screen with the .6 kexts).

Callisto 008 and ATI Radeon x800xl PCIE, on 10.4.6 Jas DVD.

OKAY, HERE IS EXACTLY HOW TO GET THE 10.4.5 KEXTS OFF YOUR 10.4.6 JAS DVD (and probably all others)

Step 1. Download Pacifist. http://www.charlesso...om/Pacifist.dmg
Step 2. Open Pacifist, then select 'Open Package', the file you want is OSinstall.mpkg, you can find it it under /System/Installation/Packages/ on your CD.
Step 3. Nagivate down to Contents of EssentialSystemSoftware, Conents of EssentialSystemSoftwareGroup, Contents of Essentials.pkg, System, Library, Extensions.
Step 4. Select the kexts you want, in this all the ATI kexts. Click the 'Extract To...' button.

Voila! 10.4.5 kexts for patching.
I'll upload patched kexts later when i figure out exactly which ones are needed.

Note: Originally I left the 10.4.6 ATI kexts, and just replaced the 9700 ones, but that resulted in black screen with mouse syndrome, so be sure to replace all the 10.4.6 ati kexts.

#33
PITIKA

PITIKA

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
MY ATI X800XL is working fine under CALLISTO 008, however when i go to step two to enable QE/CI I get a blank screen and, I ended up reinstalling my OS... I tried over 8 times so far.

I use JaS 10.4.6, and looking at the post above I have some hope to get the QE to work, i just need the old KEXT files! Could someone please send me the files to my e-mail rangelm (AT) rogers.com ...


I really appreciate!


Thanks

#34
Mnemonicman

Mnemonicman

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I also have a X800XL but neither step one or two seem to work. I followed step 1 to the letter and still couldn't change resolution. I'm using 10.4.4.

Edit: Nevermind I fixed it. Turns out it was an edit to the com.apple.boot.plist file that prevented me from changing the resolution after step 1 was completed.

#35
Mnemonicman

Mnemonicman

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Huzzah! QE and CI now enabled. But as a very new mac user having installed OS X last night and just got the networking enabled this morning I'd like to know what exactly Quartz Extreme and Core Image do. Just thought I'd ask since this thread involves enabling QE and CI.

#36
ppan76

ppan76

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
All,

I have a ATI X800 XL PCI ID 554d. The Callisto drivers are not needed at all. I tried so many times to get Callisto to work "correctly" and was never able to fix the Monitor Refresh rate problem.

So just use Koverg's patch and everything works. You CAN'T change screen resolutions BUT QE/CI and OPenGL all work.

Run Koverg's script and change the ATIRadeon9700.kext to match your PCI ID and reboot.. VOILA.

I guess people are installing Callisto just to be able to change screen resolution. But in fact that was causing my problem with my LCD. (OUT OF RANGE)

#37
flasher

flasher

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
guys, will this work for an ATI 9550 AGP card?any one with the same card succeeded?thanks.

#38
pierrandre

pierrandre

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
I just Got it...

Radeon X800 GTO2 PCI-E
Used the ATI kext extracted from the 10.4.6 JaS DVD (10.4.5 on DVD)
Used the Calisto 3 Modified drivers (I did at leat 100 boot-up in verbose mode to get it)

Then I've got them all...
QE, CI, OpenGL (tested in iTunes).. and I got the Mouse Tearing (I'll check fot it later).

I've got all the resolutions available for my Dell 2407 Wide Screen => 1920x1200 but when I change the resolution from the menu or from the control panel... The screen turns itself in blue and remain like that... until my reboot...

When I set the resolution into the boot.plist the screen change it's resolution while in verbose mode but, when the loginwindows apprears... it took the superior edge of the screen in 1024x768 stretched mode, and the mouse is movable but not usable (draw a lot of straight lines)

What can I do next ?

Thank you for your How-to... but just a little thing was missing from it... The EDID (it won't work for a DVI LCD screen without the informations of the panel).

#39
DJ Solo

DJ Solo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi Flasher, my english is not so good ok??
but i have a ATI Radeon 9550 GPx8 256 MB Sapphire and is working very good .... all work
whit OS X 10.4.5 and callisto 006

MB ASUS P4GE-MX
512 Mb RAM
Intel celeron D 2.4 GHz

all is working !!!

....DJ Solo.....
Chile

#40
phoenix3200

phoenix3200

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 116 posts

I'd like to know what exactly Quartz Extreme and Core Image do

They're video acceleration routines which are used in programs like Safari (to reduce it having to refresh the entire page when you scroll), and is critical in a decent number of video playback programs; especially DVD Player and Final Cut Pro.

just a little thing was missing from it... The EDID (it won't work for a LCD screen without the informations of the panel)

Ooookay, throw in the exception... Just kidding. On my platform I have two 19" CRT monitors (mirroring only, of course), so I never bothered going down that road. The first time I tried installing b008, I tried hardcoding the EDID from my CRT, and that lead everything to crash.

Is there a way to get the Resolution menu to work

A few people have mentioned using a separate program to change the resolution after they install Callisto. If that doesn't work, back up your existing Callisto drivers and try installing the newer Callisto drivers again to see if they will do you any good this time around.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy