Jump to content

CMOS reset fix


  • Please log in to reply
7 replies to this topic

#1
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Se você instalou o Snow Leopard e toda vez que reinicia o PC as configurações da BIOS são perdidas (CMOS checksum error - defaults loaded) a solução é simples, basta editar o DSDT, procurar pelo device RTC e alterar o length do segmento IO para 2.

Se você nunca lidou com DSDT ou nem sabe do que se trata, pode seguir esses passos:

1) baixe o DSDT Editor

2) DSL - Extract from system

3) Patch - Load from file - selecione "RTC.txt"

4) Apply

5) AML - Compile

6) AML - Save to file - dsdt.aml

7) Copie o dsdt.aml para /Extra


Vídeo demonstrativo



#2
Papa Mike

Papa Mike

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Estou tendo esse erro quando tento compilar:
Posted Image

Verificando as linhas descritas nos erros, não vejo nenhuma anormalidade e se há alguma, não faço a menor ideia de como solucionar o problema.
Posted Image

Ficaria bastante grato se pudesse me ajudar!

#3
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Use o "DSDT Editor", selecione o erro na janela da compilação, clique no botão "Fix errors" e observe o que ele muda
http://www.insanelym...howtopic=223205

Vou atualizar o tutorial para usar o editor novo.

#4
Papa Mike

Papa Mike

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts

Use o "DSDT Editor", selecione o erro na janela da compilação, clique no botão "Fix errors" e observe o que ele muda
http://www.insanelym...howtopic=223205

Vou atualizar o tutorial para usar o editor novo.


Não encontro esse botão. Poderia colocar screen shot?

Grato.

#5
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 11,137 posts
  • Gender:Male
  • Location:Rio de Janeiro
Vá em AML / COMPILE

Posted Image

#6
JuniorGump

JuniorGump

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Paraíba, Brasil
Eu tenho esse problema, mas nao é necessariamente por causa do Mac...

Toda vez que desligo a fonte do PC ou o Estabilizador, a BIOS é resetada.. ja troquei a bateria e tals,, mas nao resolve em nada...

Quem derá se o problema fosse esse ae.. rsrsr

#7
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 11,137 posts
  • Gender:Male
  • Location:Rio de Janeiro

Eu tenho esse problema, mas nao é necessariamente por causa do Mac...

Toda vez que desligo a fonte do PC ou o Estabilizador, a BIOS é resetada.. ja troquei a bateria e tals,, mas nao resolve em nada...

Quem derá se o problema fosse esse ae.. rsrsr


Já atualizou o BIOS pra última versão disponivel?

#8
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,050 posts
  • Gender:Male
  • Location:Brazil
Talvez o jumper CMOS Reset esta ligado.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy