Jump to content

Snow Leopard retail em partição MBR


  • Please log in to reply
34 replies to this topic

#21
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Se persistir o problema tente fazer o boot em 32 bit (digite "arch=i386" no Chameleon). Tava lendo esse tópico sobre a Maximus Formula e várias pessoas disseram ter tido este problema em 64 bit após a atualização para 10.6.2
http://www.insanelym...howtopic=182048

#22
Alex Novelli

Alex Novelli

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Brazil
  • Interests:web, design, html, css, mac os, os, games
Eu verifiquei a BIOS e está tudo ok...
Entrei pelo modo verbose e tirei um print. Vejam se voces reconhecem o erro. Que saco viu cara. To quase desistindo do Snow ja... rsrsrs

Obs.: vc havia me perguntado se o Chameleon estava mesmo instalado no Snow. Eu não sei se está. Como posso verificar? Só sei que no Chameleon ele inicia como principal. Quanto ao tutorial descrito neste tutorial pra instalar o Chameleon no Snow, sempre da o erro que descrevi antes. Existe outra forma de instalar o Chameleon? Ou de verificar se ele está aplicado no Snow?

Abs

Attached File  IMG_0344.jpg   237.7KB   14 downloads

Se persistir o problema tente fazer o boot em 32 bit (digite "arch=i386" no Chameleon). Tava lendo esse tópico sobre a Maximus Formula e várias pessoas disseram ter tido este problema em 64 bit após a atualização para 10.6.2
http://www.insanelym...howtopic=182048


Onde digito isto?

Rsrsrs! Descobri que e so digitar na tela de escolha de boot. FUNCIONOU!
Tem como gravar isso pra nao precisar digitar toda vez?
Abs

#23
Alex Novelli

Alex Novelli

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Brazil
  • Interests:web, design, html, css, mac os, os, games
Estava vendo seu tutorial de instalação do Chameleon 2.0 e vi a foto do Lizard. Aquela opção dele "32bit Compatibility Mode" não seria o que estou querendo? Habilitar o arch=i386 automaticamente?
Abs

#24
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil

Obs.: vc havia me perguntado se o Chameleon estava mesmo instalado no Snow. Eu não sei se está. Como posso verificar? Só sei que no Chameleon ele inicia como principal.

Se ele inicia por padrão sem você ter colocado "Default Partition" no com.apple.Boot.plist ele está na partição do Snow e ela está ativa. Para verificar você pode rodar
sudo fdisk -e /dev/disk0
   p
   exit
Vai aparecer um asterisco ao lado do número da partição ativa.

Quanto ao tutorial descrito neste tutorial pra instalar o Chameleon no Snow, sempre da o erro que descrevi antes. Existe outra forma de instalar o Chameleon?

Existem instaladores do Chameleon, mas eles fazem a mesma coisa. Qual erro? Não encontrei. Se for "fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory", é normal, não tem problema.

Descobri que e so digitar na tela de escolha de boot. FUNCIONOU!
Tem como gravar isso pra nao precisar digitar toda vez?

Para gravar edite o arquivo /Extra/com.apple.Boot.plist e adicione em "kernel flags"
<key>Kernel Flags</key>
	<string>arch=i386</string>
Naquele mesmo tópico sobre a Maximus Formula tem um cara dizendo que o KP em 64 bit é causado pela IONetworkingFamily.kext, tente movê-la para fora da pasta /S/L/E e reiniciar em 64 bit (sem digitar nada no boot). Se funcionar tente instalar a da versão 10.6.0 (pode usar o Pacifist para extrair do DVD). Tem outro cara que diz que o problema é a AppleHDA.kext, mas olhando para a sua foto do KP me parece que o problema é com a GeForce.kext, faça o mesmo teste de remover a kext e reiniciar em 64 bit, se funcionar recupere a versão anterior.

#25
Alex Novelli

Alex Novelli

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Brazil
  • Interests:web, design, html, css, mac os, os, games

....... mas olhando para a sua foto do KP me parece que o problema é com a GeForce.kext, faça o mesmo teste de remover a kext e reiniciar em 64 bit, se funcionar recupere a versão anterior.


Recuperar a versão anterior seria pegar do DVD do 10.6.0 a Geforce.kext?

#26
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil

Estava vendo seu tutorial de instalação do Chameleon 2.0 e vi a foto do Lizard. Aquela opção dele "32bit Compatibility Mode" não seria o que estou querendo? Habilitar o arch=i386 automaticamente?

Pode ser, teste e veja se ele adiciona nas kernel flags em /Extra/com.apple.Boot.plist

Recuperar a versão anterior seria pegar do DVD do 10.6.0 a Geforce.kext?

Exatamente. Mas isso se não ocorrer KP sem usar a da 10.6.2.

EDIT: confirmado, eu tinha esquecido dessa

There is panic with geforce7 cards and 64-bit kernel mode, use 32-bit kernel mode

http://netkas.org/?p=315

Se quiser rodar em 64 bit pode tentar com a Geforce.kext da 10.6.0

Se não adiantar recupere também as dependências
NVDAResman.kext
IONDRVSupport.kext
IOPCIFamily.kext
IOGraphicsFamily.kext

Como última tentativa recupere também a NVDANV40Hal.kext

#27
Alex Novelli

Alex Novelli

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Brazil
  • Interests:web, design, html, css, mac os, os, games
Seguinte, eu substitui o Geforce.kext do 10.6.2 pelo 10.6.0 e parou o KP, mas os graficos ficaram lentos e o Quartz Extreme morreu. Eu ia tentar substituir todos os outros que voce mencionou porem me lembrei que o Paragon NTFS, que eu uso, só funciona em 32bit... Então voltei a kext 10.6.2 e apliquei o 32bit automatico no Chameleon.

Outra coisa, eu apliquei o Chameleon novamente através do seu tutorial neste mesmo tópico e funcionou. (acho que o erro era que eu apliquei no Lizard a partição de boot de um jeito e no código de outro e estava dando conflito...).

Agora estou com um novo problema e pelo que percebi este problema é que o Chameleon não está mais ativo no Leopard.
Como devo proceder? O boot principal deve ficar no Snow, mas tem que aplicar algum comando pro Chameleon aplicar o conteudo da EXTRA (do Leopard) no Leopard?

A tela do verbose:
Attached File  kp.jpg   359.23KB   8 downloads

#28
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil

Agora estou com um novo problema e pelo que percebi este problema é que o Chameleon não está mais ativo no Leopard.
Como devo proceder? O boot principal deve ficar no Snow, mas tem que aplicar algum comando pro Chameleon aplicar o conteudo da EXTRA (do Leopard) no Leopard?

Você criou o Extensions.mkext no Snow Leopard? Na verdade só pode ter uma partição ativa, e o Chameleon instalado nela será executado no boot. Se você selecionar o OS em outra partição, ele vai ler o conteúdo da pasta Extra em ambas as partições, mas antes a da partição ativa, por isso você não pode ter um Extensions.mkext em /Extra, pois vai causar conflito com o outro OS.

Outra coisa, por que você instalou a SleepEnabler?

#29
Alex Novelli

Alex Novelli

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Brazil
  • Interests:web, design, html, css, mac os, os, games

Outra coisa, por que você instalou a SleepEnabler?


Antes de voce me ensinar sobre o DSDT eu ja havia aplicado ele no Leopard. Por isso ele está lá. Vou deletar ele.

Sobre o Extensions.mkext, eu não criei... deve ser as configurações que eu apliquei no smbios.plist pelo Lizard... outra vez o Lizard... rsrsrs. Vou desabilitá-las e reiniciar. Vamos ver no que dá.

#30
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Estranho, eu tenho exatamente a mesma configuração e funciona normal
Disk: /dev/disk0	geometry: 60801/255/63 [976773168 sectors]
Offset: 0	Signature: 0xAA55
		 Starting	   Ending
 #: id  cyl  hd sec -  cyl  hd sec [	 start -	   size]
------------------------------------------------------------------------
 1: 07	0   1   1 - 1023 254  63 [		63 -  766991232] HPFS/QNX/AUX
 2: AF 1023 254  63 - 1023 254  63 [ 766991295 -  104888385] HFS+		
*3: AF 1023 254  63 - 1023 254  63 [ 871879680 -  104888385] HFS+		
 4: 00	0   0   0 -	0   0   0 [		 0 -		  0] unused

/E/E do Snow Leopard
AD1988bFix.kext		OpenHaltRestart.kext	fakesmc.kext
LegacyAppleYukon2.kext	PlatformUUID.kext
OSXRestart.kext		VoodooMonitor.kext

/E/E do Leopard
AD1988bFix.kext		OpenHaltRestart.kext	fakesmc.kext
CPUi.kext		UUID.kext


#31
Alex Novelli

Alex Novelli

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Brazil
  • Interests:web, design, html, css, mac os, os, games
DESCOBRI!! Quer dizer, voce descobriu. rsrs!
Era a Extensions.mkext na EXTRA mesmo. O Kext Utility criou ela e eu não tinha visto.
Valeu! Abs

#32
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Outra coisa, se você instalou a fakesmc.kext no Leopard, pode excluir a dsmos.kext.

#33
Alex Novelli

Alex Novelli

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Brazil
  • Interests:web, design, html, css, mac os, os, games
Esqueci de responder: ja apaguei o dsmos.kext!
Valeu!

#34
Alex Novelli

Alex Novelli

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Brazil
  • Interests:web, design, html, css, mac os, os, games

Pode ser, teste e veja se ele adiciona nas kernel flags em /Extra/com.apple.Boot.plist


Exatamente. Mas isso se não ocorrer KP sem usar a da 10.6.2.

EDIT: confirmado, eu tinha esquecido dessa

http://netkas.org/?p=315

Se quiser rodar em 64 bit pode tentar com a Geforce.kext da 10.6.0

Se não adiantar recupere também as dependências
NVDAResman.kext
IONDRVSupport.kext
IOPCIFamily.kext
IOGraphicsFamily.kext

Como última tentativa recupere também a NVDANV40Hal.kext


Ontem a noite tentei substituir os kexts da nvidia 10.6.2 pelos 10.6.1 (um cara postou no Netkas dizendo que funcionou isso) e habilitar o x64.
Funcionou perfeito o video e o sistema está carregado em x64 mas... o Sleep acorda em tela preta agora...
Conhece alguma solução?
Abs

#35
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Eu acho que é bug no driver mesmo. Também acontece no meu laptop que tem o vídeo X3100, em 32 bit funciona normal, em 64 quando desperta do repouso a tela fica preta.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy