Jump to content

AppleNForceATA x32/x64 new SL version recompiled.


  • Please log in to reply
38 replies to this topic

#1
sulphide

sulphide

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Here it is Posted Image x32 + x64 (all in one) version of Medevil's AppleNForceATA.kext recompiled by me for Snow Leo, all x64 compatability issues were solved, almost nothing changed. Tested on NForce4 s939 Asus A8N-SLI... so try it. Posted Image




ps SATA DVD writing issues were not fixed.
pps fixed "out of 32b" KP

Attached Files



#2
GFOnyX

GFOnyX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 133 posts
  • Gender:Male

Here it is Posted Image x32 + x64 (all in one) version of Medevil's AppleNForceATA.kext recompiled by me for Snow Leo, all x64 compatability issues were solved, almost nothing changed. Tested on NForce4 s939 Asus A8N-SLI, fully functional... so try it. Posted Image

Um what do you mean fully working?
As far as i am concerned if the sata dvd problem is not fixed then i dont see something new.If however this is fixed then contgrats since it was the only problem that Medevil's work had.

#3
84R7

84R7

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
thank you !
ill try it out :D)

#4
84R7

84R7

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
hi! it worked for me. thanks !
bud my dvd sata burnder doasnt work now.
i get SAM multimedia rewad write error.
and my usb mouse makes very big steps ...
someone has an solution ?

#5
sulphide

sulphide

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

hi! it worked for me. thanks !
bud my dvd sata burnder doasnt work now.
i get SAM multimedia rewad write error.
and my usb mouse makes very big steps ...
someone has an solution ?


hmm.. my usb mouse had the same problem, it became jumpy after a while, but i solved this with just putting right values into smbios.plist, memory, memorytype, fsb and, put there MacPro3,1 instead of iMac9,1 and so on... got no sata dvd, so can't test this, if i have one i'll fix this issue  ;)  

#6
GFOnyX

GFOnyX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 133 posts
  • Gender:Male

hmm.. my usb mouse had the same problem, it became jumpy after a while, but i solved this with just putting right values into smbios.plist, memory, memorytype, fsb and, put there MacPro3,1 instead of iMac9,1 and so on... got no sata dvd, so can't test this, if i have one i'll fix this issue  :thumbsup_anim:  

Then it is NOT FULLY functional as mentioned on the first post (before you edit it,which is good from your part and honest).The sata dvd problem is the one and only big problem Medevil's kext has so i ask again:
What more does your kext has to offer.I ask with no bad intention.I really want to find out what is new on this coz if there is nothing new i dont see any reason uninstalling medevil's kext.

If you have the knowledge to fix the sata problem then i suggest you ask from a friend of yours to lent you his sata dvd recorder since this is actually a big problem thus by fixing it you will actually give something back to the community.

#7
sulphide

sulphide

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Then it is NOT FULLY functional as mentioned on the first post (before you edit it,which is good from your part and honest).The sata dvd problem is the one and only big problem Medevil's kext has so i ask again:
What more does your kext has to offer.I ask with no bad intention.I really want to find out what is new on this coz if there is nothing new i dont see any reason uninstalling medevil's kext.

If you have the knowledge to fix the sata problem then i suggest you ask from a friend of yours to lent you his sata dvd recorder since this is actually a big problem thus by fixing it you will actually give something back to the community.

well, my aim was to make full x64 kext with full x64 support plus x32 support... this was the only one aim for me. i even did'nt know that medevil's kext had those sata writing issues. when compiling it had about 20-25 warnings that i solved... except this i corrected everything that was connected to x64 native mode. and this is all. i trust myself more than anyone else, so i use my own kext, but not supernforceata or anv's applenforceata. it work perfect for me, have native x64 support, don't have errors. btw it is written in my first post that "nothing have been changed", so please make right decisions...if i get sata dvd i'll try to fix this issue =)

#8
Sets

Sets

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Ljubljana

Here it is Posted Image x32 + x64 (all in one) version of Medevil's AppleNForceATA.kext recompiled by me for Snow Leo, all x64 compatability issues were solved, almost nothing changed. Tested on NForce4 s939 Asus A8N-SLI... so try it. Posted Image




ps SATA DVD writing issues were not fixed.


I dont know but on my asus P5N-E SLi (nforce 650i) dosent work , it gives me and error on booting saying that culdent load some nforce related kext

#9
sulphide

sulphide

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

I dont know but on my asus P5N-E SLi (nforce 650i) dosent work , it gives me and error on booting saying that culdent load some nforce related kext


permissions repared? kextcache cleared?

#10
Sets

Sets

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Ljubljana

permissions repared? kextcache cleared?


acualy is on my install USB that i am testing it i dont want to screwup the install works fine, just last thing i am missing is the native 64bit, the kextcache is clired on the install USB yes. i hope i am on the right track to test this. i dont want to play whit my real install if i am not 100% shure is gona work.

#11
sulphide

sulphide

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
fixed "out of 32bit KP". reuploaded.

#12
iLeopod

iLeopod

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts
  • Gender:Male
  • Location:Germany
  • Interests:ileopod.wordpress.com
Hi,
fix this version also the slow boot bug (like nForceIOATAFamily.kext who is only available for 32bit)?
Because what helps 64 bit when the boott takes up a min.

Regards
iLeopod

#13
evak

evak

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi just wanted to say thanks for making the effort, it's always good when someone takes the time to try and fix something thats been left broken.

Looks like the one major biggie remaining is SATA dvd drives. THought it might be worth mentioning what happens incase you can think of something that might cause it.

It's strange since I installed 10.5.6 with my SATA DVD drive even though Disk Utility doesn't list it in the OSX installer.

the OSX profiler in utilities lists the DVD drive correctly and the drive shows in disk utility, the eject button on desktop works to open and close the drawer, but when I put a dvd in the drive locks up for a good 15 minutes and eventually says its empty.

In that whole time that the drive locks up, the burner doesn't show in profiler, and the eject button on desktop has the spinning color wheel when you mouse over.

I guess this is the problem everyone else with a SATA DVD drive is having problems with.

#14
iLeopod

iLeopod

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts
  • Gender:Male
  • Location:Germany
  • Interests:ileopod.wordpress.com
Dosn't work in 64 bit mode. (EVGA 680i)

#15
Paramount

Paramount

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:So Paulo, Brazil
Hi. I'm working on a 64 bits version of AppleNForceATA... so, can you share your moddifications to the AppleNForceATA source?

#16
ctheanh

ctheanh

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
It does not work for me with MCP 67 0550:10de (nForce 630m i think).I used AppleVIAATA.kext and AppleNforceATA.kext but without x64 support.Can you recompile it with my chipset.Thank you!

#17
kocoman

kocoman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 315 posts
I want to say thank you, your kext worked, while the slashack's one didn't.

After i upgrade from 3gb to 5gb, I keep get panics.

thanks again.

haven't got any panic anymore, but I can't boot with 64bit kernel.. I would get the still waiting for root. But 32-bit kernel is ok for now.

#18
slimshadyp

slimshadyp

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Works great, I could boot into 64bit kernel with 6 gigs of ram on an xfx 680i lt. Sata Dvd drive doesnt work though.. but i dont use that :D. I don't remember teh last time i've actually used a dvd drive other to install an OS.

#19
RaMDaY

RaMDaY

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts
  • Gender:Male
  • Location:New York City

Works great, I could boot into 64bit kernel with 6 gigs of ram on an xfx 680i lt. Sata Dvd drive doesnt work though.. but i dont use that :D . I don't remember teh last time i've actually used a dvd drive other to install an OS.


Are you sure you were booting into 64bit mode kernel mode?

#20
scififan68

scififan68

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 151 posts
  • Gender:Male

Are you sure you were booting into 64bit mode kernel mode?

Yeah as long as the board has ahci support.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy