Jump to content

Lenovo Ideapad S12 Ion Development Thread


  • Please log in to reply
113 replies to this topic

#21
minimaci

minimaci

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Female
  • Location:germany
Sorry
I don't know what my codec exactly is -- tried to patch the info.plist, but it did not work.
Is there a way to get to know which codec is used?
Any hints welcome!!!

Thanks a lot!

#22
linos

linos

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Where to find all the kext??
VoodooPowerAcpi.kext
HDAIDT.kext


I Found them.... :wub: and am delighted to share it with you...

Here you are, VampireHunter_D, Big Beluga postet it in another Thread :

http://www.insanelym...howtopic=181293

Well - now nearly everything works.. BigBelugas Description in this Lenovo Development Thread was just a little bit to unprecise for me .. I am a completly Newbee...
It was a bit more deleting things in the Terminal , and a little bit more "trail and error" than it seemed to be...
I installed the two kext and copied the DSTS an Smbios list in my EXTRA FOLDER - and now I can use my little Minimac with a nice Resolution..
Sound is still a Problem

... but I keep on searching and trying untill
I AM ABLE TO HEAR SOMETHING -



Where to get this patched VoodooHDA 0.2.1 or a instruction how to patch it.....


I've got exactly the same problem with the wlan card. Does this procedure also work without an extra DELL WLAN Card?

Ich wäre auch in deutsch per PM erreichbar ;-)

Gruß

#23
BigBeluga

BigBeluga

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Apologies for the bad link to bcc9's patch. Should be able to find it here:
http://www.insanelym...howtopic=136515

The solution for the auto crackle is to get a patched version of voodoo HDA from the Asus 1201N folks. Their thread is located in the 10.6 install forum.

The orange screen of death is caused by NVEnabler.kext, I think. There must be half a dozen copies in NetbookInstaller; pain in the ass to get rid of all of them. May just want to wait for the next version of NBI. In the meantime, the myHack script does the job.

Haven't tried 10.6.4 yet Don't expect any problems, but who knows.

#24
meronpan

meronpan

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
I'm desperated,

I tried to install SL 10.6.3 on my L S12 all day long with no success. I get 10.6 working but also without working drivers for anything (except the correct screen resolution).

I isntalled via:
SL Retail
Netbookbootmaker 0.8.4. RC1

then
10.6.3 v.1.1 Combo update

After I installed 10.6.3 I get a Dell Mini 10 Boot-Logo which seems to be just as expected. It takes several minutes until it restarts on its own and after it my screen is flickering in full red. As if the video driver is broken. The system still seems to react. (I pushed the power button, then Enter and the system shut down)

I also wonder why the correct drivers aren't installed after the initial installation. The tutorial says like it should work out-of-the-box.

Do I need the Netbookinstaller? :D

#25
BigBeluga

BigBeluga

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
The orange screen of death is caused by NVEnabler.kext. No clue why. You do not need NBI - the myHack installer will do the job just fine. However, after you update, you will not be able to boot - myHack does not patch the kernel on the fly. However, you can use a usb stick to boot (like one prepared using NBI) and then replace mach_kernel with a patched copy.

I'm desperated,

I tried to install SL 10.6.3 on my L S12 all day long with no success. I get 10.6 working but also without working drivers for anything (except the correct screen resolution).

I isntalled via:
SL Retail
Netbookbootmaker 0.8.4. RC1

then
10.6.3 v.1.1 Combo update

After I installed 10.6.3 I get a Dell Mini 10 Boot-Logo which seems to be just as expected. It takes several minutes until it restarts on its own and after it my screen is flickering in full red. As if the video driver is broken. The system still seems to react. (I pushed the power button, then Enter and the system shut down)

I also wonder why the correct drivers aren't installed after the initial installation. The tutorial says like it should work out-of-the-box.

Do I need the Netbookinstaller? :)



#26
meronpan

meronpan

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Thanks for the info? How would I do that? And why are the drivers not working, right from the install. This tutorial lets me think it should definately work. Very strange...

Too bad but I will probably install Win7 again as I need this machine fast. :)

#27
minimaci

minimaci

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Female
  • Location:germany
Hi,
No it is not working right on the flow-
boot from the USBstick you used to install OSX
And after you`ve chosen your language switch directly into the Terminal found in the Applications/Utilities folder.
Delete the NVEnabler.kext out of your Extra directory. Repack the Extensions.mkext again..
mkdir /Volumes/YOURCOMPUTERNAME/Extensions/
rm -rf /Volumes/YOURCOMPUTERNAME/Extra/GeneralExtensions/NVEnabler.kext
mkextunpack -v -d /Volumes/YOURCOMPUTERNAME/Extensions/ /Volumes/YOURCOMPUTERNAME/Extra/Extensions.mkext
rm -rf /Volumes/YOURCOMPUTERNAME/Extensions/NVEnabler.kext

kextcache -a i368 -m Extensions.mkext /Volumes/YOURCOMPUTERNAME/Extensions/ 
cp -r /Volumes/YOURCOMPUTERNAME/Extensions/Extensions.mkext /Volumes/YOURCOMPUTERNAME/Extra/ 
chmod -R 755 /Volumes/YOURCOMPUTERNAME/Extensions/Extensions.mkext
chown -R 0:0 /Volumes/YOURCOMPUTERNAME/Extensions/Extensions.mkext
Hope this will help

hah - okay, Thanks to Big Beluga...
found the kext
Thank you very much!!!

I tried this one:http://www.projectos...p?showtopic=483
it must be installed in the S/L/E Folder - than run kexthelper - and it works fine..

Now my Extra - Directory works fine for me..
Here a link to the download: Extra.zip
Maybe that will help... a little bit.





#28
battle_clown

battle_clown

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:nowhere

I assume you mean the Extensions.mkext file in my EFI partition? It contains:

AppleACPIBatteryManager.kext
AppleACPIPS2Nub.kext
ApplePS2Controller.kext
CPUInjector.kext
Disabler.kext
fakesmc.kext
HDAIDT.kext
NullCPUPowerManagement.kext
SleepEnabler.kext
SMBIOSResolver.kext
VoodooPowerAcpi.kext

VoodooHDA 0.2.1 is installed in S/L/E; this is the only way I can make sound work at present.

Which DSDT are you using? Have you solved the battery meter problem? Mine only shows a battery with the big X through it still. Just pulled the DSDT using Everest Ultimate in Win7; maybe I will get somewhere with this, but suspect it may take awhile.


Hey,
how did you configure CPUInjector, i.e., which values did you use in info.plist for the S12's Atom CPU? I did not find the correct values by looking at http://digitaldj.net...5-extreme-pack/ or anywhere else.
Also, I am using VoodooHDA 0.2.6 but I get terrible feedback from the speakers and audio seems to be crackling. Did you encounter similar issues?
Also, which smbios.plist do you use and where did you put it?
Best & thanks

#29
tobinov

tobinov

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi Guys,

i have got a Lenovo S12 Ion for 1 month and got so far: Mac Os X is installed. Not more. And so I ask you, the community, if anybody can write a tutorial how to proceed after an sucessfull installation.

Thank you very much

#30
1aquila1

1aquila1

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Seriously, could someone help me out. I have SL installed, I don't use the patched dsdt yet because something keeps going wrong when trying to repack the extensions.mkext. Could someone who got it working upload their extensions.mkext? Furthermore, I have audio workingbut it's very cracky (i prefer not having audio above this) and somethimes when I start osx it gives a very hard beep like you hold a microphone to close to your speakers. Could someone also upload the good patched voodoohda. I also read somewhere that hdaenabler.kext also works, any experiences with that ?

#31
HNO3

HNO3

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
Hello and thank you for this forum,
I installed using the guide but with netbootmaker 0.8.3 (0.8.4 doesn't run on my mac under 10.5.8)
1) 10.6.0 ok in 1027*768
2) apply netbookinstaller 0.8.4.rc1 to the hard drive
3) 10.6.0 ok with 1280*800

webcam works with ichat but not with photobooth
trackpad and keyboard worked from the very beginning
no bluetooth
no wifi
Now that i can run Netbookmaker 0.8.4 to the USB Stick (from the S12 under 10.6.0) I will restart from the begining of the guide ;-)

#32
HNO3

HNO3

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
Hello,
My Lenovo S12 model is Nvidia Ion, 2Go RAM, 320Go HD
I followed the guide exactly:
1) With Disk Utils, I Copyed SL OSX Retail DVD install Disk on an USB Stick 16Go : OK
2) i Run the netbookmaker 0.8.4RC1 targeting the USB Stick : OK
3) Restart from the USB STick (pressing Fn+F11) : OK
4) Installing Snow Leopard absolutly perfect : OK
5) I stoped here with 10.6.0 OSX

What's Work:
Screen resolution 1280x800: OK
Keyborad : OK (even Fonction Keys are fonctionning: brightness+-, volume+-, screen shutter On/Off)
Trackpad : OK
Webcam : OK with Ichat , Not working with Photobooth

Not tryed yet:
Card reader / VGA output / HDMi output

Not Working:
Bleutooth : not detected
Wifi : detected as airport card from unknown brand but airport doesn't want to activate
Audio : no card detected

If someone can help, please ?

PS: Bigbeluga : when you write Pin 20 of Wifi card must be taped what do you mean exactly ?
we must take it out of the netbook, put some kind of strip on the 20th pin and replace it to work fine ?

#33
1aquila1

1aquila1

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
@HNO 3, yes that's exactly what he means.

There's a new netbookinstaller out, ima try that one. I hope it supports this netbook like meklort promised ;)

#34
m3phisto

m3phisto

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 7 posts
i just tried the Netbookinstaller 0.8.5preview release

DON'T USE THIS ONE!!!

VGA is not working afterwords.
i switched back to 0.8.4

#35
HNO3

HNO3

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
Ok thank's for the info ... it seems that we will have to wait for the 0.8.5RC1 to have the lenovo S12 bundle included (as promised by meklor).

I have taped the 20th pin of my broadcom wifi card and it worked like a charm ... airport waves in the menu bar ... a click on activate airport ... and it was working perfectly.

What works now:
Graphic: Perfect 1280x800
Audio: OK
Internal Mic: OK
Webcam: OK
Wifi: OK
Trackpad : OK with multiple touch gesture
Keyboard : perfect (the layout is not exactly the good one, i have to change it)
Card Reader : OK

what still doens't work:
bluetooth
batterie indicator

Not tested yed:

VGA out, ethernet, sleep, hdmi, mic and audio plugs (internal mic works)

I am in dualboot now, with windows 7 on the first 60Go Partition and Snow Leopard 10.6 on the second partition (240Go).

Thanks for your help.

#36
cupang

cupang

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
does lenovo s10-3s will do the same like this type?? or different at all??

#37
m3phisto

m3phisto

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 7 posts
just tried the voodoohda driver.
if i the volume is above 50% i get an extrem loud peep sound... anyone elese got this?

#38
HNO3

HNO3

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male

Battery Status - EXTRAS - bcc9's AppleACPIPlatform patch and AppleACPIBattery.kext required

I found the AppleACPIPlatform patch
But not the AppleACPIBattery.kext
where can I find it please ?

#39
1aquila1

1aquila1

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Woow HNO3, you got it way better working then me (and i'm bussy with it for over a month). I'fe got some questions, since you're the only one reading this with a pretty nice working lenovo s12 I hope you can answer them.

What exactly did you use for the audio to work? I've got the same insane loud beep like m3phisto ( we probably use the wrong voodoohda )

And does your qe/cl work? ( I gues it does since you have the perfect resolution) how did you get it to work? You used the dsdt.aml and removed nvenabler outta extensions.mkext ? (maybe you could upload your/extra folder? It would defintly help me allot)

and just to make sure: you put tape on the 20th pin from your wifi card (nothing more) and it works ? (in windows 7 to ?)

I've tried several things to install SL on my lenovo s12 but i never got any further then booting osx, qe/cl working (but with nvenabler so it's getting very hot and the battery's up in 1,5 hours or so and when iI try it with the dsdt I get a flickering screen, probably because there's still a trace of nvenabler somewhere) very cracky audio with annoying loud beep, no wifi/bluetooth/battery

I hope you want to help me/us out a lil bit, thanks in advance

#40
HNO3

HNO3

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
hello,
first thing : you have to know that i am a newbie with hackintosh ... so i am able to do stupid things
ok ...
i will do my best :angel: to help if i can.
I have done many tries. each time restarting from scratch.

1) I started to install with NetbookBootmaker ... some things worked some over things did'nt worked
2) erased everything
3) I re-installed using Snow Leopard enabler 1.1.17 ... some things worked (not the same) for exemple audio worked
4) i used netbookinstaller over the installation ... it was great !!!
5) i deleted the 1201DSDT.aml file in the extra folder (because it's a lenovo S12 not an asus 1201 ... )
6) i taped the 20pin of the wifi card ... now wifi works perfectly ... it did nothing concerning the bluetooth (still not working, except with a usb dongle)
7) i cloned my work to an usb hard drive using carbon copy cloner ... applied netbootinstaller on this disk
8) i erased every thing using disk utils format the HD in fat 32
9) i restored the win7 partition to the disk
10) using parted magic live CD , i shrinked the win7 partition and format a new HFS+ partition.
11) I booted from the usb clone hard drive
12) I cloned the usb disk back to the new partition ... applied the netbootinstaller on this partition
13) restarted in win7 . i used easyBCD to create a dual boot Win7 / OSX

that's all





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy