Jump to content

[HELP] can't boot anymore


  • Please log in to reply
No replies to this topic

#1
typhoonman

typhoonman

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Hi i've made a biiig mistake!!!!
I had some files in my Mac HD that i can't access, i thought to get rid of all permission problems to add my user on the entire disk with xrw and apply to the disk
Basically i've messed up permissions on the System folder (at least)

from now i'm not able to boot my mac pro anymore
Before rebooting i've launched also disk utility and repaired permission, it tooks nearly 36 hours to fix all permissions, main problem is that it hasn't fixed everything.

So:

1 - When i boot it hangs at the apple logo and then reboot loop
2 - if i boot in verbose it hangs when it looks at acpi, disks goes off, then after a minute they spin up again, then it write something very fast and then reboot, can't read
3 - in single user i can access the terminal but when i write exit it hangs for a while and then reboot
4 - i've tried booting from dvd and repairing permissions, every time i repair i get "ACL found but not expected in "system/library/...." in a lot of files inside /system/library/extensions , in system/library/frameworks and system/library/privateframeworks
Unfortunately it doesn't fix that and everytime i reboot and i do disk utility again it finds the same.
5 - i've tried fixing permission on those folders by terminal in single user, i write this:
"sudo chmod 775 System/Library/Extensions"
but after a while it says "can't open /private/etc/sudoers"
I'm not skilled in unix command so i really don't know what else to try

Please help, i can as an alternative mount the disk on another mac (g5ppc), what can i do to totally restore permissions and be able to boot again?

Damned permissions!! :D
Thanks for any suggestion





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy