Jump to content

Dual display - plist question


  • Please log in to reply
5 replies to this topic

#1
sandwer

sandwer

    InsanelyMac Protégé

  • Donators
  • 97 posts
I added an ADD2 card to my setup yesterday. Worked fine - I have a SGI 1600SW on the VGA port via an SGI MultLink adaptor (which has always and still works fine)[*] and a second SGI 1600SW routed via the ADD2 port, through a GFX1600 converter (which is just a PCI card based MultiLink adaptor). Anyway - it worked fine. I had my dual desktop working fine (a desktop of 3200 x 1024 which is pretty spacious by any standards!).
I was about to post my success with this setup, when I thought I'd play around with some of the dual display settings. I ticked the box for "mirror" desktops.....

Of course, it barfed...I'm now left with a single screen, and 10.4.4 will only boot with the VGA port active - I can plug in the second monitor, and tell it to detect displays, but I get nothing but garbage on both screens. The same garbage on both screens....if thats important.

So I figure I need something as simple as a quick plist setting to turn mirror mode off, as it was working fine without that option ticked....

Any clues where I can look? I've had a look around, but there is nothing obvious. Has anyone come across the setting on their travels? Of course, this may well be the excuse I need for a completely fresh install....:)

Rich

[*] The SGI 1600SW uses a now defunct connector and requires an adaptor to use VGA or DVI....

#2
bofors

bofors

    ConvertIt2Mac.com

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,462 posts
I think you need to edit com.apple.windowserver.plist in /Library/Preferences/. In the "DisplaySets" under "0" you should have your two displays: "0" and "1", within their settings find "Mirrored" and set it to "O" (shown below).

On a related note, I tried setting my displays to mirrored and it seemed to bork as well, but I did not get junk just plain blue screens. However on rebooting, my mirroring did work and I was able to reset to extended desktop mode.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>CGSInterocitorSelectMode</key>
	<integer>0</integer>
	<key>Compositor</key>
	<dict>
		<key>deferredUpdates</key>
		<integer>1</integer>
	</dict>
	<key>DisplayLayoutToRight</key>
	<true/>
	<key>DisplayMainOnInternal</key>
	<false/>
	<key>DisplaySets</key>
	<array>
		<array>
			<dict>
				<key>Active</key>
				<integer>1</integer>
...
				<key>MirrorID</key>
				<integer>0</integer>
				<key>Mirrored</key>
				<integer>0</integer>
...
			</dict>
			<dict>
				<key>Active</key>
				<integer>1</integer>
...				<key>MirrorID</key>
				<integer>0</integer>
				<key>Mirrored</key>
				<integer>0</integer>
...
			</dict>
		</array>
	</array>
	<key>GLCompositor</key>
	<dict>
		<key>tileHeight</key>
		<integer>256</integer>
		<key>tileWidth</key>
		<integer>256</integer>
	</dict>
	<key>Quartz2DExtremeEnabled</key>
	<false/>
</dict>
</plist>


#3
winnimac

winnimac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 140 posts
  • Gender:Male
  • Location:Austria

I think you need to edit com.apple.windowserver.plist in /Library/Preferences/. In the "DisplaySets" under "0" you should have your two displays: "0" and "1", within their settings find "Mirrored" and set it to "O" (shown below).

On a related note, I tried setting my displays to mirrored and it seemed to bork as well, but I did not get junk just plain blue screens. However on rebooting, my mirroring did work and I was able to reset to extended desktop mode.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>CGSInterocitorSelectMode</key>
	<integer>0</integer>
	<key>Compositor</key>
	<dict>
		<key>deferredUpdates</key>
		<integer>1</integer>
	</dict>
	<key>DisplayLayoutToRight</key>
	<true/>
	<key>DisplayMainOnInternal</key>
	<false/>
	<key>DisplaySets</key>
	<array>
		<array>
			<dict>
				<key>Active</key>
				<integer>1</integer>
...
				<key>MirrorID</key>
				<integer>0</integer>
				<key>Mirrored</key>
				<integer>0</integer>
...
			</dict>
			<dict>
				<key>Active</key>
				<integer>1</integer>
...				<key>MirrorID</key>
				<integer>0</integer>
				<key>Mirrored</key>
				<integer>0</integer>
...
			</dict>
		</array>
	</array>
	<key>GLCompositor</key>
	<dict>
		<key>tileHeight</key>
		<integer>256</integer>
		<key>tileWidth</key>
		<integer>256</integer>
	</dict>
	<key>Quartz2DExtremeEnabled</key>
	<false/>
</dict>
</plist>




Hi,

how you have reset to extended desktop mode?

mirroring works perfect.

thanks for repost, winnimac

#4
bofors

bofors

    ConvertIt2Mac.com

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,462 posts

how you have reset to extended desktop mode?


I simply unchecked the "Mirror Displays" check box in System Preferences->Displays->Arrangement.

#5
sandwer

sandwer

    InsanelyMac Protégé

  • Donators
  • 97 posts
Hey Bofors, thanks for the push in the right direction.

Of course, it wouldn't be that simple....! I'd assumed that turning the mirroring off would be the workaround.
Its not that the mirroring is turned on or off in the plist, its a hardware issue. Now the external MultiLink adaptor is recognised by OS X as a bona fide display...and that is fine. The internal MultiLink...well thats another story. If you recall I had the DVI output from the ADD2 card fed into the Internal MultiLink, and the monitor connected to the output. When you ask OS X to get Displays, its fine for the external multilink, as it understands that. The internal one doesn't present itself correctly, and defaults to garbage on the screen....of course, I had mine mirrored, so I got garbage on both by default when it detected a second display. Replacing the plist with your one didn't seem to make any difference.

But...chucking out the internal card, and routing the DVI output to a second external MultiLink that OS X recognised as a legit second display sorted it out.

Rich

#6
winnimac

winnimac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 140 posts
  • Gender:Male
  • Location:Austria

I simply unchecked the "Mirror Displays" check box in System Preferences->Displays->Arrangement.


Hi,
i dont have this checkbox, you know why?
greetz





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy