Jump to content

Hide drives in refit


  • Please log in to reply
2 replies to this topic

#1
jdouglas25

jdouglas25

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
  • Location:Indianapolis
I have an early 2008 mac pro with 4 hard drives. Drive 1 is a WD Velociraptor split into two partitions: an HFS+ partition containing Snow Leopard, and an NTFS partition that contains my windows 7 program files. Drive 2 is an OCZ ssd with an NTFS partition containing Windows 7. Drive 3 is a WD 2TB drive with an NTFS partition for data. Drive 4 is a Seagate 1.5TB drive with another NTFS partition for data.

I installed refit and while it works, it shows all 4 NTFS partitions. Is it possible to remove the 3 non-bootable ones from the refit menu?

#2
nbreslow

nbreslow

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I have a dual boot setup with OSX 10.6 installed on its own 500gb drive (disk0), Windows 7 x64 installed on its own 300gb drive (disk1), and have rEFIt installed as a boot loader. Additionally I have a 1tb data disk for Windows (disk2 NTFS) and a 1tb data disk for OSX (disk3 HFS). The problem is that rEFIt lists four OS options on its boot menu when there should only be two (OSX or Win7). One of the extras is an option to boot a ‘Legacy OS’, the other is a duplicate of the Win7 option but doesn’t actually boot anything if selected. I have attempted to use the rEFIt partition sync tool, tried repairing the disks from the OSX install CD Disk Utility and have searched all over the internet for a way to clean up my boot tables with no luck. Here is the report from the rEFIt partition utility inside OSX followed by my diskutil list:

*** Report for internal hard disk ***

Current GPT partition table:
# Start LBA End LBA Type
1 40 409639 EFI System (FAT)
2 409640 976510983 Mac OS X HFS+

Current MBR partition table:
# A Start LBA End LBA Type
1 1 409639 ee EFI Protective
2 * 409640 976510983 af Mac OS X HFS+

MBR contents:
Boot Code: Unknown, but bootable

Partition at LBA 40:
Boot Code: None (Non-system disk message)
File System: FAT32
Listed in GPT as partition 1, type EFI System (FAT)

Partition at LBA 409640:
Boot Code: None
File System: HFS Extended (HFS+)
Listed in GPT as partition 2, type Mac OS X HFS+
Listed in MBR as partition 2, type af Mac OS X HFS+, active

diskutil list

/dev/disk0
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *500.1 GB disk0
1: EFI 209.7 MB disk0s1
2: Apple_HFS System 499.8 GB disk0s2
/dev/disk1
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *300.1 GB disk1
1: EFI 209.7 MB disk1s1
2: Microsoft Basic Data Windows 299.9 GB disk1s2
/dev/disk2
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *1.0 TB disk2
1: EFI 209.7 MB disk2s1
2: Microsoft Basic Data Files 1000.0 GB disk2s2
/dev/disk3
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *1.0 TB disk3
1: EFI 209.7 MB disk3s1
2: Apple_HFS Data 999.9 GB disk3s2

Same problem as the OP and I have seen it around the net. Any idea how to get the boot table in order? Thanks in advance,

-NBreslow

#3
VolumetricSteve

VolumetricSteve

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
This might just be the kind of thing that's not supported yet..it might be possible...maybe....if you mess around in the EFI shell that something would be able to cloak a partition, but I haven't see too much documentation there either.
In fact, I find when I tried to figure this out, I loaded up the EFI shell in refit, and typed "help" which worked...but...there doesn't seem to be a help/p command like in dos, so I don't know how to see all of the output!

I'm sure this is something that could be easily fixed by whomever controls the EFI code. I'd wait for version .15





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy