Jump to content

Asus P5E DSDT fixes


  • Please log in to reply
294 replies to this topic

#201
bubbahotep

bubbahotep

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

post a kextstat

run on terminal

kextstat


Hi Maldon,

thank you very much for looking into this...

here is what I do:
- boot ##### and install 10.6.3
- run combo update
- run ##### 3.3 with UserDSDT, SystemUtils, Evoreboot, fakesmc, IOUSBrollback, Lnx2MAc Realtek 81x, chameleon rc5 r748, osxsoftware

- install ad1998b.kext

sound ok, no sleep, reboot ends in shutdown reason 3

Here are my files:
dsl unedited - original directly after install, no #####
dsl patched - dsl patched with http://code.google.c...DeluxeChangeLog
kextstat after #####
send_me.zip - collection of config directly after update to 10.6.6

best regards
bubba

Attached Files



#202
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 11,137 posts
  • Gender:Male
  • Location:Rio de Janeiro

here is what I do:
- boot iboot and install 10.6.3
- run combo update
- run multibeast 3.3 with UserDSDT, SystemUtils, Evoreboot, fakesmc, IOUSBrollback, Lnx2MAc Realtek 81x, chameleon rc5 r748, osxsoftware

- install ad1998b.kext

sound ok, no sleep, reboot ends in shutdown reason 3


use DSDT Auto-patcher

add in boot.plist
<key>GeneratePStates</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
remove EvOreboot and NullCPUPowerManagement

after reboot
run on terminal
ioreg -lw0 | grep CSTInfo


#203
bubbahotep

bubbahotep

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

use DSDT Auto-patcher

add in boot.plist

<key>GeneratePStates</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
remove EvOreboot and NullCPUPowerManagement

after reboot
run on terminal
ioreg -lw0 | grep CSTInfo


Hi,

did that. manual sleep seems to be working now... automatic sleep doesnt, screen goes blank, pc keeps powered on, dvd access from time to time. to see console system.log attached

still shutdown,reboot doesn't.

I searched for a boot logging to .txt option and could not find one. Is there a way I can capture the boot -v data in a text file and upload it to the thread ?

alos I have two com.apple.boot.plists:
one in L/P/Systemconfig
one in /Extra

which one is used ?

I also have extensions in:
/S/L/E
and
/Extra

are both loaded ? how can I check that ?


best regards
Bubba

Attached Files



#204
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,840 posts
  • Gender:Male
  • Location:Brazil
You can use
cat /var/log/kernel.log

If you have boot.plist in /Extra it will be used.

Kexts from both /S/L/E and /E/E are loaded.

Are you using Chameleon RC5?

#205
bubbahotep

bubbahotep

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

Are you using Chameleon RC5?


using ##### & ##### with Chameleon 2.0 RC5 - ATI Experimental to r748, check C2rc5r748 in ##### during multibeats patching.

#206
bubbahotep

bubbahotep

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
ok, applied the auto patcher for p5e today, my p5e deluxe wifi ap is not in the list.

applied openhaltrestart.kext

still reboot, shutdown not working. sleep works manually, automatically i get an immediate wakeup from usb1, pc is not going to sleep noticably

Mar 7 18:43:23 christians-Mac-Pro kernel[0]: System Sleep
Mar 7 18:43:28 christians-Mac-Pro kernel[0]: Wake reason = USB1
Mar 7 18:43:28 christians-Mac-Pro kernel[0]: System Wake
Mar 7 18:43:28 christians-Mac-Pro kernel[0]: USB (UHCI):Port 2 on bus 0x3d has remote wakeup from some device

im at a loss on how to fix that....could anyone give me a hand please ?

cheers
bubba

#207
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,840 posts
  • Gender:Male
  • Location:Brazil
Your mobo is in the list

P5E3 Premium Wifi APsolo, last modified Jan 30


Use Chameleon and Extra folder from Auto-Patcher topic, don't use Multibeast.

Don't install OpenHaltRestart, restart fix is in Chameleon RC5 and shutdown patch is applied in DSDT.

Do you have something connected to USB ports (other than keyboard and mouse)?

You can try removing _PRW from USB port which is causing immediate wake after sleep.

#208
bubbahotep

bubbahotep

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

Your mobo is in the list


Use Chameleon and Extra folder from Auto-Patcher topic, don't use #####.

Don't install OpenHaltRestart, restart fix is in Chameleon RC5 and shutdown patch is applied in DSDT.

Do you have something connected to USB ports (other than keyboard and mouse)?

You can try removing _PRW from USB port which is causing immediate wake after sleep.


Hi OldNapalm,

I have the p5e3 deluxe wifi, which is X38. The Premium is x48. The Deluxe is not listed. Does that make a difference ? I looked at the results of patching with p5e3 and p5e3premium and the dsdt's are quite different.

got manual sleep to work. now sometimes when I wake up the PC the screen comes back with white noise. If I cycle the monitor inputs, its rests and displays the dektop.
any idea how to fix that ?

Repost on resume os active in Bios.

also I tried to remove _prw in USB1:
Device (USB1)
			{
				Name (_ADR, 0x001D0001)
				OperationRegion (BAR0, PCI_Config, 0xC4, One)
				Field (BAR0, ByteAcc, NoLock, Preserve)
				{
					USBW,   2, 
							Offset (0x01)
				}

				Method (_S3D, 0, NotSerialized)
				{
					If (LOr (LEqual (OSFL (), One), LEqual (OSFL (), 0x02)))
					{
						Return (0x02)
					}
					Else
					{
						Return (0x03)
					}
				}

				Method (_PSW, 1, NotSerialized)
				{
					If (Arg0)
					{
						Store (0x03, USBW)
					}
					Else
					{
						Store (Zero, USBW)
					}
				}

				Method (_PRW, 0, NotSerialized) [b]<-- Deleted[/b]
				{											  [b]<-- Deleted[/b]
					Return (GPRW (0x04, 0x04))  [b]<-- Deleted[/b]
				}											  [b]<-- Deleted[/b]

				Method (_DSM, 4, NotSerialized)
				{


my system prefs show this for my mouse:

Product ID: 0xc52b
Vendor ID: 0x046d (Logitech Inc.)
Version: 12.01
Speed: Up to 12 Mb/sec
Manufacturer: Logitech
Location ID: 0x5d100000
Current Available (mA): 500
Current Required (mA): 98

Console:
Mar 9 10:04:17 christians-Mac-Pro kernel[0]: System Sleep
Mar 9 10:04:25 christians-Mac-Pro kernel[0]: Wake reason = USB2
Mar 9 10:04:25 christians-Mac-Pro kernel[0]: System Wake
Mar 9 10:04:25 christians-Mac-Pro kernel[0]: The USB device USB Receiver (Port 1 of Hub at 0x5d000000) may have caused a wake by issuing a remote wakeup (2)


but no change, the system still wakes up on mouse movement.

are these the right lines to delete ?

best regards and thanks for all the help !
Bubbahotep

Attached Files



#209
bubbahotep

bubbahotep

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
Hi again,

I believe I got it all running on my p5e3 deluxe wifi ap, 8 GB ram, 8800 GTS

Here is what I did to get osx 10.6.6 running on the p5e3 deluxe wifi ap.

In my bios i set the ata controlelrs to achi and disabled energy saver 4.0c

used ##### 2.7 and installed osx 10.6.3, installed the 10.6.6 combo update.

downloaded dsdt se and araxis merge eval.

using the p5e3 deluxe dsdt from here: http://code.google.c...dsl?repo=deluxe
i compared my extracted dsdt to this one using araxis merge and copied the parts that are listed, leaving the ram and cpus parts untouched.

pasted new the dsdt back into dsdt se, compiled and saved it on the desktop as dsdt.aml

then i ran ##### 3.3 with the user dsdt and the following options:
system utilities
IOAHBblockstorageinjector
fakesmc
elliotforcelegacyrtc
LNx2Mac Realtek lan drivers
osx86 software

I manually added the ad1988b.kext using kext util.

then I added the c and p states and suggested on google code to the com.apple.boot.plist

I noticed that sleep didnt kick in with the energy saver settings. when i set it to sleep after 5 minutes, it never went to sleep after 10 minutes. that drove me crazy.

It actually works but i guess osx was busy and it took much longer (30 min) for sleep to kick in. so I never noticed while sitting at the pc, as I never waited long enough.
I always thought I wasnt doing the install correctly, while all the time it already worked.

I also installed the tonymacx86 nvidia drivers, not sure if they do anything though.

I eventually found this tool:
Please Sleep
http://www.dragonone...sx/pleasesleep/

and now manual sleep, timed sleep works perfectly. shudown and reboot work without any kexts (NO nullpower, evoreboot, openhaltrestart, sleepenabler and OldNapalm suggested.)

I still get system shutdown false and shutdown reason 3 in the boot log, but I read somewhere that this is "normal" even on apple hardware. (that also drive me nuts).

also the appleHDA complains and there is a post somehwere to fix it changing the pci vendor id or something. but my sounds works, so i didnt bother.

thanks all for the help in this forum!!! I cant wait to setup my next hackintosh.

cheers
bubba

#210
afiser

afiser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
anyone with a P5E get lion to work?

i havent tried yet, i havent had the time. but i would just like to get familiarized with p5e experiences before i drive straight in.

#211
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,840 posts
  • Gender:Male
  • Location:Brazil
I got it running using iBoot, the same DSDT used in Snow Leopard, just adding C-states and nVidia device properties injection.

Ethernet needed plist edit (AppleYukon2.kext edit IOPCIPrimaryMatch and remove IOPCISecondaryMatch).

AppleHDA legacy used in Snow Leopard didn't work. VoodooHDA works for output.

#212
afiser

afiser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
thanks for the info, i suppose ill just wait until the GM comes out. snow leopard seems to be fine for now. lion seems like a hassle for what little is added to it lol

#213
afiser

afiser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
did a reinstall recently and im not sure what i missed because ive done so many many times before, but on this particular reinstall shutdown is failing to work. my external hard drives stay powered and my case fans stay on but my power light goes off on my case.

it used to shut down completely and everything would shut down with it.

im using a vanilla install (no mods besides applications on my install partition)

i am using fakesmc.kext, legacyappleyukon, AD1998B, and a disabler that only disables AppleUpstreamUserClient because i suffer from mouse lag when itunes or quicktime is on and if that is disabled it fixes it. my kexts are packaged in an extensions.mkext

here is my boot.plist since its the only thing i can think of that would have a bearing on this and im using chameleon RC5 rev 747

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Boot Banner</key>
	<string>No</string>
	<key>GenerateCStates</key>
	<string>Yes</string>
	<key>GeneratePStates</key>
	<string>Yes</string>
	<key>Graphics Mode</key>
	<string>1920x1200x32</string>
	<key>Hide Partition</key>
	<string>hd(1,2)</string>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Kernel Flags</key>
	<string></string>
	<key>Legacy Logo</key>
	<string>Yes</string>
	<key>RestartFix</key>
	<string>Yes</string>
	<key>Timeout</key>
	<string>5</string>
</dict>
</plist>

any help would be greatly appreciated.

obviously i have a p5e, intel cpu E7650, nvidia 8800GTX+

if any more info is needed let me know. btw restart works perfectly fine.

#214
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,840 posts
  • Gender:Male
  • Location:Brazil
Are you using the DSDT auto-patcher? Did you check if shutdown patch is applied?

#215
atomiX_X

atomiX_X

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Location:Canada, eh!
Has anyone here had any problems waking from sleep on 10.6.7? The system will sleep fine but when woken up (from USB KB/mouse or power button), the system will wake but hang with no video out so I couldn't see what was going on.

DSDT
Chameleon RC5
fakesmc
Yukon GbE (dummy kext)
(no sleepenabler)

I'll be troubleshooting when I get back home tonight.

Thanks

#216
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,840 posts
  • Gender:Male
  • Location:Brazil
I had this problem on 10.6.6, found that the cause was video (nVidia) drivers. Restored 10.6.5 drivers (NV*, GeForce*) and sleep/wake worked again. No problem after 10.6.7 update, I guess nVidia drivers were not updated, they were last modified on 19/feb/2011.

#217
atomiX_X

atomiX_X

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Location:Canada, eh!
Thanks for the tip oldnapalm. I'll give that a try later. I never had any problems on 10.6.6 though so I'll try those drivers and see.

#218
atomiX_X

atomiX_X

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Location:Canada, eh!
I wasn't able to get it to work by replacing the video drivers. Nothing out of the ordinary in system.log either. I've been meaning to make a new DSDT from scratch so this might give me a reason to do so.

Update: I was able to get it to work using the SleepEnabler kext for 10.6.7 from this thread. I've never had to use SleepEnabler for sleep before but I don't feel like digging to find exactly why it doesn't work otherwise. This is good enough for me until 10.6.8 :)

#219
afiser

afiser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts

Are you using the DSDT auto-patcher? Did you check if shutdown patch is applied?



thanks for the pointers, my install was acting wierd with random KP's and such so i reinstalled again and remade my DSDT with the auto patcher, and all is working perfectly

and to contribute to the nvidia problem, i have a 9800GTX+ and i am not suffering the sleep problem. sleep works fine for me. must be newer graphics cards.

#220
jussy

jussy

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Hi guys,
I got a Asus P5E3 (standard), not deluxe, not premium.
May I use this dsdt or should make my own?
Anyone knows where to find?
Many thanks.
Best regards.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy