Jump to content

Firewire issues


  • Please log in to reply
98 replies to this topic

#81
polkaholga

polkaholga

    InsanelyMac Geek

  • Donators
  • 151 posts
  • Gender:Male
  • Location:Otherland
...try the attached dsdt

Like this it works for me.

Attached Files

  • Attached File  dsdt.zip   13.41KB   76 downloads


#82
mwolski

mwolski

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Unfortunately it's not working.

FRWR still prevents system from sleeping.

#83
polkaholga

polkaholga

    InsanelyMac Geek

  • Donators
  • 151 posts
  • Gender:Male
  • Location:Otherland
while reading your aml file i've seen the following....
[codebox]
Device (SLPB)
{
Name (_HID, EisaId ("PNP0C0E"))
}
[/codebox]

under Scope (_SB).

Is this some kind of "Sleepbutton" device? Maybe you should change Method 1A in a way that you notify SLPB instead of PWRB...

just a guess but i would try it...

#84
mwolski

mwolski

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
I did that and nothing changed.

Damn, I have no idea what cause this problem :/

#85
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,695 posts
  • Gender:Male
  • Location:Canary Islands
Hi all!

One question...

Where is locate the "info.plist" (and his kext) relate to firewire??? Like the AppleYukon2 for the Lan?

TIA

Fabio

#86
barbaroja

barbaroja

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
reporting here that the initial metod now lets me turn off and on my FW audio card with no issues. thanks!

#87
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,121 posts
  • Gender:Male
  • Location:Brazil

Where is locate the "info.plist" (and his kext) relate to firewire??? Like the AppleYukon2 for the Lan?

IOFireWireFamily.kext/Contents/PlugIns/AppleFWOHCI.kext.

But you can't do much with that, firewire is matched using device class, not device IDs.

#88
RayFlower

RayFlower

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
Attached File  Screen_shot_2010_11_13_at_8.02.22_AM.png   161.71KB   72 downloads

I might be a complete moron but I can't find fw in my dsdt at all:

My lspci say:

sudo lspci -nn
00:00.0 Host bridge [0600]: ATI Technologies Inc RD780 Northbridge only dual slot PCI-e_GFX and HT1 K8 part [1002:5958]
00:02.0 PCI bridge [0604]: ATI Technologies Inc RD790 PCI to PCI bridge (external gfx0 port A) [1002:5978]
00:04.0 PCI bridge [0604]: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port A) [1002:597a]
00:0a.0 PCI bridge [0604]: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port F) [1002:597f]
00:11.0 SATA controller [0106]: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode] [1002:4391]
00:12.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
00:12.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398]
00:12.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
00:13.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398]
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 3c)
00:14.1 IDE interface [0101]: ATI Technologies Inc SB700/SB800 IDE Controller [1002:439c]
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB700/SB800 LPC host controller [1002:439d]
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384]
00:14.5 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller [1002:4399]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration [1022:1200]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map [1022:1201]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller [1022:1202]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control [1022:1203]
00:18.4 Host bridge [0600]: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control [1022:1204]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Unknown device [1002:68be]
01:00.1 Audio device [0403]: ATI Technologies Inc Unknown device [1002:aa58]
02:00.0 IDE interface [0101]: JMicron Technology Corp. 20360/20363 Serial ATA Controller [197b:2363] (rev 02)
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 02)
04:0e.0 FireWire (IEEE 1394) [0c00]: Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link) [104c:8024]

And....
ioreg | grep FireWire
	| |   |	   +-o IOFireWireController  <class IOFireWireController, id 0x1000001ec, registered, matched, active, busy 0 (23087 ms), retain 13>
	| |   |		 +-o IOFireWireLocalNode  <class IOFireWireLocalNode, id 0x100000225, registered, matched, active, busy 0 (8184 ms), retain 12>
	| |   |		 | +-o IOFireWireUserClientIniter  <class IOFireWireUserClientIniter, id 0x100000226, !registered, !matched, active, busy 0, retain 4>
	| |   |		 | +-o IOFireWireUserClientIniter  <class IOFireWireUserClientIniter, id 0x1000002b1, !registered, !matched, active, busy 0, retain 4>
	| |   |		 | +-o IOFireWireIP  <class IOFireWireIP, id 0x1000002b2, registered, matched, active, busy 0 (6 ms), retain 5>
	| |   |		 +-o IOFireWireDevice@a9200d9071724  <class IOFireWireDevice, id 0x10000022b, registered, matched, active, busy 0 (23086 ms), retain 12>
	| |   |		   +-o IOFireWireUnit  <class IOFireWireUnit, id 0x10000022d, registered, matched, active, busy 0 (23082 ms), retain 10>
	| |   |		   | +-o IOFireWireUserClientIniter  <class IOFireWireUserClientIniter, id 0x10000022f, !registered, !matched, active, busy 0, retain 4>
	| |   |		   | +-o IOFireWireAVCUnit  <class IOFireWireAVCUnit, id 0x1000002a2, registered, matched, active, busy 0 (15096 ms), retain 6>
	| |   |		   |   +-o IOFireWireAVCSubUnit  <class IOFireWireAVCSubUnit, id 0x1000002a3, registered, matched, active, busy 0 (1519 ms), retain 4>
	| |   |		   |   +-o IOFireWireAVCSubUnit  <class IOFireWireAVCSubUnit, id 0x1000002a4, registered, matched, active, busy 0 (15096 ms), retain 5>
	| |   |		   +-o IOFireWireUserClientIniter  <class IOFireWireUserClientIniter, id 0x10000022e, !registered, !matched, active, busy 0, retain 4>

Oh and here is my DSDT if anyone wouldn't mid giving me a "push" in the right direction...
http://pastebin.com/0BLAAnFw

#89
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,121 posts
  • Gender:Male
  • Location:Brazil
http://www.insanelym...p...t&p=1395770

#90
RayFlower

RayFlower

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
So it's 0x040E0000 ?

Sorry for my noobishness, I just thought I would've been listed in my dsdt, I'm a bit confused about which device i should create it under, P2P seems like the obvious choice considering the tree in ioreg.

Ideas?

#91
FKA

FKA

    are we there yet?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,626 posts
  • Gender:Male

http://www.insanelym...p...t&p=1395770


Jus out of ineterest - if the DSDT patch is done correctly do you get a firewire icon on the top bar that looks a bit like a TV? (sorry no screen grabs!)

I ask as with my currently RMA'd MSI board and UEFI BIOS i saw this firewire icon for the first time and havent been able to see it with any other none UEFI BIOS build and couldn't find anything in the UEFI BIOS's DSDT code that related.

It didn't do much apart from have firewire preferences and alow to turn firewire off - but it was quite comforting to see :(

#92
barbaroja

barbaroja

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts

reporting here that the initial method now lets me turn off and on my FW audio card with no issues. thanks!


oops talked fast. is working at least intermittently now (hotplug). sometimes it works sometimes not. The power message is not there, though.

#93
hxall

hxall

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
first time posting in this forum, but a bit stuck with Firewire, have applied the DSDT fix shown here and get the following in the console logs:

FireWire (OHCI) TI ID 8024 built-in now active, GUID 0016e60000ba9132; max speed s400.
System Profiler[913] SPFWR ERROR: FireWire bus may be unstable. Other FireWire devices may be present.

Profiler also indicates "Unable to list FireWire devices"

have read elsewhere that HPET interrupts could cause the problem, but if I remove the HPET.kext I get kernel panics, any advice?


BTW, I have a Gigabyte GA-P965-DQ6 running 10.6.5 installed with kakewalk, running in 64bit mode, all's working fine except firewire, same PC is running Vista with a separate HDD and firewire works fine.

#94
hxall

hxall

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
anyone?

first time posting in this forum, but a bit stuck with Firewire, have applied the DSDT fix shown here and get the following in the console logs:

FireWire (OHCI) TI ID 8024 built-in now active, GUID 0016e60000ba9132; max speed s400.
System Profiler[913] SPFWR ERROR: FireWire bus may be unstable. Other FireWire devices may be present.

Profiler also indicates "Unable to list FireWire devices"

have read elsewhere that HPET interrupts could cause the problem, but if I remove the HPET.kext I get kernel panics, any advice?


BTW, I have a Gigabyte GA-P965-DQ6 running 10.6.5 installed with kakewalk, running in 64bit mode, all's working fine except firewire, same PC is running Vista with a separate HDD and firewire works fine.



#95
hxall

hxall

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

anyone?


can anyone help here? :D

#96
man_bites_dog

man_bites_dog

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
  • Location:London
Hi all

I'm a DSDt newb and have been trying unsuccessfully to install the firewire hack code into my DSDT. Is there a good place to learn DSDT editing?

Any help appreciated.

Thanks

#97
bookooone

bookooone

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Ok guys,

my firewire isn't working at all. p5kc mobo -> cossflashed to p5kr.
##### method and #####. i have a connected tascam audiointerface
on port 1. it will be listed as unknown device. any suggestions?


Attached File  Profiler.tiff   82.86KB   11 downloads

Attached File  Console.tiff   110.67KB   9 downloads

Attached File  dsdt.zip   1.64KB   9 downloads

#98
cero

cero

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hello,
i need Help with a annoying Problem.
When i go to sleep from Apple Menue OSX needs some seconds to go to sleep, thats fine.
But when OSX wakesup it crashes with the Grey screen which tells me to shut down the Unit.
This happens only when the Firewire RME Firewire was pluged in which is on.
When i switch the Firewire Audio Interface off before waking up and switch it on when the Unit has waked up, all runs well.

console:
10.03.12 08:26:08,000 kernel: FireWire runtime power conservation disabled. (2)
10.03.12 08:26:08,000 kernel: FireWire (OHCI) TI ID 8024 PCI now active, GUID 007be5450000241d; max speed s400.
10.03.12 08:26:08,000 kernel: FireWire runtime power conservation disabled. (2)
10.03.12 08:26:08,000 kernel: FireWire (OHCI) TI ID 8235 PCI now active, GUID 000000000000002e; max speed s400.

Can someone help me to fix this problem, what information do you need from me ?

I tried to upload all files for your information like DSDT, IOReport, but get only errors ....
I tried it with Safari, Chrome and Firefox, no upload function also the flash uploader don`t function. (???)

I`m running 10.7.3 on a GA-X58-UD4 F10 with a User built DSDT, not from me.
The Nvidia GTX 285 runs fine with Graficsenabler on.
In my Extra Folder is only Fakesmc.kext.
Running Chimera 1.8 as Boot.
Thanks in advance
Ripley

#99
rajapt

rajapt

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male

HI there people i have same problem here Firewire runtime power disable
My machine is Desktop pc _main board Asus P5E deluxe, Q660,DDR2 8 gbt (800mgz) GT9500, ASMedia AS1061, OCZ Vector 128, firewire pci card VT6306/7/8....
can anyone help me out where

 

Thanks

 

Attached File  Captura de ecrã 2013-12-4, às 14.45.09.png   895.2KB   0 downloads

 

 

Attached File  Captura de ecrã 2013-12-4, às 14.45.09 (2).png   841.67KB   0 downloads







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy