Jump to content

Como se inyecta el video en Chameleon 2.0 RC3 ?


  • Please log in to reply
4 replies to this topic

#1
iorg

iorg

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
Attached File  Picture_1.jpg   50.75KB   40 downloads

Actualmente tengo el EFI string en device-properties en el boot.plist

pero usando el nuevo chamaleon 3 junto con el efi 10.5
se puede usar el GraphicEnabler peor tengo la duda
de que tambien se puede inyectar directamente el .rom de la tarjeta Nvidia 7300GT

- como debe ser la redacción correcta en el boot.plist ?
- Una vez inyectado en el chamaleon videoROM, se deja de usar el EFI string en device-properties ??

Este es mi com.appleBoot.plis t.......

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Boot Banner</key>
<string>No</string>
<key>EthernetBuiltIn</key>
<string>y</string>
<key>ForceWake</key>
<string>y</string>
<key>GUI</key>
<string>No</string>
<key>Graphics Mode</key>
<string>1680x1050x32@60Hz</string>
<key>GraphicsEnabler</key>
<string>y</string>
<key>Instant Menu</key>
<string>No</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=386</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Quiet Boot</key>
<string>No</string>
<key>Timeout</key>
<string>5</string>
<key>USBBusfix</key>
<string>y</string>
<key>VBIOS</key>
<string>y</string>
<key>VideoROM</key>
<string></string>
<key>Wake</key>
<string></string>
<key>device-properties</key>
<string>5c0200000100000001000000500200000d00000002010c00d041030a010000000101060000010
101060000007fff04000e0000004e00560050004d0000002000000001000000000000000000000000
000000000000000000000000000000220000005600520041004d002c0074006f00740061006c00730
069007a006500000008000000000000101c0000006400650076006900630065005f00740079007000
650000000f0000004e5644412c506172656e740e0000006e0061006d00650000000b0000006469737
06c617922000000400030002c006400650076006900630065005f00740079007000650000000b0000
00646973706c617922000000400031002c006400650076006900630065005f0074007900700065000
0000b000000646973706c6179100000006d006f00640065006c000000120000004e76696469612020
37333030475420000000400031002c0063006f006d00700061007400690062006c00650000000e000
0004e5644412c4e564d616314000000400030002c006e0061006d0065000000120000004e5644412c
446973706c61792d4114000000400031002c006e0061006d0065000000120000004e5644412c44697
3706c61792d4220000000400030002c0063006f006d00700061007400690062006c00650000000e00
00004e5644412c4e564d6163100000004e00560043004100500000001800000004000000000003000
c00000000000007000000001e00000072006f006d002d007200650076006900730069006f006e0000
00260000004e76696469612020373330304754204f70656e474c20456e67696e65205b4546495d</string>
</dict>
</plist>

ahi alguien que tenga bien inyectado el video desde chamaleon y pcefi 5 que me de una explicada
tambien uso el DSDT pero solo es para que el snow no me reconfiguere el bios al reiniciar el cmos. (Placa gigabyte)

GA-EG31M-S2 (rev. 1.0) compatible totalmente con tiger,leo y snowwy (10.4, 10.5, y 10.6 )

Saludos

#2
chico_stang

chico_stang

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
Para inyectar el video con Chameleon + PCEFI necesitas remover el device-properties string del com.apple.boot.plist (en el folder /Extra). Luego añade "GraphicsEnabler=Yes". Por lo que veo lo tienes bien. En caso de que no reconozca la tarjeta correctamente, intenta subir con -pci1 ya que el PCEFI v10.5 creo que viene por defecto en pci0 y no funciona en algunas tarjetas. EN conclusion, no necesitas ningun kext de video, ni EFI string en el com.apple.boot.plist, sino solo la linea de "GraphicsEnabler".

#3
iorg

iorg

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
gracias,si ya intente configurarlo asi ( -pci1 ) y funciono pero no como esperaba el resultado fluido como esperaba, supongo que es porque el snow ya empieza a ver estas tarjetas como viejitas nvidia serie 7300,7600, 7900

en cambio las serie nvidia 9000 funcionan de maravilla.

Saludos

#4
iorg

iorg

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
supongo que en esta linea:

<key>VideoROM</key>
<string>Nvidia.rom</string>

Nvidia.rom es el rom de la tarjeta extraido con el NVFLASH con el MSDOS y puesto en el root ( / Nvidia.rom ) del directorio del disco no?

o alguna idea de como va editado esa sección.?

gracias!

#5
chico_stang

chico_stang

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts

supongo que en esta linea:

<key>VideoROM</key>
<string>Nvidia.rom</string>

Nvidia.rom es el rom de la tarjeta extraido con el NVFLASH con el MSDOS y puesto en el root ( / Nvidia.rom ) del directorio del disco no?

o alguna idea de como va editado esa sección.?

gracias!


Bueno, nunca he usado esa linea. No se que hace. Pero prueba borrandola del com.apple.boot.plist. Puede que no sea necesaria. Yo tengo una 8400 GS y funciona de maravilla utilizando solo el GraphicsEnabler y nada mas.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy