Jump to content

Broadcom 4312 mini PCI-E Snow Leopard


  • Please log in to reply
19 replies to this topic

#1
iSpliff

iSpliff

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
  • Gender:Male
  • Location:Switzerland
Hi,

Im running Snow Leopard 10.6.0 on my laptop but my Broadcom Wifi doesnt show up, although it should work OOB. My custom kexts in /Extra/Extensions are:
fakesmc
OpenHaltRestart
PlatformUUID
VoodooHDA
VoodooPS2Controller
...everything else is vanilla
Help please :S

iSpliff

#2
traderdude

traderdude

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Hi,

Im running Snow Leopard 10.6.0 on my laptop but my Broadcom Wifi doesnt show up, although it should work OOB. My custom kexts in /Extra/Extensions are:
fakesmc
OpenHaltRestart
PlatformUUID
VoodooHDA
VoodooPS2Controller
...everything else is vanilla
Help please :S

iSpliff


Hi I have the kexts your looking for use kext utility to install IONetworking and put IOPCMCIA in your extra file after you reboot you should have wireless I hope this works for you I got them from an other member and they have helped me get my wireless going

Attached Files



#3
iSpliff

iSpliff

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
  • Gender:Male
  • Location:Switzerland

Hi I have the kexts your looking for use kext utility to install IONetworking and put IOPCMCIA in your extra file after you reboot you should have wireless I hope this works for you I got them from an other member and they have helped me get my wireless going

Hi! Thanks much for your help but your method didnt work for me. But now i got it working too with the broadcom43xx enabler: http://www.insanelym...showtopic=51725

#4
Gordon Alfred

Gordon Alfred

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Hi! Thanks much for your help but your method didnt work for me. But now i got it working too with the broadcom43xx enabler: http://www.insanelym...showtopic=51725


The enabler works? It doesn't work for me

#5
traderdude

traderdude

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Hi just realized I forgot to tell anyone who down loads these kext don't forget to repair permissions

#6
rushtrader

rushtrader

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
If you got the enabler to work then you are not running 10.6.x, it only works on 10.5.x.

#7
Cissiboy

Cissiboy

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Singapore
I have a weird problem with this BCM4321 wireless card

It is seen as an Airport but it is off. If i try to turn on nothing happens.
What can i do ?

#8
rajas

rajas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 136 posts
  • Gender:Male
  • Location:USA

I have a weird problem with this BCM4321 wireless card

It is seen as an Airport but it is off. If i try to turn on nothing happens.
What can i do ?


try this:
http://www.insanelym...showtopic=44114

#9
Cissiboy

Cissiboy

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Singapore

try this:
http://www.insanelym...showtopic=44114


cool hope it works ! (it is supposed to work also in Snow Leopard right ?)

Thanks

#10
rajas

rajas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 136 posts
  • Gender:Male
  • Location:USA

cool hope it works ! (it is supposed to work also in Snow Leopard right ?)

Thanks


yup. i used that method for my e1505 running snow leopard 10.6.2 (also worked on 10.5.2 & 10.6.0)

#11
Cissiboy

Cissiboy

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Singapore
no luck so far..the "airport" is recognized but always off..

will try the "tape" trick

#12
Cissiboy

Cissiboy

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Singapore
also the tape trick on pin 10 didnt work..what to do ?

#13
rajas

rajas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 136 posts
  • Gender:Male
  • Location:USA
did you repair permissions after doing the steps?

#14
Cissiboy

Cissiboy

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Singapore

did you repair permissions after doing the steps?


yes..will try again tomorrow reinstalling Snowy

#15
Cissiboy

Cissiboy

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Singapore

yes..will try again tomorrow reinstalling Snowy


repaired permissions,reinstalled snowy, boot with -f

NO LUCK AT ALL

Always off

I have 3 wireless card available

Ralink 2780
RTL8191SE
BCM4321

no one working on Snow Leopard so far

#16
omz

omz

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hi, I am facing the same issue on a differnet laptop but same card,, did you manage to get this working since last month?

#17
rajas

rajas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 136 posts
  • Gender:Male
  • Location:USA
try this:
http://www.insanelym...p...t&p=1364000

#18
ZPK

ZPK

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:Russia/Yaroslavl
http://www.applelife...-airpor...B5но/

russian page but do not worry.....screenshots have)

#19
desireder

desireder

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Its seems good and I hope you will keep it up

#20
Tobicool

Tobicool

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
someone got a working solution?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy