Jump to content

[INSTALL/GUIDE] Snow Leopard On Dell E6500/E6400 in 8 simple steps, Dual boot Windows 7 Instruction Included


  • Please log in to reply
177 replies to this topic

#161
albert E

albert E

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts

rachanta!!!!!!!!!! Please I beg of your E6400 MASTERY! Show me the way Sifu. train me in the arts lol. Kudos to you though you have the configuration I need. Please if you can post a baby step by baby step quick tutorial and post everything I would need to clone your lion as far as kexts, dsdt, etc. I would really appreciate it. Right now I believe im using the ##### method i read from either this or another thread and seems everthing is working fine.....in snow leopard. I need Lion please. I have an 8GB flash drive i just bought today from fry's so im ready to turn it to a gold installer. Please help the experienced novice.

Im sure your lion install alone whether you dual, triple boot or not is great in itself. Lion belongs on the E6400. Please post tut if you can.



*Also any 775 socket owners interesed in a nice hackintoshable piece of hardware should consider tthe barebone XG41 Shuttle. Its a mini-itx form mini desktop and its components are very hackintosh friendly; ethernet..sound.. (still working on video but support exists) $149 @ time of posting



I don't believe he has a successful OS X Lion installation!. Just ego?

#162
jar50972

jar50972

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Has anyone install Snow Leopard or Lion on their E6400 lately? I need help from someone who has installed recently. All guides are from 2009 or 2010.

#163
Sysyphus

Sysyphus

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 137 posts
  • Gender:Male
  • Location:3rd rock from that big yellow shiny thing in the sky!

Has anyone install Snow Leopard ......


Seriously?

#164
jackhu

jackhu

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Hi Guys,thanks for all your sharing on installing Snow Leopard and Lion on this Dell E6400 notebook.Currently I've been able to run Lion 10.7.2 on my E6400,

I installed Lion by using a thumb drive,which I've made a bootable Lion Install Disk. Simple stuff as it is ,just restore base system image to the thumb drive,copy packages folder and mach_kernel from Lion install DVD, and put them in respective places in the thumb drive.You'll have to replace original 'osinstall' and 'osinstall.mpkg' with the right ones.
Install Chamelon,Copy Extra Folder and paste root directory of the thumb drive,delete or paste some kexts under S/L/E,and then everything is done.
Plug in your thumb drive,switch on your E6400 Laptop,choose to boot from usb device,press F8,then type -v -s, type some command lines to repair permissions of the thumb drive,otherwise you'll come up with countless headaches when you try to install.
After you've finished repairing permissions,type 'reboo't,then do this again:
'Plug in your thumb drive,switch on your E6400 Laptop,choose to boot from usb device'.
Just wait a few minutes, if you're lucky then you can start the installation process.
After installation is done,reboot into your newly installed Lion,set up all things as instructed.then again you'll need to add or replace some kexts under S/L/E folder,otherwise you'll get system panic when you try to boot into Lion later.Copy Extra folder to OS X drive's root directory. Run disk utility and repair disk permission.reboot,now chances are you get a working lion installed successfully!


Below is what's working and what's not.

Working part:
Wifi: Dell 1397 Wireless Mini Card,by using broadcomxxx_enabler.sh
Ethernet: Intel 82567 LM Gigabit Network Connection,by using intel 82566.kext
Bluetooth: Dell Wireless 370 Bluetooth,by installing 370 bluetooth driver.
Shutdown&Restart: Out of the box!
Webcam: Out of the box! Facetime is useable.
Graphics Card: Out of the box! Haven't get the time to test video games or dual-monitor yet,but all I can say is so far so good.

Not-working-so-fine part:
Audio: Well, it kind of works, headphone/speaker just work,volume +/- also works,while every time you boot into Lion,you'll have to press the volume+ button on your keyboard to max the sound before you can really adjust the volume and hear any music.
If anyone has got a better audio kext, plz do tell me,I appreciate it.

Not-working part:
Sleep:this is commonly seen on hackintosh,still hope to see a solution!
Keyboard:can stop working at any time,which is totally unacceptable, because I want to use this wonderful machine with OS X installed,for work! Trackpad and Trackpoint just won't work!I've tried using different sets of Keyboard kexts,like:[AppleACPIPS2Nub.kext + ApplePS2Controller.kext],and [ AppleACPIPS2Nub.kext + VoodooPS2Controller.kext ],
CPU&Ram info:not recognized correctly

Can any one please tell me how can I get my keyboard stay working on Lion instead of suddenly become dumb without a warning? I really wish this could be solved,and I appreciate any help.

#165
jar50972

jar50972

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Hi Guys,thanks for all your sharing on installing Snow Leopard and Lion on this Dell E6400 notebook.Currently I've been able to run Lion 10.7.2 on my E6400,

I installed Lion by using a thumb drive,which I've made a bootable Lion Install Disk. Simple stuff as it is ,just restore base system image to the thumb drive,copy packages folder and mach_kernel from Lion install DVD, and put them in respective places in the thumb drive.You'll have to replace original 'osinstall' and 'osinstall.mpkg' with the right ones.
Install Chamelon,Copy Extra Folder and paste root directory of the thumb drive,delete or paste some kexts under S/L/E,and then everything is done.
Plug in your thumb drive,switch on your E6400 Laptop,choose to boot from usb device,press F8,then type -v -s, type some command lines to repair permissions of the thumb drive,otherwise you'll come up with countless headaches when you try to install.
After you've finished repairing permissions,type 'reboo't,then do this again:
'Plug in your thumb drive,switch on your E6400 Laptop,choose to boot from usb device'.
Just wait a few minutes, if you're lucky then you can start the installation process.
After installation is done,reboot into your newly installed Lion,set up all things as instructed.then again you'll need to add or replace some kexts under S/L/E folder,otherwise you'll get system panic when you try to boot into Lion later.Copy Extra folder to OS X drive's root directory. Run disk utility and repair disk permission.reboot,now chances are you get a working lion installed successfully!


Below is what's working and what's not.

Working part:
Wifi: Dell 1397 Wireless Mini Card,by using broadcomxxx_enabler.sh
Ethernet: Intel 82567 LM Gigabit Network Connection,by using intel 82566.kext
Bluetooth: Dell Wireless 370 Bluetooth,by installing 370 bluetooth driver.
Shutdown&Restart: Out of the box!
Webcam: Out of the box! Facetime is useable.
Graphics Card: Out of the box! Haven't get the time to test video games or dual-monitor yet,but all I can say is so far so good.

Not-working part:
Sleep:this is commonly seen on hackintosh,still hope to see a solution!
Keyboard:can stop working at any time,which is totally unacceptable, because I want to use this wonderful machine with OS X installed,for work! Trackpad and Trackpoint just won't work!I've tried using different sets of Keyboard kexts,like:[AppleACPIPS2Nub.kext + ApplePS2Controller.kext],and [ AppleACPIPS2Nub.kext + VoodooPS2Controller.kext ],
CPU&Ram info:not recognized correctly

Can any one please tell me how can I get my keyboard stay working on Lion instead of suddenly become dumb without a warning? I really wish this could be solved,and I appreciate any help.


Hey, thanks for your post. I am unable to help you, as I am installing OSX right now for the first time. I have a question for you though: Does your Dell 1397 Wireless Mini Card a A/B/G/N card? I have an Intel 5150 which is incompatible and am looking for one to replace it... tanks!!

#166
jackhu

jackhu

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Hey, thanks for your post. I am unable to help you, as I am installing OSX right now for the first time. I have a question for you though: Does your Dell 1397 Wireless Mini Card a A/B/G/N card? I have an Intel 5150 which is incompatible and am looking for one to replace it... tanks!!

Hi dude, I'm sorry to tell you this Dell™ Wireless 1397 802.11g Mini PCI Express® Internal Card is designed as a single band card supporting 802.11b/g networks.So it's not a A/B/G/N card as is expected by you.It's recongnized as a 3rd-party wireless card instead of Airport card,but it works just fine enough.Pretty cheap card, I bought it for no more than $ 5 here in China.You have a fairly good chance to find the same model in your local area. Search this on eBay may work for you,I guess. :star_sunglasses:


#167
jar50972

jar50972

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Hi dude, I'm sorry to tell you this Dell™ Wireless 1397 802.11g Mini PCI Express® Internal Card is designed as a single band card supporting 802.11b/g networks.So it's not a A/B/G/N card as is expected by you.It's recongnized as a 3rd-party wireless card instead of Airport card,but it works just fine enough.Pretty cheap card, I bought it for no more than $ 5 here in China.You have a fairly good chance to find the same model in your local area. Search this on eBay may work for you,I guess. :star_sunglasses:


Thanks for your reply. I would like to get Wireless N, but if the speed is good, it should be fine. How is browsing speed in OSX for you?

#168
jackhu

jackhu

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Thanks for your reply. I would like to get Wireless N, but if the speed is good, it should be fine. How is browsing speed in OSX for you?


As far as I can tell, browsing speed is normal, YouTube video plays smoothly,safari runs like a charm.But if you do need better internet connection,do search Google for an answer.Good Luck!

#169
jackhu

jackhu

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Hi guys,I think I've been able to get most of my E6400's hardwares working normally on Lion 10.7.2,and I've attached some fresh snapshots.

Attached Files



#170
jar50972

jar50972

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Hi guys,I think I've been able to get most of my E6400's hardwares working normally on Lion 10.7.2,and I've attached some fresh snapshots.


Amazing! Can you please help me if you have anytime. I have a fresh, untouched SNow Leopard 10.6.3 install.

#171
jackhu

jackhu

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Amazing! Can you please help me if you have anytime. I have a fresh, untouched SNow Leopard 10.6.3 install.

Up to now, I've been working under Lion for 2 more days,and so far so good:The system seems very stable,touchpad & Keyboard work just fine.

Thanks to China's GFW,my internet connection is too slow to upload my kexts or other files,which are necessary to make Lion work like a charm on E6400,to any web disk that people in your country(US,UK,Europe,etc) may use often.However if you like You can send me a message and leave me your email,so that I can send these files to you.And if you think these files can be more widely shared,then please do it. I believe those E6400 users who also want to use Lion on their machine will appreciate your sharing.^_^

#172
jar50972

jar50972

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Up to now, I've been working under Lion for 2 more days,and so far so good:The system seems very stable,touchpad & Keyboard work just fine.

Thanks to China's GFW,my internet connection is too slow to upload my kexts or other files,which are necessary to make Lion work like a charm on E6400,to any web disk that people in your country(US,UK,Europe,etc) may use often.However if you like You can send me a message and leave me your email,so that I can send these files to you.And if you think these files can be more widely shared,then please do it. I believe those E6400 users who also want to use Lion on their machine will appreciate your sharing. ^_^


No problem, I will host for you so everyone can have the files. I just ask, what is config of your E6400?

I have
Core 2 Duo T9600 2.8Ghz
4GB Ram
Nvidia Quadro NVS 160m

#173
jackhu

jackhu

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

No problem, I will host for you so everyone can have the files. I just ask, what is config of your E6400?

I have
Core 2 Duo T9600 2.8Ghz
4GB Ram
Nvidia Quadro NVS 160m


Hi,I have
Core 2 Duo P8600 2.4GHZ
4GB Ram
Nvidia Quadro NVS 160m
Bluetooth
Web camera.
Sorry it's really late here in China,and I'm replying you from my iPad,while those kexts are stored on my laptop.I'll sent you all the files you need to build a good-enough Hackintosh tomorrow morning,so you can figure out how it works for you then.

#174
jar50972

jar50972

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
When I fresh install Snow Leopard, the trackpad doesn't work and flips out, clicking randomly and flying around the screen. Even after installing ApplePS2Controller.text, it still has the same problem.

But I have the following working:
Battery
Sound
LAN
Bluetooth

Not working:
Video (Only display @ 1200x800... maybe graphicsenabler=yes will fix? Native res is 1400x900)
Wifi ( never will work - intel wifi link 5150)
Trackpad (see above)

I really want the trackpad to work, i hate using the nub.

#175
jackhu

jackhu

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

When I fresh install Snow Leopard, the trackpad doesn't work and flips out, clicking randomly and flying around the screen. Even after installing ApplePS2Controller.text, it still has the same problem.

But I have the following working:
Battery
Sound
LAN
Bluetooth

Not working:
Video (Only display @ 1200x800... maybe graphicsenabler=yes will fix? Native res is 1400x900)
Wifi ( never will work - intel wifi link 5150)
Trackpad (see above)

I really want the trackpad to work, i hate using the nub.

Hi,in my case,the trackpad works normally, while the nub doesn't. I believe the trackpad/nub have different manufacturers so you may want to try on different keyboard kexts in order to make your trackpad work.It really needs your patience.
My video card(NVS 160m) is recognized correctly, and the res is 1440x900.

I've sent you all the files I use to make Lion work on my E6400.Hope to hear some good news from you soon. :star_sunglasses: BTW,you may wanna try on Chamelon Wizards,which's a great app for Hackintosh users.

Edited by jackhu, 14 February 2012 - 07:47 AM.


#176
jar50972

jar50972

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Jackhu,
I sent you a message on the progress of your kexts with me.

JACKHU'S KEXTS FOR OSX LION (DELL LATITUDE E6400)

Virus Scan

Attached File  Untitled.png   39.37KB   31 downloads





In S/L/E Folder:

AppleACPIPlatform.kext
AppleACPIPS2Nub.kext
AppleHDA.kext
AppleSmartBatteryManager.kext
Intel82566MM.kext
IO80211Family.kext
IOPCIFamily.kext
IOPlatformPluginFamily.kext
VoodooPS2Controller.kext


In Extras Folder:
Themes (folder)
Extensions (folder)
dsdt.aml
Extensions.bak.mkext
Extensions.mkext
884 org.chameleon.Boot.plist
smbios.plist


In Extensions Folder (inside Extras)
FakeSMC.kext
LegacyHDA.kext

Attached Files



#177
jackhu

jackhu

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Jackhu,
I sent you a message on the progress of your kexts with me.

JACKHU'S KEXTS FOR OSX LION (DELL LATITUDE E6400)

Virus Scan

Attached File  Untitled.png   39.37KB   31 downloads





In S/L/E Folder:

AppleACPIPlatform.kext
AppleACPIPS2Nub.kext
AppleHDA.kext
AppleSmartBatteryManager.kext
Intel82566MM.kext
IO80211Family.kext
IOPCIFamily.kext
IOPlatformPluginFamily.kext
VoodooPS2Controller.kext


In Extras Folder:
Themes (folder)
Extensions (folder)
dsdt.aml
Extensions.bak.mkext
Extensions.mkext
884 org.chameleon.Boot.plist
smbios.plist


In Extensions Folder (inside Extras)
FakeSMC.kext
LegacyHDA.kext

Hi,I get it. Wish you good luck on giving Lion a try. ^_^

#178
vrao123

vrao123

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
I did all of this, but after the install, I couldn't boot, and it was stuck at a place in verbose. To get to the installer, I needed a dsdt.aml patched and I suspect that this was not installed on my comp through installation. When I boot up, it said "no dsdt.aml found, using pcirootuid=0. I can still boot to installer with dsdt.aml





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy