Jump to content

Vanilla Install on MSI Wind


  • Please log in to reply
237 replies to this topic

#1
Dalton63841

Dalton63841

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 295 posts
  • Gender:Male
USB installer
Install from a Mac system with only a single 8gb usb flash drive or SD card.

1. Open Disk Utility and format a flash drive (min. 8gb) with 2 partitions, both Mac OS Journaled. one 200mb, and the other to fill the rest of the drive. Make sure to click the Options button and set it to Master Boot Record and not GPT. name the first 200mb partition BOOTLOADER, and leave the other unnamed.

2. In Disk Utility Click on the Restore tab. Set the unnamed partition as the Destination. Mount the Snow ISO, and on the left column right click the mounted Snow image and click "Set as Source". Now click restore and wait for it to finish.

3. After it finishes close Disk Utility and run my modified Chameleon 2 RC3.pkg. When it asks for the Destination point it to the BOOTLOADER partition.

4. Reboot, hit F11, and begin installing. When it is finished it will say "Install Failed". Ignore that. It only says that because there is no bootloader on the hard drive yet.

Attached File  Chameleon_2_RC3.zip   818.09KB   3459 downloads
Thanks to Dr. Hurt. Only by modifying his installer could I make the process this easy.


EFI Tutorial
This tutorial was written by 18seven from the msiwind.net forums. Credit to Munky for pioneering this process. With the forums down I decided to post it here in case it is needed. First off you need to download this: Attached File  Vanilla.zip   864.2KB   2499 downloads This should only be performed on a fresh retail install on a GUID partition scheme with no bootloader installed. You also need to download the Chameleon 2 RC3 binaries here: http://staticanime.n...r658-bin.tar.gz

1. Check to see what disk number your internal hard drive is. (With GPT it can change)

sudo -s   diskutil list

2. Format the EFI partition. From here on the capital X will be the disk number of the internal drive(Usually 0).:

newfs_hfs -v EFI /dev/diskXs1

3. Mount EFI partition:

mkdir /Volumes/EFI   mount_hfs /dev/diskXs1 /Volumes/EFI

4. Create file structure:

mkdir -p /Volumes/EFI/Extra/Extensions   mkdir /Volumes/EFI/Extra/Themes

5. Install Chameleon 2 RC3:

cd ~/Downloads/Chameleon-2.0-RC3-r658-bin/i386   fdisk -f boot0 -u -y /dev/rdiskX   sudo dd if=boot1h of=/dev/rdiskXs1   sudo cp boot /Volumes/EFI   cd ~/Downloads/Chameleon-2.0-RC3-r658-bin/Optional\ Extras   cp -R Themes smbios.plist /Volumes/EFI/Extra/

6. Unmount EFI partition:
umount -f /Volumes/EFI   rm -rf /Volumes/EFI

7. Mark EFI partition active:

fdisk -e /dev/diskX   p   f 1   w   y   q

8. Load kexts:

cd ~/Downloads/Vanilla/EFIkext ./27ae.sh ./update.sh

9. Load com.apple.Boot.plist:

cd ~/Downloads/Vanilla/boot.plist   ./update.sh

10. Reboot

If you want Sleep on Lid Close you have two choices. One is DSDT patching. The other is ClamshellDisplay,kext. For ClamshellDisplay.kext open terminal and type:

sudo -s
cd ~/Downloads/Vanilla/SLEkext/_disabled
mv *.kext ~/Downloads/Vanilla/SLEkext/
cd ..
./update.sh

Then reboot.

#2
rocksalt26

rocksalt26

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Dalton you are awsome. Could you please help me with the process of installing touchpad drivers. I had been trying to do it from the posts on msiwind.net. Maybe a step by step. I hate to ask. I know your in the middle of snowywind.iso. I really appreciate you sharing your osx knowledge.

#3
Dalton63841

Dalton63841

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 295 posts
  • Gender:Male

Dalton you are awsome. Could you please help me with the process of installing touchpad drivers. I had been trying to do it from the posts on msiwind.net. Maybe a step by step. I hate to ask. I know your in the middle of snowywind.iso. I really appreciate you sharing your osx knowledge.


If you follow this tutorial then all that is done for you. No need to install any other drivers after this tutorial is finished. Its really no problem to ask. About 10 hours a day Im at work, which is on a Windows computer, so I can't work on SnowyWindOSX during that time. If ya wanna donate some money for my help though you are more than welcome to :) J/K

#4
Odin B

Odin B

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Followed this guide for my Wind U100, but I have the RALink wireless card, so I installed the "STA_RT2860 D-1.1.2.0 UI-1.7.1.0_2009_02_17.dmg" drivers. Had an earlier version working under OSX 10.5, but this version will not work with 10.6.

Link status goes between good and no connection after I enter the WPAkey.

Anyone have a RALink driver working on 10.6?

#5
blogbod

blogbod

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
Hi Dalton,

Tried your USB install again, I tried it about 4 times before the talk of snowywind.iso , it seems o hang on booting if you use the bootloader on the USB it seems OK takes forever after you hit F11 (abot 2-3min) it seems to be searching drive for boot block or something?

#6
Dalton63841

Dalton63841

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 295 posts
  • Gender:Male
I tested it on 3 different flash drives and 2 different SD cards and it worked perfectly on all of them.

#7
blogbod

blogbod

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
The flash drives work OK it is the external USB drive that I am installing it onto that spits the dummy

#8
zirkwander

zirkwander

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
I know this is stupid of me to ask but to what does the EFI used for exactly in this method?

So, assuming I have installed currently, msiwindosx86 then it's what I will use to make the USB pen drive installer. Then after that, I proceed boot with my Wind via the pen drive then just use the same partition that my msiwindosx86 is currently using?

Also, with the EFI installation, I do that after I installed the retail SL but before I made my first reboot? And it's being done using the Terminal?

After installing everything and hopefully everything works, can I proceed updating to 10.6.1 without installing other update drivers?

You also mentioned 2 Chameleon installers. Will we be using each installer OR I can use the first one(the one I used when I made my USB installer) and totally ignore the other one?

I'm really confuse with this method but reading your post now, I think I'll give it a shot this time. Just to clarify some things.

#9
Dalton63841

Dalton63841

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 295 posts
  • Gender:Male

I know this is stupid of me to ask but to what does the EFI used for exactly in this method?

So, assuming I have installed currently, msiwindosx86 then it's what I will use to make the USB pen drive installer. Then after that, I proceed boot with my Wind via the pen drive then just use the same partition that my msiwindosx86 is currently using?

Also, with the EFI installation, I do that after I installed the retail SL but before I made my first reboot? And it's being done using the Terminal?

After installing everything and hopefully everything works, can I proceed updating to 10.6.1 without installing other update drivers?

You also mentioned 2 Chameleon installers. Will we be using each installer OR I can use the first one(the one I used when I made my USB installer) and totally ignore the other one?

I'm really confuse with this method but reading your post now, I think I'll give it a shot this time. Just to clarify some things.


They are 2 seperate tutorials. I forgot to link to the bootloader for the second one. I'll fix it real quick. The Vanilla folder you download has everything, just unzip it in your downloads folder and follow the tutorial. It installs the bootloader, kexts, and boot.plist onto the EFI partition, so the Mac filesystem remains pure. After doing this you can update to 10.6.1 with no issues at all.

#10
zirkwander

zirkwander

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
Sorry for the noob question again.

EFI is used for what? I mean, why do I have to install it?

Sorry again..

#11
ta0ngbat0

ta0ngbat0

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
"permission denied" when trying to format efi

#12
Gazoo

Gazoo

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Hey Dalton, nice to see you've moved over here!

You have any idea what happened to our forum? It's been down for about a week now.



** Dalton's Tutorial is the DEFINITIVE tutorial for installing OSX on a Wind Netbook **

Gazoo

#13
zirkwander

zirkwander

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
2. Format the EFI partition. From here on the capital X will be the disk number of the internal drive(Usually 0).:

In here, what exactly is the internal drive are you pertaining? Is it the one where you will install SL? So, if I'm gonna do a dual-boot with XP, the "X" in this instruction is the partition I alloted for SL? If so, should I format the said partition to FAT32?

#14
Dalton63841

Dalton63841

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 295 posts
  • Gender:Male

"permission denied" when trying to format efi


I guess I should have put in the tutorial that you need to sudo -s for admin privileges.

2. Format the EFI partition. From here on the capital X will be the disk number of the internal drive(Usually 0).:

In here, what exactly is the internal drive are you pertaining? Is it the one where you will install SL? So, if I'm gonna do a dual-boot with XP, the "X" in this instruction is the partition I alloted for SL? If so, should I format the said partition to FAT32?


No X will not be a partition. When I say it is usually 0 is because when enumerating drives the first or internal drive is 0, then 1 and so forth. When you run "diskutil list" you will see what I am referring to. In the pattern diskXsY:

X is the disk
Y is the partition

In a GPT partition scheme Windows must be the last partition on the drive. Yes you would format it as Fat32

Hey Dalton, nice to see you've moved over here!

You have any idea what happened to our forum? It's been down for about a week now.



** Dalton's Tutorial is the DEFINITIVE tutorial for installing OSX on a Wind Netbook **

Gazoo


Im not a big fan of these forums. A year or two ago this was THE forum to go to for osx86 information, but anymore its a bunch of whiny b*tches who've never used a search engine in their life....

#15
zirkwander

zirkwander

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
Okay, I've tried typing diskutil list in Terminal and this is what I've got:

0 FDisk_partition_scheme
1 Windows NTFS
2 Apple_HFS Partition

Given this, what I should put in the terminal would be:

disk0s2? Because like what I've said, I'm planning to install the Vanilla install in the current partition being occupied by msiwindosx86.

#16
Dalton63841

Dalton63841

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 295 posts
  • Gender:Male

Okay, I've tried typing diskutil list in Terminal and this is what I've got:

0 FDisk_partition_scheme
1 Windows NTFS
2 Apple_HFS Partition

Given this, what I should put in the terminal would be:

disk0s2? Because like what I've said, I'm planning to install the Vanilla install in the current partition being occupied by msiwindosx86.


You cannot perform this type of install. You have a MBR partition scheme, which means there is no EFI partition. As I said in the tutorial you must have a GUID partition scheme.

#17
zirkwander

zirkwander

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts

You cannot perform this type of install. You have a MBR partition scheme, which means there is no EFI partition. As I said in the tutorial you must have a GUID partition scheme.


Okay I get it now. I have to delete the currently partition alloted to my msiwindosx86 then re-format it to FAT32 then proceed to installation based on your tut? Did I get it this time? :)

#18
Dalton63841

Dalton63841

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 295 posts
  • Gender:Male

Okay I get it now. I have to delete the currently partition alloted to my msiwindosx86 then re-format it to FAT32 then proceed to installation based on your tut? Did I get it this time? :(


No. Windows, and most hacked distros of Mac use MBR partition scheme. Apple uses GUID. GUID creates a completely hidden partition at the front of the drive. This tutorial uses that partition to store the bootloader, kexts, and other hacks.

The only way to convert from MBR to GUID would be to boot into a Mac install disk. Then open Disk Utility. Click on the hard drive listing in the left column. This will make a tab called partition show up. Click on that tab. Click on Current, choose the number of partitions you want. Then click on the Options button and click on GUID. then Click Apply.

Oviously this formats the entire drive completely clean.

#19
kingwaffle

kingwaffle

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Might as well add a post to this thread...I followed the instructions to a peg and I have two quick questions:

1. Can I install Windows 7 AFTER I've already installed SL? I followed seven18's instructions and have it EFI booting with Chameleon.

2. If I let SL set the date/time automatically, when I reboot I get the "Hold the power button to turn off your mac" error message. I have to go into BIOS and roll the time back 4 hours, and then it works fine. It never used to do this, but I recently installed a Dell Wireless Card (1510) in my Wind and ever since then it's been more and more picky about booting. If I roll the time back four hours it works 100% of the time. It's annoying, since I look up to see what time it is and it says 11:14am, instead of 3:14pm.

#20
Odin B

Odin B

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Followed this guide for my Wind U100, but I have the RALink wireless card, so I installed the "STA_RT2860 D-1.1.2.0 UI-1.7.1.0_2009_02_17.dmg" drivers. Had an earlier version working under OSX 10.5, but this version will not work with 10.6.

Link status goes between good and no connection after I enter the WPAkey.

Anyone have a RALink driver working on 10.6?


Am I the only one with a RALink WLAN card going for 10.6?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy