Jump to content

Dell Optiplex GX520


  • Please log in to reply
135 replies to this topic

#41
flyfishin4trout

flyfishin4trout

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Just an update. This has worked incredibly. I have done so much with this build and not an issue. Well done. Thanks again for all your help.

#42
Rinum

Rinum

    InsanelyMac Protégé

  • Validating
  • Pip
  • 11 posts
  • Gender:Male
  • Location:U

Good to hear.


Hi
You have helped me a lot in my Desktop, It is working perfect.
Can I ask you about my Laptop Fujitsu AMilo Sa 3650?

Regards.

#43
Rinum

Rinum

    InsanelyMac Protégé

  • Validating
  • Pip
  • 11 posts
  • Gender:Male
  • Location:U

Best to start a new thread, this one about GX 520 -620

Help if I can, but others more informed with laptops I,m sure


Thanks any way.
Regards.

#44
Nick S Murray

Nick S Murray

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hey pdave,
I have a GX620 tower running 10.5.7 and I was wondering whether or not it was possible to run the SL installer without using an external USB HD? I have two internals, one with all free space.

#45
Nick S Murray

Nick S Murray

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Thanks pdave! Everything is working fine and I could even update to 10.6.2 without any problems (even the video didn't break!)

#46
OSX86-GX520

OSX86-GX520

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

Yes sure, I indicated that in an edit to one of my posts on the first page. Navigate to /Volumes/Mac OS X Install DVD/System/Installation/Packages/,OSInstall.mpkg. Install to desired destination, Before restart "myhack" from 10.5.7 & point it to the destination disk.



Go for it this is how i have installed my systems, 'myhack' works great, you can always mess arround with it after from your 10.5.7

Just an idea, if you keep both drives on the two SATA channels you can alternate between the 2 OS's from the BIOS by switching of your SATA controllers e.g 10.6.2 on SATA 1
10.5.7 on SATA 2

Switch SATA 1 off and 10.5.7 will boot. saves messing with boot loaders if you cant be bothered.

#47
ecrash

ecrash

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Some of the posts from this thread documenting how to do this are missing. Anyone have a how-to guide?

#48
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
hi Ive had a few PM's on this

All Daves posts have gone!

I cant exactly remember what I did now but basically from within leo, install SL to another drive and run the myhack installer (google it and d/l the package.) (choose the choc kernel & install to the SL drive not the leo drive!)
Then unplug the leo drive and plug the drive you just installed the SL to in to the primary channel. Should be good to go.

Try that, sorry I cant be much more help at the moment but Im really busy.

Also I found it best to create your own DSDT fixes GMA950 problems.

Seeya and good luck.

#49
Localbastard

Localbastard

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

Has anyone installed Snow Leopard on a Dell GX520? I currently have OSX Leopard 10.5.6 on it and I'm curious if a Snow Leopard upgrade is possible.




Can somebody please tell me how to install Snow Leopard on the Optiplex 520 (tower) ?
Currently mine is running kalyway like a dream.

please help me out!

#50
flea_flip

flea_flip

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

I cant exactly remember what I did now but basically from within leo, install SL to another drive and run the myhack installer (google it and d/l the package.) (choose the choc kernel & install to the SL drive not the leo drive!)
Then unplug the leo drive and plug the drive you just installed the SL to in to the primary channel. Should be good to go.



Thanks lo-fi, I installed SL on my GX520 using your method, and it worked! however, gma950 is not fully supported with a fixed resolution of 1024*768. I tried to patch DSDT as you suggested but with no luck. could you pls sent me a copy of your patched DSDT to me if it is not too much touble, since the one you posted earlier is already deadlinked. I would be much indebted if you do.

here is my mailbox: jimshan@hotmail.com, thanks again.

#51
Localbastard

Localbastard

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
is it possible to make a snow leopard "boot-132" cd for the gx520?

if so? anybody here willing to do it?

#52
Localbastard

Localbastard

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
i just installed the "Snow_Leopard_10.6.1-10.6.2_Intel_AMD_made_by_Hazard"
i got it boot and everything is kinda working...

the thing i wondering is this:

Intel GMA 950:

Chipset Model: GMA 950
Type: GPU
Bus: Built-In
VRAM (Total): 64 MB of Shared System Memory
Vendor: Intel (0x8086)
Device ID: 0x2772
Revision ID: 0x0002
Displays:
Display Connector:
Status: No Display Connected
W9006S-N:
Resolution: 1440 x 900 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes


where the hell is "QUARTZ EXTREME"???
is it activated or do i need a some special intel gma950 kext?


please help me out!?!

#53
flea_flip

flea_flip

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I used the method of pdave54 to install snow leopard on my gx520, and it's working great.

unfortunately, pdave54 had a quarrel with the administrator of this site, and had all his posts deleted from this thread. however, he sent me a copy of all the gx520 audio/video kexts along with instructions of installation to make the sound/video cards working.

if your sound and vedio cards are not working properly after installing snow leopard, you are welcome to try these kexts.

good luck

all credit goes to lo-fi and pdave.

Attached Files



#54
Localbastard

Localbastard

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

I used the method of pdave54 to install snow leopard on my gx520, and it's working great.

unfortunately, pdave54 had a quarrel with the administrator of this site, and had all his posts deleted from this thread. however, he sent me a copy of all the gx520 audio/video kexts along with instructions of installation to make the sound/video cards working.

if your sound and vedio cards are not working properly after installing snow leopard, you are welcome to try these kexts.

good luck

all credit goes to lo-fi and pdave.




thanks dude! imma try em out!

have a good week wherever you are!

#55
Prakhar

Prakhar

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Can you please list all items you selected (in 'Customize' screen) while installing hazard's SL on Dell Optiplex GX 520?

I am getting kernel panic..!

#56
Localbastard

Localbastard

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

Can you please list all items you selected (in 'Customize' screen) while installing hazard's SL on Dell Optiplex GX 520?

I am getting kernel panic..!



this are the kexts i selected in the hazard install.

ioatafamily
appleintelpiixata
nullcpupowermanagemenet
platformuuid
applertc
fakesmc
ellitforcelegacertc
smbiosresolver
uuid

then i installed the video, audio, lan kexts after the install.






i updated to 10.6.3 and my {censored} broke down.
at the pc-efi startup it just reboots.

anybody knows how to fix this??

is it possible to make a snow leopard "boot-132" cd for the gx520?

if so? anybody here willing to do it?





retail boot-123/vanila!!!

come on guys!!

please help me out here.

#57
Dellmantt

Dellmantt

    STILL LEARNING

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,122 posts
  • Gender:Male
  • Location:AUSTRALIA
Re 10.6.3 update. You have to reinstall the Legacy kernel after the update.

There is a new "mykack installer", it can be found here http://osx86.sojugarden.com/installer/

There is a new 10.6.3 Kernel that works on the GX 520, it can be found here http://www.insanelym...p;#entry1440696.

With 10.6.3, Video GMA950 (Device ID: 0x2772) works with the 10.6.3 kexts. You do need to replace the framebuffer kext with the one below. No DSDT or strings required..

Audio for 10.6.3, you need the kext below, Azalia kext in extra folder no longer required. Just the kext below.

And network for 10.6.3, the kext below.

*********************************************************
Kexts, Apps & links needed for install
Attached File  Kext_Utility.zip   57.02KB   491 downloads
Attached File  AppleAC97Audio.kext.zip   234.91KB   349 downloads
Attached File  AppleBCM5751Ethernet.kext.zip   206.88KB   319 downloads
Attached File  AppleIntelIntegratedFramebuffer.kext.zip   65.67KB   1276 downloads
Attached File  Show_Hide_Invisible_files_1.6.app.zip   62.65KB   276 downloads
http://www.insanelym...p;#entry1440696
http://osx86.sojugarden.com/installer/
http://support.apple.com/kb/DL1017
**********************************************************


Here is what I have done and I suggest (well pdave54 suggests, he is looking over my shoulder ;-) )
I did a clean install & imported my settings.

From within Tiger or Leopard (or Snow if doing an upgrade to 10.6.3). Insert retail DVD in to dvd drive, navigate to Install DVD/System/Installation/Packages/OSInstall.mpkg. Open mkpg, change install location to hard drive or partition you wish to install to, pick
what you want in custom button and install. Still from within Tiger, leopard etc. run 10.6.3 combo (point to same drive you just installed to). Still from within Tiger, leopard etc run myHack_Installer_1.0 (point to same drive you just installed to). Customise as follows
Attached File  options.png   21.27KB   159 downloads..Restart to New Install, do setup or import settings. Install Audio, Network & Framebuffer kexts with kext utility. Optionally install 10.6.3 Kernel. It has only been available a few days so is really untested, chocolate kernel is stable and time tested.

Hope this helps

EDIT &&&&&&&&&&&&&&
If you do a full import of files & settings the audio & network kexts will be imported, you still have to install the framebuffer kext.
Also Little snitch is imported, but does not show up on first start, on restart it is working (just to be certain, back up rules first)

#58
Omakayd

Omakayd

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
I'm

Re 10.6.3 update. You have to reinstall the Legacy kernel after the update.

There is a new "mykack installer", it can be found here http://osx86.sojugarden.com/installer/

There is a new 10.6.3 Kernel that works on the GX 520, it can be found here http://www.insanelym...p;#entry1440696.

With 10.6.3, Video GMA950 (Device ID: 0x2772) works with the 10.6.3 kexts. You do need to replace the framebuffer kext with the one below. No DSDT or strings required..

Audio for 10.6.3, you need the kext below, Azalia kext in extra folder no longer required. Just the kext below.

And network for 10.6.3, the kext below.

*********************************************************
Kexts, Apps & links needed for install
Attached File  Kext_Utility.zip   57.02KB   491 downloads
Attached File  AppleAC97Audio.kext.zip   234.91KB   349 downloads
Attached File  AppleBCM5751Ethernet.kext.zip   206.88KB   319 downloads
Attached File  AppleIntelIntegratedFramebuffer.kext.zip   65.67KB   1276 downloads
Attached File  Show_Hide_Invisible_files_1.6.app.zip   62.65KB   276 downloads
http://www.insanelym...p;#entry1440696
http://osx86.sojugarden.com/installer/
http://support.apple.com/kb/DL1017
**********************************************************


Here is what I have done and I suggest (well pdave54 suggests, he is looking over my shoulder ;-) )
I did a clean install & imported my settings.

From within Tiger or Leopard (or Snow if doing an upgrade to 10.6.3). Insert retail DVD in to dvd drive, navigate to Install DVD/System/Installation/Packages/OSInstall.mpkg. Open mkpg, change install location to hard drive or partition you wish to install to, pick
what you want in custom button and install. Still from within Tiger, leopard etc. run 10.6.3 combo (point to same drive you just installed to). Still from within Tiger, leopard etc run myHack_Installer_1.0 (point to same drive you just installed to). Customise as follows
Attached File  options.png   21.27KB   159 downloads..Restart to New Install, do setup or import settings. Install Audio, Network & Framebuffer kexts with kext utility. Optionally install 10.6.3 Kernel. It has only been available a few days so is really untested, chocolate kernel is stable and time tested.

Hope this helps

EDIT &&&&&&&&&&&&&&
If you do a full import of files & settings the audio & network kexts will be imported, you still have to install the framebuffer kext.
Also Little snitch is imported, but does not show up on first start, on restart it is working (just to be certain, back up rules first)


I'm trying this right now. I'll report back soon.

EDIT:

Posting from Firefox on my Dell Optiplex GX520 (small form factor) via onboard ethernet (no manual MAC address changes needed like before...) running Snow Leopard 10.6.3!

gma950 fully working, haven't noticed any artifacts anyway. Front Row, transparent menu bar and rippling effect in the dashboard all present. SL doesn't show QE and CI but I assume since these things are working that I have them...

Thank you a thousand times over Dellmantt! (followed your guide to the letter after setting my bios to default configuration)

also, sound is working great! Now to see if my pci firewire card works (no reason it shouldn't, me thinks...)

#59
Dellmantt

Dellmantt

    STILL LEARNING

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,122 posts
  • Gender:Male
  • Location:AUSTRALIA

I'm

I'm trying this right now. I'll report back soon.

EDIT:

Posting from Firefox on my Dell Optiplex GX520 (small form factor) via onboard ethernet (no manual MAC address changes needed like before...) running Snow Leopard 10.6.3!

gma950 fully working, haven't noticed any artifacts anyway. Front Row, transparent menu bar and rippling effect in the dashboard all present. SL doesn't show QE and CI but I assume since these things are working that I have them...

Thank you a thousand times over Dellmantt! (followed your guide to the letter after setting my bios to default configuration)

also, sound is working great! Now to see if my pci firewire card works (no reason it shouldn't, me thinks...)


Good to hear that it went well. No SL does not show QE & CI in System Profiler and from what you described it is working.

#60
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
Hi

I havent checked in here for a while. Good to see the 'ol Dell's are still chugging away.

I was about to post some stuff about the latest update but I see its all pretty much covered already.



Nice work.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy