Jump to content

Dell Optiplex GX520


  • Please log in to reply
135 replies to this topic

#1
TheSnuke

TheSnuke

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Has anyone installed Snow Leopard on a Dell GX520? I currently have OSX Leopard 10.5.6 on it and I'm curious if a Snow Leopard upgrade is possible.

#2
kotedo

kotedo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Has anyone installed Snow Leopard on a Dell GX520? I currently have OSX Leopard 10.5.6 on it and I'm curious if a Snow Leopard upgrade is possible.


+1 !!!

I have one of those too, and I am also in dire need for a Snow Leopard installation on it; anyone?

#3
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
Hi pdave54
Thank-you so much for your instructions, I now have my GX520 booting SL!!! After several days of trying (your method worked first pop)
The only issues I have is no network and no full video support, from what I can work out I need a patched DSDT file (or something like that) to get full native support. Is that what you found? Or did you use a different method? If you did patch the DSDT could you please post a copy of it?
I also notice that the CPU is reported incorrectly
Thanks again

#4
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
OK, got Full video support working with a patched DSDT. Im using USB audio so I dont have any sound issues.

The LAN network card is non-existent though. Did you install a kext for it? When I try to open network diagnostics it just crashes. Was working fine in 10.5.7.

Im really happy that the 'ol 520 lives to see the Snow.



Another unrelated question: has anyone got the EFI partition thing working with SL on a GX520? It would be great to be able to update without any problems.

#5
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
OK cool, I'll try that network fix tonight. Yeah Im used to the manual IP entry from Leo!

As far as video goes it is def best to edit the DSDT, as updates will then work without breaking the video as it uses the standard Kexts. I now have zero artifacts and 'front row' etc is all working.

I can send you a copy of my DSDT when I get home later tonight, I just copied it in the root. reran the myhack installer and unchecked the RTC fix (not sure if I needed to do that or not? probably did) then when it booted it automatically picked up the DSDT file. Although I think i may have lost my SATA controller (OS is on the PATA) probably need to edit something else for that. There is some really good tools for DSDT editing for Noobs around (thats what I needed.)

Ok as long as the CPU is working as 2 cores then Im happy, I dont mind what it is reported as.

#6
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
ok attached is my DSDT file

If you want to edit your own then just download the archive: MacLoader_SL_0.4
This has some DSDT tools that you can use to automate the patching process.

Then follow the guides to ensure the CMOS issue and GMA950 problem are patched.
CMOS:

Phase 1.1: Pre-Installation (DSDT.aml)
1. Open unzipped MacLoader_SL folder downloaded from above.
2. Open 1_DSDT_Patcher folder and double-click the "1_GetDSDT" file.
3. When "dsdt-fixed.dsl" file is opened, look for the "Device (RTC)" line.
4. Edit accordingly: (i.e. "//Length" should be "0x02,")
CODE
        Device (RTC)
        {
            Name (_HID, EisaId ("PNP0B00"))
            Name (ATT0, ResourceTemplate ()
            {
                IO (Decode16,
                    0x0070,             // Range Minimum
                    0x0070,             // Range Maximum
                    0x00,               // Alignment
                    0x02,               // Length
                    )
            })
            Name (ATT1, ResourceTemplate ()
            {
                IO (Decode16,
                    0x0070,             // Range Minimum
                    0x0070,             // Range Maximum
                    0x00,               // Alignment
                    0x02,               // Length
 )
            })
            Name (ATT1, ResourceTemplate ()
            {
                IO (Decode16,
                    0x0070,             // Range Minimum
                    0x0070,             // Range Maximum
                    0x00,               // Alignment
                    0x02,               // Length
                    )
            })


5. Save "dsdt-fixed.dsl" file then double-click the "2_DSDTpatcher" file.
6. Press [ENTER] then you should now have your "DSDT.aml".

I attached the method to patch the GMA950.

Goodluck.
BTW non of this is mine Ive just taken bits and pieces from different guides. So peace to whomever created the different bits.


Now to try and get my network going.

Attached Files



#7
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
Cool the network was easy, just copied that kext, although its strange cause I dont have that kext in leo and it still works fine.

This Snow Leopard is doing my head in.

When I edit and use a DSDT file my Video is perfect but I cant see my SATA drive. When I dont use a DSDT file I can not get the full video support to work but my drives show.

Actually I think there is something funny going on with my drives anyway.... Is it normal to not be able to see the desktop drive icons in Snow Leopard? (I doubt it?) In Leo they show on the desktop in Snow they only show in Finder.

pdave54 can you send me your kext's for GMA950 Ive tried my ones from leo and various ones from these forums but they either do nothing or I get a grey/garbled screen

help :)

#8
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
Hi again.

Ok that is pretty embarrassing, yes I just needed to turn the drive icons on the desktop on!
I tried to use the Kexts you posted thanks, I get partial support with them.. I have full resolution but I dont have acceleration. eg my top bar is not transparent and front row wont display.. Do you get hardware acceleration using those Kexts?

Attached is another option for the DSDT patching that I found yesterday:
If you cant download it go to the PCWiz website and d/l it from there
Its a GUI so just click the button, I didnt use the apply option I just copied the newly created file in the OS drive root.

This one works for me but I lost my SATA drive again :)

Attached Files



#9
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
Hardware acceleration, yip, sure do.
But its all a bit pointless if I cant see my SATA as this has all my music on it, and the main use of this machine is music.

Hmmm interesting about little snitch, I never used it before.

Im gonna post in one of the other topics and see if I can get any help with the DSDT.

Will let you know if I have any luck.

#10
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
just tried that...
Unfortunately it wont boot with that setting turned on... Do you have it turned on, on your system?

I get some bios messages about boot0 being OK then it says boot1 error and doesnt get as far as the boot loader.

saw this about lil snitch:


Does Little Snitch run on Mac OS X 10.6 Snow Leopard?
The upcoming Little Snitch version 2.2 is compatible with Mac OS X 10.6 (Snow Leopard). A beta version of Little Snitch 2.2 is already available.

#11
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
yep without the DSDT the SATA detects and works fine, but then I have no graphics acceleration which sucks cause then nothing like DVD player, frontrow etc work, and also the image on the screen is not as sharp/easy to read.

#12
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
OK thanks!

I can confirm that lil snitch 2.2 works fine in SL

#13
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia
Ahhh after many hours its 100%, a reinstall with the SATA mode set to combination and the DSDT.aml in the root did it.
Full graphics support on stock kExts and it see's my SATA.

I'll email you the DSDT if you want it, note it only works with the original kExts. The only extra kExt that I used was the broadcom one.

Yes I installed little snitch 2.2 and it worked fine (demo only but fine)

#14
flyfishin4trout

flyfishin4trout

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Is there a guide on how to do this. I have tried a few different things and I cant get it to start the install. Im booting off the thumb drive and the boot loader comes up choose hackintosh install and reboots.

#15
lo-fi

lo-fi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Sydney, Australia

Is there a guide on how to do this. I have tried a few different things and I cant get it to start the install. Im booting off the thumb drive and the boot loader comes up choose hackintosh install and reboots.



Hi

um... not trying to be rude, but did you read the first page of this post? if you follow Pdave54's instructions you will see that you need to run the installer from within leopard, install, then install the patch then reboot to the drive you installed SL.

Good luck, its running much nicer than Leo.

#16
flyfishin4trout

flyfishin4trout

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

Hi

um... not trying to be rude, but did you read the first page of this post? if you follow Pdave54's instructions you will see that you need to run the installer from within leopard, install, then install the patch then reboot to the drive you installed SL.

Good luck, its running much nicer than Leo.


I am on 10.5.2 kalyway. Is that going to be ok? I noticed he was on 10.5.8. Didnt know if that would cause issues. Thanks for all your help I really appreciate it.

#17
flyfishin4trout

flyfishin4trout

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
I am having a weird issue when I try to run the dsdt patcher I cant click the button. Its like the app doesnt work at all

#18
flyfishin4trout

flyfishin4trout

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
The thing that I dont understand is how to install the other kernal. Im not sure if this makes a difference either but I noticed that you have a gx520 with a core 2 duo. Mine has pentium D in it.

#19
flyfishin4trout

flyfishin4trout

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

try starting in sinle user mode % run fsck -fy


I just reset the bios for combination mode and unplugged my second sata drive. Rebooted and im its loading for lots longer. Fingers crossed.

Yahoo. Im in. Network working. No sound. 1024x768 is only option. How do I handle those. Thanks again. I owe you a beer.

#20
flyfishin4trout

flyfishin4trout

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Its a tower. using internal video. Sorry for all the questions. I am completely new to osx. Do I just copy those kext files into the directory? I used the ac97audo ones and it errored. When I tried to use osx86 tools it didnt allow me to choose those kexts to install them via the wizard. So just a bit confused.

i had no issues with network. I read somewhere that this card works really well will all OSX installs. No manual IP entry. :)

http://www.newegg.co...dnet-_-33156139

Son of a...I installed the updates and its dead again.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy